买好股公式网 > 股票公式 > 同花顺公式 > 同花顺中线趋势指标公式

同花顺中线趋势指标公式

2011年01月18日 字体: 人气:

N=9;M=6;G=3;
VarC:=(2*CLOSE+HIGH+LOW)/4;
VarD:=LLV(LOW,N);
VarE:=HHV(HIGH,M);
VarF:=EMA((VarC-VarD)/(VarE-VarD)*100,13);
Var10:=EMA(0.667*REF(VarF,1)+0.333*VarF,2);
STICKLINE(VarF>Var10,100,0,1,0),color909090;
STICKLINE(C>0,50,49.5,15,0),colorred;
STICKLINE(C>0,80,79.5,15,0),colorwhite;
STICKLINE(C>0,20,19.5,15,0),color00ff00;
VAR1:=(C-REF(C,1))/REF(C,1);
VAR2:=(INDEXC-REF(INDEXC,1))/REF(INDEXC,1);
个股:=EMA(SUM(VAR1,20),5);
大盘:=EMA(SUM(VAR2,20),5);
领涨:=(个股-大盘)>=0;
Var3:=(C-LLV(L,13))/(HHV(H,13)-LLV(L,13))*100;
Var4:=SMA(Var3,34,1);
Var5:=SMA(Var4,13,1);
中线趋势:=3*Var4-2*Var5;
中线趋势升:=(中线趋势-REF(中线趋势,1))>=0;
均五升:=(MA(C,13)-REF(MA(C,13),1))>=0;
均十升:=(MA(C,34)-REF(MA(C,34),1))>=0;
强势:=IF(均五升 AND 均十升 AND 中线趋势升 AND 领涨,4,0),colorff99ff;
VAR6:=(2*C+H+L)/4;
VAR7:=LLV(L,n);
VAR8:=HHV(H,n);
操作:=EMA((VAR6-VAR7)/(VAR8-VAR7)*100,5);
趋势:=EMA(0.618*REF(操作,1)+0.382*操作,3);
v1:=IF(操作<=趋势,操作,趋势);
PARTLINE(v1,v1>REF(v1,1),RGB(255,0,0),v1<REF(v1,1),RGB(0,255,0)),LINETHICK2;
V2:IF(趋势-操作,趋势,操作);
AA:=V2;
PARTLINE(AA,AA>REF(AA,1),RGB(255,0,0),AA<REF(AA,1),RGB(0,255,0)),linethick3;
BB:=HHV(AA,G);
PARTLINE(BB,BB>REF(BB,1),RGB(255,0,0),BB<REF(BB,1),RGB(0,255,0)),linethick2;
EE:=IF(AA<BB,(AA-(BB-AA)),BB),colorred;
PARTLINE(EE,EE>REF(EE,1),RGB(255,0,0),EE<REF(EE,1),RGB(0,255,0)),linethick2;
STICKLINE(操作>趋势 AND 操作>=REF(操作,1),操作+5,趋势-1,3.7,0),colorred,linethick2;
STICKLINE(强势=4,操作+6,趋势-1,7,0),colorff99ff;
STICKLINE(操作>=趋势 AND 均五升 AND 均十升 AND 中线趋势升,趋势-3,趋势-7,8,0),color64A0E6;

同花顺中线趋势指标公式

0% (0)
0% (10)

关于同花顺中线趋势指标公式的评论:

 以下是对 [同花顺中线趋势指标公式] 的评论,总共:条评论
加入收藏 | 联系我们 | 免责声明 | 站内地图 | 关于我们