买好股公式网 > 股票公式 > 同花顺公式 > 同花顺老指标一次聚合公式

同花顺老指标一次聚合公式

2015年01月30日 【字体: 人气:

/* 布林极限宽 */

N:=20;P:=2;

MID := MA(CLOSE,N);

UPPER:= MID + P*STD(C,n);

LOWER:= MID - P*STD(C,n);

BBW: (UPPER- LOWER) / MID, colorblue;

BBW5:= MA(BBW, 5);

BBWP:= REF(BBW, 1);

BBWP2:= REF(BBW, 2);

BBCHA:= BBWP > BBW5 AND BBW <= BBWP AND HHV(BBW, 10) = BBWP;

BBWUP:= BBWP > BBW5 AND BBW > BBWP;

BBWDOWN:= BBWP < BBW5 AND BBW < BBWP;

变化: IF(BBCHA, 0.01, 0), colorwhite;

VERLINE(BBCHA, 0);

BBSPE:= BBWP < BBW5 AND BBW >= BBWP AND LLV(BBW, 10) = BBWP;

加速: IF(BBSPE, BBW, 0), coloryellow;

BBWRATE:= (BBW - BBWP) / BBWP;

BBWRATEP: = REF(BBWRATE, 1);

/* 均线 */

MA60:= MA(CLOSE, 60);

MA30= MA(CLOSE, 30);

MA20:= MA(CLOSE, 20);

MA5:= MA(CLOSE, 5);

MAIn:= MA20 >= REF(MA20, 1) AND BBWUP AND BBWRATE > 0.1;

买入: IF(MAIn, 0.01, 0), colorred;

DRAWTEXT(MAIn, BBW, '买');

MAOut:= CROSS(MA30, CLOSE) AND MA5 < REF(MA5, 1) AND MA20 < REF(MA20, 1);

卖出: IF(MAOut, 0.01, 0), colorgray;

DRAWTEXT(MAout, BBW, '卖');

EasyDown:= CLOSE * 0.97;

MAAdd:= CLOSE < REF(CLOSE, 1) AND MA5 < REF(MA5, 1) AND CLOSE > MA60 AND ((CLOSE > MA20 AND EasyDown < MA20) OR (CLOSE > MA30 AND EasyDown < MA30));

补仓: IF(MAAdd, 0.01, 0), colorcyan;

DRAWTEXT(MAAdd, BBW, '补');

/* 成交量 */

VOLIn:= VOL / MA(VOL, 5) > 1.8 AND CLOSE < MA60 AND MA5 < MA20 AND MA20 < MA30 AND MA30 < MA60 AND MA5 <= REF(MA5, 1);

进场: IF(VOLIn, 0.01, 0), colorligray;

DRAWTEXT(VOLIn, BBW, '进');

VOLOut:= VOL / MA(VOL, 5) > 1.8 AND MA20 > MA30 AND MA30 > MA60;

出场: IF(VOLOut, 0.01, 0), colormagenta;

DRAWTEXT(VOLOut, BBW, '出');

 

 

0% (0)
0% (10)

关于同花顺老指标一次聚合公式的评论:

 以下是对 [同花顺老指标一次聚合公式] 的评论,总共:0条评论
加入收藏 | 关于我们 | 服务条款 | 广告服务 | 免责声明 | 站内地图 | 联系我们