买好股公式网 > 股票公式 > 同花顺公式 > MACD主图金叉买点公式源码

MACD主图金叉买点公式源码

2018年06月11日 字体: 人气:


DIFF:=EMA(CLOSE,9)-EMA(CLOSE,17);

DEADD:=EMA(DIFF,8),COLORFFAA00;

MACDD:=2*(DIFF-DEADD);

X1DD:=IF(DIFF<0,DIFF,0),COLOR0000FF,LINETHICK2;

X2DD:=IF(DIFF<0,0,DIFF),COLORMAGENTA,LINETHICK1;

X3DD:=IF(DIFF<DEADD,DIFF,DEADD),COLOR00FF00,LINETHICK1;

X4DD:=IF(DIFF>DEADD,DEADD,DEADD),LINETHICK1,COLORFFBB11;

高位金叉:=CROSS(DIFF,DEADD) AND DIFF>-0.1;

DRAWTEXT(高位金叉,L*0.9976,'高位金叉'),COLORYELLOW;

低位金叉:=CROSS(DIFF,DEADD) AND DIFF<-0.1;

DRAWTEXT(低位金叉,L*0.9973,'低位金叉'),COLORYELLOW;

JCCOUNT:=COUNT(CROSS(DIFF,DEADD),BARSLAST(DEADD>=0));

二次金叉:=CROSS(DIFF,DEADD) AND DEADD<0 AND COUNT(JCCOUNT=2,21)=1;

DRAWTEXT(二次金叉,L*0.9873,'二次金叉'),COLORFF00FF;

线上二次金叉:=CROSS(DIFF,DEADD) AND DEADD>=0 AND COUNT(JCCOUNT=2,21)=1;

DRAWTEXT(线上二次金叉,L*0.9976,'线上二金'),COLORFF00FF;

A1DD:=BARSLAST(REF(CROSS(DIFF,DEADD),1));

MACD底背离:=REF(CLOSE,A1DD+1)>CLOSE AND DIFF>REF(DIFF,A1DD+1) AND CROSS(DIFF,DEADD);

DRAWTEXT(MACD底背离,L*0.977,'底背驰'),COLOR6600FF;

A2DD:=BARSLAST(REF(CROSS(DEADD,DIFF),1));

顶背离:=REF(CLOSE,A2DD+1)<CLOSE AND REF(DIFF,A2DD+1)>DIFF AND CROSS(DEADD,DIFF);

DRAWTEXT(顶背离,H*1.001,'顶背离'),COLORGREEN;

EMA55:MA(CLOSE,55),POINTDOT,COLORCYAN;

BBI:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4;

UP:=BBI + 2.58*STD(BBI,10);

LOOW:=BBI - 2.58*STD(BBI,10);

A7:=(EMA((OPEN+HIGH+LOW+CLOSE)/4,21)+EMA((OPEN+HIGH+LOW+CLOSE)/4,34)+EMA((OPEN+HIGH+LOW+CLOSE)/4,68))/3;

VAR7:=FORCAST(A7,6);

MA3K:VAR7,POINTDOT,COLORYELLOW;


0% (0)
0% (10)

关于MACD主图金叉买点公式源码的评论:

 以下是对 [MACD主图金叉买点公式源码] 的评论,总共:0条评论
加入收藏 | 联系我们 | 免责声明 | 站内地图 | 关于我们