买好股公式网 > 股票公式 > 通达信公式 > 通达信缠论分形主图公式源码

通达信缠论分形主图公式源码

2018年12月09日 字体: 人气:

通达信缠论分形主图公式源码


KU1:=IF(HIGH=HHV(HIGH,3),1,0);

KD1:=IF(LOW=LLV(LOW,3),1,0);

UL:=IF(REF(KU1,2)=1 AND REF(KU1,1)=0

AND KU1=0,REF(HIGH,2),REF(HIGH,2+BARSLAST(REF(KU1,2)=1

AND REF(KU1,1)=0 AND KU1=0)));

DL:=IF(REF(KD1,2)=1 AND REF(KD1,1)=0 AND KD1=0,REF(LOW,2),REF(LOW,2+BARSLAST(REF(KD1,2)=1

AND REF(KD1,1)=0 AND KD1=0)));

HV:=H>UL AND H>REF(H,1) ;

LV:=L<DL AND L<REF(L,1) ;

GP:=BARSLAST(HV);

DP:=BARSLAST(LV);

IP:=IF(GP=0,DP,GP)>3;

HV1:=HV AND IP AND H>=HHV(H,BARSLAST(LV));

LV1:=LV AND IP AND L<=LLV(L,BARSLAST(HV));

DRAWLINE(LV1,LOW,HV1, HIGH,0),COLORYELLOW,LINETHICK2;

DRAWLINE(HV1,HIGH,LV1, LOW,0),COLORMAGENTA,LINETHICK2;

N1:=10;N2:=10;DISP:=2;K:=1;

P1:=PEAK(1,K*N1,1);

P2:=PEAK(1,K*N1,2);

WP1:=PEAKBARS(1,K*N1,1);

WP2:=PEAKBARS(1,K*N1,2);

T1:=TROUGH(2,K*N2,1);

T2:=TROUGH(2,K*N2,2);

WT1:=TROUGHBARS(2,K*N2,1);

WT2:=TROUGHBARS(2,K*N2,2);

TJ1:=P1>T1 AND P2>T2 ;

ZD:=MAX(T1,T2);

ZG:=MIN(P1,P2);

LL:=MIN(T1,T2);

HH:=MAX(P1,P2);

TJ2:=FILTER(ZG>ZD,2);

TJ3:=ZG=REF(ZG,BARSLAST(TJ2)) OR ZD=REF(ZD,BARSLAST(TJ2));

TJ4:=TJ1 AND TJ2 AND NOT(TJ3);

TJ5:=BETWEEN(ZD,REF(ZD,REF(BARSLAST(TJ4),1)),REF(ZG,REF(BARSLAST(TJ4),1)));

TJ6:=BETWEEN(ZG,REF(ZD,REF(BARSLAST(TJ4),1)),REF(ZG,REF(BARSLAST(TJ4),1)));

TJ7:=ZG>REF(ZG,REF(BARSLAST(TJ4),1)) AND ZD<REF(ZD,REF(BARSLAST(TJ4),1));

TJ8:=TJ4 AND NOT(TJ5 OR TJ6 OR TJ7);

ZSD:=IF(TJ8,ZD,REF(ZD,1));

ZSG:=IF(TJ8,ZG,REF(ZG,1));

ZSH:=IF(TJ8,HH,REF(HH,1));

ZSL:=IF(TJ8,LL,REF(LL,1));

STICKLINE(TJ8,ZSH,ZSL,0,-1),COLORMAGENTA;

STICKLINE(TJ8,ZSD,ZSG,IF(DISP=1,3,0),1),COLORMAGENTA;

{DRAWTEXT(DISP=2,ZSH,'B'),COLORWHITE;}

MA5:MA(CLOSE,5),LINETHICK1;


0% (0)
0% (10)

关于通达信缠论分形主图公式源码的评论:

 以下是对 [通达信缠论分形主图公式源码] 的评论,总共:0条评论
加入收藏 | 联系我们 | 免责声明 | 站内地图 | 关于我们