通达信主图叠加重要个股信息_通达信公式_买好股公式网
买好股公式网 > 股票公式 > 通达信公式 > 通达信主图叠加重要个股信息

通达信主图叠加重要个股信息

2018年05月12日 字体: 人气:

MA5:MA(CLOSE,5);

MA10:MA(CLOSE,10);

MA20:MA(CLOSE,20);

MA60:MA(CLOSE,60);

NE:=IF(NAMELIKE('S') OR NAMELIKE('*S'),0.05,0.1);{适用ST股}

涨停:=C/REF(C,1)-1>=NE-0.01/REF(C,1) AND C=H AND PERIOD=5;{仅在日线上变色}

STICKLINE(涨停,C,O,-1,0),COLORFF00F5;

跌停:=REF(C,1)/C-1>=NE-0.01/REF(C,1) AND L=C AND PERIOD=5;

STICKLINE(跌停,C,O,-1,0),COLOR00FF00;

曾涨停:=H/REF(C,1)-1>=NE-0.01/REF(C,1) AND C<H AND PERIOD=5;

STICKLINE(曾涨停,H-(H-MAX(O,C)),H,0,0),COLORFF00B5;

曾跌停:=REF(C,1)/L-1>=NE-0.01/REF(C,1) AND L<C AND PERIOD=5;

STICKLINE(曾跌停,L+(MIN(O,C)-L),L,0,0),COLOR00BB00;

涨停开盘:=O/REF(C,1)-1>=NE-0.01/REF(C,1) AND O=H AND PERIOD=5;{阴阳线的十分之一变色}

STICKLINE(涨停开盘,C+(O-C)*0.9,O,-1,0),COLORFF00F5;

跌停开盘:=REF(C,1)/O-1>=NE-0.01/REF(C,1) AND L=O AND PERIOD=5;

STICKLINE(跌停开盘,C-(C-O)*0.9,O,-1,0),COLOR00FF00;

总市值:=STRCAT(STRCAT('市值 ',CON2STR((TOTALCAPITAL/1000000)*C,0)),'亿   ');

流通值:=STRCAT(STRCAT('流通 ',CON2STR((CAPITAL/1000000)*C,0)),'亿');

DRAWTEXT_FIX(ISLASTBAR,0.005,0.04,0,STRCAT(HYBLOCK,STRCAT(' ',GNBLOCK))),COLORFFAA00;

DRAWTEXT_FIX(ISLASTBAR,0.005,0.10,0,STRCAT(总市值,流通值)),COLORFFAA00;

涨股:=STRCAT(CON2STR(DYNAINFO(60),0),'股上涨');

跌股:=STRCAT(CON2STR(DYNAINFO(61),0),'股下跌');

DRAWTEXT_FIX(ISLASTBAR,0.8,0.86,0,涨股),COLOR3030FF;

DRAWTEXT_FIX(ISLASTBAR,0.8,0.92,0,跌股),COLORGREEN;



0% (0)
0% (10)

关于通达信主图叠加重要个股信息的评论:

 以下是对 [通达信主图叠加重要个股信息] 的评论,总共:0条评论
加入收藏 | 联系我们 | 免责声明 | 站内地图 | 关于我们