买好股公式网 > 股票公式 > 通达信公式 > 通达信黄金操盘手主图指标公式无未来

通达信黄金操盘手主图指标公式无未来

2017年03月26日人气:Tags:通达信 操盘 主图 指标 公式


高点:=22;低点:=9;

GD:=CONST(FINDHIGH(H,0,高点*10,1));

DD:=CONST(FINDLOW(L,0,低点*10,1));

GT:=CONST(BARSLAST(GD=H))+1;

DT:=CONST(BARSLAST(DD=L))+1;

SH:=CONST(IF(GT=1,H,REF(H,GT-1)));

SL:=CONST(IF(DT=1,L,REF(L,DT-1)));

CC:=IF(DT>GT,DT,GT);

CD:=INTPART(CC-(DT+GT)/2);

CG:=IF(高点>CD,CD/2,高点);

ZG:=IF(CURRBARSCOUNT<=CD,SH,DRAWNULL);

DRAWBAND(ZG,RGB(0,0,0),ZG,RGB(0,0,0)),DOTLINE,COLORLIRED;

ZD:=IF(CURRBARSCOUNT<=CD,SL,DRAWNULL);

DRAWBAND(ZD,RGB(0,0,0),ZD,RGB(0,0,0)),DOTLINE,COLORLIRED;

X191:=IF(CURRBARSCOUNT<=CD,SH-(SH-SL)*0.191,DRAWNULL);

DRAWBAND(X191,RGB(0,0,0),X191,RGB(0,0,0)),DOTLINE,COLORLIRED;

X382:=IF(CURRBARSCOUNT<=CD,SH-(SH-SL)*0.382,DRAWNULL);

DRAWBAND(X382,RGB(0,0,0),X382,RGB(0,0,0)),DOTLINE,COLORLIRED;

X500:=IF(CURRBARSCOUNT<=CD,SH-(SH-SL)*0.500,DRAWNULL);

DRAWBAND(X500,RGB(0,0,0),X500,RGB(0,0,0)),DOTLINE,COLORRED;

X618:=IF(CURRBARSCOUNT<=CD,SH-(SH-SL)*0.618,DRAWNULL);

DRAWBAND(X618,RGB(0,0,0),X618,RGB(0,0,0)),DOTLINE,COLORLIRED;

X809:=IF(CURRBARSCOUNT<=CD,SH-(SH-SL)*0.809,DRAWNULL);

DRAWBAND(X809,RGB(0,0,0),X809,RGB(0,0,0)),DOTLINE,COLORLIRED;

DRAWTEXT(CURRBARSCOUNT=CG,(ZD)*1.02,STRCAT('起点:  ',CON2STR(ZD,2))),COLORLIGRAY;

DRAWTEXT(CURRBARSCOUNT=CG,(X191)*0.986,STRCAT('80.9%  ',CON2STR(X191,2))),COLORLIGRAY;

DRAWTEXT(CURRBARSCOUNT=CG,(X382)*0.985,STRCAT('61.8%  ',CON2STR(X382,2))),COLORLIGRAY;

DRAWTEXT(CURRBARSCOUNT=CG,(X500)*0.984,STRCAT('50%  ',CON2STR(X500,2))),COLORLIGRAY;

DRAWTEXT(CURRBARSCOUNT=CG,(X618)*0.982,STRCAT('38.2%  ',CON2STR(X618,2))),COLORLIGRAY;

DRAWTEXT(CURRBARSCOUNT=CG,(X809)*0.98,STRCAT('19.1%  ',CON2STR(X809,2))),COLORLIGRAY;

DRAWTEXT(CURRBARSCOUNT=CG,(ZG)*0.98,STRCAT('100%  ',CON2STR(ZG,2))),COLORLIGRAY;

DRAWTEXT(CURRBARSCOUNT=GT-2 ,L*0.98,'3'),COLOR00FF00;

DRAWTEXT(CURRBARSCOUNT=GT-4 ,L*0.98,'5'),COLOR00FF00;

DRAWTEXT(CURRBARSCOUNT=GT-7 ,L*0.98,'8'),COLOR00FF00;

DRAWTEXT(CURRBARSCOUNT=GT-12 ,L*0.98,'13'),COLOR00FF00;

DRAWTEXT(CURRBARSCOUNT=GT-20 ,L*0.98,'21'),COLOR00FF00;

DRAWTEXT(CURRBARSCOUNT=GT-33 ,L*0.98,'34 '),COLOR00FF00;

DRAWTEXT(CURRBARSCOUNT=GT-54 ,L*0.98,'55'),COLOR00FF00;

DRAWTEXT(CURRBARSCOUNT=GT-88 ,L*0.98,'89'),COLOR00FF00;

DRAWTEXT(CURRBARSCOUNT=GT-143 ,L*0.98,'144'),COLOR00FF00;

DRAWTEXT(CURRBARSCOUNT=GT-232 ,L*0.98,'233'),COLOR00FF00;

DRAWTEXT(CURRBARSCOUNT=GT-376 ,L*0.98,'377'),COLOR00FF00;



DRAWTEXT(CURRBARSCOUNT=DT-2,H,'3'),DRAWABOVE,COLORRED;

DRAWTEXT(CURRBARSCOUNT=DT-4,H,'5'),DRAWABOVE,COLORRED;

DRAWTEXT(CURRBARSCOUNT=DT-7,H,'8'),DRAWABOVE,COLORRED;

DRAWTEXT(CURRBARSCOUNT=DT-12,H,'13'),DRAWABOVE,COLORRED;

DRAWTEXT(CURRBARSCOUNT=DT-20,H,'21'),DRAWABOVE,COLORRED;

DRAWTEXT(CURRBARSCOUNT=DT-33,H,'34'),DRAWABOVE,COLORRED;

DRAWTEXT(CURRBARSCOUNT=DT-54,H,'55'),DRAWABOVE,COLORRED;

DRAWTEXT(CURRBARSCOUNT=DT-88,H,'89'),DRAWABOVE,COLORRED;

DRAWTEXT(CURRBARSCOUNT=DT-143,H,'144'),DRAWABOVE,COLORRED;

DRAWTEXT(CURRBARSCOUNT=DT-232,H,'233'),DRAWABOVE,COLORRED;

DRAWTEXT(CURRBARSCOUNT=DT-376,H,'377'),DRAWABOVE,COLORRED;

通达信黄金操盘手主图指标公式无未来

打赏好指标 ×

关于通达信黄金操盘手主图指标公式无未来的评论:

 以下是对 [通达信黄金操盘手主图指标公式无未来] 的评论,总共:0条评论
加入收藏 | 联系我们 | 免责声明 | 站内地图 | 关于我们