买好股公式网 > 股票公式 > 通达信公式 > 龙头爆涨主图指标源码

龙头爆涨主图指标源码

2022年08月29日人气:Tags:主图 指标

VAR1:=(COST(90+(100-90)/2)-COST((100-90)/2))/(COST(90+(100-90)/2)+COST((100-90)/2))+CLOSE;

VAR2:=REF(HHV(VAR1,20),0);

STICKLINE(VAR1>CLOSE,VAR2,VAR1,2,0),COLORGRAY;

STICKLINE(VAR1>CLOSE,VAR2,VAR1,1,0),COLORBLACK;

STICKLINE(VAR1>CLOSE,VAR2,VAR1,0.5,0),COLORGRAY;

STICKLINE(VAR1>REF(VAR1,1),VAR1,VAR2,2,0),COLOR1388A3;

STICKLINE(VAR1>REF(VAR1,1),VAR1,VAR2,1,0),COLORBLACK;

STICKLINE(VAR1>REF(VAR1,1),VAR1,VAR2,0.5,0),COLOR1388A3;

VAR3:=MA(CLOSE,5);

VAR4:=MA(CLOSE,10);

VAR5:=MA(CLOSE,20);

VAR6:=MA(CLOSE,30);

VAR7:=MA(CLOSE,250);

VAR8:=BARSLAST(CROSS(VAR3,VAR4));

VAR9:=BARSLAST(CROSS(VAR4,VAR3));

VAR10:=IF(VAR8<VAR9,VAR8+1,0);

VAR11:=IF(VAR9<VAR8,VAR9+1,0);

VAR12:=VAR3>VAR5 AND VAR4>VAR5 AND VAR5>REF(VAR5,1) AND VAR6>REF(VAR6,1);

VAR13:=VAR10*VAR12;

VAR14:=VAR11*VAR12;

VAR15:=HHV(VAR10,5)>=2 AND VAR12 AND VAR3>REF(VAR3,1) AND VAR3>VAR4;

VAR16:=VAR15*VAR10;

VAR17:=BARSLAST(VAR16>0 AND NOT(REF(VAR16,1)))+1;

VAR18:=(CLOSE/REF(CLOSE,VAR17)-1)*100;

空中加油:=VAR13>0 AND VAR16=0,POINTDOT,COLORGREEN,LINETHICK0;

VAR19:=BARSLAST(空中加油)+1;

VAR20:=ATAN((VAR3/REF(VAR3,1)-1)*100)*180/3.14159;

VAR21:=VAR20>REF(VAR20,1) AND REF(VAR20,1)<REF(VAR20,2);

VAR22:=VAR3>REF(VAR3,1) AND REF(VAR3,1)<REF(VAR3,2);

加速远航:=FILTER(VAR21 OR VAR22 AND CLOSE>VAR3 AND VAR15,3),POINTDOT,COLORYELLOW,LINETHICK0;

VAR23:=BARSLAST(加速远航);

STICKLINE(空中加油,(OPEN+CLOSE)/2-0.01,(OPEN+CLOSE)/2+0.01,4,0),COLORGREEN;

STICKLINE(空中加油,LOW,HIGH,1,1),COLORGREEN;

STICKLINE(加速远航,(OPEN+CLOSE)/2-0.01,(OPEN+CLOSE)/2+0.01,4,0),COLORYELLOW;

STICKLINE(加速远航,LOW,HIGH,1,1),COLORYELLOW;

STICKLINE(VAR23>0 AND VAR23<=5,REF(OPEN,VAR23+1),REF(OPEN,VAR23+1),4,1),COLORWHITE;

DRAWTEXT(加速远航,LOW,116),COLORYELLOW;

DRAWTEXT(VAR16,VAR6,117),COLORWHITE;

DRAWTEXT(空中加油,VAR6,118),COLORGREEN;

VAR24:=SUMBARS(VOL,CAPITAL*1);

VAR25:=SUM((COST(20)+COST(80))/2,VAR24)/VAR24;

VAR26:=SUM((COST(30)+COST(70))/2,VAR24)/VAR24;

VAR27:=SUM((COST(40)+COST(60))/2,VAR24)/VAR24;

VAR28:=SUM((COST(10)+COST(90))/2,VAR24)/VAR24;

VAR29:=SUM(COST(50),VAR24)/VAR24;

VAR30:=LLV(LOW,250)=LOW;

VAR31:=BARSLAST(VAR30);

KOLD:(5*VAR26+4*VAR25+3*VAR27+2*VAR28+VAR29)/15,CIRCLEDOT,COLORBROWN;

STICKLINE(CROSS(CLOSE,KOLD) AND VAR31>=60,OPEN,CLOSE,5,0),COLORYELLOW;

龙头暴涨:=CROSS(CLOSE,KOLD),COLORMAGENTA;

DRAWICON(龙头暴涨,CLOSE*1.08,18);

JJ1:MA(CLOSE,30);

VAR32:=MA(CLOSE,60);

入1:IF(JJ1>REF(JJ1,1),JJ1,DRAWNULL),COLORRED,LINETHICK2;

入2:IF(JJ1<REF(JJ1,1),JJ1,DRAWNULL),COLORGREEN,LINETHICK2;

DRAWKLINE(HIGH,OPEN,LOW,CLOSE);

VAR33:=(HIGH+LOW+CLOSE)/3;

VAR34:=VOL/IF(HIGH=LOW,4,HIGH-LOW);

VAR35:=IF(CAPITAL=0,VAR34*(VAR33-MIN(CLOSE,OPEN)),VAR34*IF(HIGH=LOW,1,MIN(OPEN,CLOSE)-LOW));

VAR36:=IF(CAPITAL=0,VAR34*(MIN(OPEN,CLOSE)-LOW),VAR34*IF(HIGH=LOW,1,VAR33-MIN(CLOSE,OPEN)));

VAR37:=IF(CAPITAL=0,VAR34*(HIGH-MAX(OPEN,CLOSE)),VAR34*IF(HIGH=LOW,1,HIGH-MAX(OPEN,CLOSE)));

VAR38:=IF(CAPITAL=0,VAR34*(MAX(CLOSE,OPEN)-VAR33),VAR34*IF(HIGH=LOW,1,MAX(CLOSE,OPEN)-VAR33));

VAR39:=(VAR35+VAR36-(VAR37+VAR38))/IF(CAPITAL=0,10000,10000);

VAR40:=SMA(IF(CLOSE>=REF(CLOSE,1),VAR39,(-VAR39)/100),2,1);

VAR41:=SMA(VAR40*120/FROMOPEN*5,2,1);

VAR42:=SMA(VAR41,5,1);

VAR43:=SMA(VAR42,5,1);

VAR44:=CURRBARSCOUNT=1 AND CLOSE<REF(CLOSE,1);

VAR45:=REF(VAR40,1)-VAR44;

VAR46:=VAR40*1.01-REF(VAR40,1);

VAR47:=REF(VAR40*1.01,1)-REF(VAR40,2);

VAR48:=VAR46>3*ABS(VAR47);

VAR49:=EMA(VAR40,15);

VAR50:=COST(85);

VAR51:=COST(15);

VAR52:=VAR50-VAR51;

VAR53:=(VAR50+VAR51)/2;

VAR54:=VAR52/VAR53*100<30;

VAR55:=HHV(HIGH,250);

VAR56:=LLV(LOW,250);

VAR57:=VAR55-VAR56;

VAR58:=VAR53-VAR56;

VAR59:=VAR53<VAR57*4+VAR56;

VAR60:=VAR54 AND VAR59;

VAR61:=CLOSE/REF(CLOSE,1)>1.04;

VAR62:=EMA(100*(CLOSE-LLV(LOW,30))/(HHV(HIGH,30)-LLV(LOW,30)),3);

VAR63:=VAR62>=75 AND CLOSE>0 AND CLOSE>OPEN;

筹码强势突破:=VAR63 AND VAR60 AND VAR58 AND WINNER(CLOSE)>=0.9 AND VAR61,COLORMAGENTA;

筹码集中买入:=VAR60 AND VAR46>0 AND CROSS(VAR46,VAR49) AND VAR48 AND WINNER(CLOSE)>=0.9;

DRAWICON(筹码强势突破,LOW,26);

DRAWICON(筹码集中买入,LOW*0.99,25);

DRAWTEXT(筹码强势突破,LOW,120),COLORMAGENTA;

DRAWTEXT(筹码集中买入,LOW*0.97,121),COLORGREEN;

VAR64:=1.1*CLOSE;

VAR65:=0.9*CLOSE;

VAR66:=100*(WINNER(VAR64)-WINNER(VAR65));

VAR67:=100-VAR66;

VAR68:=MA(CLOSE,13)<REF(MA(CLOSE,13),1);

VAR69:=CROSS(VAR67,90) AND VAR68 AND DATE<1220630;

VAR70:=CLOSE>OPEN AND COUNT(VAR69,10)>0;

VAR71:=VAR70 AND COUNT(VAR70,4)=1 AND DATE<1220630;

DRAWICON(VAR69,LOW,3);

DRAWICON(VAR71,LOW,9);

STICKLINE(VAR1=VAR2,OPEN,CLOSE,3,0),COLOR009999;

STICKLINE(VAR1=VAR2,OPEN,CLOSE,2,0),COLOR00DDDD;

STICKLINE(VAR1=VAR2,OPEN,CLOSE,1,0),COLORYELLOW;

STICKLINE(VAR1=VAR2,OPEN,CLOSE,0.5,0),COLORYELLOW;

STICKLINE(VAR1=VAR2,OPEN,CLOSE,0.2,0),COLORYELLOW;

{龙头爆涨主图指标源码}

打赏好指标 ×

关于龙头爆涨主图指标源码的评论:

 以下是对 [龙头爆涨主图指标源码] 的评论,总共:0条评论
加入收藏 | 联系我们 | 免责声明 | 站内地图 | 关于我们