买好股公式网 > 股票公式 > 通达信公式 > 趋势价副图指标源码

趋势价副图指标源码

2022年11月29日人气:Tags:趋势 副图 指标

ZZ50:50,DOTLINE;

高1:=50;高2:=55;高3:=60;高4:=65;高5:=70;高6:=75;高7:=80;高8:=85;高9:=90;

低1:=100-高1;低2:=100-高2;低3:=100-高3;低4:=100-高4;低5:=100-高5;低6:=100-高6;低7:=100-高7;低8:=100-高8;低9:=100-高9;

CLOH6:=(3*CLOSE+LOW+OPEN+HIGH)/6;

趋势价无BS:=(22*CLOH6+21*REF(CLOH6,1)+20*REF(CLOH6,2)+19*REF(CLOH6,3)+18*REF(CLOH6,4)+17*REF(CLOH6,5)+16*REF(CLOH6,6)+15*REF(CLOH6,7)+14*REF(CLOH6,8)+13*REF(CLOH6,9)+12*REF(CLOH6,10)+11*REF(CLOH6,11)+10*REF(CLOH6,12)+9*REF(CLOH6,13)+8*REF(CLOH6,14)+7*REF(CLOH6,15)+6*REF(CLOH6,16)+5*REF(CLOH6,17)+4*REF(CLOH6,18)+3*REF(CLOH6,19)+2*REF(CLOH6,20)+1*REF(CLOH6,21)+REF(CLOH6,26))/253;

主成本1:=EMA(CLOSE,21)*0.5+COST(30)*0.5,COLORAE00AE,LINETHICK1;

主成本:=IF(EMA(趋势价无BS,13)>0,EMA(趋势价无BS,13),主成本1),,COLORAE00AE,LINETHICK2;

做多线:=SMA((CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100,5,1)-8,COLORRED,LINETHICK2;

做空价差:=(HHV(HIGH,36)-CLOSE)/(HHV(HIGH,36)-LLV(LOW,36))*100;

空主线:SMA(做空价差,3,1),COLORGREEN,LINETHICK2;

STICKLINE(CROSS(做多线,空主线),高5,高5+5,10,0),COLOR0000FF;

STICKLINE(CROSS(空主线,做多线),低5,低5-5,10,0),COLOR005F61;

DRAWTEXT(CROSS(做多线,空主线),高5+3,'能'),COLOR0000FF;

DRAWTEXT(CROSS(空主线,做多线),低5-3,'能'),COLOR005F61;

获利:=WINNER(C)*100,COLOR9F35FF,LINETHICK1;

STICKLINE(COUNT(获利>99.99,9)<1 AND 获利>78,高6,高6+5,10,0),COLOR8117A1;

DRAWTEXT(COUNT(获利>99.99,9)<1 AND 获利>78,高6+3,'获'),COLOR8117A1;

妖股线:=EMA((CLOSE-MA((2*CLOSE+HIGH+LOW)/4,30))/MA((2*CLOSE+HIGH+LOW)/4,30)*100,3);

STICKLINE(CROSS(妖股线,15),高7,高7+5,10,0),COLOR5B00AE;

STICKLINE(CROSS(15,妖股线),低7,低7-5,10,0),COLOR006300;

DRAWTEXT(CROSS(妖股线,15),高7+3,'妖'),COLOR5B00AE;

DRAWTEXT(CROSS(15,妖股线),低7-3,'妖'),COLOR006300;

EIN139:=EMA(INDEXC,139)/MA(CLOSE,139);

大盘139:=EMA(INDEXC/EIN139,22);

大盘线:=IF(大盘139>0,IF(大盘139<COST(0.1)*0.8,COST(0.1)*0.8,大盘139),主成本),COLOR191970,LINETHICK1;

STICKLINE(CROSS(主成本,大盘线),高8,高8+5,10,0),COLOREE66DD;

STICKLINE(CROSS(大盘线,主成本),低8,低8-5,10,0),COLORGREEN;

DRAWTEXT(CROSS(主成本,大盘线),高8+3,'盘'),COLOREE66DD;

DRAWTEXT(CROSS(大盘线,主成本),低8-3,'盘'),COLORGREEN;

{趋势价副图指标源码}

打赏好指标 ×

关于趋势价副图指标源码的评论:

 以下是对 [趋势价副图指标源码] 的评论,总共:0条评论
加入收藏 | 联系我们 | 免责声明 | 站内地图 | 关于我们