买好股公式网 > 股票公式 > 通达信公式 > 通达信寻底寻庄选股公式源码

通达信寻底寻庄选股公式源码

2019年05月26日 字体: 人气:

通达信寻底寻庄选股公式源码





均价:=(2*C+(C+H+L+O)/4+O)/4;

R:=(3*L+2*均价)/5;R1:=(3*H+2*均价)/5;

KX:=(R+R1)/2;

跟庄线:=WMA(SUM(KX*V,4)/SUM(V,4),4);

RD:=(R1+H)/1.56;

寻庄1:=55*RD+54*REF(RD,1)+53*REF(RD,2)+52*REF(RD,3)+51*REF(RD,4)+50*REF(RD,5)+49*REF(RD,6)+48*REF(RD,7)+47*REF(RD,8)+46*REF(RD,9);

寻庄2:=45*REF(RD,10)+44*REF(RD,11)+43*REF(RD,12)+42*REF(RD,13)+41*REF(RD,14)+40*REF(RD,15)+39*REF(RD,16)+38*REF(RD,17)+37*REF(RD,18)+36*REF(RD,19);

寻庄3:=35*REF(RD,20)+34*REF(RD,21)+33*REF(RD,22)+32*REF(RD,23)+31*REF(RD,24)+30*REF(RD,25)+29*REF(RD,26)+28*REF(RD,27)+27*REF(RD,28)+26*REF(RD,29);

寻庄4:=25*REF(RD,30)+24*REF(RD,31)+23*REF(RD,32)+22*REF(RD,33)+21*REF(RD,34)+20*REF(RD,35)+19*REF(RD,36)+18*REF(RD,37)+17*REF(RD,38)+16*REF(RD,39);

寻庄5:=15*REF(RD,40)+14*REF(RD,41)+13*REF(RD,42)+12*REF(RD,43)+11*REF(RD,44)+10*REF(RD,45)+9*REF(RD,46)+8*REF(RD,47)+7*REF(RD,48)+6*REF(RD,49);

寻庄6:=5*REF(RD,50)+4*REF(RD,51)+3*REF(RD,52)+2*REF(RD,53)+1*REF(RD,54);

寻庄7:=寻庄1+寻庄2+寻庄3+寻庄4+寻庄5+寻庄6;

寻庄:=寻庄7/1765;

寻底1:=55*R+54*REF(R,1)+53*REF(R,2)+52*REF(R,3)+51*REF(R,4)+50*REF(R,5)+49*REF(R,6)+48*REF(R,7)+47*REF(R,8)+46*REF(R,9);

寻底2:=45*REF(R,10)+44*REF(R,11)+43*REF(R,12)+42*REF(R,13)+41*REF(R,14)+40*REF(R,15)+39*REF(R,16)+38*REF(R,17)+37*REF(R,18)+36*REF(R,19);

寻底3:=35*REF(R,20)+34*REF(R,21)+33*REF(R,22)+32*REF(R,23)+31*REF(R,24)+30*REF(R,25)+29*REF(R,26)+28*REF(R,27)+27*REF(R,28)+26*REF(R,29);

寻底4:=25*REF(R,30)+24*REF(R,31)+23*REF(R,32)+22*REF(R,33)+21*REF(R,34)+20*REF(R,35)+19*REF(R,36)+18*REF(R,37)+17*REF(R,38)+16*REF(R,39);

寻底5:=15*REF(R,40)+14*REF(R,41)+13*REF(R,42)+12*REF(R,43)+11*REF(R,44)+10*REF(R,45)+9*REF(R,46)+8*REF(R,47)+7*REF(R,48)+6*REF(R,49);

寻底6:=5*REF(R,50)+4*REF(R,51)+3*REF(R,52)+2*REF(R,53)+1*REF(R,54);

寻底7:=寻底1+寻底2+寻底3+寻底4+寻底5+寻底6;

寻底:=寻底7/1765;

寻庄黄金:=(寻底+寻庄)/2;

DD:=ABS(跟庄线-MA(寻庄黄金,60))/MA(寻庄黄金,60);

黄龙:=DMA(寻庄黄金,DD);

遁地:=黄龙*(1-14/100);

反转:=INTPART(KX);

LC := REF(KX,1);

RS1:=SMA(MAX(KX-LC,0),11,1);

RS2:=SMA(ABS(KX-LC),11,1);

天使:=(RS1*8*4)-(RS2*8);

唇吻:=WMA((RS2*8/4)-(RS1*8),3);

XG:CROSS(天使,唇吻)AND REF(反转,1)<遁地;


0% (0)
0% (10)

关于通达信寻底寻庄选股公式源码的评论:

 以下是对 [通达信寻底寻庄选股公式源码] 的评论,总共:0条评论
加入收藏 | 联系我们 | 免责声明 | 站内地图 | 关于我们