买好股公式网 > 股票公式 > 通达信公式 > 通达信波浪线副图指标公式

通达信波浪线副图指标公式

2019年02月11日 字体: 人气:

通达信波浪线副图指标公式


VAR1:=(HIGH+LOW+CLOSE)/3;

VAR2:=(VAR1-MA(VAR1,14))/(0.015*AVEDEV(VAR1,14));

VAR3:=(VAR1-MA(VAR1,70))/(0.015*AVEDEV(VAR1,70));

VAR4:=IF(VAR2>=150 AND VAR2<200 AND VAR3>=150 AND VAR3<200,-10,0);

VAR5:=IF(VAR2<=-150 AND VAR2>-200 AND VAR3<=-150 AND VAR3>-200,10,0);

天线:IF(BARSCOUNT(CLOSE)<70,120,IF(VAR3>=200 AND VAR2>=150,-15,VAR4)+120),LINETHICK2,COLORCCFF66;

地线:IF(BARSCOUNT(CLOSE)<70,-120,IF(VAR3<=-200 AND VAR2<=-150,15,VAR5)-120),LINETHICK2,COLORFF99CC;

VAR6:=SMA((CLOSE-LLV(LOW,10))/(HHV(HIGH,10)-LLV(LOW,10))*100,4,1);

SMA((VAR6-50)*2,3,1),LINETHICK2,COLORFF0033;

VAR7:=SMA((CLOSE-LLV(LOW,11))/(HHV(HIGH,11)-LLV(LOW,11))*100,4,1);

SMA((VAR7-50)*2,3,1),LINETHICK2,COLORFF2233;

(SMA((VAR7-50)*2,3,1)+SMA((VAR6-50)*2,3,1))/2,LINETHICK2,COLORFF4433;

VAR8:=SMA((CLOSE-LLV(LOW,12))/(HHV(HIGH,12)-LLV(LOW,12))*100,4,1);

SMA((VAR8-50)*2,3,1),LINETHICK2,COLORFF6633;

(SMA((VAR8-50)*2,3,1)+SMA((VAR7-50)*2,3,1))/2,LINETHICK2,COLORFF8833;

VAR9:=SMA((CLOSE-LLV(LOW,13))/(HHV(HIGH,13)-LLV(LOW,13))*100,4,1);

VARA:SMA((VAR9-50)*2,3,1),LINETHICK2,COLORFF9933; 

(SMA((VAR9-50)*2,3,1)+SMA((VAR8-50)*2,3,1))/2,LINETHICK2,COLORFFAA33;

VAR10:=SMA((CLOSE-LLV(LOW,14))/(HHV(HIGH,14)-LLV(LOW,14))*100,4,1);

SMA((VAR10-50)*2,3,1),LINETHICK2,COLORFFBB33;

VAR11:=SMA((CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100,4,1);

波浪线:SMA((VAR11-50)*2,3,1)+SMA((VAR10-50)*2,3,1)/2,LINETHICK2,COLORGREEN;

(SMA((VAR10-50)*2,3,1)+SMA((VAR9-50)*2,3,1))/2,LINETHICK2,COLORFFCC33;

波浪线,COLORSTICK,COLOR888888;

VAR12:=(VAR11-50)*6-2*SMA((VAR11-50)*2,3,1);

VAR13:=FILTER(波浪线>REF(波浪线,1)AND 波浪线<-20,10);

VAR14:=FILTER(波浪线<REF(波浪线,3)AND 波浪线>REF(波浪线,1)AND 波浪线<-10,7);

VAR15:=FILTER(波浪线<REF(波浪线,1),10);

VAR16:=FILTER(波浪线<REF(波浪线,1)AND 波浪线>110,10);

VAR17:=VAR11<REF(VAR11,3)AND VAR11>REF(VAR11,2)AND VAR11<30;

DRAWICON(FILTER(VAR13 OR VAR14 OR VAR17,5)AND VARA>REF(VARA,1),波浪线,1);

DRAWICON(FILTER(CROSS(波浪线,VAR12)OR VAR15,5)AND VAR12>60,波浪线*1.05,2);

DRAWTEXT(FILTER(CROSS(100,波浪线)OR VAR16,3),110,'顶部'),COLOR00FF00;

DRAWTEXT(CROSS(波浪线,地线),地线,'抄底'),COLORRED;


0% (0)
0% (10)

关于通达信波浪线副图指标公式的评论:

 以下是对 [通达信波浪线副图指标公式] 的评论,总共:0条评论
加入收藏 | 联系我们 | 免责声明 | 站内地图 | 关于我们