买好股公式网 > 股票公式 > 通达信公式 > 完整财务信息的好股主图公式源码

完整财务信息的好股主图公式源码

2018年10月30日 字体: 人气:

完整财务信息的好股主图公式源码


MA1:MA(CLOSE,5);

MA2:MA(CLOSE,10);

MA3:MA(CLOSE,20);

MA4:MA(CLOSE,60);

五日换手:SUM(HSL,5),NODRAW;

十日换手:SUM(HSL,10),NODRAW;

二十日换手:SUM(HSL,20),NODRAW;

三十日换手:SUM(HSL,30),NODRAW;

STICKLINE(V>=REF(V,1)*2,O,C,3,0)COLORYELLOW;

STICKLINE(V>=REF(V,1)*2,H,L,0,0)COLORYELLOW;

STICKLINE(C/REF(C,1)>=1.098,O,C,3,0)COLORRED;

STICKLINE(C/REF(C,1)>=1.098,H,L,0,0)COLORRED;

STICKLINE(C/REF(C,1)<=0.901,O,C,3,0)COLORBLUE;

STICKLINE(C/REF(C,1)<=0.901,H,L,0,0)COLORBLUE;

品种类型:=FINANCE(3);

所属板块:=HYBLOCK;

上市天数:=FINANCE(42);

股总市值:=ROUND(FINANCE(41)/100000000);

流通市值:=ROUND(FINANCE(40)/100000000);

股东人数:=FINANCE(8);

人均持股:=ROUND(FINANCE(7)/FINANCE(8));

DRAWTEXT_FIX(1,0.008,0.01,0,'基本资料:'),COLORLIBLUE;

DRAWTEXT_FIX(1,0.008,0.05,0,'上市天数:'),COLORLIGREEN;

DRAWTEXT_FIX(1,0.008,0.09,0,'股东人数:'),COLORLIGREEN;

DRAWTEXT_FIX(1,0.008,0.13,0,'人均持股:'),COLORLIGREEN;

DRAWTEXT_FIX(1,0.008,0.17,0,'品种类型:'),COLORLIGREEN;

DRAWTEXT_FIX(1,0.008,0.25,0,'行业板块:'),COLORLIGREEN;

DRAWTEXT_FIX(品种类型=1,0.066,0.17,0,'沪 深 A 股'),COLORYELLOW;

DRAWTEXT_FIX(品种类型=2,0.066,0.17,0,'  中 小 板'),COLORYELLOW;

DRAWTEXT_FIX(品种类型=3,0.066,0.17,0,'  创 业 板'),COLORYELLOW;

DRAWTEXT_FIX(1,0.068,0.25,0,HYBLOCK),COLORYELLOW;{行业板块}

DRAWTEXT_FIX(1,0.068,0.05,0,CON2STR(上市天数,0)),COLORWHITE;{数值}

DRAWTEXT_FIX(1,0.068,0.09,0,CON2STR(股东人数,0)),COLORWHITE;

DRAWTEXT_FIX(1,0.068,0.13,0,CON2STR(人均持股,0)),COLORWHITE;

DRAWTEXT_FIX(1,0.110,0.05,0,'天'),COLORWHITE;{单位}

DRAWTEXT_FIX(1,0.110,0.09,0,'人'),COLORWHITE;

DRAWTEXT_FIX(1,0.110,0.13,0,'股'),COLORWHITE;

DRAWTEXT_FIX(1,0.008,0.21,0,'地区板块:')COLORLIGREEN;{所属板块}

DRAWTEXT_FIX(1,0.068,0.21,0,DYBLOCK)COLORCYAN;

DRAWTEXT_FIX(1,0.136,0.25,0,'概念板块:')COLORLIGREEN;

DRAWTEXT_FIX(1,0.196,0.25,0,GNBLOCK)COLORCYAN;

DRAWTEXT_FIX(1,0.008,0.29,0,'风格板块:')COLORLIGREEN;

DRAWTEXT_FIX(1,0.068,0.29,0,FGBLOCK)COLORCYAN;

{财务(1)}

净资收益率:=(FINANCE(33)/FINANCE(34)*100);

主营利润率:=(FINANCE(23)/FINANCE(20)*100);

现金负债比:=(FINANCE(25)/FINANCE(15));

主营收入同比:=FINANCE(44);{主营收入同比增长率}

净利润同比:=FINANCE(43);{净利润同比增长率}

DRAWTEXT_FIX(1,0.133,0.01,0,'财务资料(1):'),COLORLIBLUE;

DRAWTEXT_FIX(1,0.133,0.05,0,'净资产收益率:'),COLORLIGREEN;

DRAWTEXT_FIX(1,0.133,0.09,0,'主营业务利润率:'),COLORLIGREEN;

DRAWTEXT_FIX(1,0.133,0.13,0,'现金流动负债比:'),COLORLIGREEN;

DRAWTEXT_FIX(1,0.133,0.17,0,'主营收入同比:'),COLORLIGREEN;

DRAWTEXT_FIX(1,0.133,0.21,0,'净利润同比:'),COLORLIGREEN;

DRAWTEXT_FIX(1,0.226,0.05,0,STRCAT(VAR2STR(净资收益率,2),' %')),COLORCYAN;

DRAWTEXT_FIX(1,0.226,0.09,0,STRCAT(VAR2STR(主营利润率,2),' %')),COLORCYAN;

DRAWTEXT_FIX(1,0.226,0.13,0,CON2STR(现金负债比,2)),COLORCYAN;

DRAWTEXT_FIX(1,0.226,0.17,0,STRCAT(VAR2STR(主营收入同比,0),' %')),COLORCYAN;

DRAWTEXT_FIX(1,0.226,0.21,0,STRCAT(VAR2STR(净利润同比,0),' %')),COLORCYAN;

{财务(2)}

每股收益:=CONST(FINANCE(38));{近期}{每股税后利润}

每股收益年:=CONST(FINANCE(33));

每股净资产:=CONST(FINANCE(34));

每股现金流:=CONST((FINANCE(25)/FINANCE(1)));

每股未分配:=CONST(FINANCE(32));

每股公积金:=CONST(FINANCE(18));

DRAWTEXT_FIX(1,0.285,0.01,0,'财务资料(2):'),COLORLIBLUE;

DRAWTEXT_FIX(1,0.285,0.05,0,'每股收益(近):'),COLORLIGREEN;

DRAWTEXT_FIX(1,0.285,0.09,0,'每股收益年:'),COLORLIGREEN;

DRAWTEXT_FIX(1,0.285,0.13,0,'每股净资产:'),COLORLIGREEN;

DRAWTEXT_FIX(1,0.285,0.17,0,'每股未分配:'),COLORLIGREEN;

DRAWTEXT_FIX(1,0.285,0.21,0,'每股公积金:'),COLORLIGREEN;

DRAWTEXT_FIX(1,0.386,0.05,1,CON2STR(每股收益,2)),COLORCYAN;

DRAWTEXT_FIX(1,0.386,0.09,1,CON2STR(每股收益年,2)),COLORCYAN;

DRAWTEXT_FIX(1,0.386,0.13,1,CON2STR(每股净资产,2)),COLORCYAN;

DRAWTEXT_FIX(1,0.386,0.17,1,CON2STR(每股未分配,2)),COLORCYAN;

DRAWTEXT_FIX(1,0.386,0.21,1,CON2STR(每股公积金,2)),COLORCYAN;

{财务(3)}

市盈率:=DYNAINFO(39);

市销率:=CONST(FINANCE(1)*DYNAINFO(7)/FINANCE(20));

市净率:=CONST(DYNAINFO(7) / FINANCE(34));

毛利率:=((FINANCE(20)-FINANCE(21))/FINANCE(20)*100);

净利润率:=CONST(FINANCE(30)/FINANCE(20));

DRAWTEXT_FIX(1,0.406,0.01,0,'财务资料(3):'),COLORLIBLUE;

DRAWTEXT_FIX(1,0.406,0.05,0,'市盈率:'),COLORLIGREEN;

DRAWTEXT_FIX(1,0.406,0.09,0,'市销率:'),COLORLIGREEN;

DRAWTEXT_FIX(1,0.406,0.13,0,'市净率:'),COLORLIGREEN;

DRAWTEXT_FIX(1,0.406,0.17,0,'毛利率:'),COLORLIGREEN;

DRAWTEXT_FIX(1,0.406,0.21,0,'净利润率:'),COLORLIGREEN;

DRAWTEXT_FIX(1,0.489,0.05,1,CON2STR(市盈率,2)),COLORCYAN;

DRAWTEXT_FIX(1,0.489,0.09,1,CON2STR(市销率,2)),COLORCYAN;

DRAWTEXT_FIX(1,0.489,0.13,1,CON2STR(市净率,2)),COLORCYAN;

DRAWTEXT_FIX(1,0.489,0.17,1,CON2STR(毛利率,2)),COLORCYAN;

DRAWTEXT_FIX(1,0.489,0.21,1,CON2STR(净利润率,2)),COLORCYAN;

经营现金流量:=FINANCE(25)/10000;

资产负债率:=FINANCE(9);

应收帐款:=FINANCE(22)/10000;

DRAWTEXT_FIX(1,0.518,0.01,0,'财务资料(4):'),COLORLIBLUE;

DRAWTEXT_FIX(1,0.518,0.05,0,'资产负债率:'),COLORLIGREEN;

DRAWTEXT_FIX(1,0.636,0.05,1,STRCAT(CON2STR(资产负债率,2),' %')),COLORCYAN;

DRAWTEXT_FIX(1,0.518,0.09,0,STRCAT('经营现金流量:',STRCAT(VAR2STR(经营现金流量,0),' 万元'))),COLORWHITE;

DRAWTEXT_FIX(1,0.518,0.13,0,STRCAT('应收帐款:',STRCAT(VAR2STR(应收帐款,0),' 万元'))),COLORWHITE;

市值:=STRCAT(STRCAT(' 流通市值: ',CON2STR((CAPITAL/1000000)*C,2)),'亿元');

DRAWTEXT_FIX(1,0.598,0.01,0,市值),COLOR0080FF;

AAA5:=STRCAT('成交金额:',CON2STR(DYNAINFO(10)/100000000,2));

AAA6:=STRCAT('成交金额:',CON2STR(DYNAINFO(7)/100000000,2)),'亿元';

DRAWTEXT_FIX(1,0.728,0.01,0,AAA5),COLORYELLOW;

DRAWTEXT_FIX(1,0.818,0.01,0,AAA6),COLORYELLOW;

AAA7:=STRCAT('换手率:',CON2STR(DYNAINFO(37)*100,2));

AAA8:=STRCAT('成交金额:',CON2STR(DYNAINFO(7)/100000000,2)),'(%)';

DRAWTEXT_FIX(1,0.868,0.01,0,AAA7),COLORYELLOW;

DRAWTEXT_FIX(1,0.928,0.01,0,AAA8),COLORYELLOW;


Tags:主图
0% (0)
0% (10)

关于完整财务信息的好股主图公式源码的评论:

 以下是对 [完整财务信息的好股主图公式源码] 的评论,总共:0条评论
加入收藏 | 联系我们 | 免责声明 | 站内地图 | 关于我们