买好股公式网 > 股票公式 > 通达信公式 > 通达信主升爆量主图指标

通达信主升爆量主图指标

2021年06月14日人气:Tags:通达信 主图 指标

DRAWTEXT_FIX(1,0.005,0,0,'所属风格:'),COLORRED;DRAWTEXT_FIX(1,0.06,0,0,FGBLOCK),COLORRED;

DRAWTEXT_FIX(1,0.005,0.06,0,'所属概念:'),COLORMAGENTA;DRAWTEXT_FIX(1,0.06,0.06,0,GNBLOCK),COLORMAGENTA;

DRAWTEXT_FIX(1,0.005,0.12,0,'所属板块:'),COLORYELLOW;DRAWTEXT_FIX(1,0.06,0.12,0,DYBLOCK),COLORYELLOW;DRAWTEXT_FIX(1,0.11,0.12,0,HYBLOCK),COLORYELLOW;

{流通盘}

DRAWTEXT_FIX(1,0.52,0.0,0,STRCAT(STRCAT('流通盘:',CON2STR((FINANCE(46)*C/100000000),2)),'亿')),COLORYELLOW;YSTB:=STRCAT(CON2STR(FINANCE(44)/1,2),'%');LRTB:=STRCAT(CON2STR(FINANCE(43)/1,2),'%');

DRAWTEXT_FIX(1,0.7,0,0,'营收同比:'),COLORWHITE;DRAWTEXT_FIX(1,0.76,0,0,YSTB),COLORWHITE;DRAWTEXT_FIX(1,0.84,0,0,'利润同比:'),COLORWHITE;DRAWTEXT_FIX(1,0.9,0,0,LRTB),COLORWHITE;

净资收益率:=(FINANCE(33)/FINANCE(34)*100);主营利润率:=(FINANCE(23)/FINANCE(20)*100);主营业增长率:=FINANCE(44);

每股净资产:=CONST(FINANCE(34));每股收益:=CONST(FINANCE(38));净利润增长率:=FINANCE(43);市销率:=CONST(FINANCE(1)*DYNAINFO(7)/FINANCE(20));

现金负债比:=(FINANCE(25)/FINANCE(15));每股未分配:=CONST(FINANCE(32));每股公积金:=CONST(FINANCE(18));

SY01:=净资收益率>3;SY02:=净资收益率>0.01 AND 净资收益率<=3;SY03:=主营利润率>2;SY04:=主营利润率>0;

SY05:=主营业增长率>1;SY06:=主营业增长率>0;SY07:=净利润增长率>2;SY08:=净利润增长率>0.2;SY09:=每股收益>0.01;

SY10:= 每股收益>0.001;SY11:=每股净资产>2;SY12:=每股净资产>0.01;SY13:=每股未分配>0.5;SY14:=每股未分配>0.001;

SY15:=每股公积金>0.5;SY16:=每股公积金>0.002;SY17:=每股未分配>=2 AND 每股公积金>=2;SY18:=每股未分配<2 OR 每股公积金<2;

优秀:=SY01 AND SY03 AND SY05 AND SY07 AND SY09 AND SY11 AND SY13 AND SY15;

较好:=SY02 AND SY04 AND SY06 AND SY08 AND SY10 AND SY12 AND SY14 AND SY16;

一般:=NOT(优秀) AND NOT(较好);DRAWTEXT_FIX(优秀 AND 较好=0,0.7,0.05,0,'综合评估基本面:优秀!'),COLORMAGENTA;

DRAWTEXT_FIX(较好,0.7,0.05,0,'综合评估基本面:较好!'),COLORRED;DRAWTEXT_FIX(一般,0.7,0.05,0,'综合评估基本面:一般!'),COLORGREEN;

DRAWTEXT_FIX(SY17,0.84,0.05,0,'是否具备高送转潜力:是!'),COLORMAGENTA;DRAWTEXT_FIX(SY18,0.84,0.05,0,'是否具备高送转潜力:否!'),COLORGREEN;

VAR2:=((((C - O) / O) * (100)) > 4);

VAR3:=((((C - (REF(C,1))) / (REF(C,1))) * (100)) > 8);

VAR4:=(((((REF(C,1)) * (1.1)) - C) < (0.01)) AND (H = C));

VAR5:=((20 * H + 19 * (REF(H,1)) + 18 * (REF(H,2)) + 17 * (REF(H,3)) + 16 * (REF(H,4)) + 15 * (REF(H,5)) + 14 * (REF(H,6)) + 13 * (REF(H,7)) + 12 * (REF(H,8)) + 11 * (REF(H,9)) + 10 * (REF(H,10)) + 9 * (REF(H,11)) + 8 * (REF(H,12)) + 7 * (REF(H,13)) + 6 * (REF(H,14)) + 5 * (REF(H,15)) + 4 * (REF(H,16)) + 3 * (REF(H,17)) + 2 * (REF(H,18)) + REF(H,20)) / (210));

黄牛线:(EMA(VAR5,90)),LINETHICK2,COLORRED;

ZT:=REF(C,1)*1.1-C<0.01 AND H=C;{涨停};

HH:=(20*H+19*REF(H,1)+18*REF(H,2)+17*REF(H,3)+16*REF(H,4)+15*REF(H,5)+14*REF(H,6)

+13*REF(H,7)+12*REF(H,8)+11*REF(H,9)+10*REF(H,10)+9*REF(H,11)+8*REF(H,12)

+7*REF(H,13)+6*REF(H,14)+5*REF(H,15)+4*REF(H,16)+3*REF(H,17)+2*REF(H,18)+

REF(H,20))/210;

黄牛线1:=EMA(HH,5);

黄牛线2:=EMA(HH,10);

黄牛线3:=EMA(HH,30);

黄牛线4:=EMA(HH,60);

黄牛线5:=EMA(HH,90);

黄牛线6:=EMA(HH,120);

黄牛线7:=EMA(HH,250);

E5:=EMA(C,5);

离合:=(黄牛线1-((H-黄牛线1)*H-黄牛线1)/黄牛线1);

离合1:=(黄牛线2-((H-黄牛线2)*H-黄牛线2)/黄牛线2);

离合2:=(黄牛线3-((H-黄牛线3)*H-黄牛线3)/黄牛线3);

离合3:=(黄牛线4-((H-黄牛线4)*H-黄牛线4)/黄牛线4);

离合4:=(黄牛线5-((H-黄牛线5)*H-黄牛线5)/黄牛线5);

离合5:=(黄牛线6-((H-黄牛线6)*H-黄牛线6)/黄牛线6);

离合6:=(黄牛线7-((H-黄牛线7)*H-黄牛线7)/黄牛线7);

最大临界线:=MAX(离合6,MAX(离合5,MAX(离合4,MAX(离合3,MAX(离合2,MAX(离合1,离合))))));

最小临界线:=MIN(离合6,MIN(离合5,MIN(离合4,MIN(离合3,MIN(离合2,MIN(离合1,离合))))));

上升离合:=(黄牛线1+((C-黄牛线1)*C-黄牛线1)/黄牛线1);

上升离合1:=(黄牛线2+((H-黄牛线2)*H-黄牛线2)/黄牛线2);

上升离合2:=(黄牛线3+((H-黄牛线3)*H-黄牛线3)/黄牛线3);

上升离合3:=(黄牛线4+((H-黄牛线4)*H-黄牛线4)/黄牛线4);

上升离合4:=(黄牛线5+((H-黄牛线5)*H-黄牛线5)/黄牛线5);

上升离合5:=(黄牛线6+((H-黄牛线6)*H-黄牛线6)/黄牛线6);

上升离合6:=(黄牛线7+((H-黄牛线7)*H-黄牛线7)/黄牛线7);

TP1:=CROSS(最大临界线,黄牛线1);

TP3:=CROSS(C,最大临界线);

TP6:=CROSS(上升离合4,E5);

持股线:((MA(C,3) + MA(C,6) + MA(C,12) + MA(C,24)) / 4),COLORYELLOW,LINETHICK2;

VAR6:=((黄牛线) - ((((C - (黄牛线)) * C) - (黄牛线)) / (黄牛线)));

VAR9:=(CROSS(黄牛线,VAR6));

VAR11:=(CROSS(C,VAR6));

DRAWTEXT(VAR9,L*0.99,'加'),COLORWHITE;

DRAWTEXT((VAR9) AND (VAR4),L*0.98,'金元宝'),LINETHICK4,COLORYELLOW;

DRAWTEXT((VAR11) AND (VAR4),L,'导弹'),LINETHICK4,COLORMAGENTA;

DRAWTEXT(TP6 AND ZT,L*0.97,'主升'),LINETHICK4,COLORYELLOW;

DRAWTEXT(VAR11,L,'买'),LINETHICK4,COLORRED;

VAR15:=(REF(H,BARSLAST(V = (HHV(V,120)))));

VAR22:=((NOT((REF(VAR15,1)) = (VAR15))) AND (VAR4));

DRAWTEXT(VAR22,L,'量爆'),COLORRED;

趋势线:=EMA(EMA(C,10),10),COLORRED,LINETHICK3;

B:=主趋势线>REF(主趋势线,1);

买:=REF(B=0,1) AND B=1;

卖出:=REF(B=1,1) AND B=0;

N1:=8;

MTM:=C-REF(C,1);

ZLGJ:=100*EMA(EMA(MTM,N1),N1)/EMA(EMA(ABS(MTM),N1),N1);

买1:=IF(LLV(ZLGJ,2)=LLV(ZLGJ,7) AND COUNT(ZLGJ<0,2) AND CROSS(ZLGJ,MA(ZLGJ,2)),1,0);

DRAWICON(FILTER(买1=1,5),LOW*0.99,7),COLORRED;

{通达信主升爆量主图指标}

打赏好指标 ×

关于通达信主升爆量主图指标的评论:

 以下是对 [通达信主升爆量主图指标] 的评论,总共:0条评论
加入收藏 | 联系我们 | 免责声明 | 站内地图 | 关于我们