买好股公式网 > 股票公式 > 通达信公式 > MACD顶背离和底背离通达信副图公式源码

MACD顶背离和底背离通达信副图公式源码

2017年12月06日人气:Tags:MACD 背离 通达信 副图 公式 源码

DIFF : EMA(CLOSE,12) - EMA(CLOSE,26);
DEA : EMA(DIFF,9);
MACD=2*(DIFF-DEA);
GJ:=MAX(C,O);
STICKLINE(MACD>0 AND MACD>=REF(MACD,1),0,MACD,2,0),COLOR0000FF;
STICKLINE(MACD>0 AND MACD<REF(MACD,1),0,MACD,2,0),COLORFFFF00;
STICKLINE(MACD<0 AND MACD>=REF(MACD,1),0,MACD,2,0),COLORFF00FF;
STICKLINE(MACD<0 AND MACD<REF(MACD,1),0,MACD,2,0),COLOR00FF00;
L4:=LLV(GJ,4);
JL:=(HHV(DIFF,55)-LLV(DIFF,55))/5;
GT:=DEA>REF(DEA,1) AND REF(DEA,1)<REF(DEA,2);
A1:=BARSLAST(REF(GT,1));
底背离:=REF(L4,A1+1)>CLOSE AND DIFF>REF(DIFF,A1+1) AND GT;
DRAWLINE(A1=0,DEA,底背离,REF(DEA,A1),0),COLORRED,LINETHICK2;
DRAWLINE(底背离,DEA,底背离,REF(DEA,A1),0),COLORRED,LINETHICK2;
DRAWTEXT(底背离,REF(DEA,A1)*1.1,'底背离'),COLORRED;
H4:=HHV(GJ,4);
GT2:=DEA<REF(DEA,1) AND REF(DEA,1)>REF(DEA,2);
A2:=BARSLAST(REF(GT2,1));
顶背离:= REF(H4,A2+1)<H4 AND DIFF<REF(DIFF,A2+1) AND GT2;
DRAWLINE(A2=0 ,DEA,顶背离,REF(DEA,A2),0),COLORCYAN,LINETHICK2;
DRAWLINE(顶背离,DEA,顶背离,REF(DEA,A2),0),COLORCYAN,LINETHICK2;
DRAWTEXT(顶背离,REF(DEA,A2)*1,'顶背离'),COLORCYAN;
A0:=DIFF<0 AND DEA<0;
A11:=A0>REF(A0,1);
A3:=BARSLAST(A11);
A4:=COUNT(DEA>0 AND DIFF >0,A3)=0;
A5:=CROSS(DIFF ,DEA);
A6:=BARSLAST(A5);
A7:=REF(A6,A6+1)+A6;
A8:=(DIFF+DEA)/2;
A9:=(HIGH+LOW)/2;
A10:=A5 AND A7<A3 AND A4 AND A8>REF(A8,A7) AND A9<REF(A9,A7) AND MACD>0;
DRAWTEXT(A10,DIFF*0.95,'▲买入'),COLORYELLOW;


MACD顶背离和底背离通达信副图公式源码

打赏好指标 ×

关于MACD顶背离和底背离通达信副图公式源码的评论:

 以下是对 [MACD顶背离和底背离通达信副图公式源码] 的评论,总共:1条评论
匿名 游客:匿名  刚刚 1
不错
加入收藏 | 联系我们 | 免责声明 | 站内地图 | 关于我们