买好股公式网 > 股票公式 > 通达信公式 > 通达信后金叉主图公式源码

通达信后金叉主图公式源码

2019年01月25日 字体: 人气:

通达信后金叉主图公式源码


动态止损度:=5;

黑:=0;

离L:=0;

提示:=0;

布林M:=0;

MMA:=0;

五:MA(CLOSE,5),COLORWHITE;

十:MA(CLOSE,10),COLOR00FFFF;

M18:=MA(CLOSE,18),COLORRED;

离基:=五;

离O:=离基*1.20,COLOR555555;

离A:离基*1.15,COLOR555555;

离B:离基*1.10,COLOR555555;

离C:离基*0.90,COLOR555555;

离D:=离基*0.85,COLOR333333;

EXP50:=EXPMA(CLOSE,50),COLORGREEN;

MA30:MA(CLOSE,30),LINETHICK1,COLORRED;

MA60:MA(CLOSE,60),COLORGREEN;


β0:=(H-L)/2+L,LINETHICK0;

α:=β0,LINETHICK0;

β:=REF(β0,1),LINETHICK0,COLORGREEN;

γ:=REF(β0,2),LINETHICK0,COLORMAGENTA;

高:PLOYLINE(1,CONST(HHV(H,50))),COLOR770077,LINETHICK1;

低:=PLOYLINE(1,CONST(LLV(L,50))),COLOR777700,LINETHICK1;

中:=PLOYLINE(1,(高-低)/2+低),COLOR005555,LINETHICK4;

止损价:=CONST(HHV(C,5)*(100-动态止损度)/100);

止:PLOYLINE(CONST(C)<=止损价,止损价),COLOR888800,LINETHICK4;

DRAWTEXT(DYNAINFO(7)<=止损价 AND ISLASTBAR,止损价*1.05,'止损');

AA:=CLOSE/REF(C,1)>=1.09;

BA:=CLOSE/REF(C,1)>=1.09;

DRAWKLINE(H,O,L,C);

STICKLINE(AA,O,C,2.5,1),COLORYELLOW;

MA1:=MA(CLOSE,5),COLORRED;

MA2:=MA(CLOSE,10),COLORYELLOW;

MA3:=MA(CLOSE,20),COLOR770077;

E50:=EXPMA(CLOSE,50),LINETHICK1,POINTDOT,COLORLIGREEN;

E100:=EXPMA(CLOSE,100),POINTDOT,COLORGRAY;

MA181:MA(C,181),COLORGRAY;

IF(CONST(α>β) AND DYNAINFO(7)>0,DYNAINFO(7),DRAWNULL),COLOR000088,LINETHICK1;

IF(CONST(α<=β)AND DYNAINFO(7)>0 ,DYNAINFO(7),DRAWNULL),COLOR008800,LINETHICK1;

IF(CONST(α>β) AND DYNAINFO(7)>0 AND DYNAINFO(7)>=高*0.99,DYNAINFO(7),DRAWNULL),COLOR000088,LINETHICK1;

IF(CONST(α<=β)AND DYNAINFO(7)>0 AND DYNAINFO(7)<=低*1.01 ,DYNAINFO(7),DRAWNULL),COLOR008800,LINETHICK1;

N1:=12;

N2:=26;

N3:=9;

DIFF:=(EMA(CLOSE,N1) - EMA(CLOSE,N2));

DEA:=EMA(DIFF,N3);

MACD:=(2 * (DIFF - DEA));

MACD2:=MACD;

SARH:=CLOSE>SAR(4,2,20);

五V:=MA(V,5);

TYP:=(HIGH+LOW+CLOSE)/3;

CCI:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14));

STICKLINE(C<MA3 AND 黑=1,H,L,0,0),COLOR555555;

STICKLINE(MA1<MA3 AND 黑=1,O,C,2.5,1),COLOR555555;

STICKLINE(BA AND C<MA3,O,C,2.7,1),COLORWHITE;

N:=14;

M:=6;

HD :=HIGH-REF(HIGH,1);

LD :=REF(LOW,1)-LOW;

DMP:=EXPMEMA(IF(HD>0&&HD>LD,HD,0),N);

DMM:=EXPMEMA(IF(LD>0&&LD>HD,LD,0),N);

PDI:=DMP*100/TR;

MDI:=DMM*100/TR;

ADX:=EXPMEMA(ABS(MDI-PDI)/(MDI+PDI)*100,M);

ADXR:=EXPMEMA(ADX,M);

DMIJX:=CROSS(PDI,MDI) AND C>O;

头上边:=MAX(O,C),NODRAW;

头下边:=MIN(O,C),NODRAW;

垂头:=ABS(O-C),NODRAW;{垂头}

长针:=(头下边-L),NODRAW;{长针}

垂:=长针/垂头>2 AND (H-头上边)<=长针 AND L<REF(L,1) AND O<REF(C,1),NODRAW;

DRAWTEXT(垂 AND L<=LLV(L,3) AND L<离C AND 提示,L/1.01,'针') AND 提示,COLORGREEN,LINETHICK4;

DRAWTEXT(H>MA(CLOSE,5)*1.07 AND ISLASTBAR AND 提示,H*1.01,'离!'),COLORGREEN,LINETHICK2;

DRAWTEXT(L<MA(CLOSE,5)*1.005 AND L>MA(CLOSE,5) AND 提示=0 AND H<MA(CLOSE,5)*1.07 AND ISLASTBAR,L/1.02,'低吸'),COLORGREEN,LINETHICK2;

上5日:=REF(EVERY(C<MA1,2),1) AND CROSS(C,MA1);

STICKLINE(上5日,H,L,0,0),COLORFF00FF;

STICKLINE(上5日,O,C,2.7,0),COLORFF00FF;

DRAWICON(上5日,L,1);

破5日:=REF(EVERY(C>MA1,4),1) AND CROSS(MA1,C);

DRAWICON(破5日,H,2);

DT:=REF(CLOSE/REF(C,1),1)<=0.95;

DRAWTEXT(AA AND DT AND CURRBARSCOUNT<60 ,H,'急挖坑'),COLORGREEN;

SC1:=MACD.MACD<0;

SC2:=CROSS(十,五);

SC3:=MA(V,5)<MA(V,10);

SC:=SC1 AND SC2 AND SC3 ;

DRAWTEXT(SC AND CURRBARSCOUNT<10 ,HHV(H,5),'三死叉'),COLORWHITE;

JC1:=MACD.MACD>0;

JC2:=CROSS(五,十);

JC3:=MA(V,5)>MA(V,10);

JC:=JC1 AND JC2 AND JC3 ;

DRAWTEXT(JC AND CURRBARSCOUNT<20 ,LLV(L,5),'后金叉'),COLORYELLOW;

DRAWTEXT(CROSS(H,离B)  AND CURRBARSCOUNT<10  ,HHV(H,3),'超乖离'),COLORYELLOW;

DRAWTEXT(CROSS(H,离A)   AND CURRBARSCOUNT<10 ,HHV(H,3),'超乖离'),COLORYELLOW;

DRAWTEXT(CROSS(离C,L) AND CURRBARSCOUNT<10 ,LLV(L,3),'负乖离'),COLORWHITE;


0% (0)
0% (10)

关于通达信后金叉主图公式源码的评论:

 以下是对 [通达信后金叉主图公式源码] 的评论,总共:0条评论
加入收藏 | 联系我们 | 免责声明 | 站内地图 | 关于我们