买好股公式网 > 股票公式 > 通达信公式 > 主图短买入卖出公式指标

主图短买入卖出公式指标

2019年01月12日 字体: 人气:

主图短买入卖出公式指标


VARDDI:=(AMOUNT / VOL);

VARJJ:=((OPEN + CLOSE) / 2);

VARPJJ:=0;

VARDDING:=EMA(CLOSE,6);

VARMMD:=MA(VARDDING,1);

VARXXD:=EMA(CLOSE,18);

VARYYZ:=REF(VARMMD,1);

VARXXD1:=REF(VARXXD,1);

VARYYZ1:=BARSCOUNT(CLOSE);

VARTDCG:=IF((VARYYZ1 = 1),0,(((VARMMD - VARYYZ) / VARYYZ) * 100));

VARZFD:=IF((VARYYZ1 = 1),0,(((VARXXD - VARXXD1) / VARXXD1) * 100));

VARJSD2:=REF(CLOSE,1);

CLOSE1:=IF((VARYYZ1 = 1),0,(((CLOSE - VARJSD2) / VARJSD2) * 100));

VARJZDF:=IF((VARYYZ1 = 1),((CLOSE + OPEN) / 2),VARYYZ);

VARDCGJ:=VARMMD;

JJ0:=VARYYZ;

JJ1:=REF(VARMMD,2);

JJ2:=(((VARDCGJ + JJ0) + JJ1) / 3);

JJ02:=(((ABS((VARDCGJ - JJ2)) + ABS((JJ0 - JJ2))) + ABS((JJ1 - JJ2))) / 3);

SS:=REF(VARTDCG,1);

VARZFD1:=REF(VARTDCG,2);

VARZFD2:=IF((VARYYZ1 < 3),0,((JJ02 / VARDCGJ) * 100));

VARDHPXS:=IF((VARYYZ1 < 3),0,IF((((VARTDCG < 0) AND (SS < 0)) AND (VARZFD1 < 0)),(0 - 1),1));

SSB:=REF(VARTDCG,1);

VARYZFZ:=IF((((VARYYZ1 > 11) AND (SSB < 0)) AND (VARTDCG > 0)),1,0);

VARJSD21:=BARSLAST((VARYZFZ = 1));

VARJSD:=REF(VARJSD21,1);

A:=IF((((VARYYZ1 > 11) AND (SS < 0)) AND (VARTDCG > 0)),(VARJSD + 1),VARJSD);

VARJSD11:=VARJZDF;

DMRJ:=VARJZDF;

DMCJ:=IF(((VARYYZ1 > 11) AND (VARJSD11 < OPEN)),OPEN,VARJZDF);

VARDMRJ:=IF(((VARYYZ1 > 11) AND (DMRJ > OPEN)),OPEN,VARJZDF);

VARDMCJ:=0;

VARDCG1:=REF(VARJZDF,1);

VARBDF5:=IF(((((VARTDCG > 0.5) AND ((VARZFD2 > 0.215) OR (LOW > VARJZDF))) AND (CLOSE >= OPEN)) AND ((CLOSE >= 200) OR ((CLOSE < 200) AND (CLOSE1 < 11)))),1,0);

VARDMR:=IF((((VARTDCG < (0 - 0.3)) AND ((VARZFD2 > 0.2) OR (HIGH < VARJZDF))) AND ((OPEN >= CLOSE) OR (CLOSE1 < (0 - 1)))),1,0);

VARDKS1:=BARSSINCE(VARBDF5);

VARTDMR:=BARSSINCE(VARDMR);

VARDMRB:=VARDMR;

VARDCGJ1:=((COUNT(VARBDF5,BARSLAST(VARDMRB)) = 1) AND VARBDF5);

VARDMRBUY:=((COUNT(VARDMRB,BARSLAST(VARBDF5)) = 1) AND VARDMRB);

VARDMCSELL:=BARSLAST(VARDMRBUY);

VARDCG10:=BARSLAST(VARDCGJ1);

VARDCG11:=((SUM(VARDMRBUY,VARDCG10) = 0) * VARDCG10);

VARDCGREAL:=REF(DMCJ,VARDCG11);

VARDMRJ11:=REF(VARDCGREAL,1);

VARDMRJ1:=IF((VARDCGJ1 = 1),(((CLOSE - DMCJ) / DMCJ) * 100),(((VARDMRJ - VARDMRJ11) / VARDMRJ11) * 100));

VARDCG:=IF((((VARDCG11 = 0) AND (VARDCGJ1 = 0)) AND (VARDMRBUY = 0)),0,VARDMRJ1);

SJ:=IF(DATE<=20190227,1,0);

DDD:=REF(CLOSE,VARDCG10);

FFF:=REF(CLOSE,VARDMCSELL);

短买入:VARDCGJ1,LINETHICK0,NODRAW;

短卖出:VARDMRBUY,LINETHICK0,NODRAW;

风口强度:VARDCG11,LINETHICK0,NODRAW;

短持股1:=VARDCG;

短买价:=IF((短卖出 = 1),VARDMRJ,0);

STICKLINE((短买入 = 1)*SJ,OPEN,CLOSE,3,0),COLOR0000FF;

STICKLINE((风口强度 > 0)*SJ,OPEN,CLOSE,0,0),COLORFFBBFF;

STICKLINE((风口强度 > 0)*SJ,OPEN,CLOSE,3,0),COLORFF99FF;

STICKLINE((风口强度 > 0)*SJ,OPEN,CLOSE,2,0),COLORFFAAFF;

STICKLINE((风口强度 > 0)*SJ,OPEN,CLOSE,1,0),COLORFFBBFF;

STICKLINE((短卖出 = 1)*SJ,OPEN,CLOSE,0,0),COLOR00FF00;

STICKLINE((短卖出 = 1)*SJ,OPEN,CLOSE,3,0),COLOR00DD00;

STICKLINE((短卖出 = 1)*SJ,OPEN,CLOSE,2,0),COLOR00EE00;

STICKLINE((短卖出 = 1)*SJ,OPEN,CLOSE,1,0),COLOR00FF00;

DRAWICON((短买入 > 0)*SJ,LOW*0.995,5);

DRAWICON((短卖出 = 1)*SJ,HIGH*1.015,4);

VARMAXDSY:=COUNT(((VARDMR = 1) AND (VARDCG <> 0)),0);

VARGLDSY:=HHV(VARDCG,0);

VARDCSLJ:=BARSSINCE(((VARDMR = 1) AND (VARDCG <> 0)));

VARDCSLY:=IF((VARDMR = 1),VARDCG,0);

板块追踪:SJ*EMA(CLOSE,7);

AA:=EMA(C,14),COLORWHITE,LINETHICK1;

B:=(AA-REF(AA,1))/REF(AA,1)*100,NODRAW;

支撑:IF(B>=0,REF(EMA(C,14),BARSLAST(CROSS(B,0))+1),DRAWNULL),COLORRED,LINETHICK2;

阻力:IF(B<0,REF(EMA(C,14),BARSLAST(CROSS(0,B))+1),DRAWNULL),COLORGREEN,LINETHICK2;


0% (0)
0% (10)

关于主图短买入卖出公式指标的评论:

 以下是对 [主图短买入卖出公式指标] 的评论,总共:0条评论
加入收藏 | 联系我们 | 免责声明 | 站内地图 | 关于我们