买好股公式网 > 股票公式 > 通达信公式 > 通达信CCI背离主图公式源码

通达信CCI背离主图公式源码

2018年10月29日 字体: 人气:

通达信CCI背离主图公式源码


TYP:=(HIGH+LOW+CLOSE+OPEN)/4;

CCI:=(TYP-MA(TYP,33))/(0.015*AVEDEV(TYP,33));

A1:=(C+O)/2;

DIF1:=EMA(CLOSE,12)-EMA(CLOSE,44);

MACD1:=EMA(DIF1,8) ;

DDIF1:=DIF1-MACD1 ; 

AA:=(C+O)/2; 

RSV:=(CLOSE-LLV(LOW,44))/(HHV(HIGH,44)-LLV(LOW,44))*100;

K:=SMA(RSV,7,1),COLOR0099FF,LINETHICK2;

D:=SMA(K,5,1)COLORFF00FF,LINETHICK2;

RSV1:=(CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100;

K1:=SMA(RSV1,4,1),COLORWHITE,LINETHICK2;

D1:=SMA(K1,3,1)COLORGREEN,LINETHICK2;

BU:=UPNDAY(DDIF1,3) AND DDIF1<0;

日:=150;昨前:=3;

高1:=REF(HHV(H,日),昨前);

低1:=REF(LLV(L,日),昨前);

H1:=高1-(高1-低1)*0.191; 

H2:=高1-(高1-低1)*0.382; 

H3:=高1-(高1-低1)*0.5; 

H4:=高1-(高1-低1)*0.618; 

H5:=高1-(高1-低1)*0.809;

BB:=(二0.618+三0.500)/2; 

MA5:MA(C,5),COLORBLUE;

MA20:MA(C,20),COLORYELLOW; 

STICKLINE( MA5>REF(MA5,1) AND K1>REF(K1,1),LOW,HIGH,0.0,0),COLORRED;

STICKLINE(MA5>REF(MA5,1) AND K1>REF(K1,1),CLOSE,OPEN,2,0),COLORRED;

CC:= CCI>=REF(CCI,1) AND MA5 <REF(MA5,1) AND CCI<-100;

STICKLINE( CCI>-100 AND K <REF(K,1),LOW,HIGH,0.0,1),COLORGREEN;

STICKLINE( CCI>-100 AND K <REF(K,1),CLOSE,OPEN,2,1),COLORGREEN;

STICKLINE( CCI<-100 AND CCI>-149 AND K <REF(K,1),LOW,HIGH,0.0,0),COLORGREEN;

STICKLINE( CCI<-100 AND CCI>-149 AND K <REF(K,1),CLOSE,OPEN,2,0),COLORGREEN;

STICKLINE(CCI<-150,LOW,HIGH,0.0,0),COLORWHITE;

STICKLINE( CCI<-150,CLOSE,OPEN,2,0),COLORWHITE;

DRAWTEXT(CC,C *0.98,' B'),COLORFFFF00;

STICKLINE(DDIF1>REF(DDIF1,1) AND DDIF1<0,LOW,HIGH,0.0,0),COLOR0099FF;

STICKLINE(DDIF1>REF(DDIF1,1) AND DDIF1<0,CLOSE,OPEN,2,0),COLOR0099FF;


0% (0)
0% (10)

关于通达信CCI背离主图公式源码的评论:

 以下是对 [通达信CCI背离主图公式源码] 的评论,总共:0条评论
加入收藏 | 联系我们 | 免责声明 | 站内地图 | 关于我们