买好股公式网 > 股票公式 > 通达信公式 > 通达信飞天牛股副图指标

通达信飞天牛股副图指标

2021年10月24日人气:Tags:通达信 牛股 副图 指标

VAR1:=5;
VAR2:=10;
VAR3:=30;
VAR4:=20;
VAR5:=MA(CLOSE,VAR1);
VAR6:=MA(CLOSE,VAR2);
VAR7:=MA(CLOSE,VAR3);
VAR8:=VAR5 < VAR6;
VAR9:=VAR5 < VAR7;
VAR10:=VAR6 < VAR7;
VAR11:=BARSLAST(VAR8);
VAR12:=BARSLAST(VAR9);
VAR13:=BARSLAST(VAR10);
VAR14:=VAR11 > VAR12 AND VAR12 > VAR13 AND VAR13=1 AND VAR11 <=VAR4;
VAR15:=CROSS(VAR7,VAR5);
VAR16:=CROSS(VAR7,VAR5) OR CROSS(VAR7,VAR6);
VAR17:=IF(BARSLAST(VAR14)=(-1),9999,BARSLAST(VAR14));
VAR18:=IF(BARSLAST(VAR15)=(-1),9999,BARSLAST(VAR15));
VAR19:=CROSS(SUM(VAR16,VAR17),0.5) AND VAR17 < 9999;
VAR20:=BARSLAST(VAR19);
VAR21:=VAR17 < VAR18;
VAR22:=IF(VAR20=(-1),9999,VAR20) > VAR17;
VAR23:=LOW < VAR7 AND CLOSE > VAR7 AND VAR21 AND VAR14 AND VAR22;
VAR24:=VAR14;
VAR25:=VAR23;
VAR26:=VAR19;
VAR27:=BARSLAST(VAR24);
VAR28:=BARSLAST(VAR26);
VAR29:=IF(VAR27 < 0,9999,VAR27) < IF(VAR28 < 0,9999,VAR28);
VAR30:=WINNER(CLOSE)*100 >=80;
VAR31:=MA(CLOSE,5);
VAR32:=MA(CLOSE,10);
VAR33:=MA(CLOSE,30);
VAR34:=VAR31 < VAR32;
VAR35:=VAR31 < VAR33;
VAR36:=VAR32 < VAR33;
VAR37:=BARSLAST(VAR34);
VAR38:=BARSLAST(VAR35);
VAR39:=BARSLAST(VAR36);
VAR40:=VAR37 > VAR38 AND VAR38 > VAR39 AND VAR39=1 AND VAR37 <=20;
VAR41:=CROSS(VAR33,VAR31);
VAR42:=CROSS(VAR33,VAR31) OR CROSS(VAR33,VAR32);
VAR43:=IF(BARSLAST(VAR40)=(-1),9999,BARSLAST(VAR40));
VAR44:=IF(BARSLAST(VAR41)=(-1),9999,BARSLAST(VAR41));
VAR45:=CROSS(SUM(VAR42,VAR43),0.5) AND VAR43 < 9999;
VAR46:=BARSLAST(VAR45);
VAR47:=VAR43 < VAR44;
VAR48:=IF(VAR46=(-1),9999,VAR46) > VAR43;
VAR49:=LOW < VAR33 AND CLOSE > VAR33 AND VAR47 AND VAR40 AND VAR48;
VAR50:=VAR40;
VAR51:=VAR49;
VAR52:=VAR45;
VAR53:=VAR50;
VAR54:=VAR51;
VAR55:=BARSLAST(VAR53);
VAR56:=BARSLAST(VAR54);
VAR57:=IF(VAR54,HIGH,0);
VAR58:=HHV(VAR57,VAR55);
VAR59:=REF(VAR56,VAR56+1)+VAR56+1;
VAR60:=REF(HIGH,VAR55);
VAR61:=VAR54 AND CLOSE > REF(REF(HIGH,VAR56),1);
VAR62:=BARSLAST(COUNT(VAR54,VAR55) > 1 AND REF(CLOSE,VAR56) > VAR58);
VAR63:=COUNT(VAR54,VAR55)=0 OR COUNT(VAR54,VAR55)=1;
VAR64:=VAR53 OR COUNT(VAR54,VAR55+1)=0;
VAR65:=VAR60;
VAR66:=COUNT(VAR54,VAR55)=1;
VAR67:=BARSLAST(VAR66 AND VAR54);
VAR68:=REF(HIGH,VAR67);
VAR69:=COUNT(VAR54,VAR55) > 1 AND REF(CLOSE,VAR56) > VAR68;
VAR70:=BARSLAST(VAR69 AND VAR54);
VAR71:=REF(HIGH,VAR70);
VAR72:=IF(VAR64,VAR65,IF(VAR69,VAR71,VAR68));
VAR73:=CLOSE/VAR72*100-100;
VAR74:=MA(CLOSE,5);
VAR75:=MA(CLOSE,20);
VAR76:=REF(VAR74,1)*0.98;
VAR77:=REF(VAR74,2)*0.98;
VAR78:=BARSLAST(REF(CLOSE,2) >=REF(VAR74,2) AND REF(CLOSE,1) < REF(VAR74,1))+2;
VAR79:=BARSLAST(REF(CLOSE,2) >=REF(VAR74,2) AND REF(CLOSE,1) < REF(VAR74,1))+1;
VAR80:=IF(REF(CLOSE,2) >=REF(VAR74,2) AND REF(CLOSE,1) < REF(VAR74,1),IF(REF(VAR74,2) < REF(VAR74,1),VAR76,VAR77),IF(BARSSINCE(REF(CLOSE,2) >=REF(VAR74,2) AND REF(CLOSE,1) < REF(VAR74,1)) > 0,IF(REF(VAR74,VAR78) < REF(VAR74,VAR79),REF(VAR74,VAR79)*0.98,REF(VAR74,VAR78)*0.98),REF(VAR74,1)));
VAR81:=REF(VAR75,1)*0.98;
VAR82:=REF(VAR75,2)*0.98;
VAR83:=BARSLAST(REF(CLOSE,2) >=REF(VAR75,2) AND REF(CLOSE,1) < REF(VAR75,1))+2;
VAR84:=BARSLAST(REF(CLOSE,2) >=REF(VAR75,2) AND REF(CLOSE,1) < REF(VAR75,1))+1;
VAR85:=IF(REF(CLOSE,2) >=REF(VAR75,2) AND REF(CLOSE,1) < REF(VAR75,1),IF(REF(VAR75,2) < REF(VAR75,1),VAR81,VAR82),IF(BARSSINCE(REF(CLOSE,2) >=REF(VAR75,2) AND REF(CLOSE,1) < REF(VAR75,1)) > 0,IF(REF(VAR75,VAR83) < REF(VAR75,VAR84),REF(VAR75,VAR84)*0.98,REF(VAR75,VAR83)*0.98),REF(VAR75,1)));
VAR86:=VAR80;
VAR87:=VAR85;
VAR88:=LLV(REF(LOW,1),2)+(HHV(REF(HIGH,1),2)-LLV(REF(LOW,1),2))/2;
VAR89:=MA(CLOSE,25)+MA(CLOSE,25)*6/100;
VAR90:=MA(CLOSE,25)+MA(CLOSE,25)*20/100;
VAR91:=MA(CLOSE,25)+MA(CLOSE,25)*13/100;
VAR92:=LLV(REF(LOW,1),2)+(HHV(REF(HIGH,1),2)-LLV(REF(LOW,1),2))/2;
VAR93:=MA(CLOSE,10) > MA(CLOSE,25) AND CROSS(CLOSE,MA(CLOSE,5)) AND VOL > MA(VOL,10) AND MA(CLOSE,10) > REF(MA(CLOSE,10),1);
VAR94:=CLOSE >=VAR89;
VAR95:=FINANCE(30) >=REF(FINANCE(30),130);
VAR96:=VAR95;
VAR97:=IF(NAMELIKE(89),0,1);
VAR98:=IF(NAMELIKE(90),0,1);
VAR99:=DYNAINFO(17) > 0;
VAR100:=CAPITAL/1000000 < 20;
VAR101:=CLOSE <=60;
VAR102:=VAR96 AND VAR97 AND VAR98 AND VAR99 AND VAR100 AND VAR101 AND NOT(CLOSE >=REF(CLOSE,1)*1.097 AND CLOSE=OPEN AND HIGH=LOW);
VAR103:=CLOSE=HHV(CLOSE,30);
VAR104:=BARSLAST(FILTER(CROSS(0.8,VAR103),2))+1;
VAR105:=REF(CLOSE,VAR104);
VAR106:=IF(CROSS(CLOSE,REF(VAR105,1)),3,0);
VAR107:=VOL=HHV(VOL,30);
VAR108:=BARSLAST(FILTER(CROSS(0.8,VAR107),2))+1;
VAR109:=REF(VOL,VAR108);
VAR110:=IF(CROSS(VOL,REF(VAR109,1)),2,0);
VAR111:=ABS(((3.48*CLOSE+HIGH+LOW+OPEN)/5-EMA(CLOSE,20))/EMA(CLOSE,20));
VAR112:=DMA((2.15*CLOSE+LOW+HIGH+OPEN)/5,VAR111);
VAR113:=EMA(VAR112,200)*1.26;
VAR114:=EMA(VAR112,200)*1.18;
VAR115:=MA((LOW+HIGH+CLOSE)/3,5);
VAR116:=HHV(VAR115,60);
VAR117:=IF(VAR116 > REF(VAR116,1),VAR116,DRAWNULL);
VAR118:=CLOSE*VOL;
VAR119:=EMA((EXPMA(VAR118,3)/EXPMA(VOL,3)+EXPMA(VAR118,6)/EXPMA(VOL,6)+EXPMA(VAR118,12)/EXPMA(VOL,12)+EXPMA(VAR118,24)/EXPMA(VOL,24))/4,13);
VAR120:=1.03*VAR119;
VAR121:=1.13*VAR119;
VAR122:=MIN(VAR117,VAR113);
VAR123:=MIN(VAR120,VAR113);
VAR124:=MIN(VAR117,VAR114);
VAR125:=MIN(VAR120,VAR114);
VAR126:=CLOSE/REF(CLOSE,1) > 1.03 AND CLOSE=HIGH;
DRAWBAND(10*VAR29,RGB(118,0,0),VAR29,RGB(0,0,0));
STICKLINE(VAR24,0,35,2,0),COLORWHITE;
STICKLINE(VAR25,0,28,2,0),COLORLIRED;{买好股公式网www.BUYHAOGU.com}
STICKLINE(VAR26,0,22,2,0),COLORLIGREEN;
DRAWBAND(30*VAR30,RGB(250,0,0),21*VAR30,RGB(0,0,0));
藏龙:CLOSE > VAR72 AND CLOSE/REF(CLOSE,1) > 1.05 AND VAR73 < 30 AND VAR94 AND CLOSE >=VAR86,NODRAW,COLORMAGENTA;
超牛:CROSS(100-100*(HHV(HIGH,1*8)-CLOSE)/(HHV(HIGH,1*8)-LLV(LOW,1*8)),99) AND (VAR106 OR VAR110) AND VAR102,NODRAW,COLORLIBLUE;
飞天:CROSS(CLOSE,VAR121) AND VAR126,NODRAW,COLORRED;
STICKLINE(飞天,80,100,2,0),COLORRED;
STICKLINE(藏龙,35,45,2,0),COLORMAGENTA;
STICKLINE(超牛,45,55,2,0),COLORLIBLUE;
DRAWTEXT_FIX(1,0.15,0.05,0,124),COLORYELLOW;
{通达信飞天牛股副图指标}

打赏好指标 ×

关于通达信飞天牛股副图指标的评论:

 以下是对 [通达信飞天牛股副图指标] 的评论,总共:0条评论
加入收藏 | 联系我们 | 免责声明 | 站内地图 | 关于我们