买好股公式网 > 股票公式 > 通达信公式 > 通达信穿越买点副图指标

通达信穿越买点副图指标

2021年04月27日人气:Tags:通达信 买点 副图 指标

VARF:=TROUGHBARS(3,9,1)<4;

STICKLINE(FILTER(VARF=1,5),3,0,10,1),COLORRED,LINETHICK2;

DRAWTEXT(FILTER(VARF=1,3),2,'低吸'),COLORYELLOW;

买线:=EMA(C,1),COLORRED;

卖线:=EMA(SLOPE(C,5)*20+C,6);

BU:=CROSS(买线,卖线);

SEL:=CROSS(卖线,买线);

界:= MA(CLOSE,8),LINETHICK1,COLORYELLOW;

XG:=CROSS(买线,界);

STICKLINE(FILTER(XG=1,5),10,0,8,1),COLORMAGENTA,LINETHICK2;

DRAWTEXT(FILTER(XG=1,3),8,'K线上穿买'),COLORGREEN;

SHORT:=5;

LONG:=9;

PASTDAYS:=2;

多方:((8)*(SMA(((CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9)))*(10),4,1))-(3)*(SMA(SMA(((CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9)))*(10),4,1),3,1))-SMA(SMA(SMA(((CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9)))*(10),4,1),3,1),2,1)),COLOR0000FF;

空方:(EMA(MA(多方,3),5)),COLORF0F000;

上升在即:= IF(CROSS(多方,空方),20,0),STICK,COLORRED,LINETHICK4;

即将启动:=IF(多方>=REF(多方,1) AND RANGE(多方,0,20),15,0),STICK,COLORRED,LINETHICK2;

LOWAREA_THRES:=16;

DIAMOND_THRES:=12;

PIT_THRES:= 21;

HIGH_THRES:=75;

PRICE:=C,NODRAW;

MA5:=MA(C,4),NODRAW;

DIF1:=EMA(CLOSE,5) - EMA(C,10); DEA1:=EMA(DIF1,3);

CMACD:=(DIF1-DEA1)*2,NODRAW;

CCCI:=CCI,NODRAW;

最新价:=C,NODRAW;

季:=MA(C,55),NODRAW,COLORCYAN;

通:=MA(C,17),NODRAW;

子:=MA(C,26),NODRAW;

午:=MA(C,100),NODRAW;

辰:=MA(C,145),NODRAW;

卯:=MA(C,455),NODRAW;

申:=MA(C,320),NODRAW;

亥:=MA(C,732),NODRAW;

突季:=CROSS(C,季) AND C>REF(C,1),NODRAW;

突子:=CROSS(C,子) AND C>REF(C,1),NODRAW;

突通:=CROSS(C,通) AND C>REF(C,1),NODRAW;

突午:=CROSS(C,子) AND C>REF(C,1),NODRAW;

突辰:=CROSS(C,辰) AND C>REF(C,1),NODRAW;

突卯:=CROSS(C,卯) AND C>REF(C,1),NODRAW;

突申:=CROSS(C,申) AND C>REF(C,1),NODRAW;

突亥:=CROSS(C,亥) AND C>REF(C,1),NODRAW;

均线最大值:=MAX(通,MAX(子,MAX(季,MAX(午,MAX(辰,MAX(卯,MAX(申,亥))))))),NODRAW;

突通子:=突通+突子,NODRAW;

突均线:=突通+突季+突子+突午+突辰+突卯+突申+突亥,NODRAW;

通线上:=C>通,NODRAW;

通增:=通>REF(通,1),NODRAW;

子线上:=C>子,NODRAW;

疯牛:=C>均线最大值,NODRAW;

突均线期:=COUNT(突均线,PASTDAYS),NODRAW;

突通子期:=COUNT(突通子,PASTDAYS),NODRAW;

通子金叉:=CROSS(通,子),NODRAW;

子午金叉:=CROSS(子,午);

小牛初现:=CROSS(通,子) AND (通>REF(通,1)) AND MACD>0 AND CCI>100 AND HIGH> MA(C,5) AND 子>REF(子,1) AND 季>REF(季,1) AND C>季  ,NODRAW;

蛟龙出海:=CROSS(子,午) AND (子>REF(子,1)) AND MACD>0 AND CCI>100 AND HIGH> MA(C,5) AND (通>REF(通,1)) AND 午>REF(午,1) AND 季>REF(季,1) AND C>季 ,NODRAW;

多方势增:=(REF(多方,1) < 多方) AND 多方>空方,NODRAW;

STICKLINE((空方<=多方),空方,多方,3,0)*4,COLOR0000FF;

STICKLINE((多方>55) AND (多方>=空方),空方,多方,5,1)*4,COLORFF33FF;

STICKLINE((空方>多方),多方,空方,3,0)*4,COLORF0F000;

低吸区:(空方<20) AND (空方>多方) AND (REF(空方,1)> 空方) AND (REF(多方,1) < 多方),COLORRED,LINETHICK2;

TJ:=FILTER(低吸区,5);

DRAWTEXT(TJ,空方*0.9,'吸'),COLORFFFF00;

探钻石矿:=(空方<12) AND (空方<=多方),COLOR00FFFF,NODRAW;

钻石底:=CROSS(多方,空方) AND (空方<PIT_THRES),COLOR0000FF,NODRAW;

钻石底低吸:=(低吸区 OR 钻石底) AND MACD>REF(MACD,1),NODRAW;

TJ1:=CROSS(探钻石矿 OR 钻石底,0.5);

TJ2:=CROSS(空方,多方);

TJ3:=COUNT(TJ2,BARSLAST(TJ1));

DRAWICON(TJ1,空方*0.9,'B');

DRAWICON(TJ2 AND TJ3=1,空方,'S');

N:=5;M1:=2;M2:=2;

RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;

K:=SMA(RSV,M1,1),COLORYELLOW,LINETHICK1;

D:=SMA(K,M2,1),COLORCYAN,LINETHICK1;

J:=3*K-2*D,COLORMAGENTA,LINETHICK1;

KDJ势增:=J>REF(J,1),NODRAW;

U1:=BARSLAST(REF(CROSS(K,D),1));

U2:=REF(C,U1+1)>C AND REF(K,U1+1)<K AND CROSS(K,D)AND D<50;

K底背离:=IF(U2>0,1,0);

RR:=MAX(C,O);

Q1:=HHV(RR,5);

Q2:=D<REF(D,1) AND REF(D,1)>REF(D,2);

A2:=BARSLAST(REF(Q2,1));

K顶背离:=(REF(Q1,A2+1)<Q1 AND K<REF(K,A2+1) AND Q2 ),NODRAW;

DRAWTEXT(K顶背离,MAX(空方,多方)*1.02,' 顶背'),COLORGREEN;

KDJ金叉:=CROSS(J,K),NODRAW;

KDJ死叉:=CROSS(K,J),NODRAW;

KDJ买点:=KDJ金叉,NODRAW;

KDJ卖点:=KDJ死叉;

KDJ买点期:= COUNT(KDJ买点,PASTDAYS)>0,NODRAW;

DIFF:=EMA(C,SHORT)-EMA(C,LONG),NODRAW;

DEA:=EMA(DIFF,5),NODRAW;

MACD:=2*(DIFF-DEA), COLORSTICK;

DIFF过0轴:=CROSS(DIFF,0),NODRAW;

A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));

M底背离:=REF(CLOSE,A1+1)>CLOSE AND DIFF>REF(DIFF,A1+1) AND CROSS(DIFF,DEA);

M顶背离:=REF(CLOSE,A2+1)<CLOSE AND REF(DIFF,A2+1)>DIFF AND CROSS(DEA,DIFF);

MACD金叉:=CROSS(DIFF,DEA),NODRAW;

MACD金叉期:=COUNT(MACD金叉,PASTDAYS),NODRAW;

MACD死叉:=CROSS(DEA,DIFF),NODRAW;

MACD买点:=MACD金叉 OR DIFF过0轴,NODRAW;

MACD买点期:=COUNT(MACD买点,PASTDAYS),NODRAW;

KM共振买点:=( ((MACD买点 AND KDJ买点期) OR (MACD买点期 AND KDJ买点) ) AND (KDJ势增) AND (M顶背离<1) AND (K顶背离<1)),NODRAW;

KM共振买点期:=COUNT(KM共振买点,PASTDAYS)>0,NODRAW;

金叉:=CROSS(多方,空方),NODRAW;

死叉:=CROSS(空方,多方),NODRAW;

买点信号数:=MACD买点 + 金叉 + 金叉 ,NODRAW;

买点:=买点信号数>0,NODRAW;

卖点信号数:= MACD死叉 + KDJ死叉 +死叉,NODRAW;

最佳共振买点:=买点信号数>1,NODRAW;

卖点多信号:=卖点信号数>1,NODRAW;

快线:=4*SMA((CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100,3,1)-3*SMA(SMA((CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100,3,1),3.2,1);

VAR2:=8,COLORGREEN,LINETHICK0;

Y:=IF((50-快线)>=0,-1,1),COLORYELLOW;

持股:IF(Y=1,10,DRAWNULL),COLORRED,LINETHICK2;

观望:IF(Y=-1,10,DRAWNULL),COLORYELLOW,LINETHICK2;

B1:=(HHV(H,3)-C)/(HHV(H,3)-LLV(LOW,3))*100- 70;

B2:=SMA(B1,2,1)+100;

B3:=(C-LLV(L,3))/(HHV(H,3)- LLV(L,3))*100;

B4:=SMA(B3,2,1);

B5:=SMA(B4,2,1)+100;

B6:=B5-B2;

启动:=(IF(B6>60,B6-60,0))*0.6,COLORWHITE;

吸筹:STICKLINE(REF(启动,1)<启动,启动,REF(启动,1),3,0),COLORRED;

{通达信穿越买点副图指标}

打赏好指标 ×

关于通达信穿越买点副图指标的评论:

 以下是对 [通达信穿越买点副图指标] 的评论,总共:0条评论
加入收藏 | 联系我们 | 免责声明 | 站内地图 | 关于我们