买好股公式网 > 股票公式 > 通达信公式 > 通达信短线进退主图公式

通达信短线进退主图公式

2018年12月11日 字体: 人气:

通达信短线进退主图公式


FB:=MA((C+H+L+O)/4,5)+ABS(MA((C+H+L+O)/4,5)-REF(MA((C+H+L+O)/4,5),1));

FS:=MA((C+H+L+O)/4,5)+MA((C+H+L+O)/4,5)-REF(MA((C+H+L+O)/4,5),1);

搏杀线:IF(MA((C+H+L+O)/4,3)<FS,FS,MA((C+H+L+O)/4,3))*1.05,LINETHICK3,COLORYELLOW;

IF(FB>FS,搏杀线,DRAWNULL),COLORWHITE;

DRAWBAND(FS*1.05,FB>FS,FB*1.05,RGB(0,100,0));

JRH:=HHV(C,2);

JRL:=LLV(C,2);

MA3:=MA(CLOSE,3);

YTSL:=(2*CLOSE+LOW+OPEN+HIGH)/5;

VAR1:=(CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2));

VAR2:=(REF(VAR1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));

VAR3:=(REF(VAR2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));

VAR4:=(REF(VAR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));

VAR5:=(REF(VAR4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));

VAR6:=(REF(VAR5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));

VAR7:=(REF(VAR6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));

VAR8:=(REF(VAR7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));

VAR9:=(REF(VAR8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));

VARA:=(REF(VAR9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));

VARB:=(REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));

VARC:=(REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));

VARD:=(CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2));

VARE:=(REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));

VARF:=(REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));

VAR10:=(REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));

VAR11:=(REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));

VAR12:=(REF(VAR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));

VAR13:=(REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));

VAR14:=(REF(VAR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));

VAR15:=(REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));

VAR16:=(REF(VAR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));

VAR17:=(REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));

VAR18:=(REF(VAR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));

VAR19:=((REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1)) AND VAR1);

VAR1A:=((REF(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,1)) AND VARD);

英雄持股:VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,COLOR0000FF,NODRAW;

英雄观望:VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,COLORFFFF00,NODRAW;

急速超跌:(CLOSE-MA(CLOSE,22))/MA(CLOSE,22)*100<-14,COLORFFFFFF,NODRAW;

辰星线:(20*YTSL+19*REF(YTSL,1)+18*REF(YTSL,2)+17*REF(YTSL,3)+16*REF(YTSL,4)+15*REF(YTSL,5)+14*REF(YTSL,6)+13*REF(YTSL,7)+12*REF(YTSL,8)+11*REF(YTSL,9)+10*REF(YTSL,10)+9*REF(YTSL,11)+8*REF(YTSL,12)+7*REF(YTSL,13)+6*REF(YTSL,14)+5*REF(YTSL,15)+4*REF(YTSL,16)+3*REF(YTSL,17)+2*REF(YTSL,18)+REF(YTSL,20))/211;

STICKLINE(ISLASTBAR AND (英雄持股 OR REF(英雄持股,1)=1),REF(IF(英雄持股,JRL,DRAWNULL),1),REF(IF(英雄持股,JRL,DRAWNULL),1),20,1),COLOR0000FF;

STICKLINE(ISLASTBAR AND (英雄观望 OR REF(英雄观望,1)=1),REF(IF(英雄观望,JRH,DRAWNULL),1),REF(IF(英雄观望,JRH,DRAWNULL),1),20,1),COLOR00FF00;

STICKLINE(C>=O,L,H,0,0),COLOR0000CC;

STICKLINE(C<O,L,H,0,0),COLOR999900;

STICKLINE(1,C,O,3.5,0),COLOR858500;

STICKLINE(C>=O,C,O,3.5,0),COLOR0000E5;

STICKLINE(英雄持股,CLOSE,O,2.8,0),COLOR000055;

STICKLINE(英雄持股,CLOSE,O,2,0),COLOR000088;

STICKLINE(英雄持股,CLOSE,O,1.5,0),COLOR0000AA;

STICKLINE(英雄持股,CLOSE,O,1,0),COLOR0000CC;

STICKLINE(英雄持股,CLOSE,O,0.5,0),COLOR0000EE;

STICKLINE(英雄观望,CLOSE,O,2.8,0),COLOR555500;

STICKLINE(英雄观望,CLOSE,O,2,0),COLOR888800;

STICKLINE(英雄观望,CLOSE,O,1.5,0),COLORAAAA00;

STICKLINE(英雄观望,CLOSE,O,1,0),COLORCCCC00;

STICKLINE(英雄观望,CLOSE,O,0.5,0),COLOREEEE00;

CO:=(C-O);

STICKLINE(急速超跌,O,C-CO/2,2.8,0),COLOR555555;

STICKLINE(急速超跌,O,C-CO/2,2,0),COLOR888888;

STICKLINE(急速超跌,O,C-CO/2,1.5,0),COLORAAAAAA;

STICKLINE(急速超跌,O,C-CO/2,1,0),COLORCCCCCC;

STICKLINE(急速超跌,O,C-CO/2,0.5,0),COLOREEEEEE;

STICKLINE(VAR1A,O,O+CO/3,2.8,0),COLOR550055;

STICKLINE(VAR1A,O,O+CO/3,2,0),COLOR880088;

STICKLINE(VAR1A,O,O+CO/3,1.5,0),COLORAA00AA;

STICKLINE(VAR1A,O,O+CO/3,1,0),COLORCC00CC;

STICKLINE(VAR1A,O,O+CO/3,0.5,0),COLOREE00EE;

IF(IF(MA3>辰星线,辰星线,MA3)>REF(IF(MA3>辰星线,辰星线,MA3),1),IF(MA3>辰星线,辰星线,MA3),DRAWNULL),LINETHICK2,COLOR00FFFF;

IF(辰星线>REF(辰星线,1),辰星线,DRAWNULL),LINETHICK2,COLOR0000FF;

IF(辰星线<REF(辰星线,1),辰星线,DRAWNULL),COLOR00FF00;

IF(MA(CLOSE,22)>REF(MA(CLOSE,22),1),MA(CLOSE,22),DRAWNULL),LINETHICK1,COLORFF00FF;

IF(MA(CLOSE,22)<REF(MA(CLOSE,22),1),MA(CLOSE,22),DRAWNULL),COLOR669933;

STICKLINE(VAR19,O,O+CO/3,2.8,0),COLOR335555;

STICKLINE(VAR19,O,O+CO/3,2,0),COLOR338888;

STICKLINE(VAR19,O,O+CO/3,1.5,0),COLOR33AAAA;

STICKLINE(VAR19,O,O+CO/3,1,0),COLOR33CCCC;

STICKLINE(VAR19,O,O+CO/3,0,0),COLOR33EEEE;

A:=(2*C+L+O+H)/5;

BB:=(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+14*REF(A,6)

+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)

+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+

REF(A,20))/210;

短线:(MA((C+H+L+O)/4,1)+MA((C+H+L+O)/4,3)+MA((C+H+L+O)/4,5))/3,COLORFFFFFF;

MY:=(CLOSE-MA(CLOSE,22))/MA(CLOSE,22)*100*(1+MA((VOL-REF(VOL,1))/REF(VOL,1),5));

IF(MA(MY,5)>=MY,短线,DRAWNULL),COLOR00FF00;

IF(MA(MY,5)<=MY,短线,DRAWNULL),COLORAA00FF;

DRAWTEXT(VAR1A,REF(CLOSE,1)+0.1,'←短撤'),COLORFF99FF;

DRAWTEXT(VAR19,REF(CLOSE,1),'←短进'),COLOR33FFCC;


0% (0)
0% (10)

关于通达信短线进退主图公式的评论:

 以下是对 [通达信短线进退主图公式] 的评论,总共:0条评论
加入收藏 | 联系我们 | 免责声明 | 站内地图 | 关于我们