买好股公式网 > 股票公式 > 通达信公式 > MACD分时主图指标

MACD分时主图指标

2020年09月06日人气:Tags:MACD 分时 主图 指标

MACD分时主图指标

MACD分时主图指标


DA:=YEAR AND MONTH AND DAY;

AA1:=STRCAT(CON2STR(YEAR,0),'年');

AA2:=STRCAT(CON2STR(MONTH,0),'月');

AA3:=STRCAT(CON2STR(DAY,0),'日');

AA4:=STRCAT('【',IF(WEEKDAY=1,'一',IF(WEEKDAY=2,'二',IF(WEEKDAY=3,'三',IF(WEEKDAY=4,'四',IF

(WEEKDAY=5,'五',IF(WEEKDAY=6,'六','日')))))));

AA:=STRCAT(STRCAT(STRCAT(AA1,AA2),STRCAT(AA3,AA4)),'】');

DRAWTEXT_FIX(DA AND FROMOPEN<=120,0.88,0,0,AA),COLORBLUE;

DRAWTEXT_FIX(DA AND FROMOPEN>120,0,0,0,AA),COLORBLUE;

{分时MACD}

DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);

DEA:=EMA(DIF,9);

MACD:=2*(DIF-DEA);

X:=CONST(HHV(ABS(C-DYNAINFO(3)),FROMOPEN))/CONST(HHV(ABS(DIF),FROMOPEN))*0.6;

DI:DIF*X+DYNAINFO(3),COLORCC00CC;

DE:DEA*X+DYNAINFO(3),COLOR00DD00;

MAC:=MACD*X;

STICKLINE(MAC>0,DYNAINFO( 3),MAC+DYNAINFO( 3),0,1),COLORRED;

STICKLINE(MAC<0,DYNAINFO( 3),MAC+DYNAINFO( 3),0,1),COLORCYAN;

{高点直线} 

V1:=TIME;

T:=IF(V1<130000,(FLOOR(V1/10000)-9.5)*60+(FLOOR(V1/100)-100*FLOOR(V1/10000)),

(FLOOR(V1/10000)-11)*60+(FLOOR(V1/100)-100*FLOOR(V1/10000))),NODRAW;

KP30:=T<240;

KPGD:=H=HHV(H,0) AND KP30;

GDSJ:=BARSLAST(KPGD);

HHHH:REF(H,GDSJ),COLORYELLOW,POINTDOT,LINETHICK1;

{低点直线} 

VQ1:=TIME;

TQ:=IF(VQ1<130000,(FLOOR(V1/10000)-9.5)*60+(FLOOR(VQ1/100)-100*FLOOR(VQ1/10000)),

(FLOOR(VQ1/10000)-11)*60+(FLOOR(VQ1/100)-100*FLOOR(VQ1/10000))),NODRAW;

KPQ30:=TQ<240;

KPGDQ:=L=LLV(L,0) AND KPQ30;

GDSJQ:=BARSLAST(KPGDQ);

HHHHQ:REF(L,GDSJQ),COLORCC00CC,POINTDOT,LINETHICK1;

最新:CLOSE,COLORWHITE;

AQA:=SUM(AMOUNT,BARSCOUNT(C))/SUM(VOL*100,BARSCOUNT(C));

DRAWTEXT( ISLASTBAR AND 最新>REF(最新,1),最新,STRCAT(' 涨▲',CON2STR(最新,2))),COLORMAGENTA;

DRAWTEXT( ISLASTBAR AND 最新<REF(最新,1),最新,STRCAT(' 跌▼',CON2STR(最新,2))),COLOR00FF00;

均价:SUM(V*C,0)/SUM(V,0),COLORGREEN,LINETHICK1;

IF(均价<=REF(均价,1),均价,DRAWNULL),COLORGREEN,LINETHICK3;

IF(均价>=REF(均价,1),均价,DRAWNULL),COLORYELLOW,LINETHICK3;

DRAWTEXT(CURRBARSCOUNT=8,均价,'均'),COLORYELLOW,LINETHICK3;

DRAWNUMBER(CURRBARSCOUNT=1,均价,均价),COLORYELLOW,LINETHICK3;

{板块概念}

DRAWTEXT_FIX(1 AND FROMOPEN<=120,0.5,0,0,DYBLOCK),COLORWHITE;

DRAWTEXT_FIX(1 AND FROMOPEN<=120,0.55,0,0,HYBLOCK),COLORYELLOW;

DRAWTEXT_FIX(1 AND FROMOPEN<=120,0.6,0,0,GNBLOCK),COLORYELLOW;

DRAWTEXT_FIX(1 AND FROMOPEN>120,0.12,0,0,DYBLOCK),COLORWHITE;

DRAWTEXT_FIX(1 AND FROMOPEN>120,0.17,0,0,HYBLOCK),COLORYELLOW;

DRAWTEXT_FIX(1 AND FROMOPEN>120,0.21,0,0,GNBLOCK),COLORYELLOW;


打赏好指标 ×

关于MACD分时主图指标的评论:

 以下是对 [MACD分时主图指标] 的评论,总共:0条评论
加入收藏 | 联系我们 | 免责声明 | 站内地图 | 关于我们