买好股公式网 > 股票公式 > 通达信公式 > 天地人和副图指标

天地人和副图指标

2022年09月23日人气:Tags:副图 指标

VAR2:=(CLOSE-LLV(LOW,20))/(HHV(HIGH,20)-LLV(LOW,20))*100;

VAR3:=SMA(SMA(VAR2,3,1),3,1)/28.57;

VAR4:=EMA(VAR3,5);

操盘:=3*VAR3-2*VAR4;

D1:=CROSS(操盘,VAR3) AND VAR3<2.1 AND C>O;

N:=14;M:=6;

TRA:=EXPMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),N);

HD :=HIGH-REF(HIGH,1);

LD :=REF(LOW,1)-LOW;

DMP:=EXPMA(IF(HD>0 AND HD>LD,HD,0),N);

DMM:=EXPMA(IF(LD>0 AND LD>HD,LD,0),N);

PDI:=DMP*100/TR;

MDI:=DMM*100/TR;

ADX:=EXPMA(ABS(MDI-PDI)/(MDI+PDI)*100,M);

ADXR:=EXPMA(ADX,M);

DRAWBAND(ADX,RGB(255,255,0),ADXR,RGB(0,255,0));

主升:=PDI,COLOR0000FF,LINETHICK2;

主跌:=MDI,COLORFFFFFF,LINETHICK2;

天:80,COLOR00FF00,POINTDOT,LINETHICK4;

地:20,COLORFF00FF,POINTDOT,LINETHICK4;

TJJ:=主升>20 AND ADX>ADXR;

TJ11:=主升>20 AND ADX<ADXR;

TJ22:=主升<=20 AND ADX>ADXR;

TJ33:=主升<=20 AND ADX<ADXR;

STICKLINE(TJJ,主升,20,0.1,0),COLORRED;

STICKLINE(TJ11,主升,20,0.1,0),COLORDDDD00;

STICKLINE(TJ22,主升,20,0.1,0),COLORDD00DD;

STICKLINE(TJ33,主升,20,0.1,0),COLOR00DD00;

STICKLINE(CROSS(ADX,主跌) AND 主跌<20 AND ADX>ADXR,20,10,4,0),COLOR990099;

STICKLINE(CROSS(ADX,主跌) AND 主跌<20 AND ADX>ADXR,20,10,2,0),COLORBB00BB;

STICKLINE(CROSS(ADX,主跌) AND 主跌<20 AND ADX>ADXR,20,10,1,0),COLORDD00DD;

STICKLINE(CROSS(ADX,主跌) AND 主跌<20 AND ADX>ADXR,20,10,0.5,0),COLORDD00FF;

DRAWICON(CROSS(ADX,ADXR) AND 主跌<20,20,23);

D2:=CROSS(ADX,主跌) AND 主跌<20 AND ADX>ADXR;

D33:=COUNT(D1 OR D2,3)>=2;

D66:=D1 AND D2;

DRAWICON(FILTER(D33,5),0,25);

DRAWICON(FILTER(D66,5),0,26);

{天地人和副图指标}

打赏好指标 ×

关于天地人和副图指标的评论:

 以下是对 [天地人和副图指标] 的评论,总共:0条评论
加入收藏 | 联系我们 | 免责声明 | 站内地图 | 关于我们