买好股公式网 > 股票公式 > 通达信公式 > 暴利线主图指标公式源码

暴利线主图指标公式源码

2021年11月21日人气:Tags:主图 指标


STICKLINE((CLOSE-REF(CLOSE,1))/REF(CLOSE,1)>0.095,CLOSE,OPEN,3.5,0),COLORMAGENTA;

N:=10;

M:=2.5;

TR1:=MAX(MAX(HIGH-LOW,ABS(REF(CLOSE,1)-HIGH)),ABS(REF(CLOSE,1)-LOW));

UP:=(HIGH+LOW)/2+MA(TR1,N)*M;

DN:=(HIGH+LOW)/2-MA(TR1,N)*M;

L1:=REF(UP,BARSLAST(UP<=REF(UP,1)));

L2:=LLV(UP,N*1.5);

LL:=IF(L2!=REF(L2,1) AND L1<REF(L1,1),L1,IF(L1=L2,L1,L2));

S1:=BARSLAST(CROSS(0.5,UP=LL))+1;

S2:=CROSS(COUNT(CROSS(CLOSE,LL) OR CROSS(CLOSE,REF(LL,2)) AND UP>LL,S1),0.5);

A6:=BARSLAST(S2);

B6:=BARSLAST(CROSS(HHV(DN,A6+1),CLOSE));

BY:=CROSS(B6,A6);

SL:=CROSS(A6,B6);

VAR266:DRAWKLINE(HIGH,OPEN,LOW,CLOSE);

趋势良友:IF(B6>A6,HHV(DN,BARSLAST(BY)+1),LLV(UP,BARSLAST(SL)+1)),COLORGREEN,LINETHICK2;

终极主升:IF(B6>A6,趋势良友,DRAWNULL),COLOR0000C8,LINETHICK2;

VAR267:DRAWICON(CROSS(B6,A6),趋势良友*0.99,34);

VAR268:DRAWICON(CROSS(A6,B6),趋势良友*1.015,35);

买进:CROSS(B6,A6)*100,NODRAW,COLORRED;

卖出:CROSS(A6,B6)*100,NODRAW;

DF:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100<(-4.95);

AA:=BARSLAST(DF);

暴利线:REF(CLOSE,AA+1),COLORGRAY;

突破:=CROSS(CLOSE,REF(CLOSE,AA+1));

VAR269:DRAWTEXT(ISLASTBAR,暴利线,2),COLORGRAY;

VAR270:DRAWICON(突破,LOW*0.99,25);

CC:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);

DD:=DMA(CLOSE,CC);

DA:=13;

智能辅助线:(1-7/100)*DD,DOTLINE,COLORGREEN;

VAR271:DRAWTEXT(ISLASTBAR,智能辅助线,3),COLORGREEN;

NS:=IF(HHV(ABS(HHV(CLOSE,DA)/LLV(CLOSE,DA)-1),DA)>10/100,3,DA);

N1:=IF(MINUTE=5,NS*48,IF(MINUTE=15,NS*16,IF(MINUTE=30,NS*8,IF(MINUTE=60,NS*4,NS))));

MM:=IF(VOL=0,MA(CLOSE,N1),SUM(AMOUNT,N1)/SUM(VOL,N1)/100);

M1:=REF(MM,1);

CT:=1;

买入1:=IF(CROSS(CLOSE,M1),M1,0);

卖出1:=IF(CROSS(M1,CLOSE),M1,0);

DW:=BARSLAST(卖出1>0);

EX10:=HHV(买入1>0,DW+1);

BJ:=IF(EX10>REF(EX10,1),买入1,0);

SJ:=IF(EX10<REF(EX10,1),卖出1,0);

VAR272:STICKLINE(CLOSE<OPEN,HIGH,LOW,0,0),COLOR555500;

VAR273:STICKLINE(CLOSE<OPEN,CLOSE,OPEN,3.05,0),COLOR888800;

VAR274:STICKLINE(CLOSE<OPEN,CLOSE,OPEN,2.75,0),COLORAAAA00;

VAR275:STICKLINE(CLOSE<OPEN,CLOSE,OPEN,2.05,0),COLORCCCC00;

VAR276:STICKLINE(CLOSE<OPEN,CLOSE,OPEN,1.75,0),COLOREEEE00;

VAR277:STICKLINE(CLOSE<OPEN,CLOSE,OPEN,1.05,0),COLORCYAN;

VAR278:STICKLINE(OPEN<CLOSE,HIGH,LOW,0,0),COLOR000088;

VAR279:STICKLINE(OPEN<CLOSE,CLOSE,OPEN,3.05,0),COLOR000088;

VAR280:STICKLINE(OPEN<CLOSE,CLOSE,OPEN,2.55,0),COLOR000099;

VAR281:STICKLINE(OPEN<CLOSE,CLOSE,OPEN,1.85,0),COLOR0000AA;

VAR282:STICKLINE(OPEN<CLOSE,CLOSE,OPEN,1.35,0),COLOR0000BB;

VAR283:STICKLINE(OPEN<CLOSE,CLOSE,OPEN,0.85,0),COLOR0000CC;

VAR284:STICKLINE(OPEN<CLOSE,CLOSE,OPEN,0.35,0),COLOR0000DD;

VAR285:STICKLINE(BJ>0 AND CT=1,OPEN,(CLOSE+OPEN)/2,3,0),COLOR0044FF;

VAR286:STICKLINE(BJ>0 AND CT=1,OPEN,(CLOSE+OPEN)/2,2.6,0),COLOR0077FF;

VAR287:STICKLINE(BJ>0 AND CT=1,OPEN,(CLOSE+OPEN)/2,2.2,0),COLOR1199FF;

VAR288:STICKLINE(BJ>0 AND CT=1,OPEN,(CLOSE+OPEN)/2,1.8,0),COLOR22BBFF;

VAR289:STICKLINE(BJ>0 AND CT=1,OPEN,(CLOSE+OPEN)/2,1.4,0),COLOR33DDFF;

VAR290:STICKLINE(BJ>0 AND CT=1,OPEN,(CLOSE+OPEN)/2,1,0),COLOR33FFFF;

VAR291:STICKLINE(BJ>0 AND CT=1,CLOSE,(CLOSE+OPEN)/2,3,0),COLOR000055;

VAR292:STICKLINE(BJ>0 AND CT=1,CLOSE,(CLOSE+OPEN)/2,2.6,0),COLOR000077;

VAR293:STICKLINE(BJ>0 AND CT=1,CLOSE,(CLOSE+OPEN)/2,2.2,0),COLOR000099;

VAR294:STICKLINE(BJ>0 AND CT=1,CLOSE,(CLOSE+OPEN)/2,1.8,0),COLOR0000BB;

VAR295:STICKLINE(BJ>0 AND CT=1,CLOSE,(CLOSE+OPEN)/2,1.4,0),COLOR0000DD;

VAR296:STICKLINE(BJ>0 AND CT=1,CLOSE,(CLOSE+OPEN)/2,1,0),COLOR0033FF;

VAR297:STICKLINE(SJ>0 AND CT=1,CLOSE,(CLOSE+OPEN)/2,3,0),COLORFF4400;

VAR298:STICKLINE(SJ>0 AND CT=1,CLOSE,(CLOSE+OPEN)/2,2.6,0),COLORFF7700;

VAR299:STICKLINE(SJ>0 AND CT=1,CLOSE,(CLOSE+OPEN)/2,2.2,0),COLORFF9911;

VAR300:STICKLINE(SJ>0 AND CT=1,CLOSE,(CLOSE+OPEN)/2,1.8,0),COLORFFBB22;

VAR301:STICKLINE(SJ>0 AND CT=1,CLOSE,(CLOSE+OPEN)/2,1.4,0),COLORFFDD33;

VAR302:STICKLINE(SJ>0 AND CT=1,CLOSE,(CLOSE+OPEN)/2,1,0),COLORFFFF33;

VAR303:STICKLINE(SJ>0 AND CT=1,OPEN,(CLOSE+OPEN)/2,3,0),COLOR550000;

VAR304:STICKLINE(SJ>0 AND CT=1,OPEN,(CLOSE+OPEN)/2,2.6,0),COLOR770000;

VAR305:STICKLINE(SJ>0 AND CT=1,OPEN,(CLOSE+OPEN)/2,2.2,0),COLOR990000;

VAR306:STICKLINE(SJ>0 AND CT=1,OPEN,(CLOSE+OPEN)/2,1.8,0),COLORBB0000;

VAR307:STICKLINE(SJ>0 AND CT=1,OPEN,(CLOSE+OPEN)/2,1.4,0),COLORDD0000;

VAR308:STICKLINE(SJ>0 AND CT=1,OPEN,(CLOSE+OPEN)/2,1,0),COLORBLUE;

{暴利线主图指标公式源码}

打赏好指标 ×

关于暴利线主图指标公式源码的评论:

 以下是对 [暴利线主图指标公式源码] 的评论,总共:0条评论
加入收藏 | 联系我们 | 免责声明 | 站内地图 | 关于我们