买好股公式网 > 股票公式 > 通达信公式 > 通达信多指标综合操盘副图公式

通达信多指标综合操盘副图公式

2018年12月31日 字体: 人气:

通达信多指标综合操盘副图公式


TYP:=(HIGH + LOW + CLOSE)/3;

N:=13;

CCI:(TYP-MA(TYP,14))*100/(1.5*AVEDEV(TYP,14)),COLORYELLOW;

强买入信号:CROSS(CCI,100),COLORYELLOW;

STICKLINE(强买入信号,100,200,1,0),COLORFF00FF;

买入信号信号:=STICKLINE(CROSS(CCI,-120),-200,-150,0.5,0),COLORRED;

STICKLINE(CROSS(CCI,-120),-150,50,0.5,0),COLORRED,LINETHICK1;

DRAWTEXT(CROSS(CCI,-120),-100,' 建仓'),COLORMAGENTA;

见底信号:10;

CCI逃逸:IF(REF(CCI,1)>99 AND CCI <98 ,1,0),COLORGREEN;

STICKLINE(CCI逃逸,180,250,0.5,0),LINETHICK3,COLORGREEN;

CS:=(CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100;

主力线:(EMA(CS,3)-50)*2;

极弱:=-80;

强势:=60;

风险:=80;

弱势:=-60;

主力线,COLORSTICK;

今日保护价:(REF(C,1)+REF(C,2)+O)/3,LINETHICK0;

VAR1:=REF(CLOSE,1);

VAR2:=SMA(MAX(CLOSE-VAR1,0),6,1)/SMA(ABS(CLOSE-VAR1),6,1)*100;

STICKLINE(CROSS(75.9,VAR2),主力线+5,主力线-5,3,0),COLORYELLOW;

DRAWTEXT(CROSS(主力线,78),78,'撤'),COLORF0FF00;

DRAWTEXT(CROSS(主力线,强势),60,'冲'),COLORYELLOW;

DRAWTEXT(CROSS(主力线,0),0,'持有'),COLORWHITE;

DRAWTEXT(CROSS(主力线,-60),-30,'补仓'),COLORRED;

DRAWTEXT(CROSS(主力线,-80),-80,'吸筹'),COLORYELLOW;

底:=-50;

顶:=50;

TTR := SUM(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(LOW-REF(CLOSE,1))),14);

HD := HIGH-REF(HIGH,1);

LD := REF(LOW,1)-LOW;

PDM:= SUM(IF(HD>0 AND HD>LD,HD,0),14);

MDM:= SUM(IF(LD>0 AND LD>HD,LD,0),14);

PDI:= PDM*100/TR;

MDI:= MDM*100/TR;

A1:=BARSLAST(REF(CROSS("MACD.DIF"(12,26,9),"MACD.DEA"(12,26,9)),1));

B1:=REF(C,A1+1)>C AND REF("MACD.DIF"(12,26,9),A1+1)<"MACD.DIF"(12,26,9) AND CROSS("MACD.DIF"(12,26,9),"MACD.DEA"(12,26,9));

A2:=BARSLAST(REF(CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3)),1));

B2:=REF(C,A2+1)>C AND REF("KDJ.K"(9,3,3),A2+1)<"KDJ.K"(9,3,3) AND CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3));

A3:=BARSLAST(REF(CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24)),1));

B3:=REF(C,A3+1)>C AND REF("RSI.RSI1"(6,12,24),A3+1)<"RSI.RSI1"(6,12,24) AND CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24));

C1:=BARSLAST(REF(CROSS("MACD.DEA"(12,26,9),"MACD.DIF"(12,26,9)),1));

D1:=REF(C,C1+1)<C AND REF("MACD.DIF"(12,26,9),C1+1)>"MACD.DIF"(12,26,9) AND CROSS("MACD.DEA"(12,26,9),"MACD.DIF"(12,26,9));

C2:=BARSLAST(REF(CROSS("KDJ.D"(9,3,3),"KDJ.K"(9,3,3)),1));

D2:=REF(C,C2+1)<C AND REF("KDJ.K"(9,3,3),C2+1)>"KDJ.K"(9,3,3) AND CROSS("KDJ.D"(9,3,3),"KDJ.K"(9,3,3));

C3:=BARSLAST(REF(CROSS("RSI.RSI2"(6,12,24),"RSI.RSI1"(6,12,24)),1));

D3:=REF(C,C3+1)<C AND REF("RSI.RSI1"(6,12,24),C3+1)>"RSI.RSI1"(6,12,24) AND CROSS("RSI.RSI2"(6,12,24),"RSI.RSI1"(6,12,24));

C4:=BARSLAST(REF(CROSS(MDI,PDI),1));

D4:=REF(C,C+1)<C AND REF(MDI,C4+1)>MDI AND CROSS(MDI,PDI);

A4:=BARSLAST(REF(CROSS(PDI,MDI),1));

B4:=REF(C,A4+1)>C AND REF(PDI,A4+1)<PDI AND CROSS(PDI,MDI);

DMI底背:IF(B4>0,-50,0),COLOR0099FF,POINTDOT;

DRAWTEXT(DMI底背,-5,'DMI底背'),COLOR0099FF;

DMI顶背:IF(D4>0,50,0),COLORFF00FF;

DRAWTEXT(DMI顶背,15,'DMI顶背'),COLORYELLOW;

MACD底背:IF(B1>0,-50,0),COLORRED,POINTDOT;

DRAWTEXT(MACD底背,-15,'MACD底背'),COLORRED;

KDJ底背:IF(B2>0,-50,0),COLORFF00FF,POINTDOT;

DRAWTEXT(KDJ底背,-25,'KDJ底背'),COLORFF00FF;

RSI底背:IF(B3>0,-50,0),COLORYELLOW,POINTDOT;

DRAWTEXT(RSI底背,-35,'RSI底背'),COLORYELLOW;

MACD顶背:IF(D1>0,50,0),COLOR00FF00,POINTDOT;

DRAWTEXT(MACD顶背,25,'MACD顶背'),COLOR00FF00;

KDJ顶背:IF(D2>0,50,0),COLORFFCC66,POINTDOT;

DRAWTEXT(KDJ顶背,35,'KDJ顶背'),COLORFFCC66;

RSI顶背:IF(D3>0,50,0),COLORFFFFFF,POINTDOT;

DRAWTEXT(RSI顶背,45,'RSI顶背'),COLORFFFFFF;

STICKLINE(B1>0,-50,0,2,0),COLORRED;

STICKLINE(B2>0,-50,0,2,0),COLORFF00FF;

STICKLINE(B3>0,-50,0,2,0),COLORYELLOW;

STICKLINE(D1>0,50,0,2,0),COLOR00FF00;

STICKLINE(D2>0,50,0,2,0),COLORFFCC66;

STICKLINE(D3>0,50,0,2,0),COLORWHITE;

STICKLINE(B4>0,-50,0,2,0),COLOR0099FF;

STICKLINE(D4>0,50,0,2,0),COLORBLUE;


0% (0)
0% (10)

关于通达信多指标综合操盘副图公式的评论:

 以下是对 [通达信多指标综合操盘副图公式] 的评论,总共:0条评论
加入收藏 | 联系我们 | 免责声明 | 站内地图 | 关于我们