通达信一张很强大的主图指标公式_通达信公式_买好股公式网
买好股公式网 > 股票公式 > 通达信公式 > 通达信一张很强大的主图指标公式

通达信一张很强大的主图指标公式

2018年05月13日 字体: 人气:


同增:FINANCE(43),NODRAW,COLORYELLOW;

N:=80;M:=3;N1:=10;M1:=11;

VAR1:=IF((CLOSE-REF(CLOSE,1))*100/REF(CLOSE,1)>=9.9 AND OPEN=HIGH AND PERIOD=5,1,0);

VAR2:=BARSLASTCOUNT(VAR1)>=2;

VAR3:=CONST(BARSLAST(VAR2));

水平线:IF(CURRBARSCOUNT<=VAR3+1,CONST(IF(VAR3=0,MAX(CLOSE,OPEN),REF(MAX(CLOSE,OPEN),VAR3))),DRAWNULL),DOTLINE,COLORLIBLUE;

VAR4:=BARSLAST(YEAR!=REF(YEAR,1));

VAR5:=BARSLAST(HHV(VOL,VAR4+1)=VOL);

VAR6:=BARSLAST(LLV(VOL,VAR4+1)=VOL);

STICKLINE(FILTERX(VAR5=0,VAR4+1),OPEN,CLOSE,1,0),COLOR009900;

STICKLINE(FILTERX(VAR6=0,VAR4+1),OPEN,CLOSE,1,0),COLORGREEN;

VAR7:=CONST(VAR5);

天量:IF(CURRBARSCOUNT<=VAR7+3,CONST(IF(VAR7=0,OPEN,REF(OPEN,VAR7))),DRAWNULL),DOTLINE,COLORGREEN;

VAR8:=STRCAT(HYBLOCK,18);

VAR9:=STRCAT(VAR8,DYBLOCK);

VAR10:=STRCAT(DYBLOCK,18);

VAR11:=STRCAT(VAR9,GNBLOCK);

VAR12:=STRCAT(VAR11,18);

DRAWBAND(EMA(CLOSE,7),RGB(83,123,68),EMA(CLOSE,13),RGB(155,50,50));

DRAWKLINE(HIGH,OPEN,LOW,CLOSE);

DRAWBAND(EMA(CLOSE,13),RGB(83,123,50),EMA(CLOSE,55),RGB(83,123,50));

DRAWKLINE(HIGH,OPEN,LOW,CLOSE);

VAR13:=REF(HHV(MAX(HIGH,OPEN),N),M);

VAR14:=REF(LLV(MIN(HIGH,OPEN),N),M);

VAR15:=VAR13-(VAR13-VAR14)*0.191;

VAR16:=VAR13-(VAR13-VAR14)*0.382;

VAR17:=VAR13-(VAR13-VAR14)*0.5;

VAR18:=VAR13-(VAR13-VAR14)*0.618;

VAR19:=VAR13-(VAR13-VAR14)*0.809;

VAR20:=REFDATE(VAR13,DATE);

VAR21:=REFDATE(VAR15,DATE);

VAR22:=REFDATE(VAR16,DATE);

VAR23:=REF(HHVBARS(MAX(CLOSE,OPEN),60),15)+15;

VAR24:=REF(MAX(CLOSE,OPEN),VAR23);

STICKLINE(BARSTATUS=2,VAR24,VAR24,2000,1),COLORRED,LINETHICK2;

VAR25:=CONST(VAR23);

突破点:IF(CURRBARSCOUNT<=VAR25+1,CONST(IF(VAR25=0,MAX(CLOSE,OPEN),REF(MAX(CLOSE,OPEN),VAR25))),DRAWNULL),POINTDOT,COLORGREEN,LINETHICK4;

IF(CURRBARSCOUNT=VAR25+1,突破点,DRAWNULL),POINTDOT,COLORAA00AA,LINETHICK4;

操做线:EXPMA(CLOSE,7),COLORYELLOW,LINETHICK2;

支撑线:EXPMA(CLOSE,13),COLORRED,LINETHICK2;

防守线:EXPMA(CLOSE,55),COLORLIRED,LINETHICK2;

生命线:MA(CLOSE,30),DOTLINE,COLORMAGENTA;

海面:EMA(CLOSE,78),COLORWHITE,LINETHICK2;

海平面:EMA(CLOSE,80),COLORBLUE,LINETHICK2;

开幅:(OPEN-REF(CLOSE,1))/REF(CLOSE,1)*100,NODRAW,COLORYELLOW;

高幅:(HIGH-REF(CLOSE,1))/REF(CLOSE,1)*100,NODRAW,COLORYELLOW;

低幅:(LOW-REF(CLOSE,1))/REF(CLOSE,1)*100,NODRAW,COLORYELLOW;

实幅:(CLOSE-OPEN)/REF(CLOSE,1)*100,NODRAW,COLORYELLOW;

振幅:(HIGH-LOW)/REF(CLOSE,1)*100,NODRAW,COLORLIMAGENTA;

流值:FINANCE(7)*CLOSE/100000000,NODRAW,COLORLIBLUE;

总值:FINANCE(1)*CLOSE/100000000,NODRAW,COLORLIBLUE;

报期:FINANCE(37),NODRAW,COLORYELLOW;

收益:FINANCE(38),NODRAW,COLORYELLOW;

VAR30:=IF((CLOSE-REF(CLOSE,1))*100/REF(CLOSE,1)>=10-0.01*100/REF(CLOSE,1),1,0);

VAR31:=IF((REF(CLOSE,1)-CLOSE)*100/REF(CLOSE,1)>=10-0.01*100/REF(CLOSE,1),1,0);

STICKLINE(VAR30,OPEN,CLOSE,3,0),COLORAA00AA;

STICKLINE(VAR30,OPEN,CLOSE,1,0),COLORBLACK;

STICKLINE(VAR30,HIGH,LOW,0,1),COLORCC00CC;

STICKLINE(VAR30,OPEN,CLOSE,3,1),COLORCC00CC;

跌停板:STICKLINE(VAR31,OPEN,CLOSE,3,0),COLORFF1100;

STICKLINE(VAR31,OPEN,CLOSE,2.5,0),COLORFF3300;

STICKLINE(VAR31,OPEN,CLOSE,2,0),COLORFF4400;

STICKLINE(VAR31,OPEN,CLOSE,1.5,0),COLORFF5500;

STICKLINE(VAR31,OPEN,CLOSE,1,0),COLORFF6600;

STICKLINE(VAR31,OPEN,CLOSE,0.5,0),COLORFF7700;

STICKLINE(VAR31,LOW,HIGH,0,0),COLORFF7700;

VAR32:=REF((CLOSE-REF(CLOSE,1))/REF(CLOSE,1)<=(-0.03),1) AND (CLOSE-REF(CLOSE,1))/REF(CLOSE,1)>=0.03;

STICKLINE(VAR32,OPEN,CLOSE,2.5,0),COLOR0000A5;

STICKLINE(VAR32,OPEN,CLOSE,2,0),COLOR0000C5;

STICKLINE(VAR32,OPEN,CLOSE,1.5,0),COLOR0000D5;

STICKLINE(VAR32,OPEN,CLOSE,1,0),COLOR0000E5;

STICKLINE(VAR32,LOW,HIGH,0,0),COLOR0000F5;

STICKLINE(VAR32,CLOSE,(OPEN+CLOSE)/2,2.5,0),COLOR008CFD;

IF(CURRBARSCOUNT=VAR7+1,天量,DRAWNULL),COLORYELLOW,LINETHICK2;

VAR33:=(HIGH-REF(CLOSE,1))/REF(CLOSE,1)*100;

VAR34:=(MAX(CLOSE,OPEN)-REF(CLOSE,1))/REF(CLOSE,1)*100;

STICKLINE(VAR33-VAR34>=2.5 AND PERIOD=5 AND CLOSE>OPEN AND MA(CLOSE,5),MAX(CLOSE,OPEN),HIGH,0,0),COLORGREEN;

STICKLINE(VAR33-VAR34>=2.5 AND PERIOD=5 AND CLOSE>OPEN AND MA(CLOSE,5),CLOSE,OPEN,3.1,0),COLORRED;

VAR35:=CLOSE<OPEN AND CLOSE>REF(CLOSE,1);

STICKLINE(VAR35,OPEN,CLOSE,2.8,1),COLOR0000CC;

VAR36:=OPEN>CLOSE AND OPEN>REF(CLOSE,1) AND CLOSE>REF(CLOSE,1);

假阴线:STICKLINE(VAR36,OPEN,CLOSE,2,0),COLORLIRED;


0% (0)
0% (10)

关于通达信一张很强大的主图指标公式的评论:

 以下是对 [通达信一张很强大的主图指标公式] 的评论,总共:0条评论
加入收藏 | 联系我们 | 免责声明 | 站内地图 | 关于我们