买好股公式网 > 股票公式 > 通达信公式 > MACD+KDJ+RSI副图指标源码

MACD+KDJ+RSI副图指标源码

2021年01月17日人气:Tags:MACD KDJ RSI 副图 指标

SQX:=(C-MA(CLOSE,13))*100;

DIF:=EMA(MA(SQX,7),1);

DEA:=EMA(DIF,7);

MACD:=(DIF-DEA)*2;

RSV:=((CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21)))*247.2-123.6;

A11:=BARSLAST(REF(CROSS(DIF,DEA),1));

B1:=REF(C,A11+1) > C AND REF(DIF,A11+1) < DIF AND CROSS(DIF,DEA);

A12:=BARSLAST(REF(CROSS( " KDJ.K " , " KDJ.D " ),1));

B2:=REF(C,A12+1) > C AND REF( " KDJ.K " ,A12+1) < " KDJ.K " AND CROSS( " KDJ.K " , " KDJ.D " );

A13:=BARSLAST(REF(CROSS( " RSI.RSI1 " , " RSI.RSI2 " ),1));

B3:=REF(C,A13+1) > C AND REF( " RSI.RSI1 " ,A13+1) < " RSI.RSI1 " AND CROSS( " RSI.RSI1 " , " RSI.RSI2 " );

C1:=BARSLAST(REF(CROSS(DEA,DIF),1));

D1:=REF(C,C1+1) < C AND REF(DIF,C1+1) > DIF AND CROSS(DEA,DIF);

C2:=BARSLAST(REF(CROSS( " KDJ.D " , " KDJ.K " ),1));

D2:=REF(C,C2+1) < C AND REF( " KDJ.K " ,C2+1) > " KDJ.K " AND CROSS( " KDJ.D " , " KDJ.K " );

C3:=BARSLAST(REF(CROSS( " RSI.RSI2 " , " RSI.RSI1 " ),1));

D3:=REF(C,C3+1) < C AND REF( " RSI.RSI1 " ,C3+1) > " RSI.RSI1 " AND CROSS( " RSI.RSI2 " , " RSI.RSI1 " );

STICKLINE(MACD > 0 AND MACD > REF(MACD,1),MACD,0,0.1,0),COLORRED;

STICKLINE(MACD > 0 AND MACD < REF(MACD,1),MACD,0,0.1,0),COLOR00FFFF;

STICKLINE(MACD < 0 AND MACD < REF(MACD,1),MACD,0,0.1,0),COLORFFFF00;

STICKLINE(MACD < 0 AND MACD > REF(MACD,1),MACD,0,0.1,0),COLORFF00FF;

K:SMA(SMA( RSV,3,1),3,1),COLORWHITE;

D:MA(EMA(K,3),3),COLORYELLOW;

J:3*K-2*D,COLORMAGENTA;

MACD底背:IF(B1 > 0,50,0),LINETHICK2,COLORRED;

KDJ底背:IF(B2 > 0,65,0),LINETHICK2,COLORFF00FF;

RSI底背:IF(B3 > 0,80,0),LINETHICK2,COLORYELLOW;

MACD顶背:IF(D1 > 0,-50,0),LINETHICK2,COLORFF00FF;

KDJ顶背:IF(D2 > 0,-65,0),LINETHICK2,COLORFFCC66;

RSI顶背:IF(D3 > 0,-80,0),LINETHICK2,COLORWHITE;

DRAWICON((CROSS(K,D) AND K < 0 ),K,7);

DRAWICON((CROSS(D,K) AND K > 0 ),D,8);

DRAWICON(J < (REF(J,1))AND K > (REF(K,1)) AND D > (REF(D,1) AND J > 0),REF(J,1),12);

DRAWICON(J > (REF(J,1)) AND K < (REF(K,1)) AND D < (REF(D,1) AND J < 0),REF(J,1),13);

{MACD+KDJ+RSI副图指标源码}

打赏好指标 ×

关于MACD+KDJ+RSI副图指标源码的评论:

 以下是对 [MACD+KDJ+RSI副图指标源码] 的评论,总共:0条评论
加入收藏 | 联系我们 | 免责声明 | 站内地图 | 关于我们