买好股公式网 > 股票公式 > 通达信公式 > 通达信众赢的特别版指标公式

通达信众赢的特别版指标公式

2012年09月05日 【字体: 人气:

众赢筹码线--副
活筹:100*(WINNER(1.1*C)-WINNER(0.9*C));
锁定: EMA(100-活筹,5);
套牢:EMA(100*(1-WINNER(CLOSE)),8);
线5:5,LINETHICK1;
线20:20, POINTDOT;
线50:50, LINETHICK1;
线70:70, POINTDOT;
线95:90, LINETHICK1;
-------------
众赢大盘雷达--副
M 2  100  5
N 2  100  13
上涨动力1:=SUM(ADVANCE-DECLINE,0);
短线趋势:MA(ADL,M),COLORWHITE,LINETHICK2;
中线趋势:MA(ADL,N),COLORLIMAGENTA,LINETHICK2;
STICKLINE(短线趋势>中线趋势,短线趋势,中线趋势,1,0),COLORMAGENTA;
STICKLINE(短线趋势<中线趋势,短线趋势,中线趋势,1,0),COLORGREEN;
多空雷达:SUM(ADVANCE-DECLINE,0),COLORYELLOW,LINETHICK1;
-----------------------
彩色量柱--副
VVOL:IF(CURRBARSCOUNT=1 AND PERIOD=5,VOL*240/FROMOPEN,DRAWNULL),NODRAW;
STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,VVOL,0,-1,-1),COLOR00C0C0;
VOL,VOLSTICK;
STICKLINE(V>REF(V*1.8,1),0,V*0.8,2,0),COLORYELLOW;

AA:V<REF(V,1);
BB:AA<REF(V,2)AND O>REF(O,1);
STICKLINE(AA AND BB,0,V*0.8,1,0),COLORGREEN;
STICKLINE(V<REF(V*0.6,1),0,V*0.6,1,0),COLORBLUE;
倍量:=REF(V,2)>REF(V*1.7,3);
缩量:=REF(V,2)>REF(V,1) AND REF(V,1)>V;
STICKLINE(倍量 AND 缩量,0,V*0.4,1,0),COLORMAGENTA;
平量:= REF(V,1)*0.9<V  AND REF(V,1)*1.1>V ;
STICKLINE(平量,0,V*0.2,1,0),COLORWHITE;
------------------------
众赢十全十美--副
N1  1  100   3
N2  1  100   5
N3  1   100  9
N4  1   100  13
N5   1  100  21
N6   1   100  34
DIFF:=EMA(CLOSE,N3)-EMA(CLOSE,N4);
DEA:=EMA(DIFF,N2);
DRAWICON(DIFF>DEA,1,1);
DRAWICON(DIFF<DEA,1,2);
{DRAWTEXT(ISLASTBAR=1,1,'.MACD'),COLORFFFFFF;}
A1:=DIFF>DEA;
RSV1:=(CLOSE-LLV(LOW,N3))/(HHV(HIGH,N3)-LLV(LOW,N3))*100;
K:=SMA(RSV1,N1,1);
D:=SMA(K,N1,1);
DRAWICON(K>D,1.1,1);
DRAWICON(K<D,1.1,2);
{DRAWTEXT(ISLASTBAR=1,1.1,'.KDJ'),COLORFFFFFF;}
A2:=K>D;
LC:=REF(CLOSE,1);
RSI1:=(SMA(MAX(CLOSE-LC,0),N2,1))/(SMA(ABS(CLOSE-LC),N2,1))*100;
RSI2:=(SMA(MAX(CLOSE-LC,0),N4,1))/(SMA(ABS(CLOSE-LC),N4,1))*100;
DRAWICON(RSI1>RSI2,1.2,1);
DRAWICON(RSI1<RSI2,1.2,2);
{DRAWTEXT(ISLASTBAR=1,1.2,'.RSI'),COLORFFFFFF;}
A3:=RSI1>RSI2;
RSV:=-(HHV(HIGH,N4)-CLOSE)/(HHV(HIGH,N4)-LLV(LOW,N4))*100;
LWR1:=SMA(RSV,N1,1);
LWR2:=SMA(LWR1,N1,1);
DRAWICON(LWR1>LWR2,1.3,1);
DRAWICON(LWR1<LWR2,1.3,2);
{DRAWTEXT(ISLASTBAR=1,1.3,'.LW&R'),COLORFFFFFF;}
A4:=LWR1>LWR2;
BBI:=(MA(CLOSE,N1)+MA(CLOSE,N2)+MA(CLOSE,N3)+MA(CLOSE,N4))/4;
DRAWICON(CLOSE>BBI,1.4,1);
DRAWICON(CLOSE<BBI,1.4,2);
{DRAWTEXT(ISLASTBAR=1,1.4,'.BBI'),COLORFFFFFF;}
A5:=CLOSE>BBI;
MTM:=CLOSE-REF(CLOSE,1);
MMS:=100*EMA(EMA(MTM,N2),N1)/EMA(EMA(ABS(MTM),N2),N1);
MMM:=100*EMA(EMA(MTM,N4),N3)/EMA(EMA(ABS(MTM),N4),N3);
DRAWICON(MMS>MMM,1.5,1);
DRAWICON(MMS<MMM,1.5,2);
{DRAWTEXT(ISLASTBAR=1,1.5,'.ZLMM'),COLORFFFFFF;}
A6:=MMS>MMM;
BIAS:=(C-MA(C,N2))/MA(C,N2);
DIF:=(BIAS-REF(BIAS,16));
DBCD:=SMA(DIF,76,1);
MM:=MA(DBCD,5);
DRAWICON(DBCD>MM ,1.6,1);
DRAWICON(DBCD<MM,1.6,2);
{DRAWTEXT(ISLASTBAR=1,1.6,'.DBCD'),COLORFFFFFF;}
A7:=DBCD>MM;
持股:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1),LINETHICK0,COLORRED;
支撑:=LLV(持股,3),LINETHICK0,COLOR00FFFF;
下跌:=MA(持股,12),COLOR6B8E23,LINETHICK0;
转向:=CROSS(持股,下跌){ AND 下跌<30};
MA1:=MA(持股,5);
向下:=CROSS(MA1,持股) AND MA1>80;
DRAWICON(持股>下跌 ,1.7,1);
DRAWICON(持股<下跌,1.7,2);
{DRAWTEXT(ISLASTBAR=1,1.7,'.CGZ'),COLORFFFFFF;}
A8:=持股>下跌;
MT:=C-REF(C,1);
ZLGJ:=100*EMA(EMA(MT,N3),N3)/EMA(EMA(ABS(MT),N3),N3);
MAZL:=MA(ZLGJ,5);
DRAWICON(ZLGJ>MAZL,1.8,1);
DRAWICON(ZLGJ<MAZL,1.8,2);
A9:=ZLGJ>MAZL;
{DRAWTEXT(ISLASTBAR=1,1.8,'.ZLGJ'),COLORFFFFFF;}
PJJ:=DMA((HIGH+LOW+CLOSE*2)/4,0.9);
JJ:=REF(EMA(PJJ,3),1);
QJJ:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
XVL:=IF(CLOSE>OPEN,QJJ*(HIGH-LOW),IF(CLOSE<OPEN,QJJ*(HIGH-OPEN+CLOSE-LOW),VOL/2))+IF(CLOSE>OPEN,0-QJJ*(HIGH-CLOSE+OPEN-LOW),IF(CLOSE<OPEN,0-QJJ*(HIGH-LOW),0-VOL/2));
HSL:=(XVL/20)/1.15;
攻击流量:=((HSL*0.55+(REF(HSL,1)*0.33))+(REF(HSL,2)*0.22));
GJJ:=EMA(攻击流量,8);
LLJX:=EMA(攻击流量,3);
资金流量:=LLJX,LINETHICK0,COLOR0000FF;
DRAWICON(资金流量>0,1.95,1);
DRAWICON(资金流量<0,1.95,2);
A10:=资金流量>0;
{DRAWTEXT(ISLASTBAR=1,1.89,'.ZJL'),COLORFFFFFF;}
指导线:=(A1+A2+A3+A4+A5+A6+A7+A8+A9+A10),LINETHICK0,COLORFFFF00;
操作:IF(指导线 >6 ,1.1,1),LINETHICK3,COLORYELLOW;

---------
众赢八方聚宝---副
N1:=3;N2:=5;N3:=8;N4:=13;
DIFF:=EMA(CLOSE,N3)-EMA(CLOSE,N4);
DEA:=EMA(DIFF,N2);
DRAWICON(DIFF>DEA,1,1);
DRAWICON(DIFF<DEA,1,2);
A1:=DIFF>DEA;
RSV1:=(CLOSE-LLV(LOW,N3))/(HHV(HIGH,N3)-LLV(LOW,N3))*100;
K:=SMA(RSV1,N1,1);
D:=SMA(K,N1,1);
DRAWICON(K>D,2,1);
DRAWICON(K<D,2,2);
A2:=K>D;
LC:=REF(CLOSE,1);
RSI1:=(SMA(MAX(CLOSE-LC,0),N2,1))/(SMA(ABS(CLOSE-LC),N2,1))*100;
RSI2:=(SMA(MAX(CLOSE-LC,0),N4,1))/(SMA(ABS(CLOSE-LC),N4,1))*100;
DRAWICON(RSI1>RSI2,3,1);
DRAWICON(RSI1<RSI2,3,2);
A3:=RSI1>RSI2;
RSV:=-(HHV(HIGH,N4)-CLOSE)/(HHV(HIGH,N4)-LLV(LOW,N4))*100;
LWR1:=SMA(RSV,N1,1);
LWR2:=SMA(LWR1,N1,1);
DRAWICON(LWR1>LWR2,4,1);
DRAWICON(LWR1<LWR2,4,2);
A4:=LWR1>LWR2;
BBI:=(MA(CLOSE,N1)+MA(CLOSE,N2)+MA(CLOSE,N3)+MA(CLOSE,N4))/4;
DRAWICON(CLOSE>BBI,5,1);
DRAWICON(CLOSE<BBI,5,2);
A5:=CLOSE>BBI;
MTM:=CLOSE-REF(CLOSE,1);
MMS:=100*EMA(EMA(MTM,N2),N1)/EMA(EMA(ABS(MTM),N2),N1);
MMM:=100*EMA(EMA(MTM,N4),N3)/EMA(EMA(ABS(MTM),N4),N3);
DRAWICON(MMS>MMM,6,1);
DRAWICON(MMS<MMM,6,2);
A6:=MMS>MMM;
WJ:=(H+L+C)/3;
V1:=IF(H=L,1,H-MAX(O,C));
V2:=IF(H=L,1,MAX(C,O)-WJ);
V3:=IF(H=L,1,MIN(O,C)-L);
V4:=IF(H=L,1,WJ-MIN(C,O));
V5:=VOL/IF(H=L,4,H-L);
V6:=(V1*V5);
V7:=(V2*V5);
V8:=(V3*V5);
V9:=(V4*V5);
买盘:=(V9+V8);
卖盘:=(V6+V7);
买卖差:=买盘-卖盘;
DDX:=买卖差;
DX:=MA(买卖差,5)*20;
DDX1:=SMA(DX,3,1);
DDX2:=SMA(DDX1,3,1);
DDX3:=(5*DDX2+4*REF(DDX2,1)+3*REF(DDX2,2)+2*REF(DDX2,3)+REF(DDX2,4))/15;
DRAWICON(DDX1>DDX2,7,1);
DRAWICON(DDX1<DDX2,7,2);
A7:=DDX1>DDX2;
量:=V;
换手:=V/CAPITAL*100;
VAR1:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
买盘1:=IF(CLOSE>OPEN,VAR1*(HIGH-LOW),IF(CLOSE<OPEN,VAR1*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2));
卖盘1:=IF(CLOSE>OPEN,0-VAR1*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,0-VAR1*(HIGH-LOW),0-VOL/2));
DLX:=(买盘1-(-卖盘1))/量*换手;
DLX1:=SUM(DLX,6);
DLX2:=MA(DLX1,5);
DRAWICON(DLX1>DLX2,8,1);
DRAWICON(DLX1<DLX2,8,2);
A8:=DLX1>DLX2;
买入:A1 AND A2 AND A3 AND A4 AND A5 AND A6 =1
AND REF(A1 AND A2 AND A3 AND A4 AND A5 AND A6 ,1)=0,COLORYELLOW;
持有:(A1 AND A2 AND A3 AND A4 AND A5 AND A6),COLORMAGENTA,LINETHICK2;
{猎狼指导线:(A1+A2+A3+A4+A5+A6+A7+A8),LINETHICK2,COLORRED;
{动力线1:0;
DDX02:0;
ZLMM3:0;
BBI4:0;
LW&R5:0;
RSI6:0;
KDJ7:0;
MACD8:0;};
-----------------------------
众赢六六大顺--副

DIFF:=EMA(CLOSE,8)-EMA(CLOSE,13);
DEA:=EMA(DIFF,5);
DRAWICON(DIFF>DEA,1,1);
DRAWICON(DIFF<DEA,1,2);
{DRAWTEXT(ISLASTBAR=1,1,'.MACD'),COLORFFFFFF;}
A1:=DIFF>DEA;
RSV1:=(CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100;
K:=SMA(RSV1,3,1);
D:=SMA(K,3,1);
DRAWICON(K>D,2,1);
DRAWICON(K<D,2,2);
{DRAWTEXT(ISLASTBAR=1,2,'.KDJ'),COLORFFFFFF;}
A2:=K>D;
LC:=REF(CLOSE,1);
RSI1:=(SMA(MAX(CLOSE-LC,0),5,1))/(SMA(ABS(CLOSE-LC),5,1))*100;
RSI2:=(SMA(MAX(CLOSE-LC,0),13,1))/(SMA(ABS(CLOSE-LC),13,1))*100;
DRAWICON(RSI1>RSI2,3,1);
DRAWICON(RSI1<RSI2,3,2);
{DRAWTEXT(ISLASTBAR=1,3,'.RSI'),COLORFFFFFF;}
A3:=RSI1>RSI2;
RSV:=-(HHV(HIGH,13)-CLOSE)/(HHV(HIGH,13)-LLV(LOW,13))*100;
LWR1:=SMA(RSV,3,1);
LWR2:=SMA(LWR1,3,1);
DRAWICON(LWR1>LWR2,4,1);
DRAWICON(LWR1<LWR2,4,2);
{DRAWTEXT(ISLASTBAR=1,4,'.LW&R'),COLORFFFFFF;}
A4:=LWR1>LWR2;
BBI:=(MA(CLOSE,3)+MA(CLOSE,5)+MA(CLOSE,8)+MA(CLOSE,13))/4;
DRAWICON(CLOSE>BBI,5,1);
DRAWICON(CLOSE<BBI,5,2);
{DRAWTEXT(ISLASTBAR=1,5,'.BBI'),COLORFFFFFF;}
A10:7;
A5:=CLOSE>BBI;
MTM:=CLOSE-REF(CLOSE,1);
MMS:=100*EMA(EMA(MTM,5),3)/EMA(EMA(ABS(MTM),5),3);
MMM:=100*EMA(EMA(MTM,13),8)/EMA(EMA(ABS(MTM),13),8);
DRAWICON(MMS>MMM,6,1);
DRAWICON(MMS<MMM,6,2);
{DRAWTEXT(ISLASTBAR=1,6,'.ZLMM'),COLORFFFFFF;}
A6:=MMS>MMM;
买入:A1 AND A2 AND A3 AND A4 AND A5 AND A6=1
AND REF(A1 AND A2 AND A3 AND A4 AND A5 AND A6,1)=0,COLORYELLOW,LINETHICK2;
持有:(A1 AND A2 AND A3 AND A4 AND A5 AND A6),COLORMAGENTA,LINETHICK2;
{DRAWICON(DIFF>DEA,1,1);}
{DRAWICON(DIFF<DEA,1,2);}
{DRAWICON(K>D,2,1);}
{DRAWICON(K<D,2,2);}
{DRAWICON(RSI1>RSI2,3,1);}
{DRAWICON(RSI1<RSI2,3,2);}
{DRAWICON(LWR1>LWR2,4,1);}
{DRAWICON(LWR1<LWR2,4,2);}
{DRAWICON(CLOSE>BBI,5,1);}
{DRAWICON(CLOSE<BBI,5,2);}
{DRAWICON(MMS>MMM,6,1);}
{DRAWICON(MMS<MMM,6,2);}
{7,COLORWHITE;};
-----------------------------
众赢风洞判势--副
N   1   300   35
VAR1:=FORCAST(CLOSE,30);
A:WINNER(VAR1), LINETHICK1,COLORYELLOW;
A1:REVERSE(A),LINETHICK1 , COLORWHITE;
A2:(CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55)),COLOR00FF00;
A3:REVERSE(A2), COLORRED;
STICKLINE(C>0,1,{1}0.96,4,0),COLORFF9999;
STICKLINE(C>0,-1,{-1}-0.95,4,0),COLORFF9999;
-0.3,COLORDDDDDD,POINTDOT,LINETHICK2;
0.3,COLORDDDDDD,POINTDOT,LINETHICK2;
---------------------------
众赢波段跟涨--副
STICKLINE(1,0,0,1,0),POINTDOT,LINETHICK3,COLOR0000FF;
QQ:=(((((MA(CLOSE,1) + MA(CLOSE,3)) + MA(CLOSE,5)) + MA(CLOSE,7)) + MA(CLOSE,9)) / 5);
WW:=(((((MA(CLOSE,2) + MA(CLOSE,4)) + MA(CLOSE,6)) + MA(CLOSE,8)) + MA(CLOSE,10)) / 5);
A:=EMA(QQ,3);
B:=EMA(WW,10);
VAR1:=EMA(AMOUNT,1)/EMA(VOL,1)/100;
AA:=DMA(A,VAR1);
BB:=DMA(B,VAR1);
VAR29:=MAX((2 * (AA - BB)),0) * 100;
动能:EMA(VAR29,3),COLORFFFFFF;
CB:=WINNER(CLOSE)*100;
CC:=EMA(CB,2);
追涨热度:MAX((EMA(CC,2) - EMA(CC,5)),0),LINETHICK1,COLOR00FFFF;
STICKLINE(1,0,0,1,0),POINTDOT,LINETHICK3;
STICKLINE(1,0,0,1,0),POINTDOT,LINETHICK3;
敢死队:IF((((VAR29 > 0) AND (VAR29 > REF(VAR29,1)))),(BARSLAST(CROSS(VAR29,0.01)) + 1),0),LINETHICK0;
主力拉升:IF((((VAR29 > 0) AND (VAR29 > REF(VAR29,1)))),66,0),LINETHICK0,COLORFF00FF;
主力启动:DRAWICON(IF((CROSS(VAR29,0.01)),66,0),5,6);

STICKLINE(((VAR29 > 0) AND (VAR29 > REF(VAR29,1))),REF((动能* 1.035),1),(动能 * 1.035),6,1),COLORFF00FF;
HHHD:=IF(CROSS(VAR29,0.01),CLOSE,REF(CLOSE,BARSLAST(CROSS(VAR29,0.01))));
HHH:=IF(CROSS(VAR29,0.01),(LOW * 0.995),REF((LOW * 0.995),BARSLAST(CROSS(VAR29,0.01))));
成本:IF((((VAR29 > 0) AND (VAR29 > REF(VAR29,1)))),HHHD,0),COLORRED,LINETHICK0;
止赢:IF((((VAR29 > 0) AND (VAR29 > REF(VAR29,1)))),(HHHD * 1.06),0),LINETHICK0,COLOR0000FF;
止赢1:=IF((((VAR29 > 0) AND (VAR29 > REF(VAR29,1)))),(HHHD * 1.1),0);
止损:IF((((VAR29 > 0) AND (VAR29 > REF(VAR29,1))) ),HHH,0),LINETHICK0,COLORFFFF00;
离场:IF(((主力拉升 = 0) ),(BARSLAST(CROSS(主力拉升,0.01)) + 1),0),LINETHICK0,COLOR00FFFF;
KZ:="KDJ.K"(9,3,3);
DZ:="KDJ.D"(9,3,3);
K:="KDJ.K"(9,3,3);
KA:="KDJ.D"(9,3,3);
DA:="KDJ.K"(9,3,3);
NN:="KDJ.D"(9,3,3);
NNN:=(BARSLAST((CROSS(KZ,DZ) AND (KZ < 50))) < 13);
NNNN:=(BARSLAST((CROSS(K,KA) AND (K < 20))) < 13);
AAK:=(BARSLAST((CROSS(DA,NN) AND (DA < 20))) < 13);
BBK:=IF((((MA(VOL,5) / 240) >= 5) AND ((CLOSE > (REF(CLOSE,1) * 0.98)) = 1)),88,0);
VAR1MM:=IF(((((((CLOSE / REF(CLOSE,1)) >= 1) AND (((VOL / CAPITAL) * 100) <= 30)) AND (((VOL / CAPITAL) * 100) >= 1.5)) AND ((HIGH / CLOSE) <= 1.001)) AND (BBK >= 1)),93,0);
IF((((((VAR1MM > 90) AND NNN) AND NNNN) AND AAK) ),20,0);
IF(((((VAR1MM > 90) AND NNN) AND NNNN) ),20,0);
VAR2MM:=EMA(MA(IF((CLOSE > OPEN),((CLOSE - OPEN) * VOL),IF((CLOSE < OPEN),((CLOSE - OPEN) * VOL),0)),5),1);
VAR3MM:=EMA(MA(IF((CLOSE > REF(CLOSE,1)),((CLOSE - REF(CLOSE,1)) * VOL),IF((CLOSE < REF(CLOSE,1)),((CLOSE - REF(CLOSE,1)) * VOL),0)),5),1);
VAR4MM:=EMA(MA(IF((OPEN > REF(CLOSE,1)),((OPEN - REF(CLOSE,1)) * VOL),IF((OPEN < REF(CLOSE,1)),((OPEN - REF(CLOSE,1)) * VOL),0)),5),1);
VAR5MM:=EMA(MA(IF((CLOSE < OPEN),((OPEN - CLOSE) * VOL),IF((CLOSE > OPEN),((OPEN - CLOSE) * VOL),0)),10),1);
VAR6MM:=EMA(MA(IF((CLOSE < REF(CLOSE,1)),((REF(CLOSE,1) - CLOSE) * VOL),IF((CLOSE > REF(CLOSE,1)),((REF(CLOSE,1) - CLOSE) * VOL),0)),10),1);
VAR7MM:=EMA(MA(IF((OPEN < REF(CLOSE,1)),((REF(CLOSE,1) - OPEN) * VOL),IF((OPEN > REF(CLOSE,1)),((REF(CLOSE,1) - OPEN) * VOL),0)),10),1);
VAR8MM:=(CLOSE > OPEN);
VAR9MM:=(CLOSE > REF(CLOSE,1));
VARAMM:=(OPEN > REF(CLOSE,1));
VARBMM:=((VAR8MM OR VAR9MM) OR VARAMM);
VARCMM:=((((VAR2MM + VAR3MM) + VAR4MM) / 3) / 100);
VARDMM:=((((VAR5MM + VAR6MM) + VAR7MM) / 3) / 100);
VAR25MM:=EMA((((((((COUNT(VAR9MM,12) / 12) + (COUNT(VAR8MM,12) / 12)) + (COUNT(VARAMM,12) / 12)) / 3) * MA(VARCMM,5)) * 2) * 1.1),2);
换手:=(((VARDMM < 0) AND (VARCMM > VAR25MM)) AND (((CLOSE + OPEN) / 2) > MA(CLOSE,5)));
NMB:=((VOL / CAPITAL) * 100);
IF((((((CROSS(换手,0.1) AND ((VARCMM / 50) >= 0.1)) AND (NMB >= 3)) AND NNN) AND NNNN)),20,0);

LC:=REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LC,0),4.1,1)/SMA(ABS(CLOSE-LC),4.1,1)*100;
预备:CROSS(RSI,11)*80,COLORBLUE;
DRAWTEXT(预备,39,'预备'),COLOR66FFCC;
---------------------------
众赢运钞专列--副
{可选股,条件是:运钞专列上穿和谐一号 }
 
VAR1:=(2*CLOSE+HIGH+LOW)/4;
VAR2:=LLV(LOW,34);
VAR3:=HHV(HIGH,34);
运钞专列: EMA((VAR1-VAR2)/(VAR3-VAR2)*100,13);
和谐一号:= EMA(0.667*REF(运钞专列,1)+0.333*运钞专列,2);
众赢一号:和谐一号;
X1:STICKLINE(CROSS(运钞专列,20) AND 和谐一号<运钞专列,运钞专列+19,运钞专列-10,4,1),COLORRED;
X2:DRAWTEXT(CROSS(运钞专列,20) AND 和谐一号<运钞专列,运钞专列-5,'众赢贵宾建仓 '),
LINETHICK3, COLORMAGENTA ;
金砖:STICKLINE(和谐一号<运钞专列,运钞专列,和谐一号,2.5,1),COLORRED;
瓦砾:STICKLINE(和谐一号>运钞专列,运钞专列,和谐一号,2.5,1),COLORBLUE;
选股:=CROSS(运钞专列,30) AND 和谐一号<运钞专列; 
一叉:DRAWICON(CROSS(运钞专列,和谐一号),和谐一号,5);
二叉:DRAWICON(CROSS(和谐一号,运钞专列),和谐一号,15);
-------------------------
众赢短线赢家--副
股价趋势:=((3 * SMA((((CLOSE - LLV(LOW,27)) / (HHV(HIGH,27) - LLV(LOW,27))) * 100),5,1)) - (2 * SMA(SMA((((CLOSE - LLV(LOW,27)) / (HHV(HIGH,27) - LLV(LOW,27))) * 100),5,1),3,1)));
底部警戒:=10;
买入警戒:STICKLINE((股价趋势 <= 10),0,20,2,0),LINETHICK2,COLORYELLOW;
买入信号:=STICKLINE(CROSS(股价趋势,底部警戒),0,30,3,0),COLORWHITE;
顶部警戒:=90;
卖出警戒:STICKLINE((股价趋势 >= 85),100,80,2,0),LINETHICK2,COLOR66FF00;
止损出局:STICKLINE(CROSS(顶部警戒,股价趋势),130,90,3,0),LINETHICK5,COLORFF3300;
QQQ:=CROSS(顶部警戒,股价趋势);
{DRAWICON(QQQ,70,19);
DRAWTEXT(QQQ,130,'*止损');}
多方趋势线:(((7 * SMA((((CLOSE - LLV(LOW,27)) / (HHV(HIGH,27) - LLV(LOW,27))) * 30),4,1))
- (3 * SMA(SMA((((CLOSE - LLV(LOW,27)) / (HHV(HIGH,27) - LLV(LOW,27))) * 30),4,1),3,1)))
- SMA(SMA(SMA((((CLOSE - LLV(LOW,27)) / (HHV(HIGH,27) - LLV(LOW,27))) * 30),4,1),3,1),2,1)),COLOR8811FF,LINETHICK2;
主升线:=14;
天线:=78.89;
抄底:=CROSS(多方趋势线,主升线);
逃顶:=CROSS(天线,多方趋势线);
DRAWICON(抄底,多方趋势线,5);
DRAWICON(逃顶,110,6);
VARX:=((3 * SMA((((CLOSE - LLV(LOW,27)) / (HHV(HIGH,27) - LLV(LOW,27))) * 100),5,1))
- (2 * SMA(SMA((((CLOSE - LLV(LOW,27)) / (HHV(HIGH,27) - LLV(LOW,27))) * 100),5,1),3,1)));
股价启动在即:=IF(CROSS(VARX,3),100,0);
捕食秘密买点:=IF((VARX <= 3),25,0);
建增补仓:IF((VARX < 5),100,0),COLORRED;
VAR21:=REF(CLOSE,1);
VAR22:=((SMA(MAX((CLOSE - VAR21),0),6,1) / SMA(ABS((CLOSE - VAR21)),6,1)) * 100);
短期顶部:(CROSS(80,VAR22) * 160),COLORWHITE;
DRAWTEXT(CROSS(80,VAR22),150,'★见顶 '),COLORWHITE;
VAR31:=((SMA(MAX((CLOSE - VAR21),0),7,1) / SMA(ABS((CLOSE - VAR21)),7,1)) * 100);
VAR41:=((SMA(MAX((CLOSE - VAR21),0),13,1) / SMA(ABS((CLOSE - VAR21)),13,1)) * 100);
VAR51:=BARSCOUNT(CLOSE);
短期底部:=(((VAR31 < 20) AND (VAR41 < 25)) AND (VAR51 > (50 * 300)));
DRAWTEXT(CROSS(100,短期底部),40,'☆短底 '),COLORBROWN;
VAR441:=((LLV(LOW,5) = LLV(LOW,45)) AND (CLOSE >= (OPEN * 1.04)));
VAR442:=(CLOSE > ((REF(HIGH,1) + REF(LOW,1)) / 2));
红灯:=(VAR441 AND VAR442);
VAR33:=REF(CLOSE,1);
VAR43:=((SMA(MAX((CLOSE - VAR33),0),6,1) / SMA(ABS((CLOSE - VAR33)),6,1)) * 100);
绿灯:=CROSS(80,VAR43);
VAR2:=REF(LOW,1);
VAR3:=((SMA(ABS((LOW - VAR2)),3,1) / SMA(MAX((LOW - VAR2),0),3,1)) * 100);
VAR4:=EMA(IF((CLOSE * 1.2),(VAR3 * 10),(VAR3 / 10)),3);
VAR5:=LLV(LOW,38);
VAR6:=HHV(VAR4,38);
VAR7:=IF(LLV(LOW,90),1,0);
VAR8:=((EMA(IF((LOW <= VAR5),((VAR4 + (VAR6 * 2)) / 2),0),3) / 618) * VAR7);
秘密吸筹:STICKLINE(VAR8,0,VAR8,6,1),COLORFFFF66;
XL1:=(MA(LOW,2) * 0.96);
XL2:=(MA(LOW,26) * 0.85);
XL3:=(((REF(XL1,1) < XL2) AND (REF(XL1,1) < XL1)) AND (REF(XL1,1) < REF(XL1,2)));
STICKLINE(XL3,0,(VAR8 * 2),6,0),COLORFF00CC;
{DRAWTEXT(XL3,(VAR8 * 2),'短线出击'),COLORRED;}
↑短线突击:DRAWICON(XL3,40,25),COLORFF99CC;
DRAWICON(红灯,1.1,9);
DRAWICON(绿灯,80,15);
----------------------------------
众赢波段专家--副
T1:=5;
T2:=4;
P:=((2)*(CLOSE) + HIGH + LOW + OPEN)/(5);
BB:=MA(P,3);
CC:=(SUM(IF((P > REF(P,1)),(P)*(VOL),0),4))/(SUM(IF((P < REF(P,1)),(P)*(VOL),0),4));
DD:=REF(100 - (100)/(1 + CC),1);
A1:=HHV(P,15);
A2:=LLV(P,15);
A3:=A1 - A2;
A4:=(EMA((P - A2)/(A3),2))*(100);
B1:=HHV(P,60);
B2:=LLV(P,60);
B3:=B1 - B2;
B4:=(EMA((P - B2)/(B3),2))*(100);
C1:=HHV(P,240);
C2:=LLV(P,240);
C3:=C1 - C2;
C4:=(EMA((P - C2)/(C3),2))*(100);
长风险:C4,LINETHICK2,COLORAA7755{COLOR443434};
中风险:B4,COLOR44AABB,LINETHICK2;
短风险:A4,COLORRED;
VAR4:=LLV(LOW,T1);
VAR5:=HHV(HIGH,T2);
散户:=EMA(((P - VAR4)/(VAR5 - VAR4))*(100),T2),LINETHICK2,COLOR3333DD;
庄家:=EMA((0.667)*(REF(散户,1)) + (0.333)*(散户),2),LINETHICK2,COLORDDCC00;
快线:散户,COLORMAGENTA,LINETHICK2;
慢线:庄家,COLORYELLOW,LINETHICK2;
警戒线:80,COLORYELLOW;
启动线:20,COLORMAGENTA;
50,POINTDOT,COLOR00DCDC;

IF(FILTER((中风险 < REF(中风险,1)) AND (中风险 > 90) AND (BB < REF(BB,1)),5),92,100),LINETHICK2,COLOR44BB00;
IF(FILTER((中风险 > REF(中风险,1)) AND (中风险 < 5) AND (CLOSE > REF(CLOSE,1)),5),14,0),LINETHICK2,COLOR2222FF;

VAR6:=((HHV(HIGH,4) - P)/(HHV(HIGH,4) - LLV(LOW,4)))*(100) - 72;
VAR7:=((P - LLV(LOW,4))/(HHV(HIGH,4) - LLV(LOW,4)))*(100);
VAR8:=SMA(VAR7,2,1);
DRAWTEXT(CROSS(散户,庄家) AND (散户 < 50) AND (25 < 散户),20,8),COLORRED;
DRAWTEXT(CROSS(庄家,散户) AND (散户 > 40) AND (71 > 散户),70,9),COLORFF0000;
DRAWTEXT(CROSS(散户,庄家) AND (散户 < 30),30,10),COLORRED;
DRAWICON(CROSS(散户,庄家) AND (散户 < 30),20,5),COLORYELLOW;
DRAWICON(CROSS(庄家,散户) AND (庄家 > 73),80,6),COLORFF00FF;
VAR9:=CLOSE - REF(CLOSE,5);
VARA:=((EMA(EMA(VAR9,5),5))/(EMA(EMA(ABS(VAR9),5),5)))*(100);
VARB:=((EMA(EMA(VAR9,10),10))/(EMA(EMA(ABS(VAR9),10),10)))*(100);
VARC:=((EMA(EMA(VAR9,20),20))/(EMA(EMA(ABS(VAR9),20),20)))*(100);
卖出:=IF((VARA > 0) AND CROSS(VARC,VARA),10,0);
{DRAWICON((卖出 > 0),60,19),COLOR00FF00;}
CCI:=((P - MA(P,14))*(100))/((1.5)*(AVEDEV(P,14)));
RSI1:=((SMA(MAX(CLOSE - REF(CLOSE,1),0),6,1))/(SMA(ABS(CLOSE - REF(CLOSE,1)),6,1)))*(100);
STICKLINE((CCI > 100),106,100,2,0),COLOR00AC00;
STICKLINE((RSI1 > 80),103,100,2,0),COLORBLUE;
STICKLINE((CCI < (-100)),(-6),0,2,0),COLORYELLOW;
STICKLINE((RSI1 < 25),(-3),(-0),2,0),COLORMAGENTA;
D1:=(中风险 > REF(中风险,1)) AND (短风险 > REF(短风险,1)) AND (长风险 > REF(长风险,1))
AND (长风险 < 8) AND (中风险 < 10) AND (短风险 < 15);
D2:=CROSS(短风险,中风险) AND (中风险 < 8);
D3:=CROSS(短风险,长风险) AND (长风险 < 8) AND (中风险 < 20);
DRAWICON(FILTER(D1 OR D2 OR D3 AND (DD < 15)
AND (CLOSE > REF(CLOSE,1)),5),8,25);
DRAWICON(FILTER((中风险 < REF(中风险,1)) AND (短风险 < REF(短风险,1))
AND (长风险 < REF(长风险,1)) AND (中风险 > 95) AND (短风险 > 85)
OR (长风险 > 100) AND (中风险 > 100) AND (短风险 > 100),5),95,23);

---------------------------
众赢顺势而为--副
DIFF :=( EMA(CLOSE,12) - EMA(CLOSE,26))*100;
DEA  :=EMA(DIFF,9);
MACD :=2*(DIFF-DEA);
绿柱消失买入:STICKLINE(DIFF<0,0,DIFF,2,0),COLOR00FF00;
红柱消失卖出:STICKLINE(DIFF>=0,0,DIFF,2,0),COLORRED;
STICKLINE(DEA>=0,0,DEA,2,0),COLORBLUE;
STICKLINE(DEA<0,0,DEA,2,0),COLORYELLOW;
DRAWICON(CROSS(DIFF,DEA),DEA*1.1,1);
DRAWICON(CROSS(DEA,DIFF),DEA*1.1,2);
强1:IF(DIFF>DEA,DIFF,DRAWNULL),COLORRED,LINETHICK2;
强2:IF(DEA<DIFF,DEA,DRAWNULL),COLORMAGENTA,LINETHICK2;
抄底:=ABS((CROSS("MACD.DIF","MACD.DEA")
&&"MACD.DEA"<=-0.07)*"MACD.DIF")*1.09,COLORLIMAGENTA,LINETHICK2;
DRAWTEXT(ABS(抄底)>0,抄底,' 抄底'),COLORRED;
DRAWICON(ABS(抄底)>0,抄底,9);
-----------------------
众赢MACD优化--副
SQX:=(C-MA(CLOSE,13))*100;
DIF:EMA(MA(SQX,7),1),LINETHICK1;
DEA:EMA(DIF,7),LINETHICK1;
MACD: (DIF-DEA)*2,COLORSTICK;
红柱持股:IF(MACD>REF(MACD,1),MACD,DRAWNULL),STICK,COLORRED,LINETHICK3;
绿柱持币:IF(MACD<REF(MACD,1),MACD,DRAWNULL),STICK,COLORGREEN,LINETHICK3;
低位金叉:IF(CROSS(DIF,DEA) AND DIF<-0.1,0.3,0),COLORYELLOW,POINTDOT;
STICKLINE(低位金叉,0,10,8,1),COLORYELLOW;
DRAWICON(低位金叉,0.3,1);
JCCOUNT:=COUNT(CROSS(DIF,DEA),BARSLAST(DEA>=0));
二次金叉:IF(CROSS(DIF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1,0.2,0),COLORFF00FF,POINTDOT;
STICKLINE(二次金叉,25,15,8,1),COLORFF00FF;
A1:=BARSLAST(REF(CROSS(DIF,DEA),1));
底背离:IF(REF(CLOSE,A1+1)>CLOSE AND DIF>REF(DIF,A1+1) AND CROSS(DIF,DEA),0.1,0),COLORRED,POINTDOT;
STICKLINE(底背离,40,30,8,1),COLORMAGENTA;
DRAWLINE(A1=0,DEA,底背离,DEA,0),COLORMAGENTA,LINETHICK3;
A2:=BARSLAST(REF(CROSS(DEA,DIF),1));
顶背离:REF(CLOSE,A2+1)<CLOSE AND REF(DIF,A2+1)>DIF AND CROSS(DEA,DIF),COLORGREEN;
DRAWLINE(A2=0,DEA,顶背离,DEA,0),COLORBLUE,LINETHICK3;
A3:=CROSS(DIF,DEA) AND DEA<0;
零下二次金叉:IF(FILTER(COUNT(A3,21)=2,10),0.05,0),COLORWHITE,POINTDOT;
STICKLINE(零下二次金叉,45,55,8,1),COLORWHITE;
金叉:DRAWICON(CROSS(DIF,DEA),DIF,1);
死叉:DRAWICON(CROSS(DEA,DIF),DIF,2);

---------------------
众 赢 B B D--副
ZZ:=(HHV(H,3)+LLV(L,3))/2;A:=IF(C>ZZ,VOL,0);B:=IF(C<ZZ,VOL,0);总0:=(A-B);
众赢BBD:EMA(总0,3)/SUM(VOL,5)*100,LINETHICK;
BBD:=众赢BBD;
STICKLINE(BBD>=0,0,BBD,3,0),COLOR000088;
STICKLINE(BBD>=0,0,BBD,1.5,0),COLOR0000AA;
STICKLINE(BBD>=0,0,BBD,1,0),COLOR0000CC;
STICKLINE(BBD>=0,0,BBD,0.5,0),COLOR0000FF;
STICKLINE(BBD<0,0,BBD,3,0),COLOR888800;
STICKLINE(BBD<0,0,BBD,1.5,0),COLORAAAA00;
STICKLINE(BBD<0,0,BBD,1,0),COLORCCCC00;
STICKLINE(BBD<0,0,BBD,0.5,0),COLORFFFF00;
XH1:=REF(BBD,1)<REF(BBD,2) AND REF(BBD,1)<-10 AND BBD>REF(BBD,1) AND BBD>0;
XH2:=REF(BBD,1)>=REF(BBD,2) AND REF(BBD,1)>8 AND BBD<REF(BBD,1) AND BBD<0;
DRAWICON(XH1,-20,1);DRAWICON(XH2,20,2);
-------------------
众赢资金监测--副
VAR1:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
主动买盘:IF(CLOSE>OPEN,VAR1*(HIGH-LOW),IF(CLOSE<OPEN,VAR1*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2)),LINETHICK0;
主动卖盘:IF(CLOSE>OPEN,0-VAR1*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,0-VAR1*(HIGH-LOW),0-VOL/2)),LINETHICK0,COLORGREEN;
【买卖差】:主动买盘+主动卖盘,NODRAW,COLORFF0099;
资金异动:VOL/MA(VOL,55)*100,COLORYELLOW;
5日换手:SUM(100*V/CAPITAL,5);
STICKLINE(C<O ,0,VOL,3.2,0),COLORFF1100;
STICKLINE(C<O ,0,VOL,2.7,0),COLORFF3300;
STICKLINE(C<O ,0,VOL,2.1,0),COLORFF5500;
STICKLINE(C<O ,0,VOL,1.5,0),COLORFF7700;
STICKLINE(C<O ,0,VOL,0.9,0),COLORFF9900;
STICKLINE(C<O ,0,VOL,0.3,0),COLORFFBB00;
STICKLINE(C=O AND C<REF(C,1),0,VOL,3.2,0),COLOR006000;
STICKLINE(C=O AND C<REF(C,1),0,VOL,2.7,0),COLOR007500;
STICKLINE(C=O AND C<REF(C,1),0,VOL,2.1,0),COLOR009100;
STICKLINE(C=O AND C<REF(C,1),0,VOL,1.5,0),COLOR00A600;
STICKLINE(C=O AND C<REF(C,1),0,VOL,0.9,0),COLOR00BB00;
STICKLINE(C=O AND C<REF(C,1),0,VOL,0.3,0),COLOR00CC00;
STICKLINE(C=O AND C>REF(C,1),0,VOL,3.2,0),COLOR555555;
STICKLINE(C=O AND C>REF(C,1),0,VOL,2.7,0),COLOR777777;
STICKLINE(C=O AND C>REF(C,1),0,VOL,2.1,0),COLOR999999;
STICKLINE(C=O AND C>REF(C,1),0,VOL,1.5,0),COLORBBBBBB;
STICKLINE(C=O AND C>REF(C,1),0,VOL,0.9,0),COLORDDDDDD;
STICKLINE(C=O AND C>REF(C,1),0,VOL,0.3,0),COLORFFFFFF;
STICKLINE(C>O,0,VOL,3.2,0),COLORFF11FF;
STICKLINE(C>O,0,VOL,2.7,0),COLORFF33FF;
STICKLINE(C>O,0,VOL,2.1,0),COLORFF55FF;
STICKLINE(C>O,0,VOL,1.5,0),COLORFF77FF;
STICKLINE(C>O,0,VOL,0.9,0),COLORFF99FF;
STICKLINE(C>O,0,VOL,0.3,0),COLORFFBBFF;
STICKLINE(主动买盘>0,0,主动买盘,3.2,0),COLOR000055;
STICKLINE(主动买盘>0,0,主动买盘,2.7,0),COLOR000077;
STICKLINE(主动买盘>0,0,主动买盘,2.1,0),COLOR000099;
STICKLINE(主动买盘>0,0,主动买盘,1.5,0),COLOR0000BB;
STICKLINE(主动买盘>0,0,主动买盘,0.9,0),COLOR0000DD;
STICKLINE(主动买盘>0,0,主动买盘,0.3,0),COLOR0000FF;
STICKLINE(主动卖盘<0,0,主动卖盘,3.2,0),COLOR006000;
STICKLINE(主动卖盘<0,0,主动卖盘,2.7,0),COLOR007500;
STICKLINE(主动卖盘<0,0,主动卖盘,2.1,0),COLOR009100;
STICKLINE(主动卖盘<0,0,主动卖盘,1.5,0),COLOR00A600;
STICKLINE(主动卖盘<0,0,主动卖盘,0.9,0),COLOR00BB00;
STICKLINE(主动卖盘<0,0,主动卖盘,0.3,0),COLOR00CC00;
STICKLINE(资金异动>100 ,0,VOL,0.1,0),COLORYELLOW;
SQX:=(C-MA(CLOSE,13))*100;
DIFF:EMA(MA(SQX,7),1),COLORYELLOW,LINETHICK1;
DEA:EMA(DIFF,7),COLOR00FF00,LINETHICK1;
-----------------------
众赢多空趋势--主图叠加
多:EMA(C,3),COLORYELLOW;
空:EMA(C,5),COLOR00FF00;
均衡:EMA(空,5),COLORWHITE,;
VARF1:=COUNT(CROSS(多,均衡),2)=1;
VARF2:=COUNT(CROSS(空,均衡),2)=1;
ZAI:=FILTER(VARF1 AND VARF2,2);
DRAWTEXT(ZAI,均衡*0.99,' →●¤主升'),COLORFF00FF;
VV2:=REF(CLOSE,1);
VV3:=SMA((CLOSE-VV2),6,1)/SMA(ABS(CLOSE-VV2),6,1)*100;
DRAWICON(REF(VV3,1)>81 AND VV3<80,HIGH,2);
DRAWTEXT(REF(VV3,1)>81 AND VV3<80,HIGH*0.99,' →●逃顶↓'),COLORGREEN;
VF1:=MA(CLOSE,60)-MA(CLOSE,5)/3.2;
DRAWTEXT(IF(CLOSE<VF1 AND VOL/240>MA(VOL,5)/240 AND CLOSE>=REF(CLOSE,1)*1.08 AND CLOSE<MA(CLOSE,13)*1.3,1,0),LOW,'☆'),COLORRED;
VARA:=(CLOSE-REF(OPEN,29))/REF(OPEN,29)*100;
VARB:=EMA(0.667*REF(VARA,1)+0.333*VARA,5);
DRAWTEXT(IF(VOL>=1.3*MA(VOL,5) AND COUNT(VARA>=VARB AND VARA<-17,3) AND
REF(LOW,1)=LLV(LOW,120),1,0),LOW,'★买');
VARR1:=SMA(MAX(CLOSE-REF(C,1),0),6,1)/SMA(ABS(CLOSE-REF(C,1)),6,1)*100;
DRAWICON(CROSS(82,VARR1),HIGH,2);
DRAWTEXT(CROSS(82,VARR1),HIGH,'短空↓'),COLORYELLOW;
VAR1:=(HIGH+LOW+OPEN+2*CLOSE)/5;
VAR2:=REF(VAR1,1);
VAR3:=SMA(MAX(VAR1-VAR2,0),10,1)/SMA(ABS(VAR1-VAR2),10,1)*100;
HY3:=IF(COUNT(VAR3<20,5)>=1 AND COUNT(VAR1=LLV(VAR1,10),10)>=1 AND
CLOSE>=OPEN*1.038 AND VOL>MA(VOL,5)*1.2,1,0);
DRAWTEXT(HY3,LOW*0.99,'→◆●注意买入'),COLORLIRED;

----------------------------
众赢专用主图--主图叠加
B1:=MA(C,1);
B2:=SMA(SMA(SMA(B1,2,1),2,1),2,1);
SMA2:=MA(B2,3);
停损下限:IF(LLV(MA(B2,8),3)<B2,LLV(MA(B2,8),3),B2);
IF(B2>SMA2,B2,DRAWNULL),COLORRED,LINETHICK4;
IF(B2<SMA2,B2,DRAWNULL),COLORGREEN,LINETHICK4;
SNAKEA:HHV(MA(B2,1),13),COLORYELLOW;
VAR1:=(2*CLOSE+HIGH+LOW)/4;
VAR2:=MA(VAR1,7);
VAR3:=VAR2-MA(VAR1,7/2)<0;
VAR4:=VAR2-MA(VAR1,7/2)>0;
VAR5:=BARSLAST(VAR3);
VAR6:=0-BARSLAST(VAR4);
VAR7:=IF(VAR3<=0,VAR5,VAR6);
STICKLINE(SNAKEA>B2 AND B2>SMA2,SNAKEA,B2,0,1),COLORLIBLUE;
STICKLINE(SNAKEA>SMA2 AND B2<SMA2,SNAKEA,SMA2,0,1),COLORBLUE;
VAR11:=(CLOSE*2+HIGH+LOW)/4;
VAR21:=EMA(VAR11,13)-EMA(VAR11,34);
VAR31:=EMA(VAR21,5);
STICKLINE((C>=O),OPEN,LOW,0,0),COLOR0726CA;
STICKLINE((C>=O),CLOSE,HIGH,0,0),COLOR0726CA;
STICKLINE((C<O),CLOSE,LOW,0,0),COLORDE9100;
STICKLINE((C<O),OPEN,HIGH,0,0),COLORDE9100;
STICKLINE((C<O),CLOSE,OPEN,4,0),COLORFF5B00;
STICKLINE((C<O),CLOSE,OPEN,3.4,0),COLORFF6C00;
STICKLINE((C<O),CLOSE,OPEN,2.8,0),COLORFF7B00;
STICKLINE((C<O),CLOSE,OPEN,2.2,0),COLORFF9C00;
STICKLINE((C<O),CLOSE,OPEN,1.6,0),COLORFFBE00;
STICKLINE((C<O),CLOSE,OPEN,1,0),COLORFFCC00;
STICKLINE((C<O),CLOSE,OPEN,0.3,0),COLORFFFF00;
STICKLINE((C>O),CLOSE,OPEN,4,0),COLOR070084;
STICKLINE((C>O),CLOSE,OPEN,3.4,0),COLOR0000A3;
STICKLINE((C>O),CLOSE,OPEN,2.8,0),COLOR0000B7;
STICKLINE((C>O),CLOSE,OPEN,2.2,0),COLOR0000CD;
STICKLINE((C>O),CLOSE,OPEN,1.6,0),COLOR0000E9;
STICKLINE((C>O),CLOSE,OPEN,1,0),COLOR0754E9;
STICKLINE((C>O),CLOSE,OPEN,0.5,0),COLOR076EF3;
STICKLINE((C>O),CLOSE,OPEN,0.2,0),COLOR077BF3;
VAR2A:=((CLOSE > REF(CLOSE,1)) AND (CLOSE > REF(CLOSE,2)));
VAR3A:=((REF(VAR2A,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR4A:=((REF(VAR3A,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR5A:=((REF(VAR4A,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR6A:=((REF(VAR5A,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR7A:=((REF(VAR6A,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR8A:=((REF(VAR7A,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR9A:=((REF(VAR8A,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VARAA:=((REF(VAR9A,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VARBA:=((REF(VARAA,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VARCA:=((REF(VARBA,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VARDA:=((REF(VARCA,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAREAA:=((CLOSE < REF(CLOSE,1)) AND (CLOSE < REF(CLOSE,2)));
VARFA:=((REF(VAREAA,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF
(CLOSE,2)));
VAR10A:=((REF(VARFA,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF
(CLOSE,2)));
VAR11A:=((REF(VAR10A,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF
(CLOSE,2)));
VAR12A:=((REF(VAR11A,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF
(CLOSE,2)));
VAR13A:=((REF(VAR12A,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF
(CLOSE,2)));
VAR14A:=((REF(VAR13A,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF
(CLOSE,2)));
VAR15A:=((REF(VAR14A,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF
(CLOSE,2)));
VAR16A:=((REF(VAR15A,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF
(CLOSE,2)));
VAR17A:=((REF(VAR16A,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF
(CLOSE,2)));
VAR18A:=((REF(VAR17A,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF
(CLOSE,2)));
VAR19A:=((REF(VAR18A,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF
(CLOSE,2)));
VAR1A:=(REF((((((((((((VAREAA OR VARFA) OR VAR10A) OR VAR11A) OR VAR12A) OR
VAR13A) OR VAR14A) OR VAR15A) OR VAR16A) OR VAR17A) OR VAR18A) OR VAR19A),1) AND
VAR2A);
STICKLINE(VAR1A,O,O+(C-O)/3,4,0),COLOR1029FF;
STICKLINE(VAR1A,O,O+(C-O)/3,3.4,0),COLOR1040FF;
STICKLINE(VAR1A,O,O+(C-O)/3,2.8,0),COLOR1083FF;
STICKLINE(VAR1A,O,O+(C-O)/3,2.2,0),COLOR10ABFF;
STICKLINE(VAR1A,O,O+(C-O)/3,1.6,0),COLOR10D0FF;
STICKLINE(VAR1A,O,O+(C-O)/3,1,0),COLOR10FFFF;
STICKLINE(VAR1A,O,O+(C-O)/3,0.3,0),COLOR00FFFF;
AA:=(REF((((((((((((VAR2A OR VAR3A) OR VAR4A) OR VAR5A) OR VAR6A) OR VAR7A) OR
VAR8A) OR VAR9A)
OR VARAA) OR VARBA) OR VARCA) OR VARDA),1) AND VAREAA);

STICKLINE(AA,O,O+(C-O)/3,4.3,0),COLOR009900;
STICKLINE(AA,O,O+(C-O)/3,3.2,0),COLOR00AA00;
STICKLINE(AA,O,O+(C-O)/3,2.4,0),COLOR00BB00;
STICKLINE(AA,O,O+(C-O)/3,1.7,0),COLOR00CC00;
STICKLINE(AA,O,O+(C-O)/3,1.1,0),COLOR00DD00;
STICKLINE(AA,O,O+(C-O)/3,0.5,0),COLOR00EE00;
STICKLINE(AA,O,O+(C-O)/3,0.2,0),COLOR00FF00;
A13:=EMA(CLOSE,55);
A14:=MA(CLOSE,75);
A15:=EMA(A14,3);
A16:=EMA(A15,3);
A17:=(HIGH + LOW) / 5;
A18:=(MA(A17,4)) - (MA(A17,34));
A19:=CROSS(A18,0);
A20:=CROSS(0,A18);
A21:=BARSLAST(A19);
A22:=BARSLAST(A20);
A23:=REF(A19,1);
A24:=REF(A20,1);
A25:=BARSLAST(A23);
A26:=BARSLAST(A24);
A27:=IF((A25 < A26),(REF((HHV(HIGH,2)),A25)),(REF((LLV(LOW,2)),A26)));
A28:=(((REF(CLOSE,1)) <= (REF(A27,1))) AND (CLOSE > A27)) AND (A21 < A22);
A29:=(((REF(CLOSE,1)) >= (REF(A27,1))) AND (CLOSE < A27)) AND (A22 < A21);
A30:=A28 AND ((COUNT(A28,A21)) = 1);
A31:=A29 AND ((COUNT(A29,A22)) = 1);
A32:=A30 AND ((REF(BARSLAST(A31),1)) < (REF(BARSLAST(A30),1)));
A33:=A31 AND ((REF(BARSLAST(A31),1)) > (REF(BARSLAST(A30),1)));
DRAWTEXT(A32,SMA2*0.99,'←═≒∝'),COLORYELLOW;
AC:=AMOUNT/(VOL);
YY:=MA(AC,13);
LLL:=(C-YY)/YY*100;
MIDC :=  MA(CLOSE,22);
UPPERC:= MIDC + 2*STD(C,22);
LOWERC:= MIDC - 2*STD(C,22);
BBA:=(C-LOWERC)/(UPPERC-LOWERC);
L55188CYC:=(REF(LLL,1)<-15 AND REF(BBA,1)<0 AND LLL>REF(LLL,1));
STICKLINE(L55188CYC,LOW*0.93,LOW*0.95,6,0)COLORRED;
STICKLINE(L55188CYC>0,C,O,4,0),COLORRED;
STICKLINE(L55188CYC>0,C,O,3.4,0),COLOR1029FF;
STICKLINE(L55188CYC>0,C,O,2.8,0),COLOR1040FF;
STICKLINE(L55188CYC>0,C,O,2.2,0),COLOR1083FF;
STICKLINE(L55188CYC>0,C,O,1.6,0),COLOR10ABFF;
STICKLINE(L55188CYC>0,C,O,1,0),COLOR10D0FF;
STICKLINE(L55188CYC>0,C,O,0.3,0),COLOR10FFFF;
DRAWTEXT(L55188CYC>0,LOW*0.98,'☆')COLORFF00FF;
DRAWTEXT(A32,REF(C,10)*0.92,'☆众赢投资网制作QQ411606593☆'),COLORFF00FF;
-------------------------------
众赢我的未来--主图叠加
N  20   999   150
高1:=REF(HHV(H,N),3);
低1:=REF(LLV(L,N),3);
H1:=高1-(高1-低1)*0.809;
H2:=高1-(高1-低1)*0.618;
H3:=高1-(高1-低1)*0.5;
H4:=高1-(高1-低1)*0.382;
H5:=高1-(高1-低1)*0.191;

天:REFDATE(高1,DATE),COLORGREEN,CROSSDOT,LINETHICK1;
地:REFDATE(低1,DATE),COLORRED,CROSSDOT,LINETHICK1;
下191:REFDATE(H1,DATE),COLORCYAN,POINTDOT;
下382:REFDATE(H2,DATE),COLORYELLOW,POINTDOT;
中5:REFDATE(H3,DATE),COLORMAGENTA,LINETHICK2;
上618:REFDATE(H4,DATE),COLORYELLOW,POINTDOT;
上809:REFDATE(H5,DATE),COLORCYAN,POINTDOT;

DRAWICON(CROSS(ZIG(3,12),REF(ZIG(3,12),1)),LOW*0.80,7);
DRAWICON(CROSS(ZIG(3,5),REF(ZIG(3,5),1)),LOW*0.98,1);
DRAWICON(CROSS(ZIG(3,8),REF(ZIG(3,8),1)),LOW*0.92,3);
DRAWICON(CROSS(ZIG(3,10),REF(ZIG(3,10),1)),LOW*0.86,5);
DRAWICON(CROSS(REF(ZIG(3,12),1),ZIG(3,12)),HIGH*1.16,8);
DRAWICON(CROSS(REF(ZIG(3,10),1),ZIG(3,10)),HIGH*1.11,6);
DRAWICON(CROSS(REF(ZIG(3,8),1),ZIG(3,8)),HIGH*1.06,4);
DRAWICON(CROSS(REF(ZIG(3,5),1),ZIG(3,5)),HIGH*1.02,2);


红轨道:=MA(MA(CLOSE,3),1);
轨道:MA(MA(CLOSE,3),3),COLORBLUE,LINETHICK2;
升:IF(红轨道>=轨道,轨道,红轨道),COLORYELLOW,LINETHICK2;

------------------------
众赢捕风捉影--主图叠加
FS:=MA(CLOSE,13)+MA(CLOSE,13)-REF(MA(CLOSE,13),1);
CG:=IF(MA(CLOSE,13)<FS,FS,MA(CLOSE,13));
A:=CG-(EMA(C,3)-CG);
X:=(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+14*REF(A,6)+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+REF(A,20))/210;
MTM:=C-REF(C,1);
DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);
卖1:=IF(HHV(DX,2)=HHV(DX,7) AND COUNT(DX>50,2) AND CROSS(MA(DX,2),DX),1,0);
DRAWICON(FILTER(卖1=1,1),H*1.01,6);
买1:=IF(LLV(DX,2)=LLV(DX,7) AND COUNT(DX<0,2) AND CROSS(DX,MA(DX,2)),1,0);
DRAWICON(FILTER(买1=1,5),L*0.96,5);
日均价:=(C*3+H+L+O)/6;
ZIA:=日均价;
裁决:=(REF(ZIA,1)*0.5+REF(ZIA,2)+REF(ZIA,3)*0.5)/2;
VAR1:=IF(C<裁决 AND BETWEEN(裁决,C,O),1,0);
VAR2:=IF(C<裁决 AND REF(C,1)>裁决 AND BETWEEN(裁决,C,O)=0,1,0);
VAR3:=IF(C<裁决 AND REF(C,1)>裁决 ,1,0);
VAR4:=IF(C>=裁决 AND BETWEEN(裁决,C,O),1,0);
VAR5:=IF(C>=裁决 AND REF(C,1)>裁决,1,0);
VAR6:=IF(C>=裁决 AND BETWEEN(裁决,C,O)=0 AND REF(C,1)>裁决,1,0);
CO:=(C-O);

捕风:MA(C,5)-MA(C,13)+MA(C,8),COLORYELLOW,LINETHICK1;
修正:=SMA(SMA(EMA(日均价,5)*2-MA(日均价,5),3,1),3,1);
补偿:=FLOOR(((修正-MA(修正,5))/MA(修正,5)*100));
SA:=EMA(日均价,5)*2-MA(日均价,5);
捉影:SMA(SMA((EMA(SA,(5+ABS(补偿)))),2,1),2,1),COLORMAGENTA,LINETHICK2;
捉影角度:ATAN((捉影/REF(捉影,1)-1)*100)*57.3,NODRAW,COLORYELLOW;
MA64:MA(C,64),COLORFF9900;
MA64角度:ATAN((MA64/REF(MA64,1)-1)*100)*57.3,NODRAW,COLORFF9900;
买点A:FILTER(买1=1,5),COLORGRAY,NODRAW;
买点B:VAR4,COLORGRAY,NODRAW;
涨幅:(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100,COLORMAGENTA,NODRAW;
换手:SUM(100*V/CAPITAL,1),COLORFF9900,NODRAW;


STICKLINE(CLOSE> REF(CLOSE,1) ,HIGH,LOW,0,1 ),COLORRED;
STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,3,0 ),COLOR000055;
STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,2.7,0 ),COLOR000077;
STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,2.1,0 ),COLOR000099;
STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,1.5,0 ),COLOR0000BB;
STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,0.9,0 ),COLOR0000DD;
STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,0.3,0 ),COLOR0000FF;
STICKLINE(CLOSE= REF(CLOSE,1) ,HIGH,LOW,0,1 ),COLORWHITE;
STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,3,0 ),COLOR555555;
STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,2.7,0 ),COLOR777777;
STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,2.1,0 ),COLOR999999;
STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,1.5,0 ),COLORBBBBBB;
STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,0.9,0 ),COLORDDDDDD;
STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,0.3,0 ),COLORFFFFFF;
STICKLINE(CLOSE< REF(CLOSE,1) ,HIGH,LOW,0,1 ),COLORCYAN;
STICKLINE(CLOSE< REF(CLOSE,1) ,OPEN,CLOSE,3,0 ),COLOR990000;
STICKLINE(CLOSE< REF(CLOSE,1) ,OPEN,CLOSE,2.7,0 ),COLORCC0000;
STICKLINE(CLOSE< REF(CLOSE,1) ,OPEN,CLOSE,2.1,0 ),COLORFF4400;
STICKLINE(CLOSE< REF(CLOSE,1) ,OPEN,CLOSE,1.5,0 ),COLORFF8800;
STICKLINE(CLOSE< REF(CLOSE,1) ,OPEN,CLOSE,0.9,0 ),COLORFFCC00;
STICKLINE(CLOSE< REF(CLOSE,1) ,OPEN,CLOSE,0.3,0 ),COLORCYAN;

STICKLINE(VAR5 OR VAR6 ,OPEN,CLOSE,3,0 ),COLOR000055;
STICKLINE(VAR5 OR VAR6 ,OPEN,CLOSE,2.7,0 ),COLOR000077;
STICKLINE(VAR5 OR VAR6 ,OPEN,CLOSE,2.1,0 ),COLOR000099;
STICKLINE(VAR5 OR VAR6 ,OPEN,CLOSE,1.5,0 ),COLOR0000BB;
STICKLINE(VAR5 OR VAR6 ,OPEN,CLOSE,0.9,0 ),COLOR0000DD;
STICKLINE(VAR5 OR VAR6 ,OPEN,CLOSE,0.3,0 ),COLOR0000FF;
STICKLINE(VAR4,O,O+CO/3,2.7,0),COLOR335555;
STICKLINE(VAR4,O,O+CO/3,2.1,0),COLOR338888;
STICKLINE(VAR4,O,O+CO/3,1.5,0),COLOR33AAAA;
STICKLINE(VAR4,O,O+CO/3,0.9,0),COLOR33CCCC;
STICKLINE(VAR4,O,O+CO/3,0.3,0),COLOR33EEEE;
STICKLINE(VAR1,O,O+CO/3,2.7,0),COLOR550055;
STICKLINE(VAR1,O,O+CO/3,2.1,0),COLOR880088;
STICKLINE(VAR1,O,O+CO/3,1.5,0),COLORAA00AA;
STICKLINE(VAR1,O,O+CO/3,0.9,0),COLORCC00CC;
STICKLINE(VAR1,O,O+CO/3,0.3,0),COLOREE00EE;
------------------------------------
众赢白黄蓝绿--主图叠加  白买进黄加码蓝洗盘绿下跌
{用法:白色买进黄色加码蓝色洗盘绿色下跌,白买进黄加码蓝洗盘绿下跌};

MA3:MA(CLOSE,3),COLORWHITE;
MA5:MA(CLOSE,5),COLORYELLOW;
MA10:MA(CLOSE,10),COLORRED;
MA20:MA(CLOSE,20),COLORBLUE;
MA30:MA(CLOSE,30),COLORGREEN;
MA60:MA(CLOSE,60),COLORMAGENTA,POINTDOT,LINETHICK2;
VAR1:=EMA(CLOSE,3);
VAR2:=EMA(CLOSE,5);
VAR3:=EMA(CLOSE,10);
VAR4:=EMA(CLOSE,20);
VAR5:=EMA(CLOSE,30);
VAR6:=(VAR2+VAR3+VAR4+VAR5)/4;
VAR7:=(VAR6-REF(VAR6,15))/REF(VAR6,15)*100;
VAR8:=(VAR6-REF(VAR6,15))/REF(VAR6, 15)*100;
VAR9:=EMA(VAR7,8);
STICKLINE(VAR7<1*REF(VAR7,1),HIGH,LOW,0,0),COLORGREEN;
STICKLINE(VAR7<1*REF(VAR7,1),OPEN,CLOSE,2.5, 0),COLOR006000;
STICKLINE(VAR7<1*REF(VAR7,1),OPEN,CLOSE,1.9, 0),COLOR007500;
STICKLINE(VAR7<1*REF(VAR7,1),OPEN,CLOSE,1.4, 0),COLOR009100;
STICKLINE(VAR7<1*REF(VAR7,1),OPEN,CLOSE,1, 0),COLOR00A600;
STICKLINE(VAR7<1*REF(VAR7,1),OPEN,CLOSE,0.7, 0),COLOR00BB00;
STICKLINE(VAR7<1*REF(VAR7,1),OPEN,CLOSE,0.4, 0),COLOR00CC00;
STICKLINE(VAR7<1*REF(VAR7,1),OPEN,CLOSE,0.1, 0),COLORGREEN;

STICKLINE(VAR7>1*REF(VAR7,1),HIGH,LOW,0,0),COLORRED;
STICKLINE(VAR7>1*REF(VAR7,1),OPEN,CLOSE,2.5, 0),COLOR000055;
STICKLINE(VAR7>1*REF(VAR7,1),OPEN,CLOSE,1.9, 0),COLOR000077;
STICKLINE(VAR7>1*REF(VAR7,1),OPEN,CLOSE,1.3, 0),COLOR000099;                         
STICKLINE(VAR7>1*REF(VAR7,1),OPEN,CLOSE,0.7, 0),COLOR0000DD;
STICKLINE(VAR7>1*REF(VAR7,1),OPEN,CLOSE,0.2, 0),COLOR0000FF;

STICKLINE(VAR7<1*REF(VAR7,1) AND VAR9>1*REF(VAR9,1),HIGH,LOW,0,0),COLORBLUE;
STICKLINE(VAR7<1*REF(VAR7,1) AND VAR9>1*REF(VAR9,1),OPEN,CLOSE,2.5, 0),COLORA12100;
STICKLINE(VAR7<1*REF(VAR7,1) AND VAR9>1*REF(VAR9,1),OPEN,CLOSE,1.9, 0),COLORB72100;
STICKLINE(VAR7<1*REF(VAR7,1) AND VAR9>1*REF(VAR9,1),OPEN,CLOSE,1.4, 0),COLORC32100;
STICKLINE(VAR7<1*REF(VAR7,1) AND VAR9>1*REF(VAR9,1),OPEN,CLOSE,1, 0),COLORCF2100;
STICKLINE(VAR7<1*REF(VAR7,1) AND VAR9>1*REF(VAR9,1),OPEN,CLOSE,0.6, 0),COLORDB2100;
STICKLINE(VAR7<1*REF(VAR7,1) AND VAR9>1*REF(VAR9,1),OPEN,CLOSE,0.3, 0),COLORFF5E00;
STICKLINE(VAR7<1*REF(VAR7,1) AND VAR9>1*REF(VAR9,1),OPEN,CLOSE,0.1, 0),COLORFF6E00;


买进价:=((CLOSE-REF(MA(CLOSE,6),1))/6+MA(CLOSE,6))*1.004;
买进条件:=CROSS(CLOSE,买进价) AND 买进价>REF(买进价,1);
STICKLINE(买进条件,HIGH,LOW,0,1),COLORWHITE,LINETHICK2;
STICKLINE(买进条件,OPEN,CLOSE,2.8,0),COLOR808080;
STICKLINE(买进条件,OPEN,CLOSE,2.5,0),COLOR919890;
STICKLINE(买进条件,OPEN,CLOSE,2.2,0),COLORB4B5AF;
STICKLINE(买进条件,OPEN,CLOSE,1.7,0),COLORCCCCCC;
STICKLINE(买进条件,OPEN,CLOSE,1.2,0),COLORDDDDDD;
STICKLINE(买进条件,OPEN,CLOSE,0.8,0),COLOREEEEEE;
STICKLINE(买进条件,OPEN,CLOSE,0.4,0),COLORF5F1F1;
STICKLINE(买进条件,OPEN,CLOSE,0.1,0),COLORFFFAFA;
加码价:=((CLOSE-REF(MA(CLOSE,18),1))/18+MA(CLOSE,18))*1.004;
加码条件:=CROSS(CLOSE,加码价) AND 加码价>REF(加码价,1);
STICKLINE(加码条件,HIGH,LOW,0,1),COLORYELLOW,LINETHICK2;
STICKLINE(加码条件,OPEN,CLOSE,2.5,0),COLOR0033FF;
STICKLINE(加码条件,OPEN,CLOSE,2.1,0),COLOR00BEFF;
STICKLINE(加码条件,OPEN,CLOSE,1.7,0),COLOR13BCFF;
STICKLINE(加码条件,OPEN,CLOSE,1.3,0),COLOR13D1FF;
STICKLINE(加码条件,OPEN,CLOSE,0.9,0),COLOR00D6FF;
STICKLINE(加码条件,OPEN,CLOSE,0.4,0),COLOR13E5FF;
STICKLINE(加码条件,OPEN,CLOSE,0,0),COLOR00F6FC;

------------------------------
众赢春夏秋冬---主图叠加
LC:=REF(CLOSE,1);
RSI:=((SMA(MAX((CLOSE - LC),0),3,1) / SMA(ABS((CLOSE - LC)),3,1)) * 100);
FF:=EMA(CLOSE,3);
MA15:=EMA(CLOSE,21);
攻击线: EMA((EMA(CLOSE,4)+EMA(CLOSE,6)+EMA(CLOSE,12)+EMA(CLOSE,24))/4,2),LINETHICK1,COLORFFFFFF;
防守线: MA(CLOSE,27),LINETHICK1,COLOR00FFFF;
STICKLINE((MA15 > REF(MA15,1)),MA15,MA15,9,6),LINETHICK2,COLOR0000FF;
STICKLINE((MA15 < REF(MA15,1)),MA15,MA15,9,6),LINETHICK2,COLORFF0000;
买线:=EMA(C,2);
卖线:=EMA(SLOPE(C,21)*20+C,42);
BU:=CROSS(买线,卖线);
SEL:=CROSS(卖线,买线);
STICKLINE(买线>=卖线,LOW,HIGH,0,0),COLORRED;
STICKLINE(买线>=卖线,CLOSE,OPEN,2.7,0),COLOR02007A;
STICKLINE(买线>=卖线,CLOSE,OPEN,2.3,0),COLOR020090;
STICKLINE(买线>=卖线,CLOSE,OPEN,1.9,0),COLOR0200A6;
STICKLINE(买线>=卖线,CLOSE,OPEN,1.5,0),COLOR0200A9;
STICKLINE(买线>=卖线,CLOSE,OPEN,1.1,0),COLOR0200B2;
STICKLINE(买线>=卖线,CLOSE,OPEN,0.7,0),COLOR0200C1;
STICKLINE(买线>=卖线,CLOSE,OPEN,0.3,0),COLOR0200EC;
STICKLINE(买线>=卖线,CLOSE,OPEN,0,0),COLOR0200F5;
STICKLINE(买线<卖线,CLOSE,OPEN,2.7,0),COLOR8B6A00;
STICKLINE(买线<卖线,CLOSE,OPEN,2.3,0),COLORAF6A00;
STICKLINE(买线<卖线,CLOSE,OPEN,1.9,0),COLORB56A00;
STICKLINE(买线<卖线,CLOSE,OPEN,1.5,0),COLORC06A00;
STICKLINE(买线<卖线,CLOSE,OPEN,1.1,0),COLORD16A00;
STICKLINE(买线<卖线,CLOSE,OPEN,0.7,0),COLORDB6A00;
STICKLINE(买线<卖线,CLOSE,OPEN,0.4,0),COLORE76A00;
STICKLINE(买线<卖线,CLOSE,OPEN,0.2,0),COLORFF8000;
STICKLINE(买线<卖线,H,L,0,0),COLORFF8000;
STICKLINE(CROSS(买线,卖线) OR CROSS(卖线,买线),OPEN,CLOSE,2,0),COLOR00FFFF;


STICKLINE(CROSS(卖线,买线),HIGH,LOW,0,0),COLORGREEN;
STICKLINE(CROSS(卖线,买线),OPEN,CLOSE,2.5, 0),COLOR006000;

立春:=FILTER(MONTH=2 AND (DAY=3 OR DAY=5 ),2);
雨水:=FILTER(MONTH=2 AND (DAY=18 OR DAY=20),2);
惊蛰:=FILTER(MONTH=3 AND (DAY=5 OR DAY=7 ),2);
春分:=FILTER(MONTH=3 AND (DAY=20 OR DAY=22),2);
清明:=FILTER(MONTH=4 AND (DAY=4 OR DAY=6 ),2);
谷雨:=FILTER(MONTH=4 AND (DAY=19 OR DAY=21),2);
立夏:=FILTER(MONTH=5 AND (DAY=6 OR DAY=8 ),2);
小满:=FILTER(MONTH=5 AND (DAY=20 OR DAY=22),2);
芒种:=FILTER(MONTH=6 AND (DAY=5 OR DAY=7 ),2);
夏至:=FILTER(MONTH=6 AND (DAY=20 OR DAY=22),2);
小暑:=FILTER(MONTH=7 AND (DAY=6 OR DAY=8 ),2);
大署:=FILTER(MONTH=7 AND (DAY=22 OR DAY=24),2);
立秋:=FILTER(MONTH=8 AND (DAY=7 OR DAY=9 ),2);
处暑:=FILTER(MONTH=8 AND (DAY=22 OR DAY=24),2);
白露:=FILTER(MONTH=9 AND (DAY=7 OR DAY=9 ),2);
秋分:=FILTER(MONTH=9 AND (DAY=22 OR DAY=24),2);
寒露:=FILTER(MONTH=10 AND (DAY=7 OR DAY=9 ),2);
霜降:=FILTER(MONTH=10 AND (DAY=22 OR DAY=24),2);
立冬:=FILTER(MONTH=11 AND (DAY=7 OR DAY=9 ),2);
小雪:=FILTER(MONTH=11 AND (DAY=22 OR DAY=24),2);
大雪:=FILTER(MONTH=12 AND (DAY=6 OR DAY=8 ),2);
冬至:=FILTER(MONTH=12 AND (DAY=21 OR DAY=23),2);
小寒:=FILTER(MONTH=1 AND (DAY=5 OR DAY=7 ),2);
大寒:=FILTER(MONTH=1 AND (DAY=19 OR DAY=21),2);
DRAWTEXT(立春,HIGH*1.02,'立春'),COLORGREEN;
DRAWTEXT(雨水,HIGH*1.02,'雨水'),COLORGREEN;
DRAWTEXT(惊蛰,HIGH*1.02,'惊蛰'),COLORGREEN;
DRAWTEXT(春分,HIGH*1.02,'春分'),COLORGREEN;
DRAWTEXT(清明,HIGH*1.02,'清明'),COLORGREEN;
DRAWTEXT(谷雨,HIGH*1.02,'谷雨'),COLORGREEN;
DRAWTEXT(立夏,HIGH*1.02,'立夏'),COLORMAGENTA;
DRAWTEXT(小满,HIGH*1.02,'小满'),COLORMAGENTA;
DRAWTEXT(芒种,HIGH*1.02,'芒种'),COLORMAGENTA;
DRAWTEXT(夏至,HIGH*1.02,'夏至'),COLORMAGENTA;
DRAWTEXT(小暑,HIGH*1.02,'小暑'),COLORMAGENTA;
DRAWTEXT(大署,HIGH*1.02,'大署'),COLORMAGENTA;
DRAWTEXT(立秋,HIGH*1.02,'立秋'),COLORYELLOW;
DRAWTEXT(处暑,HIGH*1.02,'处暑'),COLORYELLOW;
DRAWTEXT(白露,HIGH*1.02,'白露'),COLORYELLOW;
DRAWTEXT(秋分,HIGH*1.02,'秋分'),COLORYELLOW;
DRAWTEXT(寒露,HIGH*1.02,'寒露'),COLORYELLOW;
DRAWTEXT(霜降,HIGH*1.02,'霜降'),COLORYELLOW;
DRAWTEXT(立冬,HIGH*1.02,'立冬'),COLORWHITE;
DRAWTEXT(小雪,HIGH*1.02,'小雪'),COLORWHITE;
DRAWTEXT(大雪,HIGH*1.02,'大雪'),COLORWHITE;
DRAWTEXT(冬至,HIGH*1.02,'冬至'),COLORWHITE;
DRAWTEXT(小寒,HIGH*1.02,'小寒'),COLORWHITE;
DRAWTEXT(大寒,HIGH*1.02,'大寒'),COLORWHITE;
------------------------
众赢操盘主图---主图叠加
A:=AMOUNT/V/100;
VARA:=EMA((((A-EMA(A,13))/EMA(A,13))*(0-100)),5);
QQ:=EMA(((VARA/10)+EMA(A,13)),0);
行情线:=MA(A,1);
重心:=(C+0.618*REF(C,1)+0.382*REF(C,1)+0.236*REF(C,3)+0.146*REF(C,4))/2.382;
【操盘线】:EMA(((SLOPE(C,22)*20)+C),55),COLORYELLOW,LINETHICK4;
【黄金线】:IF(重心>=【操盘线】,【操盘线】,DRAWNULL),COLORRED,LINETHICK2;
【空仓线】:IF(重心<【操盘线】,【操盘线】,DRAWNULL),COLORCYAN,LINETHICK2;
DRAWTEXT(ISLASTBAR,【操盘线】,'【操盘线】'),COLORRED;
{引:EMA(CLOSE,2),LINETHICK1,COLORMAGENTA;
探:MA(CLOSE,5),LINETHICK1;}
变:EMA(CLOSE,5),LINETHICK2,COLORYELLOW;
金:IF(变>REF(变,1),变,DRAWNULL),COLORRED,LINETHICK2;
空:IF(变<REF(变,1),变,DRAWNULL),COLORGREEN,LINETHICK2;
DRAWTEXT(ISLASTBAR,变,'【雷达线】'),COLORRED;
{顶底信号}
辅助线:MA(C,8),COLORMAGENTA,LINETHICK1;
上升:IF(辅助线>REF(辅助线,1),辅助线,DRAWNULL),COLORMAGENTA,LINETHICK2;
下降:IF(辅助线<REF(辅助线,1),辅助线,DRAWNULL),COLORGRAY,LINETHICK1;
DA:=(EMA(H,1)+EMA(L,1)+EMA(H,1)+EMA(H,1))/4,;
DB:=EMA(REF(HHV(H,25),1),2),COLORGREEN,LINETHICK1;
{DRAWTEXT(CROSS(DB,DA),DB,'←险'),COLORGREEN,LINETHICK1;}
DRAWICON(CROSS(DA,【操盘线】)AND DA>REF(DA,2),【操盘线】,9);
DRAWICON(CROSS(辅助线,DA)AND DA<=REF(DA,1)AND MA(C,6)<REF(MA(C,6),1)AND DA>【操盘线】, 辅助线,15);
DRAWICON(CROSS(DA,辅助线)AND DA>=REF(DA,1)AND MA(C,5)>REF(MA(C,5),1)AND DA<【操盘线】, 辅助线,5);
{涨跌停显示}
涨停:=IF((C-REF(C,1))*100/REF(C,1)>=(10-0.01*100/REF(O,1)),1,0);
STICKLINE(涨停,O,C,1,0),COLORYELLOW;
ZDF:=(C-REF(C,1))/REF(C,1)*100;
STICKLINE(ZDF<-9.9,O,C,1,0),COLORBLUE;
VAR3:=LLV(HIGH,240);
VAR4:=100*(CLOSE-VAR3)/VAR3;
VAR5:=(CLOSE-LLV(LOW,528))/(HHV(HIGH,528)-LLV(LOW,528))*100;
VAR6:=(CLOSE-LLV(CLOSE,530))/(HHV(CLOSE,530)-LLV(CLOSE,530))*100;
VAR7:=0;
VAR8:=SMA(MAX(CLOSE-REF(CLOSE,1),0),34,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),7,1)*100;
VAR9:=SMA(MAX(CLOSE-REF(CLOSE,1),0),13,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),13,1)*100;
VAR10:=IF(TROUGHBARS(3,16,1)=0 AND HIGH>LOW+0.04,4,0);
VAR11:=ZIG(3,6)>REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)<=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)<=REF(ZIG(3,6),3);
VAR12:=ZIG(3,6)<REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)>=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)>=REF(ZIG(3,6),3);
VAR13:=ZIG(3,22)>REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)<=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)<=REF(ZIG(3,22),3);
VAR14:=ZIG(3,22)<REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)>=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)>=REF(ZIG(3,22),3);
VAR15:=ZIG(3,51)>REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)<=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)<=REF(ZIG(3,51),3);
VAR16:=ZIG(3,51)<REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)>=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)>=REF(ZIG(3,51),3);
VAR17:=ZIG(3,72)>REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)<=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)<=REF(ZIG(3,72),3);
VAR18:=ZIG(3,72)<REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)>=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)>=REF(ZIG(3,72),3);
VAR19:=EMA(CLOSE,2)-EMA(CLOSE,150);
买1:=VAR10;
买2:=(VAR11+VAR13+VAR15+VAR17);
卖1:=(VAR12+VAR14+VAR16+VAR18);
VAR100:=(100 - ((90 * (HHV(HIGH,20) - CLOSE)) / (HHV(HIGH,20) - LLV(LOW,20))));
VAR200:=(100 - ((90 * (HHV(HIGH,20) - CLOSE)) / (HHV(HIGH,20) - LLV(LOW,20))));
VAR300:=(100 - MA(((100 * (HHV(HIGH,5) - CLOSE)) / (HHV(HIGH,5) - LLV(LOW,5))),34));
{价:}
{JC1:=(REF(C,3)+REF(C,5)+REF(C,7)+REF(C,8)+REF(C,13)+REF(C,21))/6;
参考价1:SMA(JC1,5,1),CIRCLEDOT,COLORGREEN;
IF(C>=参考价1,参考价1,DRAWNULL),CIRCLEDOT,COLOR0000FF;}
PH:=TROUGHBARS(2,5,1);
LL:=HHV(H,PH);
TJ1:=LL=HIGH AND LL<REF(LL,1);{//=1}
TS:=SUMBARS(TJ1,2);
TJ:=PEAKBARS(2,5,1)=1 AND TS>=PH;

PL:=BARSLAST(TJ);
支撑:IF(BARSLAST(TJ1),
REF(LOW,BARSLAST(TJ1)),DRAWNULL),COLOREA91B5;
压力:IF(BARSLAST(TJ),REF(HIGH,PL),DRAWNULL),COLORYELLOW;
TJ_2:=LOW>REF(REF(LOW,TS),PL);
DRAWTEXT(ISLASTBAR,压力,'压力'),COLORYELLOW;
DRAWTEXT(ISLASTBAR,支撑,'支撑'),COLOREA91B5;
{DRAWICON(BARSLAST(TJ1),REF(LOW*0.995,BARSLAST(TJ1)),1);};

---------------------------
动力一号--副图
HSL:=VOL/CAPITAL*100;
CYF:=(100-100/(1+EMA(HSL/3,13)))/2;
均价:=SUM(AMOUNT,3)/SUM(VOL*100,3);
CYS3:=(CLOSE-均价)/均价*100;
动力一号:CYF*689*CYS3*MA(VOL,10)/10000000;
热度指数:(MA(VOL,3)/VOL)*((CLOSE-REF(CLOSE,1))/REF(CLOSE,1))*1000;
----------------------------
飞鱼出水-副
VAR1:=REF(LOW,1);
VAR2:=SMA(ABS(LOW-VAR1),3,1)/SMA(MAX(LOW-VAR1,0),3,1)*100;
VAR3:=EMA(IF(CLOSE*1.2,VAR2*10,VAR2/10),3);
VAR4:=LLV(LOW,38);
VAR5:=HHV(VAR3,38);
VAR6:=IF(LLV(LOW,90),1,0);
VAR7:=EMA(IF(LOW<=VAR4,(VAR3+VAR5*2)/2,0),3)/618*VAR6;
底部吸筹: STICKLINE(VAR7,0,VAR7,4,1),COLORWHITE ;
V1:=LLV(H,240);
飞鱼:100*(C-V1)/V1,COLORRED,LINETHICK1;
V2:=HHV(H,240);
海洋:100*(V2-C)/C,COLORGREEN,LINETHICK1;
V3:=SUM(VOL,5)/CAPITAL;
CYF5:=100-(100/(1+V3));
--------------------
流动资金--副
VAR1:=SMA(AMOUNT,10,1)/10000;
VAR2:=REF(VAR1,1);
VAR3:=SMA(AMOUNT,10,1)/10000;
资金运转: STICKLINE(VAR1>VAR2,VAR1,VAR2,3,0),COLORRED;
资金流失: STICKLINE(VAR1< VAR2,VAR1,VAR2,3,0),COLORGREEN;
--------------------
资金进出--副
XL_0:=SMA(AMOUNT,10,1)/10000000;
XL_1:=(XL_0-LLV(XL_0,4))/(HHV(XL_0,4)-LLV(XL_0,4))*100;         
XL_2:=LLV(XL_0,4)+SMA(XL_1,4,1)/100*(HHV(XL_0,4)-LLV(XL_0,4));
XL_3:=SMA(XL_2,3,1);
资金:XL_0,LINETHICK1,COLORFFA9FF;
分界:MA(XL_0,8),LINETHICK1,COLOR00BBAB;
{资金进出}
STICKLINE(XL_0<REF(XL_0,1) OR
(AMOUNT/REF(AMOUNT,1)<0.97),XL_0,REF(XL_0,1),2.5,0),COLORWHITE;{资金离场}
STICKLINE(XL_0>=REF(XL_0,1),XL_0,REF(XL_0,1),2.5,0),COLORRED;{资金进场}
STICKLINE(XL_0<分界,XL_0,REF(XL_0,1),2.5,0),COLORFFA900;{空仓};
------------------

 

Tags:指标
0% (0)
0% (10)

关于通达信众赢的特别版指标公式的评论:

 以下是对 [通达信众赢的特别版指标公式] 的评论,总共:0条评论
加入收藏 | 关于我们 | 服务条款 | 广告服务 | 免责声明 | 站内地图 | 联系我们