买好股公式网 > 股票公式 > 通达信公式 > 机会风险主图指标源码

机会风险主图指标源码

2022年09月15日人气:Tags:风险 主图 指标

MA10:MA(C,10);

MA60:MA(C,60);

VAR6:=(( ABS((OPEN-CLOSE))/(HIGH-LOW))*VOL);

VAR7:=(( (HIGH-IF((CLOSE>OPEN),CLOSE,OPEN))/(HIGH-LOW))*VOL);

VAR8:=(( (IF((CLOSE>OPEN),OPEN,CLOSE)-LOW)/(HIGH-LOW))*VOL);

VAR9:=IF(((VOL/CAPITAL)>0.001),1,EXP(ABS(LOG(((VOL/CAPITAL)*100)))));

加仓:VAR6>=VAR7 AND VAR6>=VAR8 AND CLOSE>OPEN,NODRAW,colorred;

减仓:VAR6>=VAR7 AND VAR6>=VAR8 AND CLOSE<OPEN,NODRAW,colorblue;

洗盘:VAR8>VAR6 AND VAR8>VAR7,NODRAW,colorwhite;

高抛:VAR7>VAR6 AND VAR7>VAR8,NODRAW,colormagenta;

地量:VAR9>2 AND VOL<MA(VOL,5)/2,NODRAW,colorgreen;

DRAWKLINE(H,O,L,C);

TY:=C;

A1:=REF(TY,10)=HHV(TY,2*10+1); B1:=FILTER(A1,10); C1:=BACKSET(B1,10+1); HD:=FILTER(C1,10);

A2:=REF(TY,10)=LLV(TY,2*10+1); B2:=FILTER(A2,10); C2:=BACKSET(B2,10+1); LD:=FILTER(C2,10);

前期高位:REF(H,BARSLAST(HD)), COLORFF00FF,POINTDOT,LINETHICK3;

前期低位:REF(L,BARSLAST(LD)), colorgreen,POINTDOT,LINETHICK3;

STICKLINE(加仓,O,C,1,0),colorred;

STICKLINE(洗盘,O,C,1,0),colorwhite;

STICKLINE(减仓,O,C,1,0),colorblue;

STICKLINE(高抛,O,C,1,0),colormagenta;

STICKLINE(地量,O,C,1,0),colorgreen;

JJ:=(3*C+H+L+O)/6;

VAR1:=(8*JJ+7*REF(JJ,1)+6*REF(JJ,2)+5*REF(JJ,3)+4*REF(JJ,4)+3*REF(JJ,5)+2*REF(JJ,6)+REF(JJ,8))/36;

TJ1:=VOL=HHV(VOL,10) AND VOL>2*REF(VOL,1) AND CLOSE>VAR1 AND C>REF(C,1);

LJL:=FILTER(TJ1,5);

STICKLINE(CLOSE,REF(LOW,BARSLAST(LJL)),REF(LOW,BARSLAST(LJL)),1,0),colorred;

STICKLINE(CLOSE,REF(CLOSE,BARSLAST(LJL)),REF(CLOSE,BARSLAST(LJL)),1,0),coloryellow;

STICKLINE(LJL,OPEN,CLOSE,1,0),coloryellow;

DRAWTEXT_FIX(1,0.0,0.0,0,'蓝芯-主力低位深度洗盘或高位出货坚决'),colorblue,LINETHICK1;

DRAWTEXT_FIX(1,0.00,0.06,0,'白芯-主力轻度洗盘'),colorwhite,LINETHICK1;

DRAWTEXT_FIX(1,0.00,0.12,0,'棕芯-出现了近期相对地量'),colorgreen,LINETHICK1;

DRAWTEXT_FIX(1,0.00,0.18,0,'粉芯-主力在做高抛低吸或低吸高抛'),COLORFF00FF,LINETHICK1;

DRAWTEXT_FIX(1,0.00,0.24,0,'红芯-主力吸筹进货积极主动'),colorred,LINETHICK1;

DRAWTEXT_FIX(1,0.00,0.3,0,'黄芯-主力吸筹进货强并且成交量出现黄金柱'),coloryellow,LINETHICK1;

EN1:=ZIG(3,5)>REF(ZIG(3,5),1) AND REF(ZIG(3,5),1)<=REF(ZIG(3,5),2) AND REF(ZIG(3,5),2)<=REF(ZIG(3,5),3);

PL10:=ZIG(3,10);

走强2:=BARSLAST(PL10<REF(PL10,1));

ZTJZ5:=IF(PL10>REF(PL10,1),COUNT(EN1,走强2),0);

追2:=EN1 AND PL10>REF(PL10,1) AND ZTJZ5=2;

追4:=EN1 AND PL10>REF(PL10,1) AND ZTJZ5=3;

DRAWTEXT(追2 OR 追4,LOW*0.978,'追'),coloryellow;

PL5:=ZIG(3,5);

EX1:=ZIG(3,5)<REF(ZIG(3,5),1) AND REF(ZIG(3,5),1)>=REF(ZIG(3,5),2) AND REF(ZIG(3,5),2)>=REF(ZIG(3,5),3);

EN2:=ZIG(3,10)>REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)<=REF(ZIG(3,10),2) AND REF(ZIG(3,10),2)<=REF(ZIG(3,10),3);

EX2:=ZIG(3,10)<REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)>=REF(ZIG(3,10),2) AND REF(ZIG(3,10),2)>=REF(ZIG(3,10),3);

PL20:=ZIG(3,20);

EN3:=ZIG(3,20)>REF(ZIG(3,20),1) AND REF(ZIG(3,20),1)<=REF(ZIG(3,20),2) AND REF(ZIG(3,20),2)<=REF(ZIG(3,20),3);

EX3:=ZIG(3,20)<REF(ZIG(3,20),1) AND REF(ZIG(3,20),1)>=REF(ZIG(3,20),2) AND REF(ZIG(3,20),2)>=REF(ZIG(3,20),3);

PL40:=ZIG(3,40);

走强1:=BARSLAST(PL5<REF(PL5,1));

走弱1:=BARSLAST(PL5>REF(PL5,1));

走弱2:=BARSLAST(PL10>REF(PL10,1));

走强3:=BARSLAST(PL20<REF(PL20,1));

走弱3:=BARSLAST(PL20>REF(PL20,1));

{ZTJZ5:=IF(PL10>REF(PL10,1),COUNT(EN1,走强2),0);}

ZTJD5:=IF(PL10>REF(PL10,1),COUNT(EX1,走强2),0);

DTJZ5:=IF(PL10<REF(PL10,1),COUNT(EN1,走弱2),0);

DTJD5:=IF(PL10<REF(PL10,1),COUNT(EX1,走弱2),0);

ZTJZ10:=IF(PL20>REF(PL20,1),COUNT(EN2,走强3),0);

ZTJD10:=IF(PL20>REF(PL20,1),COUNT(EX2,走强3),0);

DTJZ10:=IF(PL20<REF(PL20,1),COUNT(EN2,走弱3),0);

DTJD10:=IF(PL20<REF(PL20,1),COUNT(EX2,走弱3),0);

DRAWTEXT(EN1 AND DTJZ5=1,L*0.98,'反弹低点'),colorlired;

DRAWTEXT(EX1 AND DTJD5=2,H*1.02,'反弹高点!'),colorliblue;

DRAWTEXT(EN2 AND ZTJZ5=1,L*0.98,'底'),coloryellow;

DRAWTEXT(EX1 AND PL10>REF(PL10,1) AND ZTJD5=1,H*1.02,'减仓'),COLORFFFF00;

DRAWTEXT(EN1 AND PL10>REF(PL10,1) AND ZTJZ5=2,L*0.98,'----买'),COLOR0000FF;

DRAWTEXT(EX1 AND PL10>REF(PL10,1) AND ZTJZ5=2,H*1.02,'短卖'),colorgreen;

DRAWTEXT(EN1 AND PL10>REF(PL10,1) AND ZTJZ5=3,L*0.98,'----短买'),COLOR0000FF;

DRAWTEXT(EX2 AND PL20>REF(PL20,1) AND ZTJD10=1,H*1.02,'短卖'),colorgreen;

DRAWTEXT(EN2 AND DTJZ10=1,L*0.96,'Ⅰ'),COLORFF00FF;

DRAWTEXT(EX2 AND DTJD10=2,H*1.03,'Ⅱ'),COLORFF6000;

DRAWTEXT(EN3 AND ZTJZ10=1,L*0.95,'Ⅲ'),coloryellow;

DRAWTEXT(EX2 AND PL20>REF(PL20,1) AND ZTJD10=1,H*1.06,'①'),LINETHICK3,COLORFFFF00;

DRAWTEXT(EN2 AND PL20>REF(PL20,1) AND ZTJZ10=2,L*0.96,'②'),LINETHICK3,coloryellow;

DRAWTEXT(EX2 AND PL20>REF(PL20,1) AND ZTJD10=2 OR (ZTJD10=0 OR ZTJD10=2) AND EX2,H*1.02,'清仓!'),LINETHICK3,colorwhite;

DRAWTEXT(EN2 AND PL20>REF(PL20,1) AND ZTJZ10=3,L*0.96,'④'),LINETHICK3,coloryellow;

DRAWTEXT(EN1 AND PL10>REF(PL10,1) AND ZTJZ5=3,L*0.95,'⑷'),coloryellow;

EMA13:=EMA(C,13);

EMA34:=EMA(C,34);

EMA55:=EMA(C,55);

EMA120:=EMA(C,120);

CR1:=(C-REF(C,1))/REF(C,1)*100>0.5;

CR2:=V>MA(V,5)*0.6;

CR3:=COUNT(CROSS(EMA13,EMA55),3)=1;

CR4:=ABS(EMA34-EMA55)/EMA55<0.03;

CR5:=EMA55<=EMA120 AND EMA55>=REF(EMA55,1);

CR6:=FILTER(CR1 AND CR2 AND CR3 AND CR4 AND CR5,2);

DRAWTEXT(CR6,C*0.98,'风险'),colorwhite;

{机会风险主图指标源码}

打赏好指标 ×

关于机会风险主图指标源码的评论:

 以下是对 [机会风险主图指标源码] 的评论,总共:1条评论
匿名 游客:匿名   前天 07:11 1
我是贵网站的忠粉,现在所用的指标公式都是贵站找到的,非常给力,现在贵店的更新速度提高了很多,我隔几天就会看一次,点开网站,各公式效果图一目了然,一键复制公式也很赞。各公式运用下来的准确度也有所区别,但我都是准中挑准,谢谢贵网站编辑人员的辛苦付出……
加入收藏 | 联系我们 | 免责声明 | 站内地图 | 关于我们