买好股公式网 > 股票公式 > 通达信公式 > 通达信双均线变色主图公式源码

通达信双均线变色主图公式源码

2012年09月02日 【字体: 人气:

利用两条均线的走势及变色方法及图中的提示讯号相互配合来提供买卖的讯号作为操盘的参考。




源码:(具体参数可根据自己的喜好进行选择,已达到最优的效果)
{P1:1 100 10 P2: 1 100 20}
MAR1:=MA(CLOSE,P1);
C1:=C>=MAR1;
C2:=C<MAR1;
AA:=C1>=C2 ;
BB:=C2>C1 ;
STICKLINE(AA,C,O,3,0),COLORRED;
STICKLINE(AA,H,L,0,0),COLORRED;
STICKLINE(BB,C,O,3,0),COLOR00FF00;
STICKLINE(BB,H,L,0,0),COLOR00FF00;
STICKLINE(AA,CLOSE,OPEN,3,0),COLOR000099;
STICKLINE(AA,CLOSE,OPEN,2.2,0),COLOR0000CC;
STICKLINE(AA,CLOSE,OPEN,1.5,0),COLOR0000FF;
STICKLINE(AA,CLOSE,OPEN,0.5,0),COLORCC66FF;
STICKLINE(BB,CLOSE,OPEN,3,0),COLORFF7700;
STICKLINE(BB,CLOSE,OPEN,2.2,0),COLORFF9900;
STICKLINE(BB,CLOSE,OPEN,1.5,0),COLORFFBB00;
STICKLINE(BB,CLOSE,OPEN,0.5,0),COLORCYAN;
MAA:MAR1,COLOR00FF00,LINETHICK2;
IF(MAA>=REF(MAA,1),MAA,DRAWNULL),COLORRED,,LINETHICK2;
IF(MAA<REF(MAA,1),MAA,DRAWNULL),COLORFFFFFF,LINETHICK2;
MAB:MA(CLOSE,P2),COLOR00FF00,LINETHICK2;
IF(MAB>=REF(MAB,1),MAB,DRAWNULL),COLORMAGENTA,LINETHICK2;
IF(MAB<REF(MAB,1),MAB,DRAWNULL),COLORGREEN,LINETHICK2;
DRAWICON(MAA>=REF(MAA,1) AND CROSS(MAA,MAB),MAA*0.98,1);
DRAWICON(CROSS(MAB,MAA),MAB*1.02,2);
VAR2:=(2*CLOSE+HIGH+LOW)/4;
VAR3:=IF(YEAR>=2099 AND MONTH>2,0,1);
VAR4:=LLV(LOW,5);
VAR5:=HHV(HIGH,4);
VAR6:=EMA((VAR2-VAR4)/(VAR5-VAR4)*100,4)*VAR3;
VAR7:=EMA(0.667*REF(VAR6,1)+0.333* VAR6,2)*VAR3;
DRAWTEXT(CROSS(VAR6, VAR7) AND VAR6<30,L-0.05,'←低吸'),COLOR00FFFF;
DRAWTEXT(CROSS(VAR7, VAR6) AND VAR6>70,H+0.05,'←高抛'),COLOR00FFFF;
DRAWICON(CROSS(VAR6, VAR7) AND VAR6<30,L-0.05,13);
DRAWICON(CROSS(VAR7, VAR6) AND VAR6>70,H+0.05,14);
AAA:= MAA>=REF(MAA,1);{C>=MAA;}
BBB:= MAA<REF(MAA,1);{ C<MAA;}
DDD:=MAB>=REF(MAB,1);
EEE:=MAB<REF(MAB,1);
TT:=IF(ISLASTBAR,240/FROMOPEN,1);
NN:=120;
HH:=HHV(V*TT,NN);
LL:=LLV(V,NN);
最高:=CONST(HH);
最低:=CONST(LL);
最高2:=CONST(HHV(H,NN));
最低2:=CONST(LLV(L,NN));
PP:=IF((最高2*0.9-(最高2-最低2)*0.5)>CONST(LLV(L,20)),0.9,IF((最高2*0.9-(最高2-最低2)*0.5)>CONST(LLV(L,50)),0.7,0.6)),NODRAW;
RCC1:=最高2*0.9-(最高2-最低2)*PP;
最低3:=MIN(RCC1,最低2);
AA1:=最低3;
STICKLINE(AAA,AA1-0.000*AA1,AA1-0.040*AA1,4,0),COLOR0000FF;
STICKLINE(BBB,AA1-0.000*AA1,AA1-0.040*AA1,4,1),COLOR686868;
STICKLINE(DDD,AA1-0.050*AA1,AA1-0.090*AA1,4,0),COLORFF00FF;
STICKLINE(EEE,AA1-0.050*AA1,AA1-0.090*AA1,4,1),COLOR686868;
DRAWTEXT_FIX(1,0.5,0.84,0,'★★ 红色--均线A持股★★粉色--均线B持股★★'),COLOR00FFFF;
 


 

0% (0)
0% (10)

关于通达信双均线变色主图公式源码的评论:

 以下是对 [通达信双均线变色主图公式源码] 的评论,总共:0条评论
加入收藏 | 关于我们 | 服务条款 | 广告服务 | 免责声明 | 站内地图 | 联系我们