买好股公式网 > 股票公式 > 通达信公式 > 通达信飘带主图公式源码

通达信飘带主图公式源码

2012年09月02日人气:Tags:主图 源码

飘带

DRAWGBK(OPEN>0,RGB(8,88,188),RGB(0,0,0),0,'02',0);
DRAWKLINE(HIGH,OPEN,LOW,CLOSE);
RC:=DYNAINFO(3);
S2:=SMA(C,3,1);
S6:=SMA(C,5,1);
DK:=2*(S2-S6);
STICKLINE(DK>0,RC,RC+DK,3,0),COLOR0000D5;
STICKLINE(DK<0,RC,RC+DK,3,0),COLORFF9900;
VAR2:=(3*CLOSE+LOW+OPEN+HIGH)/6;
多头线:(20*VAR2+19*REF(VAR2,1)+18*REF(VAR2,2)+17*REF(VAR2,3)+16*REF(VAR2,4)+15*REF(VAR2,5)+14*REF(VAR2,6)+13*REF(VAR2,7)+12*REF(VAR2,8)+11*REF(VAR2,9)+10*REF(VAR2,10)
+9*REF(VAR2,11)+8*REF(VAR2,12)+7*REF(VAR2,13)+6*REF(VAR2,14)+5*REF(VAR2,15)+4*REF(VAR2,16)+3*REF(VAR2,17)+2*REF(VAR2,18)+REF(VAR2,20))/210,CIRCLEDOT;

空头线:MA(多头线,5),CIRCLEDOT;
STICKLINE(多头线>空头线,多头线,空头线,2,4),COLORRED;
STICKLINE(多头线<空头线,多头线,空头线,2,4),COLOR00FF00;
工作线:MA(C,14),COLORRED,LINETHICK2;

EA0:MA(C,5),COLORFFC010;
REF(EA0,13),COLORFFC010;
REF(EA0,12),COLORFFC010;
REF(EA0,11),COLORFFC010;
REF(EA0,10),COLORFFC010;
REF(EA0,9),COLORFFC010;
REF(EA0,8),COLORFFC010;
REF(EA0,7),COLORFFC010;
REF(EA0,6),COLORFFC010;
REF(EA0,5),COLORFFC010;
REF(EA0,4),COLORFFC010;
REF(EA0,3),COLORFFC010;
REF(EA0,2),COLORFFC010;
REF(EA0,1),COLORFFC010;

STICKLINE(C>OPEN,OPEN,C,2.5,0),COLOR0000D5;
STICKLINE(C>OPEN,OPEN,C,0.6,0),COLORCC66FF;
STICKLINE(C<OPEN,OPEN,C,2.5,0),COLORFF6600;
STICKLINE(C<OPEN,OPEN,C,0.6,0),COLORFF9900;
STICKLINE(C/REF(C,1)>1.097,C,O,2.8,0),COLORMAGENTA;
STICKLINE(C/REF(C,1)>1.097,H,L,0.6,0),COLORCC66FF;
AA1:=MA(C,5);
BB1:=MA(C,15);
AF:=CROSS(AA1,BB1);
STICKLINE(AF,LLV(L,4),LLV(L,4),50,1),COLORYELLOW,LINETHICK9;
DRAWTEXT(AF,LLV(L,4),'止损线'),COLORYELLOW;


DRAWICON((ZIG(3,5)>REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)<=REF(ZIG(3,5),2)) AND (REF(ZIG(3,5),2)<=REF(ZIG(3,5),3)),LOW*0.98,34) ;
DRAWICON((ZIG(3,5)<REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)>=REF(ZIG(3,5),2)) AND (REF(ZIG(3,5),2)>=REF(ZIG(3,5),3)),HIGH*1.01,35);


AAX:=IF((CLOSE < 100),CLOSE,(CLOSE / 100));
A5:=INTPART(((4 * (LOG(AAX) / LOG(2))) + 1));
B5:=((A5 - 1) / 4);
支撑:IF((CLOSE > 100),(POW(2,B5) * 100),POW(2,B5)),POINTDOT,LINETHICK6,COLORBROWN;
压力:IF((CLOSE > 100),(POW(2,(B5 + (1 / 4))) * 100),POW(2,(B5 + (1 / 4)))),POINTDOT,LINETHICK6;

N11:=10;
M:=INTPART(3*N11/5);
AAA:=REF(H,M)=HHV(H,2*M+1);
QYY:=BACKSET(AAA,M+1);
CCC:=FILTER(QYY,M) AND H=HHV(H,M+1);
DDDDQ:=BARSLAST(CCC),NODRAW;
GDTSS:=IF(CCC,CURRBARSCOUNT,0);
DINGBUTSS:=IF(DDDDQ,REF(GDTSS,DDDDQ),GDTSS);
GDCS11:=CONST(DINGBUTSS);
DINGBUTS11:=REF(DINGBUTSS,DDDDQ+1);
GDCS22:=CONST(DINGBUTS11);
AAQ11:=REF(L,M)=LLV(L,2*M+1);
QYQ11:=BACKSET(AAQ11,M+1);
CCQ11:=FILTER(QYQ11,M) AND L=LLV(L,M+1);
DDQ11:=BARSLAST(CCQ11);
DDTSS:=IF(CCQ11,CURRBARSCOUNT,0);
DDTS11:=IF(DDQ11,REF(DDTSS,DDQ11),DDTSS);
DDCS11:=CONST(DDTS11);
DDTS22:=REF(DDTS11,DDQ11+1);
DDCS22:=CONST(DDTS22);
压力线:DRAWLINE(CURRBARSCOUNT=GDCS22,H,CURRBARSCOUNT=GDCS11,H,1),COLORFFAA99,LINETHICK1;
支撑线:DRAWLINE(CURRBARSCOUNT=DDCS22,L,CURRBARSCOUNT=DDCS11,L,1),COLOR9966FF,LINETHICK1;
Y3:=CLOSE/REF(CLOSE,1)>1.07;
X3:=VOL>MA(VOL,5);
A1:=Y3 AND X3;
DRAWTEXT(A1,MA(CLOSE,5),'攻涨停'),COLORCYAN;
Z:=CLOSE/REF(CLOSE,1)<0.93;
W:=VOL<MA(VOL,5);
A2:=Z AND W;
DRAWTEXT(A2,MA(CLOSE,5),'小心跌停'),COLORGREEN;


DRAWTEXT_FIX(1,0.18,1-0.2,0,STRCAT('千股千评: ',EXTERNSTR(0,1)))COLORCYAN;
DRAWTEXT_FIX(1,0.18,1-0.13,0,STRCAT('智能诊断:',EXTERNSTR(0,12)))COLORYELLOW;

DRAWTEXT_FIX(1,0.400,1-0.05,0,DYBLOCK),COLORWHITE;
DRAWTEXT_FIX(1,0.700,1-0.05,0,HYBLOCK),COLORYELLOW;

超B:=L2_AMO(0,2)/10000.0;
大B:=L2_AMO(1,2)/10000.0;
中B:=L2_AMO(2,2)/10000.0;
小B:=L2_AMO(3,2)/10000.0;
超S:=L2_AMO(0,3)/10000.0;
大S:=L2_AMO(1,3)/10000.0;
中S:=L2_AMO(2,3)/10000.0;
小S:=L2_AMO(3,3)/10000.0;
TESTSKIP(NOT(超B OR 大B OR 中B OR 小B OR 超S OR 大S OR 中S OR 小S)!=0);
大宗进:=(超B)+(大B),NODRAW;
大宗出:=(超S)+(大S),NODRAW;
非大宗进:=(中B)+(小B),NODRAW;
非大宗出:=(中S)+(小S),NODRAW;
DAZHIV:=CONST(MAX(ABS(大宗进),MAX(ABS(大宗出),MAX(ABS(非大宗进),ABS(非大宗出))))),NODRAW;

DRAWRECTREL(0,CONST(950-(ABS(大宗进)*250/DAZHIV)),30,970,IF(CONST(大宗进>0),RGB(255,0,0),RGB(23,125,255)));
DRAWRECTREL(32,CONST(950-(ABS(大宗出)*250/DAZHIV)),62,970,IF(CONST(大宗出>0),RGB(23,125,255),RGB(255,0,0)));

DRAWRECTREL(92,CONST(950-(ABS(非大宗进)*250/DAZHIV)),122,970,IF(CONST(非大宗进>0),RGB(255,0,0),RGB(23,125,255)));
DRAWRECTREL(124,CONST(950-(ABS(非大宗出)*250/DAZHIV)),154,970,IF(CONST(非大宗出>0),RGB(23,125,255),RGB(255,0,0)));

DRAWTEXT_FIX(CURRBARSCOUNT=1,0.015,1,0,'主力进出'),COLORMAGENTA;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.107,1,0,'散户进出'),COLORCY筹码空间AN;
来源自超越。集成了杨文峰老师的资金原创。

筹码空间
IF(WINNER(CLOSE),WINNER(CLOSE)*100,20),VOLSTICK;

VAR1:=LLV(LOW,21);
VAR2:=HHV(HIGH,21);
K: EMA((CLOSE-VAR1)/(VAR2-VAR1)*100,6),COLORYELLOW,LINETHICK3;
D: EMA(0.667*REF(K,1)+0.333*K,2),COLORFF9900,LINETHICK3;
VAR3:=LLV(LOW,55);
VAR4:=HHV(HIGH,34);
VAR5:=EMA((CLOSE-VAR3)/(VAR4-VAR3)*100,3);
VAR6:=(K+VAR5)/2;
VAR7:=EMA(0.667*REF(VAR5,1)+0.333*K,2);
VAR8:=EMA(VAR6,5);

DRAWICON(LONGCROSS(D,K,0.1),D,35),COLORRED,LINETHICK3;
DRAWICON(LONGCROSS(K,D,0.1),K,34),COLORGREEN,LINETHICK3;

超B:=L2_AMO(0,2)/10000.0;
大B:=L2_AMO(1,2)/10000.0;
中B:=L2_AMO(2,2)/10000.0;
小B:=L2_AMO(3,2)/10000.0;
超S:=L2_AMO(0,3)/10000.0;
大S:=L2_AMO(1,3)/10000.0;
中S:=L2_AMO(2,3)/10000.0;
小S:=L2_AMO(3,3)/10000.0;
净流入:(超B+大B+中B+小B)-(超S+大S+中S+小S),NODRAW;
超大单:(超B)-(超S),NODRAW;
大单:(大B)-(大S),NODRAW;
中单:(中B)-(中S),NODRAW;
小单:(小B)-(小S),NODRAW;

DAZHI:CONST(MAX(ABS(净流入),MAX(ABS(超大单),MAX(ABS(大单),MAX(ABS(中单),ABS(小单)))))),NODRAW;

DRAWRECTREL(0,0,182,999.2,IF(120,RGB(10,0,0),0));
DRAWRECTREL(0,CONST(830-(ABS(净流入)*500/DAZHI)),30,830,IF(CONST(净流入)>0,RGB(255,0,0),RGB(23,125,255)));
DRAWRECTREL(38,CONST(830-(ABS(超大单)*500/DAZHI)),68,830,IF(CONST(超大单)>0,RGB(255,0,0),RGB(23,125,255)));
DRAWRECTREL(76,CONST(830-(ABS(大单)*500/DAZHI)),106,830,IF(CONST(大单)>0,RGB(255,0,0),RGB(23,125,255)));
DRAWRECTREL(114,CONST(830-(ABS(中单)*500/DAZHI)),144,830,IF(CONST(中单)>0,RGB(255,0,0),RGB(23,125,255)));
DRAWRECTREL(152,CONST(830-(ABS(小单)*500/DAZHI)),182,830,IF(CONST(小单)>0,RGB(255,0,0),RGB(23,125,255)));

DRAWTEXT_FIX(CURRBARSCOUNT=1,0.001,1,0,'净流入'),COLORRED;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.037,1,0,'超大单'),COLORRED;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.073,1,0,'大单'),COLORRED;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.109,1,0,'中单'),COLORRED;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.145,1,0,'小单'),COLORRED;

DRAWTEXT_FIX(CURRBARSCOUNT=1,0.0,0.001,0,'单位(万元)'),COLORYELLOW;
M:=0.58;M1:=0.39;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.001,M-ABS(净流入)*M1/DAZHI,0,CEILING(净流入));
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.037,M-ABS(超大单)*M1/DAZHI,0,CEILING(超大单));
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.073,M-ABS(大单)*M1/DAZHI,0,CEILING(大单));
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.111,M-ABS(中单)*M1/DAZHI,0,CEILING(中单));
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.147,M-ABS(小单)*M1/DAZHI,0,CEILING(小单));
TX80:80,POINTDOT, COLORYELLOW,LINETHICK4;
DX20:20,POINTDOT, COLORGREEN,LINETHICK4;
WK10:10,COLORCYAN,;
VAR9:EMA(0.667*REF(VAR8,1)+0.333*VAR8,2)LINETHICK0;

REFLINE: -15, {0}, {20}, {40}, {60};
VAR1K:=MA(WINNER(CLOSE),9)*100;
买!: CROSS(VAR1K,2)*30,COLOR0000FF ,LINETHICK3 ;
VAR2K:=(1-EMA((HHV(HIGH,15)-CLOSE)/(HHV(HIGH,15)-LLV(LOW,15)),15))*100;
VAR3K:=(CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100;
VAR4K:=SMA(VAR3K,9,1);
VAR5K:=SMA(VAR4K,9,1);
VAR6K:=(CLOSE-SMA(CLOSE,13,1))/SMA(CLOSE,13,1)*(-100);
VAR7K:=REF(VAR6K,1)>13 AND REF(VAR6K,1)/VAR6K>1.23 AND CLOSE/REF(CLOSE,1)>1.03;

VAR8K:=MA(CLOSE,27);
VAR9K:=(CLOSE-VAR8K)/VAR8K*100;
VARA:=MA(VAR9K,2);
VARB:=BARSLAST(CROSS(-10,VARA)=1);
VARC:=BARSLAST(CROSS(VARA,10)=1);
VARD:=VARA<-10 AND VARB>3;
VARE:=VARA>10 AND VARC>3;
黄金坑: IF(VARD,VARA,0),LINESTICK , COLORYELLOW;
注 来源自 瘦石老师的原公式优化。

翻红买入副
N:=6;
VAR1:=(HHV(HIGH,N)-CLOSE)/(HHV(HIGH,N)-LLV(LOW,N))*1000-700;
VAR2:=SMA(VAR1,N,1)+100;
VAR3:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*10000;
VAR4:=SMA(VAR3,3,1);
VAR5:=SMA(VAR4,3,1)+100;
VAR6:=VAR5-VAR2;
DDDD:= IF(VAR6>100,VAR6-100,0);
STICKLINE(REF(DDDD,1)<DDDD,DDDD,REF(DDDD,1),8,0),COLORRED;
STICKLINE(REF(DDDD,1)>DDDD,DDDD,REF(DDDD,1),8,0),COLORCYAN;
低吸:IF(CROSS(RSI,11),8000,0),COLORFF9900,LINETHICK3;
STICKLINE(低吸,6000,0,3,0),COLORFF9900;
DRAWTEXT(低吸,8500,'低吸!') ,COLORWHITE;
VAR7:=EMA(AMOUNT/VOL/100,3);
VAR8:=EMA(VAR7,88);
VAR9:=EMA(VAR7,88)*0.85;
VARA:=VAR9*0.87;
VARB:=LOW<VARA AND CLOSE>REF(CLOSE,1)*1.02;
STICKLINE(FILTER(VARB,6),1500,0,7,0),COLORRED;
坚决买进:IF(FILTER(VARB,6),2000,0),COLORCYAN,LINETHICK3;

VAR1R:=(CLOSE-LLV(LOW,24))/(HHV(HIGH,24)-LLV(LOW,24))*100;
VAR2R:=SMA(VAR1R,3,1);
VAR3R:=SMA(VAR2R,3,1)*VAR1R,LINETHICK2,COLORRED;
VAR4R:=SMA(VAR3R,3,1),LINETHICK2,COLOR0099FF;
VAR9R:=CROSS(VAR4R,VAR3R) AND VAR3R>80;
STICKLINE(VAR9R,VAR3R-5,100,1,0),LINETHICK2,COLORYELLOW;


HL99 := MA(COST(99 ),5);{获利99}
HL80:=MA(COST(80),5);{获利80}
HL20:=MA(COST(20),5);{获利20}
A5:=(HL99-HL80)/HL80*100;
A6:=(HL80-HL20)/HL20*100;
A8:=IF(A6<10 ,10000 ,0 );
A9:=IF(A6<15 ,5000 ,0 );
A10:=IF(A6<20 ,2500 ,0 );
高密集:A8,COLORFF1493,LINETHICK2;
中密集:A9,COLORWHITE,LINETHICK2;
低密集:A10,COLORC187FF,LINETHICK2;

VARF:=(2*CLOSE+HIGH+LOW)/4;
VA4:=LLV(LOW,34);
VA5:=HHV(HIGH,34);
VA6:=EMA((VARF-VA4)/(VA5-VA4)*100,6);
VA7:=EMA(0.667*REF(VA6,1)+0.333*VA6,4);
出击:IF(IF(COUNT(CLOSE<REF(CLOSE,1),8)/8>0.3 AND COUNT(VA6>VA7,3) AND REF(LOW,1)=LLV(LOW,120) AND
CLOSE>OPEN,1,0),5000,0),COLORRED,POINTDOT;
STICKLINE(IF(COUNT(CLOSE<REF(CLOSE,1),8)/8>0.3 AND COUNT(VA6>VA7,3) AND
REF(LOW,1)=LLV(LOW,120) AND CLOSE>OPEN,1,0),5000,0,3,0),COLORRED;
A:=(3*CLOSE+LOW+OPEN+HIGH)/6;
D1:=(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+14*REF(A,6)
+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)
+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+
REF(A,20))/211;
D2:=EMA(D1,2);
D3:=EMA(D2,2);
K1:=EMA(D3,2);
波段买入:IF(CROSS(D1,K1),2500,0),COLOR0099FF,POINTDOT;
STICKLINE(CROSS(D1,K1),2500,0,3,0),COLOR0099FF;
多方趋势:=7*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*30,4,1)
-3*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*30,4,1),3,1)
-SMA(SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*30,4,1)
,3,1),2,1);
天线:=7500.8900;
STICKLINE(CROSS(天线,多方趋势),7500,8900,6,0),COLOR00FF00;
DRAWTEXT(CROSS(天线,多方趋势),8000,'卖吧!别贪了!') ,COLORWHITE;
DRAWICON(CROSS(天线,多方趋势),8000,5);

VARL:=TROUGHBARS(3,15,1)<10;
VARK:=PEAKBARS(3,15,1)<10;
VARJ:=IF(VARL=1,5000,0);
VARH:=IF(VARK=1,5000,0);
底部:=IF(VARJ=5000,1000,0);
多头能量:0,COLORWHITE,LINETHICK2;
神仙脚买入:IF(底部=1000 AND REF(底部,1)=1000 AND REF(底部,2)=0,5000,0),COLORFFFF00,LINETHICK3;
DRAWTEXT(底部=1000 AND REF(底部,1)=1000 AND REF(底部,2)=0,7000,'神仙脚买入')COLORCYAN;
买入延迟线:底部,LINETHICK3 ,COLOR00CCFF;
VARQ:=LLV(LOW,3)<=LLV(LOW,240);
VARW:= C>O AND (C/O>1.08 OR C>=1.08*REF(C,1));
绝地反击:IF(VARQ AND VARW,2500,0),COLORYELLOW,LINETHICK2;
吸货线:1500,POINTDOT,LINETHICK5,COLORCYAN;
DRAWTEXT(ISLASTBAR,1500,'吸货线'),COLORFF9900;
强弱分界线:5000,POINTDOT,LINETHICK5,COLOR70DB93;
DRAWTEXT(ISLASTBAR,5000,'强弱分界'),COLOR70DB93;
卖股线:8000,POINTDOT,LINETHICK5,COLORCYAN;
DRAWTEXT(ISLASTBAR,8000,'卖股线'),COLORYELLOW;
DRAWTEXT(FILTER(VARB,6),4000,'买吧!别等了!'),COLORYELLOW;
DRAWTEXT(VAR9R AND COUNT(VAR9R,10)=1,VAR3R-15,'庄逃了!'),LINETHICK2,COLORWHITE;
来自理想论坛


MACD+RSI

LC:=REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LC,0),12,1)/SMA(ABS(CLOSE-LC),12,1)*100;
RSIE:=EMA(RSI,3);
DIFF : EMA(RSIE,12) - EMA(RSIE,26);
BBDIFF:=DIFF-REF(DIFF,1);
DEA : EMA(DIFF,9);
DRAWBAND(DIFF,RGB(255,105,180),DEA,RGB(34,139,34));
BBDEA:=DEA-REF(DEA,1);
MACD : 2*(DIFF-DEA), COLORSTICK;
STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,2,0),COLORFFFF00;
STICKLINE(MACD<REF(MACD,1)AND MACD<0,0,MACD,2,0),COLOR00FF00;
STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,2,0),COLOR0099FF;
STICKLINE(MACD>REF(MACD,1)AND MACD>0,0,MACD,2,0),COLORRED;
0,COLORFF8855,LINETHICK2;
IF(DIFF>DEA,DIFF,DRAWNULL),COLORRED,LINETHICK2;
IF(DEA>REF(DEA,1),DEA,DRAWNULL),COLORMAGENTA;
DRAWICON(CROSS(DIFF,DEA),DEA,1);
DRAWICON(CROSS(DEA,DIFF),DEA,2);
低位金叉:=CROSS(DIFF,DEA) AND DIFF<-0.1;
STICKLINE(低位金叉,0,-1.5,2,0),COLORFFFF00;
DRAWTEXT(低位金叉,-1.5,' 低位金叉'),COLORFFFF00;
JCCOUNT:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0));
二次金叉:=CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1;
STICKLINE(二次金叉,0,-1,5,0),COLORFF00FF;
DRAWICON(二次金叉,DEA*1.2,11) ;
DRAWTEXT(二次金叉,-1,' 二次金叉'),COLORFF00FF;
A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));
底背离:=REF(CLOSE,A1+1)>CLOSE AND DIFF>REF(DIFF,A1+1) AND CROSS(DIFF,DEA);
STICKLINE(底背离,0,1.5,3,0),COLOR00FF00;
DRAWLINE(A1=0,DEA,底背离,DEA,0),COLORRED,LINETHICK1;
DRAWTEXT(底背离,2,' 底背离'),COLOR00FF00;
A2:=BARSLAST(REF(CROSS(DEA,DIFF),1));
顶背离:=REF(CLOSE,A2+1)<CLOSE AND REF(DIFF,A2+1)>DIFF AND CROSS(DEA,DIFF);
STICKLINE(顶背离,0,2,3,0),COLORFF8855;
DRAWLINE(A2=0,DEA,顶背离,DEA,0),COLORFF8855,LINETHICK1;
DRAWTEXT(顶背离,2,' 顶背离'),COLORFF8855;
VAR9:=((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27)))*(100);
VAR10:=SMA(VAR9,3,1);
VAR11:=SMA(VAR10,3,1);
VAR12:=SMA(VAR11,3,1);
DRAWTEXT(CROSS(VAR11,VAR12) AND (VAR11<40),2.3,'启动!'),COLORYELLOW;
STICKLINE(CROSS(VAR11,VAR12) AND (VAR11<40),0,2,1.5,0 ),COLORCYAN;
主力出现:DRAWICON(CROSS(VAR11,VAR12) AND (VAR11<40),3.0,9);

MM:=IF(MACD< 0,MACD,0);
JJ1:=MM> REF(MM,1);
ZZ:=REF(JJ1,1)=1;
介入区:(JJ1 AND ZZ)*DEA,POINTDOT,COLOR0066FF;{MACD蓝柱缩短---指今日比昨天短}
STICKLINE(介入区=DEA,DEA,DIFF,3,0),COLORMAGENTA;

DRAWTEXT(CROSS(DIFF,DEA ),-0.05,'金\N叉'),COLORCYAN;
DRAWTEXT(CROSS(DEA,DIFF ),-0.05,'死叉'),COLORWHITE;

来源 网络

感谢原创老师的分享!!!!!!!!!!!!!!!!!

打造适合自己的指标模版才是最好的。
 


 

通达信飘带主图公式源码
 


打赏好指标 ×

关于通达信飘带主图公式源码的评论:

 以下是对 [通达信飘带主图公式源码] 的评论,总共:0条评论
加入收藏 | 联系我们 | 免责声明 | 站内地图 | 关于我们