买好股公式网 > 股票公式 > 通达信公式 > 大资金活动副图指标源码

大资金活动副图指标源码

2022年09月18日人气:Tags:资金 副图 指标

VAR1:=EMA(EMA(CLOSE,9),9);

控盘:=(VAR1-REF(VAR1,1))/REF(VAR1,1)*1000;

STICKLINE(控盘<0,控盘,0,2,0),colorred;

STICKLINE(控盘<REF(控盘,1)AND 控盘<0,0,控盘,6,0 ),colorgreen;

A10:=CROSS(控盘,0);

无庄控盘:IF(控盘<0,控盘,0),colorblue,NODRAW;

开始控盘:IF(A10,5,0),LINETHICK2,coloryellow;

STICKLINE(控盘>REF(控盘,1) AND 控盘>0,控盘,0,6,0),colorred;

有庄控盘:IF(控盘>REF(控盘,1) AND 控盘>0,控盘,0),colorred,NODRAW;

VAR2:=100*WINNER(CLOSE*0.95);

STICKLINE(VAR2>50 AND COST(85)<CLOSE AND 控盘>0,控盘,0,6,0),COLORFF00FF;

高度控盘:IF(VAR2>50 AND COST(85)<CLOSE AND 控盘>0,控盘,0),COLORFF00FF,NODRAW;

STICKLINE(控盘<REF(控盘,1) AND 控盘>0,控盘,0,6,0),COLOR00FF00;

主力出货:IF(控盘<REF(控盘,1) AND 控盘>0,控盘,0),COLOR00FF00,NODRAW;

VAR3:=AMOUNT/VOL/7;VAR4:=(3*HIGH+LOW+OPEN+2*CLOSE)/7;

VAR7:=REF((LOW+OPEN+CLOSE+HIGH)/4,1);

VAR8:=SMA(ABS(LOW-VAR7),13,1)/SMA(MAX(LOW-VAR7,0),10,1);

VAR9:=EMA(VAR8,10);

VAR10:=LLV(LOW,33);

VAR11:=EMA(IF(LOW<=VAR10,VAR9,0),3);

进场:IF(VAR11>REF(VAR11,1),VAR11,0),colorblack,NODRAW;

STICKLINE(VAR11>REF(VAR11,1),0,VAR11,2,0 ),colorblack;

洗盘:IF(VAR11<REF(VAR11,1),VAR11,0),COLORFFFF00,NODRAW;

STICKLINE(VAR11<REF(VAR11,1),0,VAR11,2,0),COLORFFFF00;

DRAWTEXT(CROSS(EMA(ZIG(3,10),2),ZIG(3,10)),ZIG(3,10)+2,'高'),colorblack;

DRAWTEXT(CROSS(ZIG(3,10),EMA(ZIG(3,10),2)),ZIG(3,10)-2,'低'),ColorFF00FF;

VAEC:=(ZIG(3,5)>REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)<=REF(ZIG(3,5),2)) AND (REF(ZIG

(3,5),2)<=REF(ZIG(3,5),3));

VAED:=(ZIG(3,5)<REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)>=REF(ZIG(3,5),2)) AND (REF(ZIG

(3,5),2)>=REF(ZIG(3,5),3));

STICKLINE((VAEC=1),(-5),0,2,0),ColorFF00FF;

DRAWTEXT((VAEC=1),(-5),'买'),ColorFF00FF;

STICKLINE((VAED=1),-5,0,2,0),colorblack;

DRAWTEXT((VAED=1),-5,'卖'),colorblack;

VAEE:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;

VAEF:=100-3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA

((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);

VAR20:=100-3*SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA

((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);

VAR21:=VAEF<REF(VAR20,1) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1);

DRAWTEXT(VAR21 AND COUNT(VAR21,30)=1,20,'★大资金活动'),LINETHICK1,COLORF00FF0;

STICKLINE(VAR21 AND COUNT(VAR21,30)=1,1,15,3,0),COLORF00FF0;

VAR22:=(HIGH+LOW+CLOSE)/3;

VAR23:=(VAR22-MA(VAR22,14))/(0.015*AVEDEV(VAR22,14));

VAR24:=(VAR22-MA(VAR22,70))/(0.015*AVEDEV(VAR22,70));

VAR25:=IF(VAR23>=150 AND VAR23<200 AND VAR24>=150 AND VAR24<200,10,0);

VAR26:=IF(VAR23<=-150 AND VAR23>-200 AND VAR24<=-150 AND VAR24>-200,-10,VAR25);

VAR27:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;

VAR28:=100-ABS(VAR27);

VAR29:=IF(VAR28<90,VAR28,100);

VAR2A:=IF(VAEE>0,VAEE,0);

VAR2B:=IF(VAR24>=200 AND VAR23>=150,15,IF(VAR24<=-200 AND VAR23<=-150,-15,VAR26))+60;

VAR2C:=VAR2A>48 AND VAR2B>60 AND VAR29<100;

DRAWTEXT(VAR2C AND COUNT(VAR2C,30)=1,30,'★大笔异动'),LINETHICK1,colormagenta;

STICKLINE(VAR2C AND COUNT(VAR2C,30)=1,0,25,1,0),colormagenta;

V9:=TROUGHBARS(3,15,1)<10;

V11:=IF(V9=1,50,0);

DRAWTEXT(IF( IF(V11=50,50,0)>REF(IF(V11=50,50,0),1),L,0),L*-2.0,'★抄底'),colorblack; 

{大资金活动副图指标源码}

打赏好指标 ×

关于大资金活动副图指标源码的评论:

 以下是对 [大资金活动副图指标源码] 的评论,总共:0条评论
加入收藏 | 联系我们 | 免责声明 | 站内地图 | 关于我们