买好股公式网 > 股票公式 > 通达信公式 > 通达信飞龙寻底幅图公式源码

通达信飞龙寻底幅图公式源码

2018年01月22日人气:Tags:通达信 公式 源码

VA:=IF(CLOSE>REF(CLOSE,1),VOL,-VOL);
 OBV:=SUM(IF(CLOSE=REF(CLOSE,1),0,VA),0);
 MAOBV:=MA(OBV,30);
 DIF:=(EMA(CLOSE,12)-EMA(CLOSE,26))*1;
 DEA:=(EMA(DIF,9))*1;
 MACD:=(DIF-DEA)*2,COLORSTICK;
 M:=CROSS(DIF,DEA);
 HJZ:=(3*C+H+L+O)/6;
 HJZ2:=(8*HJZ+7*REF(HJZ,1)+6*REF(HJZ,2)+5*REF(HJZ,3)+4*REF(HJZ,4)+3*REF(HJZ,5)

+2*REF(HJZ,6)+REF(HJZ,8))/36;
 HJZ3:=VOL=HHV(VOL,10) AND VOL>2*REF(VOL,1) AND CLOSE>HJZ2 AND C>O;
 H1:=FILTER(HJZ3,5),STICK,COLORRED,LINETHICK4;
 HJ:=COUNT(H1,6)=1;

 MA6:=MA(CLOSE,60);
 MA5:=MA(CLOSE,5);
 V05:=MA(VOL,5),LINETHICK1,COLORWHITE;
 V35:=MA(VOL,35),LINETHICK1,COLORYELLOW ;
 VL135:=MA(VOL,135),LINETHICK1,COLORMAGENTA;
 ML:=(CROSS(V05,VL135) OR CROSS(V05,V35)) AND OBV>MAOBV;
 MLL:=CROSS(C,MA6);
 MA13:=EMA(C,13);
 UP:=DRAWLINE(L=LLV(L,BARSLAST(CROSS(MA13,MA5))+1),LLV(L,BARSLAST(CROSS
 (MA13,MA5))+1),H=HHV(H,BARSLAST(CROSS(MA5,MA13))+1),HHV(H,BARSLAST(CROSS
 (MA5,MA13))+1),0),COLOR0000FF;
 DOWN:=DRAWLINE(H=HHV(H,BARSLAST(CROSS(MA5,MA13))+1),HHV(H,BARSLAST(CROSS
 (MA5,MA13))+1),L=LLV(L,BARSLAST(CROSS(MA13,MA5))+1),LLV(L,BARSLAST(CROSS
 (MA13,MA5))+1),0),COLOR00FF00;
 STICKLINE(UP,0,0.05,3,0),COLOR0000FF;
 STICKLINE(DOWN,0,0.05,3,0),COLOR00FF00;
 HR:=HHV(HIGH,55);
 HRY:=LLV(LOW,55);
 HRY11:=HR*HRY;
 HRY33:=SQRT(HRY11);
 TJ202:=REF(DOWN,1)<REF(DOWN,2) AND UP>REF(DOWN,1) AND C<HRY33;
 ZN:ML AND MLL AND COUNT(TJ202,50)>=1,COLORMAGENTA;
 {DRAWICON(ZN,1,5); }
 DRAWTEXT(ZN,0.6,'抓'),COLORGREEN;
 DRAWTEXT(ZN,0.3,'牛'),COLORGREEN;
 VARF:=100-3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA
 ((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
 VAR10:=100-3*SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA
 ((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
 VAR11:=VARF<REF(VAR10,1) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1);
 DZJ:=VAR11 AND COUNT(VAR11,30)=1;
 STICKLINE(DZJ,0,0.15,3,0),COLORFF80FF;
 STICKLINE(DZJ,0.15,0.35,2,0),COLOR3000FF;
 STICKLINE(DZJ,0.35,0.51,1,0),COLOR00FFFF;
 DRAWTEXT(DZJ,0.55,'大资金'),COLORMAGENTA;
 DIF18:=EMA(DCLOSE,12)-EMA(DCLOSE,26);
 DEA18:=EMA(DIF18,9);
 AAA1:=(DIF18-DEA18)*2*60;
 AA:=AAA1-REF(AAA1,1);
 VAR18:=(CLOSE*2+HIGH+LOW)/4;
 VAR28:=EMA(VAR18,13)-EMA(VAR18,34);
 VAR38:=EMA(VAR28,5);
 BB:=(VAR38-VAR28)*5,COLORGREEN,LINETHICK2;
 CC:=(VAR28-VAR38)*5,COLORWHITE,LINETHICK2;
 LZL:=VOL=HHV(VOL,40) AND VOL>1.9*REF(VOL,1);
 LT:=IF(BARSLAST(LZL)=1 AND CLOSE>REF(HIGH,1),1,IF(BARSLAST(LZL)=2 AND CLOSE>REF

(HIGH,2),1,IF(BARSLAST(LZL)=3 AND CLOSE>REF(HIGH,3),1,0)));
 LB:=BARSLAST(LZL)=3 AND REF(LOW,3)<=MIN(MIN(C,REF(C,1)),REF(C,2));
 BACKSET300:=BACKSET(LB,4);
 BACKSET301:=BACKSET(LT,4);
 LL:=FILTER(BACKSET300,3) AND BACKSET301 AND LZL;
 QN:CROSS(AA,15) AND CC>BB,COLORYELLOW,LINETHICK4,STICK;
 DRAWICON(QN,0.6,1);
 DRAWICON(QN,0.8,1);
 QQN:=COUNT(QN,3)=1 AND COUNT(LL,3)>=1 AND HJ,COLORRED;
 BLZ:=VOL>REF(V,1)*1.9;
 BLZ1:=VOL<REF(LLV(VOL,13),1);
 BLZ2:=VOL<REF(LLV(VOL,55),1);
 BL2:=BLZ AND REF(BLZ,1);
 X:=CONST(DATE);
 Y:=IF(DATE<X, 240, FROMOPEN);
 ZR:=BARSCOUNT(CLOSE);
 LD:=IF((VOL/Y*240)=CONST(LLV(VOL,60)) AND (VOL/Y*240)>CONST(LLV(VOL,ZR)),6,0);
 ZD:=IF((VOL/Y*240)=CONST(LLV(VOL,60)) AND (VOL/Y*240)=CONST(LLV(VOL,ZR)),6,0);
 DL:ZD OR LD;
 DRAWTEXT(DL,0.4,'量底'),COLORYELLOW;
 {DRAWICON(QQN>0,0.9,9);}
 VAR1:=C-REF(C,1);
 VAR2:=100*EMA(EMA(VAR1,6),6)/EMA(EMA(ABS(VAR1),6),6);
 BT:=(LLV(VAR2,2)=LLV(VAR2,7) AND COUNT(VAR2<0,2) AND CROSS(VAR2,MA(VAR2,2))) AND
 REF(DOWN,1)<REF(DOWN,2) AND UP>REF(DOWN,1);
 TJ1:=REF(DOWN,1)<REF(DOWN,2) AND UP>REF(DOWN,1) AND C<HHV(H,21)*0.82;
 ND:=TJ202 AND TJ1 AND BT;
 STICKLINE(ND,0,0.8,0.1,0),COLORRED;
 DRAWTEXT(ND,0.7,'牛底'),COLORYELLOW;
 YK:="KDJ.K"(89,3,3),COLOR00FF00;
 YD:="KDJ.D"(89,3,3),COLOR00FF00,LINETHICK2;
 ZK:="KDJ.K"(27,3,3),COLORRED;
 Z1D:="KDJ.D"(27,3,3),COLORRED,LINETHICK2;
 RK:="KD.K"(5,3,3),COLORWHITE;
 RD:="KD.D"(5,3,3),COLORWHITE,LINETHICK2;
 RJC:=IF(CROSS(RK,RD),50,0),COLORFFFFFF;
 ZJC:=IF(CROSS(ZK,Z1D),30,0),COLORRED;
 YJC:=IF(CROSS(YK,YD),20,0),COLOR0080FF;
 HZ:=COUNT(MACD>0,4)=4 AND COUNT(MACD<REF(MACD,1),4)>2 AND MACD>REF(MACD,1)AND MA

(C,5)>REF(MA(C,5),1);
 NN:=(HZ AND RJC AND ZJC AND YJC) AND UP;
 N22:NN;
 DRAWTEXT(N22,0.6,'牛'),COLORRED;
 DRAWTEXT(N22,0.3,'庄'),COLORRED;
 DIFFV:=EMA(DCLOSE,9)-EMA(DCLOSE,27);
 DEAV:=EMA(DIFFV,5);
 A1V:=CROSS(DIFFV,DEAV);
 DB2:=REF(CLOSE,A1V+1)>CLOSE AND DIFFV>REF(DIFFV,A1V+1) AND CROSS(DIFFV,DEAV);
 DEA0:=EMA(DIFFV*100,9);
 MACD0:=2*(DIFFV*100-DEA0);
 HM:=(MACD0>REF(MACD0,1)*2.5 AND MACD0>15);
 LHT:=DB2 AND HM;
 QS:LHT;

DRAWTEXT(LHT,0.3,'牛势'),COLORRED;
 DRAWICON(LHT,0.1,1);
 KK:=ATAN((MA5/REF(MA5,1)-1)*100)*180/3.14159,COLORSTICK;
 MAA:=(KK/REF(KK,1)>=2 AND KK>0 AND C>0 AND (H=HHV(H,10) OR C=HHV(C,10)))

*80,STICK,COLORWHITE,LINETHICK3;
 QMM:=(MA(C,30)>REF(MA(C,30),1) AND KK/REF(KK,1)>=2 AND KK>0 AND COUNT(KK<REF

(KK,1),4)>=1
 AND CROSS(KK,45) AND (H=HHV(H,10) OR C=HHV(C,10)))*100,COLORWHITE,LINETHICK2;
 N:=14;MM:=6;
 MTR:=EXPMEMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),N);
 HD:=HIGH-REF(HIGH,1);
 LD1:=REF(LOW,1)-LOW;
 DMP:=EXPMEMA(IF(HD>0&&HD>LD1,HD,0),N);
 DMM:=EXPMEMA(IF(LD1>0&&LD1>HD,LD1,0),N);
 PDI:=DMP*100/MTR;
 MDI:=DMM*100/MTR;
 ADX:=EXPMEMA(ABS(MDI-PDI)/(MDI+PDI)*100,MM);
 ADXR:=EXPMEMA(ADX,MM);
 MAI:=IF(CROSS(PDI,MDI) AND (C >1.05*REF(C,1) OR REF(C,1)>1.05*REF(C,2)) AND

(V>2*REF(V,1) OR REF(V,1)>2*REF(V,2))AND MA(V,5)>MA(V,60)

,20,0),COLORRED,LINETHICK2;
 RSV9:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
 K1:=SMA(RSV9,3,1);
 DK1:=K1-REF(K1,1),COLORSTICK;
 MA10:=MA(CLOSE,10),;
 MA20:=MA(CLOSE,20);
 MA30:=MA(CLOSE,30);
 MA60:=MA(CLOSE,60);
 Q5:=MA5>REF(MA5,1),;
 Q10:=MA10>REF(MA10,1),;
 Q20:=MA20>REF(MA20,1),;
 Q30:=MA30>REF(MA30,1),;
 Q60:=MA60>REF(MA60,1),;
 XJQ:=(Q5 AND Q10)*0.5,;
 JJD:=(H+L+C)/3;
 QSX1:=HHV(MA((((LOW + HIGH) + CLOSE) / 3),8),60),COLORRED,LINETHICK2;
 QSX2:=HHV(MA((((LOW + HIGH) + CLOSE) / 3.18),8),20),COLORWHITE,LINETHICK2;
 QSX3:=HHV(MA((((LOW + HIGH) + CLOSE) / 3.258),8),10),COLORYELLOW,LINETHICK2;
 QSX4:=HHV(MA((((LOW + HIGH) + CLOSE) / 3.08),80),13),COLORLIMAGENTA,LINETHICK2;
 ZQ1:=QSX1>REF(QSX1,1),;
 ZQ2:=QSX2>REF(QSX2,1),;
 ZQ3:=QSX3>REF(QSX3,1),;
 ZQ4:=QSX4>REF(QSX3,1),;
 SQ1:=ZQ1 AND ZQ2,;
 SQ2:=ZQ2 AND ZQ3,;
 SQ3:=ZQ2 AND ZQ3,;
 SQ4:=ZQ3 AND ZQ4,;
 Q3:=ZQ1 AND ZQ2 AND ZQ3,;
 Q4:=ZQ1 AND ZQ2 AND ZQ3 AND ZQ4,;
 QSWW:=SQ1 OR SQ2 OR SQ3 OR SQ4 OR Q3 OR Q4,;
 VV:=(C+L+H)/3;
 DSA:=SMA(XMA(VV,15),2,1)LINETHICK3;
 DU1:=DSA*0.9518,COLORLICYAN,LINETHICK1;
 MA1:=MA(CLOSE,5);
 MA2:=MA(CLOSE,10);
 MA3:=MA(CLOSE,20);
 MA4:=MA(CLOSE,60);
 Z5Q:=MA1>REF(MA1,1),;
 Z10Q:=MA2>REF(MA2,1),;
 Z20Q:=MA3>REF(MA3,1),;
 Z60Q:=MA4>REF(MA4,1),;
 DS:=Z5Q AND Z10Q AND Z60Q,;
 ZSL:=Z5Q AND Z10Q AND Z20Q,;
 DZSL:=Z10Q AND Z20Q AND Z60Q,;
 DZSL2:=Z5Q AND Z10Q AND Z20Q AND Z60Q,;
 ZZS:=ZSL AND DZSL AND DZSL2,;
 ZZSL:=DS OR ZSL OR DZSL OR DZSL2 OR ZZS,;
 QSZ:=(L<DU1 AND ZZSL AND QSWW AND C<DSA AND UP)*0.5,COLORYELLOW,LINETHICK2;
 LO:=(L<DU1 AND C<DSA AND QSWW AND UP)*0.5,COLORMAGENTA,LINETHICK2,LINESTICK;
 CJ:=QSZ AND LO AND H<DSA,COLORRED,;
 A:=MA(C,30);
 A1:=A*1.1;
 A4:=A*0.9;
 A2:=A1-(A1-A4)*0.191;
 CCC:=IF(HIGH*1.01>A2 OR REF(HIGH,1)>REF(A2,1),A1,A4),LINETHICK3,COLORRED;
 SSS:=IF(HIGH*1.01>A2 OR REF(HIGH,1)>REF(A2,1),A2,A4),LINETHICK3,COLORFFFFFF;
 ZC:=CCC>SSS,;
 ZA1:=CCC>REF(CCC,1),;
 ZA2:=SSS>REF(SSS,1),;
 ZA:=ZA1 AND ZA2,;
 ZW:=(CJ AND ZC AND ZA) OR (LO AND ZC AND ZA),;
 SSSSS:=((ZW AND XJQ) OR (LO AND XJQ) AND UP)*0.5,COLORLIRED,LINETHICK4,STICK;
 DRAWICON(SSSSS>0,0.1,1);

通达信飞龙寻底幅图公式源码
打赏好指标 ×

关于通达信飞龙寻底幅图公式源码的评论:

 以下是对 [通达信飞龙寻底幅图公式源码] 的评论,总共:0条评论
加入收藏 | 联系我们 | 免责声明 | 站内地图 | 关于我们