买好股公式网 > 股票公式 > 通达信公式 > 通达信机构分时主图公式源码

通达信机构分时主图公式源码

2016年06月12日人气:Tags:通达信 机构 分时 主图 公式 源码
现价:CLOSE,COLORFFFFFF,LINETHICK2;
均价:SUM(C*V,240)/SUM(V,240),COLORYELLOW,LINETHICK2;
H1:=MAX(DYNAINFO(3),DYNAINFO(5));
L11:=MIN(DYNAINFO(3),DYNAINFO(6));
P1:=H1-L11;
阻力:L11+P1*7/8,COLOR00DD00;
支撑:L11+P1*0.5/8,COLORMAGENTA;
中:阻力*0.5+支撑*0.5,DOTLINE; 
STICKLINE(CROSS(支撑,现价),中,现价,2,0),COLORYELLOW,LINETHICK5; 
STICKLINE(CROSS(现价,阻力),现价,中,2,0),COLORFFCC66,LINETHICK5; 
DRAWTEXT(LONGCROSS(支撑,C,2),C,'--反弹'),COLORYELLOW;
DRAWTEXT(LONGCROSS(C,阻力,2),C,'--出货'),COLORYELLOW;
A1:=(DVOL/C)/2,NODRAW;
A2:=SUM(IF(A1>100 AND CLOSE>REF(CLOSE,1),A1,0),0);
A3:=SUM(IF(A1>100 AND CLOSE<REF(CLOSE,1),A1,0),0);
A4:=SUM(IF(A1<100 AND CLOSE>REF(CLOSE,1),A1,0),0);
A5:=SUM(IF(A1<100 AND CLOSE<REF(CLOSE,1),A1,0),0);
A6:=A2+A3+A4+A5;
A7:=IF((BARSTATUS=2),((100*A2)/A6),0);
A8:=((IF((BARSTATUS=2),((100*A3)/A6),0)));
A9:=((IF((BARSTATUS=2),((100*A4)/A6),0)));
A10:=((IF((BARSTATUS=2),((100*A5)/A6),0)));
机构买盘:=(A2),LINETHICK2;
机构卖盘:=(A3),LINETHICK2;
散户买盘:=(A4);
散户卖盘:=(A5);
机构买:=(A2),LINETHICK6,COLORRED;
机构卖:=(A3),LINETHICK6,COLORGREEN;
DD1:=1;
AAA1:=STRCAT(STRCAT('机构买',CON2STR((100*A2)/A6,0)),'%');
AAA2:=STRCAT(STRCAT('机构卖',CON2STR((100*A3)/A6,0)),'%');
AAA3:=STRCAT(STRCAT('净买入',CON2STR((100*(A2-A3))/A6,0)),'%');
DRAWTEXT_FIX(DD1=1,0,0.04,0,AAA1),COLORRED;
DRAWTEXT_FIX(DD1=1,0,0.12,0,AAA2),COLORGREEN;
DRAWTEXT_FIX(DD1=1,0,0.20,0,AAA3),COLOR00FFFF;
A11:=C>REF(C,4);
NT:=BARSLASTCOUNT(A11);
TJ11:=NT=9;
TJ13:=ISLASTBAR AND BETWEEN(NT,5,8);
AY:=(BACKSET(TJ11>0,9) OR   BACKSET(TJ13>0,NT))*NT;
DRAWTEXT(AY>0,H*1.001,VAR2STR(AY,0)),COLORFF00FF;
DRAWTEXT(NT=9,H*1.001,'9'),COLORGREEN;
B1:=C<REF(C,4);
NT0:=BARSLASTCOUNT(B1);
TJ21:=NT0=9 ;
TJ23:=ISLASTBAR AND BETWEEN(NT0,5,8);
AY1:=(BACKSET(TJ21>0,9)  OR  BACKSET(TJ23>0,NT0))*NT0;
DRAWTEXT(AY1>0,L*0.999,VAR2STR(AY1,0)),COLORFF00FF;
DRAWTEXT(NT0=9,L*0.999,'9'),COLORGREEN;
ZRS:=CONST(DYNAINFO(3)),NODRAW;
 A12:=3.5*(EMA(CLOSE,48)-EMA(CLOSE,104))+ZRS,COLORLIMAGENTA;
 A22:=EMA(A12,36),COLORLIBLUE;
 MACD:=(A12-A22)*2+ZRS; 
 DRAWKLINE(H,O,L,C);
 STICKLINE(A12>=A22,ZRS,MACD ,0,0),COLORRED;
STICKLINE(A12>=A22 AND MACD<REF(MACD,1),ZRS,MACD ,0,0),COLORYELLOW;
 STICKLINE(A12<A22,ZRS,MACD ,0,0),COLORCYAN;
STICKLINE(A12<A22 AND MACD>REF(MACD,1),ZRS,MACD ,0,0),COLORFFFFFF;

通达信机构分时主图公式源码
打赏好指标 ×

关于通达信机构分时主图公式源码的评论:

 以下是对 [通达信机构分时主图公式源码] 的评论,总共:0条评论
加入收藏 | 联系我们 | 免责声明 | 站内地图 | 关于我们