买好股公式网 > 股票公式 > 通达信公式 > 通达信火焰令副图指标公式

通达信火焰令副图指标公式

2019年02月11日 字体: 人气:

通达信火焰令副图指标公式


X1:=HHV(H,5);

X2:=REF(HHV(H,5),1);

VERTLINE:=(X1>=X2,1),POINTDOT,COLOR808080;

VARAA:=LLV(LOW,30);

VARBB:=HHV(HIGH,30); 

VARCC:=EMA((CLOSE-VARAA)/(VARBB-VARAA)*4,4)*25; 

底背离:= STICKLINE(VARCC<10 AND 100*(HHV(HIGH,14)-CLOSE)/(HHV(HIGH,14)-LLV(LOW,14))>97,0,-5,5,2),COLORRED; 

顶背离:= STICKLINE(VARCC>90,100,105,10,2),COLORRED; 

趋势: VARCC,COLORRED,LINETHICK1;

VARDD:=90; 

VAREE:=(VARCC-LLV(VARCC,4))/(HHV(VARCC,4)-LLV(VARCC,4))*4*25; 

DRAWTEXT(IF(CROSS(趋势,VARDD) AND VAREE=100,50,0),85,'目标'),COLORFF00FF;

DRAWTEXT(IF(CROSS(趋势,VAREE) AND 趋势>87,95,0),88,'险'),COLOR00FF00;

DRAWICON(CROSS(VARDD,趋势),95,10);

STICKLINE(FILTER(C/REF(C,1)>1.0918 AND C>LLV(LOW,120)*1.62,21), 90,100, 3,0),COLOR00FF00;

DRAWTEXT(FILTER(C/REF(C,1)>1.0918,21) AND C>LLV(LOW,120)*1.62,80,'高出'),COLOR00FF00;

VAR1:=EMA(HHV(HIGH,500),21);

VAR2:=EMA(HHV(HIGH,250),21);

VAR3:=EMA(HHV(HIGH,90),21); 

VAR4:=EMA(LLV(LOW,500),21); 

VAR5:=EMA(LLV(LOW,250),21); 

VAR6:=EMA(LLV(LOW,90),21);  

VAR7:=EMA((VAR4*0.96+VAR5*0.96+VAR6*0.96+VAR1*0.558+VAR2*0.558+VAR3*0.558)/6,21);

VAR8:=EMA((VAR4*1.25+VAR5*1.23+VAR6*1.2+VAR1*0.55+VAR2*0.55+VAR3*0.65)/6,21);

VAR9:=EMA((VAR4*1.3+VAR5*1.3+VAR6*1.3+VAR1*0.68+VAR2*0.68+VAR3*0.68)/6,21);

VAR10:=IF(DATE>=1340722,0,1);

VARA:=EMA((VAR7*3+VAR8*2+VAR9)/6*1.738,21);

VARB:=REF(LOW,1);

VARC:=SMA(ABS(LOW-VARB),3,1)/SMA(MAX(LOW-VARB,0),3,1)*100;

VARD:=EMA(IF(CLOSE*1.35<=VARA,VARC*10,VARC*VAR10/10),3);

VARE:=LLV(LOW,30)*VAR10;

VARF:=HHV(VARD,30);

VAR11:=IF(MA(CLOSE,58),1,0);

火焰山:EMA(IF(LOW<=VARE,(VARD+VARF*2)/2,0),3)/618*VAR11,COLOR99FFFF,LINETHICK2;

火焰:=STICKLINE(火焰山>0 ,0 ,火焰山 ,4 ,1);

今量:=火焰山*VAR10;

STICKLINE(火焰山>0,0 ,今量*1.2,8,0 ),COLOR00EEFF; 

STICKLINE(火焰山>0,0 ,今量*0.8,8,0 ),COLOR00BBFF; 

STICKLINE(火焰山>0,0 ,今量*0.6,8,0 ),COLOR0099FF; 

STICKLINE(火焰山>0,0 ,今量*0.4,8,0 ),COLOR0066FF; 

STICKLINE(火焰山>0,0 ,今量*0.2,8,0 ),COLOR0000FF;

VAR13:=IF(YEAR>=2005 AND MONTH>=11 AND DAY>=1,0,1);

AA:=(MA(C,1)+MA(C,3)+MA(C,5)+MA(C,7)+MA(C,9))/5;

BB:=(MA(C,2)+MA(C,4)+MA(C,6)+MA(C,8)+MA(C,10))/5;

CC:=EMA(AA,2);

DD:=EMA(BB,5);

VAR14:=MAX(EMA(AA,2)-EMA(BB,5),0)*300;

VAR15:=EMA(VAR14,5);

SS:=EMA(VAR15,2);

风险:=100,COLOR666666;

风险系数:(VAR15-SS)/10*VAR13,POINTDOT,COLORFFFFFF;

波浪系数:VAR15*VAR13,STICK,COLORFF00FF;

STICKLINE(VAR15>REF(VAR15,1) AND VAR13,VAR15,0,1,0),COLORFF00FF;

STICKLINE(VAR15>REF(VAR15,1) AND VAR13,VAR15,SS,3.5,0),COLORFFFFFF;

STICKLINE(VAR15<REF(VAR15,1) AND VAR13,0,VAR15,1,0),COLOR00FF00;

STICKLINE(VAR15<REF(VAR15,1) AND VAR13,VAR15,SS,3.5,0),COLORFFFFFF;

升跌:=EMA((C/MA((2*C+H+L)/4,8)-1)*100,3);

多情箭:(CROSS(CC,DD) AND VAR13)*30,COLORRED,LINETHICK3;

DRAWICON(CROSS(CC,DD) AND VAR13,0,23);

EE:=REF(C,1);

VAR16:=SMA(MAX(C-EE,0),6,1)/SMA(ABS(C-EE),6,1)*100;

STICKLINE(CROSS(84,VAR16) AND VAR13,105,100,6,0),COLOR00FF00;

DRAWICON(CROSS(84,VAR16) AND VAR13,95,2);

FF:=SMA(MAX(C-EE,0),5,1)/SMA(ABS(C-EE),5,1)*100;

STICKLINE(CROSS(80,FF) AND VAR13,105,100,6,0),COLOR00FF00;

DRAWICON(CROSS(80,FF) AND VAR13,95,2);

GG:=100*(1-WINNER(C))>99.8 AND V/CAPITAL*100<5 AND 100*(WINNER(1.1*C)-WINNER(0.9*C))<3.9;

火焰令:C>REF(C,1) AND REF(GG,1)>0 AND VAR13,COLOR00FFFF;

STICKLINE(C>REF(C,1) AND REF(GG,1)>0 AND VAR13,0,-5,6,0),COLORRED;

VAR200:=(CLOSE-LLV(LOW,20))/(HHV(HIGH,20)-LLV(LOW,20))*100;

VAR300:=SMA(SMA(VAR200,3,1),3,1)/28.57;

VAR400:=EMA(VAR300,5);

操盘:=3*VAR300-2*VAR400;

A1:=CROSS(操盘,VAR300) AND VAR300<2.1 AND C>O;

STICKLINE(A1,30,0,4,0),COLOR770077;

STICKLINE(A1,30,0,3,0),COLOR990099;

STICKLINE(A1,30,0,2,0),COLORBB00BB;

STICKLINE(A1,30,0,1,0),COLORDD00DD;

STICKLINE(A1,30,0,0.3,0),COLORFF00FF;

DRAWTEXT(A1,36,'全仓'),COLORRED;


0% (0)
0% (10)

关于通达信火焰令副图指标公式的评论:

 以下是对 [通达信火焰令副图指标公式] 的评论,总共:0条评论
加入收藏 | 联系我们 | 免责声明 | 站内地图 | 关于我们