买好股公式网 > 股票公式 > 通达信公式 > 通达信天风地火强弱跌涨主图指标公式

通达信天风地火强弱跌涨主图指标公式

2013年12月15日 【字体: 人气:





主图指标:
{天风地火 N:1 100 3 M:1 100 30}
VAR0:=(3*CLOSE+LOW+OPEN+HIGH)/6;
多头线: (20*VAR0+19*REF(VAR0,1)+18*REF(VAR0,2)+17*REF(VAR0,3)+16*REF(VAR0,4)+15*REF(VAR0,5)+14*REF(VAR0,6)+13*REF(VAR0,7)+12*REF(VAR0,8)+11*REF(VAR0,9)+10*REF(VAR0,10)+9*REF(VAR0,11)+8*REF(VAR0,12)+7*REF(VAR0,13)+6*REF(VAR0,14)+5*REF(VAR0,15)+4*REF(VAR0,16)+3*REF(VAR0,17)+2*REF(VAR0,18)+REF(VAR0,20))/210, CIRCLEDOT,COLORF00FF0,LINETHICK2;
空头线: MA(多头线,5), CIRCLEDOT,COLORGREEN,LINETHICK2;
STICKLINE(多头线>空头线,多头线,空头线,2,14),,COLORF00FF0;
STICKLINE(多头线<空头线,多头线,空头线,2,14), ,COLORGREEN;
STICKLINE(C>O,O,C,7,0),COLORRED;
STICKLINE(C>O,O,C,1,0),COLORB0B0FF;
STICKLINE(C>O,O,C,4,0),COLORYELLOW;
STICKLINE(C>O,L,H,0.1,0),COLORRED;
STICKLINE(C< O,O,C,5,0),COLOR00FF00;
STICKLINE(C< O,O,C,1,0),COLORFF6600;
STICKLINE(C< O,O,C,2,0),COLOR399C7F;
STICKLINE(C< O,L,H,0.1,0),COLORFFCC66;
STICKLINE(C=O AND C>=REF(C,1),O,C,7,0),COLORRED;
STICKLINE(C=O AND C>=REF(C,1),O,C,4,0),COLORB0B0FF;
STICKLINE(C=O AND C>=REF(C,1),O,C,2,0),COLORYELLOW;
STICKLINE(C=O AND C>=REF(C,1),L,H,0.1,0),COLORYELLOW;
STICKLINE(C=O AND C< REF(C,1),O,C,7,0),COLORFF2020;
STICKLINE(C=O AND C< REF(C,1),O,C,4,0),COLORFF6600;
STICKLINE(C=O AND C< REF(C,1),O,C,2,0),COLORFFCC66;
STICKLINE(C=O AND C< REF(C,1),L,H,0.1,0),COLORFFCC66;
VAR1:=EMA((WINNER(CLOSE*1.1)-WINNER(CLOSE*0.9))*80,5);
A1:=CLOSE/MA(CLOSE,40);
A2:=(CLOSE-OPEN)/OPEN*100>4;
A3:=LOW*1.051<HIGH;
A4:=A3 AND COUNT(A3,5)>1;
B1:=INDEXC;
B2:=MA(B1,5);
B3:=MA(B1,20);
B4:=B1*1.03<B2 AND B1*1.13<B3;
买入1:=(VAR1<6 AND A1<0.85 AND A2)*90;
买入2:=(VAR1<6 AND A1<0.76 AND A4)*70;
买入3:=(VAR1<6 AND B4)*60;
DRAWICON(VAR1<6 AND A1<0.85 AND A2,L*0.9,1);
DRAWTEXT(VAR1<6 AND A1<0.85 AND A2,L*0.85,'--->买入1'),COLORRED;
DRAWICON(VAR1<6 AND A1<0.76 AND A4,L*0.9,1);
DRAWTEXT(VAR1<6 AND A1<0.76 AND A4,L*0.85,'--->买入2'),COLORRED;

DRAWTEXT(VAR1<6 AND B4,L*0.85,'--->买入3'),COLORRED;
VAR2:=MAX(ABS(HIGH-AMOUNT/VOL/100),ABS(AMOUNT/VOL/100-LOW));
VAR3:=ABS((OPEN+CLOSE)/2-AMOUNT/VOL/100);
MV:=(VAR2+VAR3)/AMOUNT*VOL*100*50;

VAR4:=EMA((EMA(CLOSE,95)-EMA(CLOSE,120)),35);
VAR5:=((EMA(CLOSE,95)-EMA(CLOSE,120))-VAR4)*2;

DRAWTEXT(CROSS(多头线,空头线),多头线*0.985,'风火轮'),COLORWHITE;
DRAWTEXT(CROSS(多头线,空头线),多头线*0.985,''),COLORRED;
DRAWTEXT(CROSS(多头线,空头线),多头线*0.985,''),COLORRED ;
DRAWTEXT(CROSS(多头线,空头线),多头线*0.975,''),COLORYELLOW;


 


强弱跌涨副图指标:
{N: 5 250 14}
K:=N/2;
DTPL:=MA(C,N)>MA(C,N*1.5) AND MA(C,N*1.5)>MA(C,N*3) AND MA(C,3)>MA(C,N*6);
选择均线:N,POINTDOT,COLORYELLOW;
强弱天数:K,POINTDOT,COLORFF00FF;
连续走强:=COUNT(C>MA(C,N),K)=K;
ZQSJ:=BARSLAST(连续走强);
STICKLINE(连续走强 ,0 ,K*0.3 ,5 ,1 ),COLORYELLOW;
下穿:=CROSS(MA(C,N),C);
GL:=MA(C,N/2)/MA(C,N*2)>=1.05;
买跌:(下穿 AND ZQSJ<=3 AND DTPL AND GL)*N,COLOR00FF00,LINETHICK2;
连续走弱:=COUNT(C<MA(C,N),K)=K;
ZRSJ:=BARSLAST(连续走弱);
STICKLINE(连续走弱 ,0 ,K*-0.3 ,5 ,1 ),COLOR00FF00;
上穿:=CROSS(C,MA(C,N));
买涨:(上穿 AND ZRSJ<=3)*K,COLORFF00FF,LINETHICK2;
强:连续走强*K*0.3,COLORYELLOW;
弱:连续走弱*K*-0.3,COLOR00FF00;

 

0% (0)
0% (10)

关于通达信天风地火强弱跌涨主图指标公式的评论:

 以下是对 [通达信天风地火强弱跌涨主图指标公式] 的评论,总共:0条评论
加入收藏 | 关于我们 | 服务条款 | 广告服务 | 免责声明 | 站内地图 | 联系我们