买好股公式网 > 股票公式 > 通达信公式 > 波段反弹背离区副图指标

波段反弹背离区副图指标

2021年11月23日人气:Tags:波段 反弹 背离 副图 指标

N:=13;

M:=3;

X:=7;

趋势3:=MA((3*SMA((C-LLV(L,21))/(HHV(H,21)-LLV(L,21))*100,3,1)),2)

-MA((2*SMA(SMA((C-LLV(L,21))/(HHV(H,21)-LLV(L,21))*100,3,1),3,1)),2);

动态底部3:=IF(EMA(IF(L<=LLV(L,13),SMA(ABS(L-REF(L,1)),5,1)

/SMA(MAX(L-REF(L,1),0),5,1),0),3)*10 AND 好趋势3<REF(好趋势3,1)

AND 好趋势3<50,0,40),COLORWHITE;

DRAWBAND(动态底部3,RGB(100,00,100),0,DRAWNULL);

好趋势2:=MA((3*SMA((C-LLV(L,M))/(HHV(H,M)-LLV(L,M))*100,3,1)),2)

-MA((2*SMA(SMA((C-LLV(L,M))/(HHV(H,M)-LLV(L,M))*100,3,1),3,1)),2);

动态底部2:=IF(EMA(IF(L<=LLV(L,13),SMA(ABS(L-REF(L,1)),5,1)

/SMA(MAX(L-REF(L,1),0),5,1),0),3)*10 AND 好趋势2<REF(好趋势2,1)

AND 好趋势2<50,0,20),COLORWHITE;

好趋势:=MA((3*SMA((C-LLV(L,N))/(HHV(H,N)-LLV(L,N))*100,3,1)),2)

-MA((2*SMA(SMA((C-LLV(L,N))/(HHV(H,N)-LLV(L,N))*100,3,1),3,1)),2);

动态底部:=IF(EMA(IF(L<=LLV(L,13),SMA(ABS(L-REF(L,1)),5,1)

/SMA(MAX(L-REF(L,1),0),5,1),0),3)*10 AND 好趋势<REF(好趋势,1)

AND 好趋势<50,0,30),COLORYELLOW;

DRAWBAND(动态底部,RGB(100,100,000),0,DRAWNULL);

TT:=240/FROMOPEN;

比:=TT;

WJ:=(H+L+C)/3;

V1:=IF(H=L,1,H-MAX(O,C));

V2:=IF(H=L,1,MAX(C,O)-WJ);

V3:=IF(H=L,1,MIN(O,C)-L);

V4:=IF(H=L,1,WJ-MIN(C,O));

V5:=VOL/IF(H=L,4,H-L);

V6:=(V1*V5);

V7:=(V2*V5);

V8:=(V3*V5);

V9:=(V4*V5);

买盘1:=DYNAINFO(23)*比;

卖盘1:=DYNAINFO(22)*比;

买盘2:=IF(ISLASTBAR AND C>300,(V9+V8)*TT,(V9+V8));

卖盘2:=IF(ISLASTBAR AND C>300,(V6+V7)*TT,(V6+V7));

买盘:=IF(ISLASTBAR AND PERIOD=5 AND C<300,买盘1,买盘2);

卖盘:=IF(ISLASTBAR AND PERIOD=5 AND C<300,卖盘1,卖盘2);

买卖差1:=买盘-卖盘;

换手买:=IF(PERIOD=5 AND C<300,买盘/CAPITAL*100,买盘/3);

换手卖:=IF(PERIOD=5 AND C<300,卖盘/CAPITAL*100,卖盘/3);

买卖差:=换手买-换手卖;

买卖:=换手买+换手卖;

W:=IF(C<300,X,0);

STICKLINE(C>=O,0,(换手买+换手卖)*W,2.2,1),COLORRED;

STICKLINE( C<O,0,(换手买+换手卖)*W,2.2,1),COLORFFFF00;

STICKLINE( 买卖差>=0,0,换手买*W,1.5,0),COLORRED;

STICKLINE(买卖差>=0 AND C>=MA(C,30),0,换手买*W,2.2,0),COLORRED;

STICKLINE(买卖差>=0,0,换手卖*W,0.8,0),COLOR998800;

STICKLINE( 买卖差>=0 AND C>=MA(C,30),0,换手卖*W,1,0),COLORDDCC00;

STICKLINE( 买卖差<0,0,换手买*W,1.8,0),COLORRED;

STICKLINE( 买卖差<0 AND C>=MA(C,30),0,换手买*W,2.2,0),COLORRED;

STICKLINE( 买卖差<0,0,换手卖*W,0.8,0),COLOR998800;

STICKLINE(买卖差<0 AND C>=MA(C,30),0,换手卖*W,1,0),COLORDDCC00;

STICKLINE(1,0,MAX(换手买*W,换手卖*W),0,0),COLORFFFFFF;

IF(EMA(IF(L<=LLV(L,13),SMA(ABS(L-REF(L,1)),5,1)

/SMA(MAX(L-REF(L,1),0),5,1),0),3)*10 AND 好趋势2<REF(好趋势2,1)

AND 好趋势2<50,0,20),COLORWHITE;

IF(EMA(IF(L<=LLV(L,13),SMA(ABS(L-REF(L,1)),5,1)

/SMA(MAX(L-REF(L,1),0),5,1),0),3)*10 AND 好趋势3<REF(好趋势3,1)

AND 好趋势3<50,0,40),COLORFF00FF;

走势强弱分界线:STICKLINE(WINNER(C)*50>3 AND EMA((C+3*L)/4,21)

>REF(EMA((C+3*L)/4,21),1),95,100,3,1),COLORYELLOW;

波段反弹背离区:STICKLINE(WINNER(C)*30>3 AND EMA(((C+3*L)/4+3*L)/4,3)>

REF(EMA(((C+3*L)/4+3*L)/4,3),1),95,100,3,1),COLORMAGENTA;

VARA2:=LLV(MA(LOW,3),3);

VARA3:=HHV(MA(HIGH,3),3);

KK:EMA((CLOSE-VARA2)/(VARA3-VARA2)*100,4)*0.7+20,COLORFF00FF,LINETHICK1;

DD:EMA(0.667*REF(KK,1)+0.333*KK,2)*0.7+20,COLORFFFF00;

KK2:=EMA(ABS(VARA2-CLOSE)/ABS(VARA2-VARA3)*100,4)*0.7+20,COLORFF00FF,LINETHICK2;

DD2:=EMA(0.667*REF(KK2,1)+0.333*KK2,2)*0.7+20,COLORFFFF00;

超前提示:IF((KK2-KK)*2.5>35,-5,0),COLORFFFF00,LINETHICK2;

{波段反弹背离区副图指标}

打赏好指标 ×

关于波段反弹背离区副图指标的评论:

 以下是对 [波段反弹背离区副图指标] 的评论,总共:0条评论
加入收藏 | 联系我们 | 免责声明 | 站内地图 | 关于我们