买好股公式网 > 股票公式 > 通达信公式 > 通达信主图角度公式源码

通达信主图角度公式源码

2019年01月12日 字体: 人气:

通达信主图角度公式源码


N1:=5;Q:=12;M1:=21;

SHORT:=12;LONG:=26;M:=9;

MID:=12;

AA05:MA(C,5),COLOR0099CC;五日乖离率:=(C-AA05)/AA05*100;

BB05:=ATAN((AA05/REF(AA05,1)-1)*100)*180/3.1416;

速度5:=SMA(EMA((AA05-REF(AA05,1))/REF(AA05,1),3)*100,3,1);

加速度5:=EMA((速度5-REF(速度5,1)),3),LINETHICK0;

STICKLINE(BB05>30 AND AA05>REF(AA05,1),AA05,REF(AA05,1),3,1),COLORCYAN;

AA10:MA(C,10);

AA20:=MA(C,20);

BB10:=ATAN((AA10/REF(AA10,1)-1)*100)*180/3.1416;

STICKLINE(BB05<0 AND AA05<REF(AA05,1),AA05,REF(AA05,1),3,1),COLORYELLOW;

AA30:MA(C,30);三拾日乖离率:=(C-AA30)/AA30*100;

VAR1:=(AA20-AA30)>REF((AA20-AA30),1)

AND AA20>REF(AA20,1) AND AA30>REF(AA30,1);

VAR2:=(AA30-AA20)<REF((AA30-AA20),1) AND AA20<REF(AA20,1) AND AA30<REF(AA30,1);

BB30:=ATAN((AA30/REF(AA30,1)-1)*100)*180/3.1416;

STICKLINE(BB30>15 AND

AA30>REF(AA30,1),

AA30,REF(AA30,1),3,1),COLORFF00FF;

强势狙击:=FILTER(BB30>30 AND BB10>45 AND

CROSS(BB05,60),10);

加仓:=FILTER(COUNT(CROSS(BB05,30),5)>=1 AND

AA05>REF(AA05,1) AND 三拾日乖离率>REF(三拾日乖离率,1) AND AA10>REF(AA10,1)

AND 加速度5>REF(加速度5,1) AND 速度5>REF(速度5,1) ,10);

清仓:=FILTER(COUNT(CROSS(30,BB05),5)>=1 AND (C>AA30 OR O>AA30) AND AA05<REF(AA05,1) AND 三拾日乖离率<REF(三拾日乖离率,1) AND

AA10<REF(AA10,1),10);

DRAWTEXT(加仓,LOW*0.98,'←加仓'),COLORRED;

JC:=CROSS(0,五日乖离率) AND 三拾日乖离率<REF(三拾日乖离率,1) AND AA10>REF(AA10,1) ;

减仓:=FILTER(JC,10);

MR:=COUNT(CROSS(五日乖离率,0),3)>=1

AND 三拾日乖离率>REF(三拾日乖离率,1) AND AA05>REF(AA05,1) AND (C/REF(C,1)-1)*100>5 AND REF(C,1)<AA30;

买入:=FILTER(MR,10);DRAWTEXT(减仓,HIGH*1.02,'←减仓'),COLORCYAN;

DRAWTEXT(买入,LOW*0.98,'←买入'),COLORYELLOW;

DRAWTEXT(清仓,HIGH*1.02,'←清仓'),COLORGREEN;

DRAWTEXT(强势狙击,LOW*0.98,'←强势狙击'),COLORYELLOW;

VAR21:=MAX(ABS(HIGH-AMOUNT/VOL/100),ABS(AMOUNT/VOL/100-LOW));

VAR3:=ABS((OPEN+CLOSE)/2-AMOUNT/VOL/100);MV:=(VAR21+VAR3)/AMOUNT*VOL*100*50;


0% (0)
0% (10)

关于通达信主图角度公式源码的评论:

 以下是对 [通达信主图角度公式源码] 的评论,总共:0条评论
加入收藏 | 联系我们 | 免责声明 | 站内地图 | 关于我们