买好股公式网 > 股票公式 > 通达信公式 > 通达信行情周期统计副图指标

通达信行情周期统计副图指标

2021年11月21日人气:Tags:通达信 副图 指标

N:=5;

M:=13;

AA:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));

买量:=IF(CLOSE>OPEN,AA*(HIGH-LOW),IF(CLOSE<OPEN,AA*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2)),LINETHICK0,COLORRED;

卖量:=IF(CLOSE>OPEN,0-AA*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,0-AA*(HIGH-LOW),0-VOL/2)),LINETHICK0,COLORFFFF00;

进出量:=买量+卖量;

STICKLINE(进出量<0,0,进出量,4,0),COLORFF6600;

STICKLINE(进出量<0,0,进出量,3,0),COLORFF9900;

STICKLINE(进出量<0,0,进出量,1.5,0),COLORFFCC00;

STICKLINE(进出量<0,0,进出量,0.5,0),COLORFFFF00;

STICKLINE(进出量>0,0,进出量,4,0),COLOR000099;

STICKLINE(进出量>0,0,进出量,3,0),COLOR0000CC;

STICKLINE(进出量>0,0,进出量,1.5,0),COLOR0000FF;

STICKLINE(进出量>0,0,进出量,0.5,0),COLORCC66FF;

N日内净流入:SUM(进出量,N),LINETHICK2,COLOR33FF33;

TJ:=进出量>0 AND REF(进出量,1)<0;

连红天:IF(进出量>0,BARSLAST(TJ)+1,0),COLORFF00FF;

M日内翻红天:COUNT(进出量>0,M),COLORRED;

TJ1:=CROSS(0,N日内净流入);

FT:=BARSLAST(TJ1);

走熊天:IF(N日内净流入<0,FT+1,0),COLORFFFF00;

TJ2:=CROSS(N日内净流入,0);

FT2:=BARSLAST(TJ2);

走牛天:IF(N日内净流入>0,FT2+1,0),COLORRED; 

{通达信行情周期统计副图指标}

打赏好指标 ×

关于通达信行情周期统计副图指标的评论:

 以下是对 [通达信行情周期统计副图指标] 的评论,总共:0条评论
加入收藏 | 联系我们 | 免责声明 | 站内地图 | 关于我们