买好股公式网 > 股票公式 > 通达信公式 > 通达信趋势图指标源码

通达信趋势图指标源码

2011年12月06日 字体: 人气:

这个公式的主要内容就是KDJ日月周金叉。信号发出当天必定有未来,第二天要是大跌,就叉不上去了呗。所以不合适信号发生当天买入。但是因为有这个未来就拒绝用KDJ周线金叉公式的人,是错误的。你完全可以用普通的KDJ来对比看啊。因此,我认为使用KDJ周线金叉选股公式的人,要多使用“COUNT(XG,N)>=1;”,N天里曾经出现股。看前两天发生的事情。

周J:=MA("KDJ.J#WEEK"(9,3,3) ,5),COLORFFFF00,LINETHICK2;
STICKLINE(周J>=REF(周J,1) ,0,100,4,0),COLORCC8800;
AA:IF(周J<=0 ,-5,0),COLOR00CCCC,LINETHICK3;
DRAWBAND(0,RGB(250,0,0),AA,RGB(0,0,0));
BB:IF(周J>=85 ,105,100),COLOR00CC00,LINETHICK3;
DRAWBAND(BB,RGB(0,250,0),100,RGB(0,0,0));
长线:MA("KDJ.J#WEEK"(9,3,3) ,5),COLORFFFF00,LINETHICK2;
IF(周J>=REF(周J,1),周J,DRAWNULL),COLORFF00FF,LINETHICK2;
VAR1:=(CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100;
VAR2:=EMA(VAR1,3);
VAR3:VAR2,COLOR00FF00,LINETHICK2;
IF(VAR2>=REF(VAR2,1),VAR2,DRAWNULL),COLORRED,LINETHICK3;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1),COLORWHITE,LINETHICK3;
D:=SMA(K,3,1),COLORYELLOW,LINETHICK3;
J:=K-2*D,COLORFF00FF,LINETHICK2;
{DRAWBAND(K,RGB(200,0,200),D,RGB(190,190,0));}
STICKLINE(K>=D, K,D,1,0),COLORBB00DD;
STICKLINE(K<D,K,D,1,1),COLOR00DD00;
周K:="KDJ.K#WEEK"(9,3,3),COLORLIMAGENTA,LINETHICK2;
周D:="KDJ.D#WEEK"(9,3,3),COLORDDDD00,LINETHICK2;
月K:="KDJ.K#MONTH"(9,3,3),COLORGRAY;
月D:="KDJ.D#MONTH"(9,3,3),COLORLIGRAY;
100,COLORGREEN;
0,COLORYELLOW;
日金叉:IF(CROSS(K,D),5,0),COLORMAGENTA,LINETHICK2;
DRAWBAND(日金叉,RGB(250,0,250),0,RGB(0,0,0));
日死叉: IF(CROSS(D,K),95,100), COLOR00FF00,LINETHICK2;
DRAWBAND(100,RGB(0,250,0),日死叉,RGB(0,0,0));
周金叉:IF(CROSS(周K,周D),10,0),COLORRED,LINETHICK2;
DRAWBAND(周金叉,RGB(250,0,0),0,RGB(0,0,0));
周死叉:IF(CROSS(周D,周K),90,100), COLORFFFF00,LINETHICK2;
DRAWBAND(100,RGB(0,250,250),周死叉,RGB(0,0,0));
月金叉:IF(CROSS(月K,月D),15,0),COLORYELLOW,LINETHICK2;
DRAWBAND(月金叉,RGB(250,250,0),0,RGB(0,0,0));
月死叉:IF(CROSS(月D,月K),85,100),COLORFF0000,LINETHICK2;
DRAWBAND(100,RGB(0,0,250),月死叉,RGB(0,0,0));

 {选股:周线金叉。使用条件,尽量盘后选股,金叉则纳入观察,特别是前期强股}
周K:="KDJ.K#WEEK"(9,3,3);
周D:="KDJ.D#WEEK"(9,3,3);
周金叉:CROSS(周K,周D);

{选股:个股处在蓝色区域。这个不要轻易单独选,太多了,但可以作为其实选股公式的并列条件。目标是选出安全股}

周J:=MA("KDJ.J#WEEK"(9,3,3) ,5);
XC:周J>=REF(周J,1);

{选股:绿变红。。可以在目标股池里进行选择,也可以试着在超跌股里选择}
VAR1:=(CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100;
VAR2:=EMA(VAR1,3);
XG:VAR2>=REF(VAR2,1);

通达信趋势图指标源码

0% (0)
0% (10)

关于通达信趋势图指标源码的评论:

 以下是对 [通达信趋势图指标源码] 的评论,总共:条评论
加入收藏 | 联系我们 | 免责声明 | 站内地图 | 关于我们