买好股公式网 > 股票公式 > 通达信公式 > 通达信资金流向找到了主力方向指标公式无未来

通达信资金流向找到了主力方向指标公式无未来

2013年06月14日 【字体: 人气:

很多人热衷于技术均线的研判,这个我觉得很多,但是可以加上一个资金流向的研判,更能把握主力资金的流向,股市是一个资金推动型的股市,是一个主力操控的股市,是一个大户吃小户的股市,是机构横行游资狂扫的股市,因此能准确把握主力资金的动向很重要,今天发一个关于资金流向的指标来给大家分享,不喜欢的可以绕道,我发这个指标的宗旨是和有心人热宗于研判资金主力动向的朋友学友交流和运用!希望有识之士一起进步!
下面的贴图说明资金一直流入短中长期资金扎堆股价就涨 。

通达信资金流向找到了主力方向指标公式无未来

{量能饱和度}
N1:=10,100,34;N2:=N1*1.05;N3:=N1+3;SAT:=(AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20));量能饱和度:IF(SAT>1,1,SAT)*100,COLORLIBLUE,NODRAW;中点:=REFDATE(HHV(V,100)/2,DATE);{量能饱和的变色切换}STICKLINE(CURRBARSCOUNT=N1,中点*1.9,中点*1.5,100,1),COLOR00DDDD;STICKLINE(CURRBARSCOUNT=N1,中点*1.88,中点*1.52,量能饱和度,0),COLOR0033FF;STICKLINE(CURRBARSCOUNT=N1,中点*1.82,中点*1.58,量能饱和度,0),COLOR0077FF;STICKLINE(CURRBARSCOUNT=N1,中点*1.76,中点*1.64,量能饱和度,0),COLOR0099FF;STICKLINE(CURRBARSCOUNT=N1,中点*1.7,中点*1.7,量能饱和度,0),COLOR00DDFF;DRAWTEXT(CURRBARSCOUNT=N3,中点*1.70,'量能饱和度'),COLOR000000;VAR1:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));买盘:IF(CLOSE>OPEN,VAR1*(HIGH-LOW),IF(CLOSE<OPEN,VAR1*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2)),COLORRED,POINTDOT;卖盘:-IF(CLOSE>OPEN,0-VAR1*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,0-VAR1*(HIGH-LOW),0-VOL/2)),COLORCYAN,POINTDOT;成交量比%:买盘/VOL*100,COLORWHITE,NODRAW; 五日: MA(V,5)COLORWHITE; 十日: MA(V,10)COLORYELLOW;万手:VOL/10000,LINETHICK0; AA:=IF(CURRBARSCOUNT=1 AND PERIOD=5,VOL*240/FROMOPEN,DRAWNULL); 预测:AA/10000; BB:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN)); 主动买:=IF(CLOSE>OPEN,BB*(HIGH-LOW),IF(CLOSE<OPEN,BB*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2)); 主买:主动买/10000,COLORRED; 主动卖:=IF(CLOSE>OPEN,0-BB*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,0-BB*(HIGH-LOW),0-VOL/2)); 主卖:-主动卖/10000,COLORGREEN; 差额:(主动买+主动卖)/10000; STICKLINE(CLOSE=REF(CLOSE,1),0,VOL,3.5,0),COLORWHITE; STICKLINE(CLOSE>REF(CLOSE,1),0,VOL,3.5,0),COLORRED; STICKLINE(CLOSE<REF(CLOSE,1),0,VOL,3.5,0),COLORGREEN; STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,AA,1 , 3.5 , 0 ) , COLOR00FFFF ;STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,AA,1 , 3.2 , 0 ) , COLOR007777 ; STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,AA,1 , 2.7 , 0 ) , COLOR009999 ; STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,AA,1 , 2.1 , 0 ) , COLOR00BBBB ; STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,AA,1 , 1.5 , 0 ) , COLOR00DDEE ; STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,AA,1 , 0.9 , 0 ) , COLOR66FFFF ; STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,AA,1 , 0.2 , 0 ) , COLORFFFFFF ; STICKLINE(主动买>=0,VOL,-主动卖,3.2,0),COLOR000033; STICKLINE(主动买>=0,VOL,-主动卖,2.7,0),COLOR000066; STICKLINE(主动买>=0,VOL,-主动卖,2.1,0),COLOR000099; STICKLINE(主动买>=0,VOL,-主动卖,1.5,0),COLOR0000CC; STICKLINE(主动买>=0,VOL,-主动卖,0.9,0),COLOR0000FF; STICKLINE(主动买>=0,VOL,-主动卖,0.2,0),COLORCC66FF; STICKLINE(主动卖<=0,0,-主动卖,3.2,0),COLOR990000; STICKLINE(主动卖<=0,0,-主动卖,2.7,0),COLORCC0000; STICKLINE(主动卖<=0,0,-主动卖,2.1,0),COLORFF4400; STICKLINE(主动卖<=0,0,-主动卖,1.5,0),COLORFF8800; STICKLINE(主动卖<=0,0,-主动卖,0.9,0),COLORFFCC00; STICKLINE(主动卖<=0,0,-主动卖,0.2,0),COLORCYAN; 持币:IF(SAR(10,2,20)>=H,SAR(10,2,20),DRAWNULL),CIRCLEDOT,COLOR00FF00,LINETHICK1;DRAWICON(持币>0,持币,35 );   持股:IF(SAR(10,2,20)<=L,SAR(10,2,20),DRAWNULL),CIRCLEDOT,COLORRED,LINETHICK1;DRAWICON(持股>0,持股,34 );个股资金线:=MA(C,1)/MA(REF(C,18),18)*100;资金生命线:=MA(FORCAST(个股资金线,20),6);生命线:个股资金线>资金生命线,COLOR000000,STICK,LINETHICK1;DRAWICON(生命线>0,生命线,34);预测量:=IF(CURRBARSCOUNT=1 AND PERIOD=5,VOL*240/FROMOPEN,VOL),NODRAW;STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,预测量,0,-1,-1),COLOR00C0C0;五换:SUM(100*V/CAPITAL,5),COLORRED,NODRAW;十换:SUM(100*V/CAPITAL,10),COLORRED,NODRAW;超B:=L2_AMO(0,2)/10000.0;大B:=L2_AMO(1,2)/10000.0;中B:=L2_AMO(2,2)/10000.0;小B:=L2_AMO(3,2)/10000.0;超S:=-L2_AMO(0,3)/10000.0;大S:=-L2_AMO(1,3)/10000.0;中S:=-L2_AMO(2,3)/10000.0;小S:=-L2_AMO(3,3)/10000.0;TESTSKIP(NOT(超B OR 大B OR 中B OR 小B OR 超S OR 大S OR 中S OR 小S)!=0);净流入:=(超B+大B+中B+小B)+(超S+大S+中S+小S);大宗净流入:=(超B+大B)+(超S+大S);超大单:=(超B)+(超S);大单:=(大B)+(大S);中单:=(中B)+(中S);小单:=(小B)+(小S);大宗进:=(超B)+(大B);大宗出:=(超S)+(大S);非大宗进:=(中B)+(小B);非大宗出:=(中S)+(小S);资金流向:=(超B+大B+中B+小B)+(超S+大S+中S+小S);近5日流向:=SUM(资金流向,5);近10日流向:=SUM(资金流向,10);{股海网提供:WWW.GUHAI.COM.CN}主力资金线:=(L2_AMO(0,0)+L2_AMO(1,0)-L2_AMO(0,1)-L2_AMO(1,1))/100.0,LINETHICK2;主力买力度:=LARGEINTRDVOL*100/VOL;主力卖力度:=LARGEOUTTRDVOL*100/VOL;DRAWRECTREL(0,0,235,999,RGB(100,330,30));DRAWRECTREL(0,0,235,515,RGB(0,30,50));DRAWRECTREL(75,515,235,999,RGB(0,30,50));DRAWRECTREL(144,0,235,515,RGB(100,330,30));AA1:=CONST(MAX(ABS(净流入),MAX(ABS(大宗净流入),MAX(ABS(大宗进),MAX(ABS(大宗出),MAX(ABS(非大宗进),ABS(非大宗出)))))))*3,NODRAW;DRAWRECTREL(5,CONST(830-(ABS(净流入)*500/AA1)),35,945,IF(CONST(净流入)>0,RGB(250,150,10),RGB(0,100,100)));DRAWRECTREL(40,CONST(830-(ABS(大宗净流入)*500/AA1)),70,945,IF(CONST(大宗净流入)>0,RGB(250,150,10),RGB(0,100,100)));DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.005,0.88,0,INTPART(净流入)),COLORWHITE;DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.041,0.88,0,INTPART(大宗净流入)),COLORWHITE;DRAWTEXT_FIX(CURRBARSCOUNT=1,0.008,1,0,'净流   大宗流'),COLORWHITE;DRAWRECTREL(80,CONST(830-(ABS(大宗进)*500/AA1)),115,945,IF(CONST(大宗进)>0,RGB(255,0,0),RGB(23,125,255)));DRAWRECTREL(117,CONST(830-(ABS(大宗出)*500/AA1)),152,945,IF(CONST(大宗出)<0,RGB(0,50,0),RGB(0,50,0)));DRAWRECTREL(158,CONST(830-(ABS(非大宗进)*500/AA1)),193,945,IF(CONST(非大宗进)>0,RGB(255,0,0),RGB(23,125,255)));DRAWRECTREL(195,CONST(830-(ABS(非大宗出)*500/AA1)),230,945,IF(CONST(非大宗出)<0,RGB(0,50,0),RGB(0,50,0)));DRAWTEXT_FIX(CURRBARSCOUNT=1,0.09,1,0,'主力   进出         散户   进出'),COLORWHITE;DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.082,0.88,0,INTPART(大宗进)),COLORWHITE;DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.12,0.88,0,INTPART(大宗出)),COLORWHITE;DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.161,0.88,0,INTPART(非大宗进)),COLORWHITE;DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.196,0.88,0,INTPART(非大宗出)),COLORWHITE;AAB:=CONST(MAX(ABS(超大单),MAX(ABS(大单),MAX(ABS(中单),ABS(小单))))),NODRAW;DRAWRECTREL(5,CONST(830-(ABS(超大单)*500/AAB))/2,35,460,IF(CONST(超大单)>0,RGB(255,0,255),RGB(0,255,255)));DRAWRECTREL(40,CONST(830-(ABS(大单)*500/AAB))/2,70,460,IF(CONST(大单)>0,RGB(255,0,255),RGB(0,255,255)));DRAWRECTREL(75,CONST(830-(ABS(中单)*500/AAB))/2,105,460,IF(CONST(中单)>0,RGB(255,0,255),RGB(0,255,255)));DRAWRECTREL(110,CONST(830-(ABS(小单)*500/AAB))/2,140,460,IF(CONST(小单)>0,RGB(255,0,255),RGB(0,255,255)));DRAWTEXT_FIX(CURRBARSCOUNT=1,0.007,0.46,0,'超 户    大 户   中 户    散 户'),COLORWHITE;DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.007,0.4,0,INTPART(超大单)),COLORWHITE;DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.042,0.4,0,INTPART(大单)),COLORWHITE;DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.076,0.4,0,INTPART(中单)),COLORWHITE;DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.112,0.4,0,INTPART(小单)),COLORWHITE;DRAWTEXT_FIX(CURRBARSCOUNT=1,0,0,0,'【综合资金分析】     (¥万元)'),COLORRED;AAC:=CONST(MAX(ABS(近5日流向),ABS(近10日流向))),NODRAW;DRAWRECTREL(149,CONST(830-(ABS(近5日流向)*500/AAC))/2,189,460,IF(CONST(近5日流向)>0,RGB(250,150,10),RGB(0,100,100)));DRAWRECTREL(191,CONST(830-(ABS(近10日流向)*500/AAC))/2,230,460,IF(CONST(近10日流向)>0,RGB(250,150,10),RGB(0,100,100)));DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.15,0.4,0,INTPART(近5日流向)),COLORWHITE;DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.19,0.4,0,INTPART(近10日流向)),COLORWHITE;DRAWTEXT_FIX(CURRBARSCOUNT=1,0.152,0.46,0,'五日流   十日流'),COLORWHITE;DDX:=(LARGEINTRDVOL-LARGEOUTTRDVOL)*1000/FINANCE(7);DDY:=IF(TRADENUM>0,(TRADEOUTNUM-TRADEINNUM)*100/TRADENUM,0);DDZ:=IF(TRADENUM>0,(LARGETRDINNUM-LARGETRDOUTNUM)/TRADENUM*100,0);DRAWRECTREL(144,0,235,40,IF(CONST(DDX)>0,RGB(255,0,0),RGB(0,50,0)));DRAWRECTREL(144,45,235,85,IF(CONST(DDY)>0,RGB(255,0,0),RGB(0,50,0)));DRAWRECTREL(144,90,235,130,IF(CONST(DDZ)>0,RGB(255,0,0),RGB(0,50,0)));DRAWTEXT_FIX(1,0.15,0,0,STRCAT('DDX:',CON2STR(DDX,0))),COLORYELLOW;DRAWTEXT_FIX(1,0.15,0.04,0,STRCAT('DDY:',CON2STR(DDY,0))),COLORYELLOW;DRAWTEXT_FIX(1,0.15,0.09,0,STRCAT('DDZ:',CON2STR(DDZ,0))),COLORYELLOW;AAD:=CONST(MAX(ABS(主力买力度),ABS(主力卖力度)))*4,NODRAW;DRAWRECTREL(0,515,CONST(ABS(主力买力度)*500/AAD),568,IF(CONST(主力买力度)>0,RGB(250,150,10),RGB(0,255,255)));DRAWRECTREL(0,570,CONST(ABS(主力卖力度)*500/AAD),623,IF(CONST(主力卖力度)>0,RGB(23,125,255),RGB(0,255,255)));DRAWTEXT_FIX(1,0,0.512,0,STRCAT('主力买力度:',CON2STR(主力买力度,0))),COLORRED;DRAWTEXT_FIX(1,0,0.57,0,STRCAT('主力卖力度:',CON2STR(主力卖力度,0))),COLORRED;

 

0% (0)
0% (10)

关于通达信资金流向找到了主力方向指标公式无未来的评论:

 以下是对 [通达信资金流向找到了主力方向指标公式无未来] 的评论,总共:4条评论
匿名 游客:匿名  刚刚 4
这个公式需要开通LEVEL2
匿名 游客:匿名  2016/9/7 3
注意:发现未来函数FINANCE!
注意:发现未来函数CAPITAL!
注意:发现未来函数DVOL!
匿名 游客:匿名  2016/9/5 2
思路不错,要是能做个像 指南针 的资金指标非常好用
匿名 游客:匿名  2015/10/17 1
老师,你好,能提供下这个公式的使用方法吗
加入收藏 | 关于我们 | 服务条款 | 广告服务 | 免责声明 | 站内地图 | 联系我们