买好股公式网 > 股票公式 > 通达信公式 > 通达信实用通道无未来指标公式

通达信实用通道无未来指标公式

2019年06月02日 字体: 人气:

通达信实用通道无未来指标公式


M:=17;

P:=2;

N:=5;

大盘指数:INDEXC,NODRAW,COLORLIMAGENTA ;

C3:=REF(C,1);

涨停:=IF((C-C3)*100/C3>=(10-0.01*100/C3),1,0);

STICKLINE(涨停,OPEN,CLOSE,2.5,0),COLORYELLOW;

跌停:=IF((C3-C)*100/C3>=(10-0.01*100/C3),1,0);

STICKLINE(跌停,OPEN,CLOSE,2.5,0),COLORBLUE;

EMA5:EMA(C,5),NODRAW;

操盘:=EMA(C,17);

KDJ_K:="KDJ.K"(9,3,3);KDJ_D:="KDJ.D"(9,3,3);KDJ_J:="KDJ.J"(9,3,3);

买1:=CROSS(KDJ_J,0) OR (CROSS(KDJ_J,KDJ_K) AND KDJ_D<26);

买2:=CROSS("RSI.RSI1"(6,2,2),20) OR CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24));

买3:=CROSS("MACD.DIF","MACD.DEA") OR CROSS("MACD.MACD",0);

买0:=买1+买2+买3;

DRAWICON(买0>1,L*0.98,16);

X6:=REF(CLOSE,1);

X7:=((SMA(MAX((CLOSE - X6),0),7,1) / SMA(ABS((CLOSE - X6)),7,1)) * 100);

X8:=CROSS(79,X7);

X9:=FILTER(X8,4);

DRAWTEXT(X9,(HIGH * 1.02),'●出货'),COLOR9000F5;

上升压力: 操盘 + P*STD(CLOSE,M),COLOR0099FF,LINETHICK2;

下跌支撑: 操盘 - P*STD(CLOSE,M),COLORMAGENTA,LINETHICK2;

DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);

DEA:=EMA(DIF,9);

MACD1:=(DIF-DEA)*2,COLORSTICK;

A:=MA(CLOSE,5);

B:=MA(CLOSE,20);

TYP:=(HIGH+LOW+CLOSE)/3;

CCI:=(TYP-MA(TYP,84))/(0.015*AVEDEV(TYP,84));

BB:=BETWEEN(REF(CLOSE,1),A,B);

DRAWTEXT(CLOSE>A AND A>B AND B>REF(B,1) AND CROSS(CCI,100) AND MACD1>0 AND REF(MACD1,1)>0,B,'追'),COLORYELLOW;

CBFB:=MA(C,2);

JL:=IF(C>CBFB,V,0);

CL:=IF(C<CBFB,V,0);

JLH:=SUM(JL,4);

CLH:=SUM(CL,4);

LHB:=CLH/JLH;

TJ1:=IF(HHV(LHB,5)>4 AND CROSS(2,LHB) AND C>=O,1,0);

DRAWICON(TJ1,L*0.96,9);

Z:=MA(C,120);

VAR3:=(MA(C,5)-Z)/Z;

VAR4:=MA((CLOSE-LLV(LOW,20))/(HHV(HIGH,20)-LLV(LOW,20))*100,3);

VAR5:=(MA(AMOUNT,5)/MA(VOL,5)/100-MA(AMOUNT,120)/MA(VOL,120)/100)/(MA(AMOUNT,5)/MA(VOL,5)/100);

D1:DRAWTEXT(CLOSE>Z AND REF(VAR4,1)<30 AND VAR4>REF(VAR4,1) AND REF(VAR4,1)<REF(VAR4,2) ,LOW ,'★B'),COLORRED;

D2:DRAWTEXT(REF(VAR5,1)<5 AND VAR5>REF(VAR5,1) AND REF(VAR5,1)<REF(VAR5,2) AND VAR3<-0.3,LOW ,'★B'),COLORGREEN;

D3:DRAWTEXT(CROSS(VAR4,5) AND VAR3<-0.4,LOW ,'★B'),COLORBLUE;

Y:=MA(C,120);

VAR6:=(MA(C,5)-Y)/Y;

VAR7:=MA((CLOSE-LLV(LOW,10))/(HHV(HIGH,10)-LLV(LOW,10))*100,3);

VAR8:=(MA(AMOUNT,5)/MA(VOL,5)/100-MA(AMOUNT,120)/MA(VOL,120)/100)/(MA(AMOUNT,5)/MA(VOL,5)/100);

D4:DRAWTEXT(CLOSE<Y AND Y<REF(Y,1) AND REF(VAR7,1)>80 AND VAR7<REF(VAR7,1) AND REF(VAR7,1)>REF(VAR7,2),HIGH,'★S'),COLORYELLOW;

D5:DRAWTEXT(CROSS(90,VAR7) AND VAR8>0.2,HIGH,'★S'),COLORGREEN;

D6:DRAWTEXT(CROSS(95,VAR7) AND VAR6>0.5,HIGH ,'★S'),COLORRED;

MAA5:=MA(C,5),COLORFF00FF,LINETHICK2;

MAA10:=MA(C,10);

MAA30:=MA(C,30),COLORRED;

KS:=IF(MAA10>MAA30,MAA10,MAA30),COLORBLUE;

A3:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;

A4:=SMA(A3,3,1);

A5:=SMA(A4,3,1);

A6:=3*A4-2*A5;

A7:=C-REF(C,1);

A8:=100*EMA(EMA(A7,6),6)/EMA(EMA(ABS(A7),6),6);

买:=LLV(A8,2)=LLV(A8,7) AND COUNT(A8<0,2) AND CROSS(A8,MA(A8,2));

DRAWTEXT(FILTER(买=1,5),LOW-0.05,'↖买进'),COLORYELLOW;

STICKLINE(买,OPEN,CLOSE,2,0),COLORYELLOW;

X1:=(C+L+H)/3;

BB13:=ATAN(EMA(X1,13)-REF(EMA(X1,13),1))*3.1416*10;

EMA8:=EMA(C,8);

DRAWTEXT(FILTER(BB13>1 AND EMA(X1,13)>REF(EMA(X1,8),1),10),

EMA8,'∠45升'),COLORWHITE;

A01:=MA(CLOSE, 28);

A02:=MA(CLOSE, 66);

A03:=AMOUNT / VOL / 100.000;

A04:=SUMBARS(VOL,CAPITAL * 1.618);

A05:=IF((A04 > 100.000), 1.033,IF(((A04 <= 100.000) AND (A04 > 33.000)), 1.039, 1.05));

运作成本:MA(A03, 10),NODRAW;

中线成本:EMA(A03, 34) * A05,NODRAW;

总体成本:DMA(中线成本,VOL / CAPITAL),NODRAW;

VAR12:=(2*CLOSE+HIGH+LOW)/4;

VAR13:=IF(YEAR>=2099 AND MONTH>2,0,1);

VAR14:=LLV(LOW,5); VAR15:=HHV(HIGH,4);

散户:=EMA((VAR12-VAR14)/(VAR15-VAR14)*100,4)*VAR13;

庄家:=EMA(0.667*REF(散户,1)+0.333*散户,2)*VAR13;

DRAWTEXT(CROSS(散户,庄家) AND 散户<30,L-0.05,'←低吸'),COLORLIRED;

DRAWTEXT(CROSS(庄家,散户) AND 散户>70,H+0.05,'←高抛'),COLORGREEN;


0% (0)
0% (10)

关于通达信实用通道无未来指标公式的评论:

 以下是对 [通达信实用通道无未来指标公式] 的评论,总共:0条评论
加入收藏 | 联系我们 | 免责声明 | 站内地图 | 关于我们