买好股公式网 > 股票公式 > 通达信公式 > 通达信多空位点主图指标

通达信多空位点主图指标

2022年03月26日人气:Tags:通达信 多空 主图 指标

SJTJ:=1;

VAR1:=IF(1=1 OR 1=3,HIGH,CLOSE);

VAR2:=IF(1=1 OR 1=3,LOW,CLOSE);

VAR3:=3=1 OR 3=2 OR 3=3;

VAR4:=3=2 OR 3=3;

VAR5:=3=3;

VAR6:=C;

VAR7:=IF(VAR6=1,REF(VAR6,1)-1,IF(VAR6=(-1),REF(VAR6,1)+1,VAR6));

VAR8:=IF(VAR7 < 0,VAR7+1,VAR7-1);

VAR9:=TROUGHBARS(3,3,1);

VAR10:=PEAKBARS(3,3,1);

VAR11:=IF(VAR9=0,(-1),IF(VAR10=0,1,0));

VAR12:=IF(VAR9=0,VAR10,IF(VAR10=0,-VAR9,IF(VAR9 > VAR10,VAR10,-VAR9)));

VAR13:=H;

VAR14:=BARSLAST(VAR13 < 0);

VAR15:=BARSLAST(VAR13 > 0);

VAR16:=IF(VAR14=0,(-1),IF(VAR15=0,1,0));

VAR17:=IF(VAR14=0,VAR15,IF(VAR15=0,-VAR14,IF(VAR14 > VAR15,VAR15,-VAR14)));

VAR18:=IF(1=2,VAR11,IF(1=3,VAR16,VAR6));

VAR19:=IF(1=2,VAR12,IF(1=3,VAR17,VAR8));

VAR20:=IF(VAR19 < 0,-VAR19,VAR19);

VAR21:=IF(VAR19 > 0,100*(VAR2/REF(VAR1,VAR20)-1),100*(VAR1/REF(VAR2,VAR20)-1));

VAR22:=INBLOCK(1)=1 AND NOT(NAMEINCLUDE(2));

VAR23:=IF(0=0,VAR20,MIN(VAR20,0));

VAR24:=IF(VAR19 > 0,100*(VAR2/REF(VAR1,VAR23)-1),100*(VAR1/REF(VAR2,VAR23)-1));

VAR25:=IF(VAR22,AMOUNT/100000000,VOL/100);

VAR26:=SUM(VAR25,VAR23);

VAR27:=VAR26/VAR24/1;

VAR28:=BARSLAST(VAR18=1);

VAR29:=BARSLAST(VAR18=(-1));

VAR30:=IF(VAR28=0 OR VAR29=0,DRAWNULL,(REF(VAR1,VAR28)+REF(VAR2,VAR29))/2);

VAR31:=IF(HIGH < REF(LOW,1),REF(LOW,1),HIGH);

VAR32:=IF(LOW > REF(HIGH,1),REF(HIGH,1),LOW);

VAR33:=HHV(VAR31,3);

VAR34:=LLV(VAR32,3);

VAR35:=BARSLAST(VAR34 < REF(VAR34,1));

VAR36:=BARSLAST(VAR33 > REF(VAR33,1));

VAR37:=IF(HHV(VAR31,VAR36+1)=VAR31,1,0);

VAR38:=IF(LLV(VAR32,VAR35+1)=VAR32,1,0);

VAR39:=BARSLAST(VAR37);

VAR40:=REF(LLV(VAR32,3),VAR39);

VAR41:=BARSLAST(VAR38);

VAR42:=REF(HHV(VAR31,3),VAR41);

VAR43:=VALUEWHEN(VAR42 > 0,VAR42);

VAR44:=VALUEWHEN(VAR40 > 0,VAR40);

VAR45:=IF(CLOSE > VAR43,(-1),IF(CLOSE < VAR44,1,0));

VAR46:=VALUEWHEN(VAR45!=0,VAR45);

VAR47:=BARSLAST(CROSS(0,VAR46));

VAR48:=BARSLAST(CROSS(VAR46,0));

VAR49:=IF(VAR46=1,IF(LLV(VAR43,VAR48+1)=VAR43,VAR43,LLV(VAR43,VAR48+1)),VAR43);

VAR50:=IF(VAR46=(-1),IF(HHV(VAR44,VAR47+1)=VAR44,VAR44,HHV(VAR44,VAR47+1)),VAR44);

VAR51:=IF(CLOSE > VAR49,(-1),IF(CLOSE < VAR50,1,0));

VAR52:=VALUEWHEN(VAR51!=0,VAR51);

VAR53:=BARSLAST(CROSS(0,VAR51));

VAR54:=BARSLAST(CROSS(VAR51,0));

VAR55:=IF(VAR52=1,IF(LLV(VAR49,VAR54+1)=VAR49,VAR49,LLV(VAR49,VAR54+1)),IF(HHV(VAR50,VAR53+1)=VAR50,VAR50,HHV(VAR50,VAR53+1)));

周期:VAR20,NODRAW,COLORWHITE;

涨跌幅:VAR21,NODRAW,COLORWHITE;

速度指数:VAR27,NODRAW,COLORWHITE;

DRAWLINE(VAR3 AND VAR18=(-1),VAR2,VAR3 AND VAR18=1,VAR1,0),DOTLINE,COLORYELLOW;

DRAWLINE(VAR3 AND VAR18=1,VAR1,VAR3 AND VAR18=(-1),VAR2,0),DOTLINE,COLORYELLOW;

DRAWNUMBER(VAR4 AND VAR18=1,HIGH,ROUND(VAR27)),COLORWHITE,LINETHICK9;

DRAWNUMBER(VAR4 AND VAR18=(-1),LOW,ROUND(VAR27)),COLORWHITE;

R50%:IF(VAR5,VAR30,DRAWNULL),POINTDOT,COLORWHITE;

多头止损:IF(VAR5 AND VAR52 < 0,VAR55,DRAWNULL),DOTLINE,COLORMAGENTA;

空头止损:IF(VAR5 AND VAR52 > 0,VAR55,DRAWNULL),DOTLINE,COLORCYAN;

{买好股公式网WWW.BUYHAOGU.COM};

{通达信多空位点主图指标}

打赏好指标 ×

关于通达信多空位点主图指标的评论:

 以下是对 [通达信多空位点主图指标] 的评论,总共:1条评论
第一股票公式网 游客:第一股票公式网  刚刚 1
亮剑斩贪魔,钱袋子是买入信号,长黄柱是卖出信号下载地址:https://www.chnmoney.net/tongdaxingongshi/97001.html
加入收藏 | 联系我们 | 免责声明 | 站内地图 | 关于我们