买好股公式网 > 股票公式 > 通达信公式 > 涨停启动位副图指标公式

涨停启动位副图指标公式

2022年11月24日人气:Tags:涨停 副图 指标

VAR2:=EMA(SLOPE(EMA(CLOSE,20),10)*34+CLOSE,30);

VAR3:=EMA(VAR2,3);

VAR4:=EMA(VAR3,3);

VAR5:=EMA(VAR4,3);

VAR6:=EMA(VAR5,3);

VA7:=EMA(VAR6,3);

VAR7:=EMA(VA7,3);

VA8:=EMA(VAR7,3);

VAR8:=EMA(VA8,3);

VAR9:=EMA(VAR8,3);

VARA:=BARSLAST(CROSS(CLOSE,VAR9));

VARB:=BARSLAST(CROSS(VAR9,CLOSE));

启动位:IF(CLOSE>VAR9 AND CLOSE>REF(CLOSE,VARA),REF(CLOSE,VARA),REF(CLOSE,VARA)),colorred,POINTDOT,LINETHICK3;

DRAWTEXT(ISLASTBAR AND 启动位,启动位,'【升浪启动位】'),colorred;

DRAWNUMBER(ISLASTBAR AND 启动位,启动位,启动位),colorred;

STICKLINE(CLOSE>VAR9 AND CLOSE>REF(CLOSE,VARA),REF(CLOSE,VARA),LOW*1,5,0),colorred,LINETHICK2;

强:=IF(CLOSE<VAR9 AND CLOSE<REF(CLOSE,VARB),REF(CLOSE,VARB),REF(CLOSE,VARB)),colorred,POINTDOT,LINETHICK1;

STICKLINE(CLOSE<VAR9 AND CLOSE<REF(CLOSE,VARB),REF(CLOSE,VARB),HIGH*1,5,0),colorgreen,LINETHICK2;

势:=IF(CLOSE>VAR9 AND CLOSE<REF(CLOSE,VARA),REF(CLOSE,VARA),REF(CLOSE,VARA)),coloryellow,POINTDOT;

STICKLINE(CLOSE>VAR9 AND CLOSE<REF(CLOSE,VARA),REF(CLOSE,VARA),LOW*1.02,6,0),colorligray;

回调位:IF(CLOSE<VAR9,REF(CLOSE,VARB),REF(CLOSE,VARB)),colorliblue,POINTDOT,LINETHICK3;

DRAWTEXT(ISLASTBAR AND 回调位,回调位,'回调位'),colorliblue;

DRAWNUMBER(ISLASTBAR AND 回调位,回调位,回调位),colorliblue;

STICKLINE(CLOSE<VAR9,REF(CLOSE,VARB),REF(CLOSE,VARB),16,0),colorliblue,LINETHICK5;

STICKLINE(CLOSE>VAR9,REF(CLOSE,VARA),REF(CLOSE,VARA),16,0),colorred,LINETHICK5;

STICKLINE(C>=O,H,L,0,0),colormagenta,LINETHICK2;

MA1:=MA(C,1);

启动比:(MA1-启动位)/启动位*100,coloryellow,NODRAW;

回调比:(MA1-回调位)/回调位*100,colorgreen,NODRAW;C3:=REF(C,1);

涨停:=IF((C-C3)*100/C3>=(10-0.01*100/C3),1,0),COLOR2DFFFF;

STICKLINE(涨停,OPEN,CLOSE,10,0),COLOR008C8C;

STICKLINE(涨停,OPEN,CLOSE,8,0),COLOR00AAAA;

STICKLINE(涨停,OPEN,CLOSE,6,0),COLOR00CacA;

STICKLINE(涨停,OPEN,CLOSE,5,0),COLOR00E3E3;

STICKLINE(涨停,OPEN,CLOSE,4,0),COLOR02FFFF;

STICKLINE(涨停,OPEN,CLOSE,3,0),COLOR02FFFF;

STICKLINE(涨停,OPEN,CLOSE,2,0),COLOR2DFFFF;

STICKLINE(涨停,OPEN,CLOSE,1,0),COLOR2DFFFF;

跌停:=IF((C3-C)*100/C3>=(10-0.01*100/C3),1,0),COLOR33FF33;

STICKLINE(跌停,OPEN,CLOSE,10,0),COLOR009B00;

STICKLINE(跌停,OPEN,CLOSE,8,0),COLOR00B700;

STICKLINE(跌停,OPEN,CLOSE,6,0),COLOR00D200;

STICKLINE(跌停,OPEN,CLOSE,5,0),COLOR00EA00;

STICKLINE(跌停,OPEN,CLOSE,4,0),COLOR0FFF0F;

STICKLINE(跌停,OPEN,CLOSE,3,0),COLOR0FFF0F;

STICKLINE(跌停,OPEN,CLOSE,2,0),COLOR33FF33;

STICKLINE(跌停,OPEN,CLOSE,1,0),COLOR33FF33;

ZT:=C/REF(C,1)>1.097;

BH:=BARSLAST(ZT);

STICKLINE(C,REF(L,BH),REF(L,BH),15,0),colorligray,LINETHICK1;

涨停启动位:=C,REF(L,BH),REF(L,BH);

DRAWTEXT(ISLASTBAR AND 涨停启动位,涨停启动位,'【启动涨停位】'),colorligray;

DRAWNUMBER(ISLASTBAR AND 涨停启动位,涨停启动位,涨停启动位),colorwhite;

{涨停启动位副图指标公式}

打赏好指标 ×

关于涨停启动位副图指标公式的评论:

 以下是对 [涨停启动位副图指标公式] 的评论,总共:0条评论
加入收藏 | 联系我们 | 免责声明 | 站内地图 | 关于我们