买好股公式网 > 股票公式 > 通达信公式 > 通达信趋势划线综合主图指标

通达信趋势划线综合主图指标

2022年06月10日人气:Tags:通达信 趋势 主图 指标

X:=5;

VAR1:=1;

VAR2:=20;

VAR3:=REF(LOW,1);

VAR4:=REF(HIGH,1);

VAR5:=(LOW > VAR4);

VAR6:=(HIGH < VAR3);

STICKLINE(((PERIOD >= 3) AND VAR5),LOW,VAR4,VAR2,-1),COLORRED;

STICKLINE(((PERIOD >= 3) AND VAR6),HIGH,VAR3,VAR2,-1),COLORGREEN;

MA5:EMA(CLOSE,5),COLORMAGENTA;

VAR10:=EMA(CLOSE,10);

VAR11:=(LLVBARS(LOW,5) = 0);

VAR12:=(HHVBARS(HIGH,5) = 0);

VAR13:=IF(((BARSLAST(VAR12) OR 0) = 1),BARSLAST(VAR12),0);

VAR14:=IF(((BARSLAST(VAR11) OR 0) = 1),BARSLAST(VAR11),0);

VAR15:=IF(((VAR13 = VAR14) AND (MA5 > VAR10)),VAR12,IF((VAR14 > VAR13),VAR12,0));

VAR16:=IF(((VAR13 = VAR14) AND (VAR10 > MA5)),VAR11,IF((VAR13 > VAR14),VAR11,0));

VAR17:=((VAR15 AND (REFX(HIGH,1) < REF(HIGH,VAR13))) AND (REFX(LOW,1) < REF(LOW,VAR13)));

VAR18:=((VAR16 AND (REFX(LOW,1) > REF(LOW,VAR14))) AND (REFX(HIGH,1) > REF(HIGH,VAR14)));

NOTEXT_GP:(IF((VAR17 = 1),HIGH,DRAWNULL) * VAR1),CIRCLEDOT,LINETHICK2,COLORYELLOW;

NOTEXT_DP:(IF((VAR18 = 1),LOW,DRAWNULL) * VAR1),CIRCLEDOT,LINETHICK2,COLORYELLOW;

VAR21:=IF((PERIOD <= 4),X,IF((PERIOD = 5),X,IF((PERIOD = 6),X,IF((PERIOD = 7),X,X))));

VAR22:=(LLVBARS(LOW,VAR21) = 0);

VAR23:=(HHVBARS(HIGH,VAR21) = 0);

VAR24:=IF(((BARSLAST(VAR23) OR 0) = 1),BARSLAST(VAR23),0);

VAR25:=IF(((BARSLAST(VAR22) OR 0) = 1),BARSLAST(VAR22),0);

VAR26:=IF(((VAR24 = VAR25) AND (VAR10 >= MA5)),VAR22,IF((VAR24 > VAR25),VAR22,0));

VAR27:=IF(((VAR24 = VAR25) AND (MA5 >= VAR10)),VAR23,IF((VAR25 > VAR24),VAR23,0));

NOTEXT_L1:(DRAWLINE(VAR26,LOW,VAR27,HIGH,0) * VAR1),LINETHICK2,COLORRED;

NOTEXT_L2:(DRAWLINE(VAR27,HIGH,VAR26,LOW,0) * VAR1),LINETHICK2,COLORGREEN;

VAR30:=IF((BARSTATUS = 1),(VAR26 AND (NOTEXT_L1 < REFX(NOTEXT_L1,1))),VAR26);

VAR31:=IF((BARSTATUS = 1),(VAR27 AND (NOTEXT_L2 > REFX(NOTEXT_L2,1))),VAR27);

VAR32:=IF(((VAR30 OR 0) = 1),VAR30,0);

VAR33:=IF(((VAR31 OR 0) = 1),VAR31,0);

VAR34:=((((NOTEXT_L1 OR 0) > 0) AND ((NOTEXT_L2 OR 0) = 0)) OR (((NOTEXT_L1 OR 0) = 0) AND ((NOTEXT_L2 OR 0) > 0)));

VAR35:=BARSLAST(VAR34);

VAR36:=(((((ROUND((NOTEXT_L1 * 100)) = ROUND((NOTEXT_L2 * 100))) AND ((NOTEXT_L1 OR 0) > 0)) AND ((NOTEXT_L2 OR 0) > 0)) OR ((((BARSTATUS = 1) AND ((REF(NOTEXT_L1,1) OR 0) = 0)) AND ((REF(NOTEXT_L2,1) OR 0) = 1)) = 1)) OR ((((BARSTATUS = 1) AND ((REF(NOTEXT_L2,1) OR 0) = 0)) AND ((REF(NOTEXT_L1,1) OR 0) = 1)) = 1));

VAR37:=IF(((BARSLAST(VAR36) OR 0) = 1),BARSLAST(VAR36),0);

VAR38:=((REF(VAR37,(VAR37 + 1)) + VAR37) + 1);

VAR39:=((REF(VAR38,(VAR37 + 1)) + VAR37) + 1);

VAR40:=((REF(VAR39,(VAR37 + 1)) + VAR37) + 1);

VAR41:=((REF(VAR40,(VAR37 + 1)) + VAR37) + 1);

VAR42:=((REF(VAR41,(VAR37 + 1)) + VAR37) + 1);

VAR43:=((REF(VAR42,(VAR37 + 1)) + VAR37) + 1);

VAR44:=((REF(VAR43,(VAR37 + 1)) + VAR37) + 1);

VAR45:=((REF(VAR44,(VAR37 + 1)) + VAR37) + 1);

VAR46:=((REF(VAR45,(VAR37 + 1)) + VAR37) + 1);

VAR47:=((REF(VAR46,(VAR37 + 1)) + VAR37) + 1);

VAR48:=((REF(VAR47,(VAR37 + 1)) + VAR37) + 1);

VAR49:=((REF(VAR48,(VAR37 + 1)) + VAR37) + 1);

VAR50:=((REF(VAR49,(VAR37 + 1)) + VAR37) + 1);

VAR51:=((REF(VAR50,(VAR37 + 1)) + VAR37) + 1);

VAR52:=((REF(VAR51,(VAR37 + 1)) + VAR37) + 1);

VAR53:=((REF(VAR52,(VAR37 + 1)) + VAR37) + 1);

VAR54:=((REF(VAR53,(VAR37 + 1)) + VAR37) + 1);

VAR55:=((REF(VAR54,(VAR37 + 1)) + VAR37) + 1);

VAR56:=TOTALBARSCOUNT;

VAR57:=IF((((CURRBARSCOUNT <= CONST((VAR35 + 1))) AND REF(VAR33,VAR35)) AND (VAR35 < VAR56)),REF(HIGH,VAR35),IF((((CURRBARSCOUNT <= CONST((VAR35 + 1))) AND REF(VAR32,VAR35)) AND (VAR35 < VAR56)),REF(LOW,VAR35),DRAWNULL));

VAR58:=IF((((CURRBARSCOUNT <= CONST((VAR37 + 1))) AND REF(VAR33,VAR37)) AND (VAR37 < VAR56)),REF(HIGH,VAR37),IF((((CURRBARSCOUNT <= CONST((VAR37 + 1))) AND REF(VAR32,VAR37)) AND (VAR37 < VAR56)),REF(LOW,VAR37),DRAWNULL));

VAR59:=IF((((CURRBARSCOUNT <= CONST((VAR38 + 1))) AND REF(VAR33,VAR38)) AND (VAR38 < VAR56)),REF(HIGH,VAR38),IF((((CURRBARSCOUNT <= CONST((VAR38 + 1))) AND REF(VAR32,VAR38)) AND (VAR38 < VAR56)),REF(LOW,VAR38),DRAWNULL));

VAR60:=IF((((CURRBARSCOUNT <= CONST((VAR39 + 1))) AND REF(VAR33,VAR39)) AND (VAR39 < VAR56)),REF(HIGH,VAR39),IF((((CURRBARSCOUNT <= CONST((VAR39 + 1))) AND REF(VAR32,VAR39)) AND (VAR39 < VAR56)),REF(LOW,VAR39),DRAWNULL));

VAR61:=IF((((CURRBARSCOUNT <= CONST((VAR40 + 1))) AND REF(VAR33,VAR40)) AND (VAR40 < VAR56)),REF(HIGH,VAR40),IF((((CURRBARSCOUNT <= CONST((VAR40 + 1))) AND REF(VAR32,VAR40)) AND (VAR40 < VAR56)),REF(LOW,VAR40),DRAWNULL));

VAR62:=IF((((CURRBARSCOUNT <= CONST((VAR41 + 1))) AND REF(VAR33,VAR41)) AND (VAR41 < VAR56)),REF(HIGH,VAR41),IF((((CURRBARSCOUNT <= CONST((VAR41 + 1))) AND REF(VAR32,VAR41)) AND (VAR41 < VAR56)),REF(LOW,VAR41),DRAWNULL));

VAR63:=IF((((CURRBARSCOUNT <= CONST((VAR42 + 1))) AND REF(VAR33,VAR42)) AND (VAR42 < VAR56)),REF(HIGH,VAR42),IF((((CURRBARSCOUNT <= CONST((VAR42 + 1))) AND REF(VAR32,VAR42)) AND (VAR42 < VAR56)),REF(LOW,VAR42),DRAWNULL));

VAR64:=IF((((CURRBARSCOUNT <= CONST((VAR43 + 1))) AND REF(VAR33,VAR43)) AND (VAR43 < VAR56)),REF(HIGH,VAR43),IF((((CURRBARSCOUNT <= CONST((VAR43 + 1))) AND REF(VAR32,VAR43)) AND (VAR43 < VAR56)),REF(LOW,VAR43),DRAWNULL));

VAR65:=IF((((CURRBARSCOUNT <= CONST((VAR44 + 1))) AND REF(VAR33,VAR44)) AND (VAR44 < VAR56)),REF(HIGH,VAR44),IF((((CURRBARSCOUNT <= CONST((VAR44 + 1))) AND REF(VAR32,VAR44)) AND (VAR44 < VAR56)),REF(LOW,VAR44),DRAWNULL));

VAR66:=IF((((CURRBARSCOUNT <= CONST((VAR45 + 1))) AND REF(VAR33,VAR45)) AND (VAR45 < VAR56)),REF(HIGH,VAR45),IF((((CURRBARSCOUNT <= CONST((VAR45 + 1))) AND REF(VAR32,VAR45)) AND (VAR45 < VAR56)),REF(LOW,VAR45),DRAWNULL));

VAR67:=IF((((CURRBARSCOUNT <= CONST((VAR46 + 1))) AND REF(VAR33,VAR46)) AND (VAR46 < VAR56)),REF(HIGH,VAR46),IF((((CURRBARSCOUNT <= CONST((VAR46 + 1))) AND REF(VAR32,VAR46)) AND (VAR46 < VAR56)),REF(LOW,VAR46),DRAWNULL));

VAR68:=IF((((CURRBARSCOUNT <= CONST((VAR47 + 1))) AND REF(VAR33,VAR47)) AND (VAR47 < VAR56)),REF(HIGH,VAR47),IF((((CURRBARSCOUNT <= CONST((VAR47 + 1))) AND REF(VAR32,VAR47)) AND (VAR47 < VAR56)),REF(LOW,VAR47),DRAWNULL));

VAR69:=IF((((CURRBARSCOUNT <= CONST((VAR48 + 1))) AND REF(VAR33,VAR48)) AND (VAR48 < VAR56)),REF(HIGH,VAR48),IF((((CURRBARSCOUNT <= CONST((VAR48 + 1))) AND REF(VAR32,VAR48)) AND (VAR48 < VAR56)),REF(LOW,VAR48),DRAWNULL));

VAR70:=IF((((CURRBARSCOUNT <= CONST((VAR49 + 1))) AND REF(VAR33,VAR49)) AND (VAR49 < VAR56)),REF(HIGH,VAR49),IF((((CURRBARSCOUNT <= CONST((VAR49 + 1))) AND REF(VAR32,VAR49)) AND (VAR49 < VAR56)),REF(LOW,VAR49),DRAWNULL));

VAR71:=IF((((CURRBARSCOUNT <= CONST((VAR50 + 1))) AND REF(VAR33,VAR50)) AND (VAR50 < VAR56)),REF(HIGH,VAR50),IF((((CURRBARSCOUNT <= CONST((VAR50 + 1))) AND REF(VAR32,VAR50)) AND (VAR50 < VAR56)),REF(LOW,VAR50),DRAWNULL));

VAR72:=IF((((CURRBARSCOUNT <= CONST((VAR51 + 1))) AND REF(VAR33,VAR51)) AND (VAR51 < VAR56)),REF(HIGH,VAR51),IF((((CURRBARSCOUNT <= CONST((VAR51 + 1))) AND REF(VAR32,VAR51)) AND (VAR51 < VAR56)),REF(LOW,VAR51),DRAWNULL));

VAR73:=IF((((CURRBARSCOUNT <= CONST((VAR52 + 1))) AND REF(VAR33,VAR52)) AND (VAR52 < VAR56)),REF(HIGH,VAR52),IF((((CURRBARSCOUNT <= CONST((VAR52 + 1))) AND REF(VAR32,VAR52)) AND (VAR52 < VAR56)),REF(LOW,VAR52),DRAWNULL));

VAR74:=IF((((CURRBARSCOUNT <= CONST((VAR53 + 1))) AND REF(VAR33,VAR53)) AND (VAR53 < VAR56)),REF(HIGH,VAR53),IF((((CURRBARSCOUNT <= CONST((VAR53 + 1))) AND REF(VAR32,VAR53)) AND (VAR53 < VAR56)),REF(LOW,VAR53),DRAWNULL));

VAR75:=IF((((CURRBARSCOUNT <= CONST((VAR54 + 1))) AND REF(VAR33,VAR54)) AND (VAR54 < VAR56)),REF(HIGH,VAR54),IF((((CURRBARSCOUNT <= CONST((VAR54 + 1))) AND REF(VAR32,VAR54)) AND (VAR54 < VAR56)),REF(LOW,VAR54),DRAWNULL));

VAR76:=IF((((CURRBARSCOUNT <= CONST((VAR55 + 1))) AND REF(VAR33,VAR55)) AND (VAR55 < VAR56)),REF(HIGH,VAR55),IF((((CURRBARSCOUNT <= CONST((VAR55 + 1))) AND REF(VAR32,VAR55)) AND (VAR55 < VAR56)),REF(LOW,VAR55),DRAWNULL));

VAR77:=IF((CURRBARSCOUNT <= CONST(VAR56)),CONST(IF(((VAR58 OR 0) = 1),VAR58,0)),0);

VAR78:=IF((CURRBARSCOUNT <= CONST(VAR56)),CONST(IF(((VAR59 OR 0) = 1),VAR59,0)),0);

VAR79:=IF((CURRBARSCOUNT <= CONST(VAR56)),CONST(IF(((VAR60 OR 0) = 1),VAR60,0)),0);

VAR80:=IF((CURRBARSCOUNT <= CONST(VAR56)),CONST(IF(((VAR61 OR 0) = 1),VAR61,0)),0);

VAR81:=IF((CURRBARSCOUNT <= CONST(VAR56)),CONST(IF(((VAR62 OR 0) = 1),VAR62,0)),0);

VAR82:=IF((CURRBARSCOUNT <= CONST(VAR56)),CONST(IF(((VAR63 OR 0) = 1),VAR63,0)),0);

VAR83:=IF((CURRBARSCOUNT <= CONST(VAR56)),CONST(IF(((VAR64 OR 0) = 1),VAR64,0)),0);

VAR84:=IF((CURRBARSCOUNT <= CONST(VAR56)),CONST(IF(((VAR65 OR 0) = 1),VAR65,0)),0);

VAR85:=IF((CURRBARSCOUNT <= CONST(VAR56)),CONST(IF(((VAR66 OR 0) = 1),VAR66,0)),0);

VAR86:=IF((CURRBARSCOUNT <= CONST(VAR56)),CONST(IF(((VAR67 OR 0) = 1),VAR67,0)),0);

VAR87:=IF((CURRBARSCOUNT <= CONST(VAR56)),CONST(IF(((VAR68 OR 0) = 1),VAR68,0)),0);

VAR88:=IF((CURRBARSCOUNT <= CONST(VAR56)),CONST(IF(((VAR69 OR 0) = 1),VAR69,0)),0);

VAR89:=IF((CURRBARSCOUNT <= CONST(VAR56)),CONST(IF(((VAR70 OR 0) = 1),VAR70,0)),0);

VAR90:=IF((CURRBARSCOUNT <= CONST(VAR56)),CONST(IF(((VAR71 OR 0) = 1),VAR71,0)),0);

VAR91:=IF((CURRBARSCOUNT <= CONST(VAR56)),CONST(IF(((VAR72 OR 0) = 1),VAR72,0)),0);

VAR92:=IF((CURRBARSCOUNT <= CONST(VAR56)),CONST(IF(((VAR73 OR 0) = 1),VAR73,0)),0);

VAR93:=IF((CURRBARSCOUNT <= CONST(VAR56)),CONST(IF(((VAR74 OR 0) = 1),VAR74,0)),0);

VAR94:=IF((CURRBARSCOUNT <= CONST(VAR56)),CONST(IF(((VAR75 OR 0) = 1),VAR75,0)),0);

VAR95:=IF((CURRBARSCOUNT <= CONST(VAR56)),CONST(IF(((VAR76 OR 0) = 1),VAR76,0)),0);

VAR96:=IF((VAR77 < VAR78),MIN(VAR78,IF(((VAR80 OR 0) = 1),VAR80,VAR78)),MIN(VAR77,VAR79));

VAR97:=IF((VAR77 < VAR78),MAX(VAR77,VAR79),MAX(VAR78,IF(((VAR80 OR 0) = 1),VAR80,VAR78)));

VAR98:=IF((VAR77 < VAR78),MIN(VAR96,VAR82),MIN(VAR96,VAR81));

VAR99:=IF((VAR77 < VAR78),MAX(VAR97,VAR81),MAX(VAR97,VAR82));

VAR100:=IF((((((VAR98 OR 0) = 0) OR ((VAR99 OR 0) = 0)) AND (VAR96 >= VAR97)) AND ((VAR96 OR 0) = 1)),VAR96,IF(((VAR98 >= VAR99) AND ((VAR98 OR 0) = 1)),VAR98,IF((VAR96 > VAR97),VAR96,VAR96)));

VAR101:=IF((((((VAR98 OR 0) = 0) OR ((VAR99 OR 0) = 0)) AND (VAR96 >= VAR97)) AND ((VAR97 OR 0) = 1)),VAR97,IF(((VAR98 >= VAR99) AND ((VAR99 OR 0) = 1)),VAR99,IF((VAR96 > VAR97),VAR97,VAR79)));

ZSGD1:(IF(((CURRBARSCOUNT <= CONST(VAR42)) AND ((VAR100 OR 0) = 1)),CONST(VAR100),DRAWNULL) * VAR1),DOTLINE,COLOR8080FF;

ZSDD1:(IF(((CURRBARSCOUNT <= CONST(VAR42)) AND ((VAR100 OR 0) = 1)),CONST(VAR101),DRAWNULL) * VAR1),DOTLINE,COLORRED;

VAR104:=IF((VAR77 < VAR78),MIN(VAR80,VAR82),MIN(VAR79,VAR81));

VAR105:=IF((VAR77 < VAR78),MAX(VAR79,VAR81),MAX(VAR80,VAR82));

VAR106:=IF((VAR77 < VAR78),MIN(VAR104,VAR84),MIN(VAR104,VAR83));

VAR107:=IF((VAR77 < VAR78),MAX(VAR105,VAR83),MAX(VAR105,VAR84));

VAR108:=(((VAR104 >= VAR105) AND ((VAR104 OR 0) = 1)) AND (VAR98 <= VAR99));

VAR109:=IF((((((VAR106 OR 0) = 0) OR ((VAR107 OR 0) = 0)) AND VAR108) OR (((((VAR106 OR 0) = 1) AND ((VAR107 OR 0) = 1)) AND VAR108) AND (VAR106 < VAR107))),VAR104,IF((((VAR106 >= VAR107) AND ((VAR106 OR 0) = 1)) AND (VAR98 <= VAR99)),VAR106,VAR100));

VAR110:=IF((((((VAR106 OR 0) = 0) OR ((VAR107 OR 0) = 0)) AND VAR108) OR (((((VAR106 OR 0) = 1) AND ((VAR107 OR 0) = 1)) AND VAR108) AND (VAR106 < VAR107))),VAR105,IF((((VAR106 >= VAR107) AND ((VAR107 OR 0) = 1)) AND (VAR98 <= VAR99)),VAR107,VAR101));

VAR111:=IF((VAR77 < VAR78),MIN(VAR82,VAR84),MIN(VAR81,VAR83));

VAR112:=IF((VAR77 < VAR78),MAX(VAR81,VAR83),MAX(VAR82,VAR84));

VAR113:=IF((VAR77 < VAR78),MIN(VAR111,VAR86),MIN(VAR111,VAR85));

VAR114:=IF((VAR77 < VAR78),MAX(VAR112,VAR85),MAX(VAR112,VAR86));

VAR115:=((((VAR111 >= VAR112) AND ((VAR111 OR 0) = 1)) AND (VAR98 <= VAR99)) AND (VAR106 < VAR107));

VAR116:=IF((((((VAR113 OR 0) = 0) OR ((VAR114 OR 0) = 0)) AND VAR115) OR ((VAR115 AND (((VAR113 OR 0) = 1) AND ((VAR114 OR 0) = 1))) AND (VAR113 < VAR114))),VAR111,IF(((((VAR113 >= VAR114) AND ((VAR113 OR 0) = 1)) AND (VAR98 <= VAR99)) AND (VAR106 < VAR107)),VAR113,VAR109));

VAR117:=IF((((((VAR113 OR 0) = 0) OR ((VAR114 OR 0) = 0)) AND VAR115) OR ((VAR115 AND (((VAR113 OR 0) = 1) AND ((VAR114 OR 0) = 1))) AND (VAR113 < VAR114))),VAR112,IF(((((VAR113 >= VAR114) AND ((VAR113 OR 0) = 1)) AND (VAR98 <= VAR99)) AND (VAR106 < VAR107)),VAR114,VAR110));{www.buyhaogu.com}

VAR118:=IF((VAR77 < VAR78),MIN(VAR84,VAR86),MIN(VAR83,VAR85));

VAR119:=IF((VAR77 < VAR78),MAX(VAR83,VAR85),MAX(VAR84,VAR86));

VAR120:=IF((((((((VAR118 OR 0) = 0) OR ((VAR119 OR 0) = 0)) AND (VAR116 >= VAR117)) AND (VAR98 <= VAR99)) AND (VAR106 < VAR107)) AND (VAR113 < VAR114)),VAR116,IF((((((VAR118 > VAR119) AND ((VAR118 OR 0) = 1)) AND (VAR98 <= VAR99)) AND (VAR106 < VAR107)) AND (VAR113 < VAR114)),VAR118,VAR116));

VAR121:=IF((((((((VAR118 OR 0) = 0) OR ((VAR119 OR 0) = 0)) AND (VAR116 >= VAR117)) AND (VAR98 <= VAR99)) AND (VAR106 < VAR107)) AND (VAR113 < VAR114)),VAR117,IF((((((VAR118 > VAR119) AND ((VAR119 OR 0) = 1)) AND (VAR98 <= VAR99)) AND (VAR106 < VAR107)) AND (VAR113 < VAR114)),VAR119,VAR117));

VAR122:=IF((VAR120 = 0),DRAWNULL,IF(((((VAR120 > VAR121) AND (VAR116 > VAR121)) AND (VAR109 > VAR121)) AND (VAR100 > VAR121)),MIN(MIN(MIN(VAR120,VAR116),VAR109),VAR100),VAR120));

VAR123:=IF((VAR121 = 0),DRAWNULL,IF((((VAR121 = VAR77) AND (VAR104 > VAR105)) AND (VAR106 > VAR107)),MIN(VAR105,VAR107),IF((((VAR121 = VAR77) AND (VAR104 > VAR105)) AND (VAR106 < VAR107)),VAR105,VAR121)));

VAR124:=IF(((((VAR122 > VAR123) AND (VAR84 < VAR123)) AND (VAR85 < VAR123)) OR (((VAR122 > VAR123) AND (VAR84 > VAR122)) AND (VAR85 > VAR122))),VAR44,IF(((((VAR122 > VAR123) AND (VAR85 < VAR123)) AND (VAR86 < VAR123)) OR (((VAR122 > VAR123) AND (VAR85 > VAR122)) AND (VAR86 > VAR122))),VAR45,IF(((((VAR122 > VAR123) AND (VAR86 < VAR123)) AND (VAR87 < VAR123)) OR (((VAR122 > VAR123) AND (VAR86 > VAR122)) AND (VAR87 > VAR122))),VAR46,IF(((((VAR122 > VAR123) AND (VAR87 < VAR123)) AND (VAR88 < VAR123)) OR (((VAR122 > VAR123) AND (VAR87 > VAR122)) AND (VAR88 > VAR122))),VAR47,IF(((((VAR122 > VAR123) AND (VAR88 < VAR123)) AND (VAR89 < VAR123)) OR (((VAR122 > VAR123) AND (VAR88 > VAR122)) AND (VAR89 > VAR122))),VAR48,IF(((((VAR122 > VAR123) AND (VAR89 < VAR123)) AND (VAR90 < VAR123)) OR (((VAR122 > VAR123) AND (VAR89 > VAR122)) AND (VAR90 > VAR122))),VAR49,IF(((((VAR122 > VAR123) AND (VAR90 < VAR123)) AND (VAR91 < VAR123)) OR (((VAR122 > VAR123) AND (VAR90 > VAR122)) AND (VAR91 > VAR122))),VAR50,VAR51)))))));

VAR125:=IF(((VAR124 OR 0) = 1),VAR124,VAR56);

VAR126:=IF((VAR125 >= VAR48),VAR88,IF((VAR125 = VAR47),VAR87,IF((VAR125 = VAR46),VAR86,IF((VAR125 = VAR45),VAR85,IF((VAR125 = VAR44),VAR84,IF((VAR125 = VAR43),VAR83,VAR82))))));

VAR127:=IF((VAR125 >= VAR48),VAR89,IF((VAR125 = VAR47),VAR88,IF((VAR125 = VAR46),VAR87,IF((VAR125 = VAR45),VAR86,IF((VAR125 = VAR44),VAR85,IF((VAR125 = VAR43),VAR84,VAR83))))));

VAR128:=IF((VAR125 >= VAR48),VAR90,IF((VAR125 = VAR47),VAR89,IF((VAR125 = VAR46),VAR88,IF((VAR125 = VAR45),VAR87,IF((VAR125 = VAR44),VAR86,IF((VAR125 = VAR43),VAR85,VAR84))))));

VAR129:=IF((VAR125 >= VAR48),VAR91,IF((VAR125 = VAR47),VAR90,IF((VAR125 = VAR46),VAR89,IF((VAR125 = VAR45),VAR88,IF((VAR125 = VAR44),VAR87,IF((VAR125 = VAR43),VAR86,VAR85))))));

VAR130:=IF((VAR125 >= VAR48),VAR92,IF((VAR125 = VAR47),VAR91,IF((VAR125 = VAR46),VAR90,IF((VAR125 = VAR45),VAR89,IF((VAR125 = VAR44),VAR88,IF((VAR125 = VAR43),VAR87,VAR86))))));

VAR131:=IF((VAR125 >= VAR48),VAR93,IF((VAR125 = VAR47),VAR92,IF((VAR125 = VAR46),VAR91,IF((VAR125 = VAR45),VAR90,IF((VAR125 = VAR44),VAR89,IF((VAR125 = VAR43),VAR88,VAR87))))));

VAR132:=IF((VAR125 >= VAR48),VAR94,IF((VAR125 = VAR47),VAR93,IF((VAR125 = VAR46),VAR92,IF((VAR125 = VAR45),VAR91,IF((VAR125 = VAR44),VAR90,IF((VAR125 = VAR43),VAR89,VAR88))))));

VAR133:=IF((VAR125 >= VAR48),VAR95,IF((VAR125 = VAR47),VAR94,IF((VAR125 = VAR46),VAR93,IF((VAR125 = VAR45),VAR92,IF((VAR125 = VAR44),VAR91,IF((VAR125 = VAR43),VAR90,VAR89))))));

VAR134:=IF((VAR126 < VAR127),MIN(VAR127,IF(((VAR129 OR 0) = 1),VAR129,VAR127)),MIN(VAR126,VAR128));

VAR135:=IF((VAR126 < VAR127),MAX(VAR126,VAR128),MAX(VAR127,IF(((VAR129 OR 0) = 1),VAR129,VAR127)));

VAR136:=IF((VAR126 < VAR127),MIN(VAR134,VAR131),MIN(VAR134,VAR130));

VAR137:=IF((VAR126 < VAR127),MAX(VAR135,VAR130),MAX(VAR135,VAR131));

VAR138:=IF((((((VAR136 OR 0) = 0) OR ((VAR137 OR 0) = 0)) AND (VAR134 >= VAR135)) AND ((VAR134 OR 0) = 1)),VAR134,IF(((VAR136 >= VAR137) AND ((VAR136 OR 0) = 1)),VAR136,IF((VAR134 > VAR135),VAR134,VAR134)));

VAR139:=IF((((((VAR136 OR 0) = 0) OR ((VAR137 OR 0) = 0)) AND (VAR134 >= VAR135)) AND ((VAR135 OR 0) = 1)),VAR135,IF(((VAR136 >= VAR137) AND ((VAR137 OR 0) = 1)),VAR137,IF((VAR134 > VAR135),VAR135,VAR128)));

VAR140:=IF((VAR126 < VAR127),MIN(VAR129,VAR131),MIN(VAR128,VAR130));

VAR141:=IF((VAR126 < VAR127),MAX(VAR128,VAR130),MAX(VAR129,VAR131));

VAR142:=IF((VAR126 < VAR127),MIN(VAR140,VAR133),MIN(VAR140,VAR132));

VAR143:=IF((VAR126 < VAR127),MAX(VAR141,VAR132),MAX(VAR141,VAR133));

VAR144:=(((VAR140 >= VAR141) AND ((VAR140 OR 0) = 1)) AND (VAR136 <= VAR137));

VAR145:=IF((((((VAR142 OR 0) = 0) OR ((VAR143 OR 0) = 0)) AND VAR144) OR (((((VAR142 OR 0) = 1) AND ((VAR143 OR 0) = 1)) AND VAR144) AND (VAR142 < VAR143))),VAR140,IF((((VAR142 >= VAR143) AND ((VAR142 OR 0) = 1)) AND (VAR136 <= VAR137)),VAR142,VAR138));

VAR146:=IF((((((VAR142 OR 0) = 0) OR ((VAR143 OR 0) = 0)) AND VAR144) OR (((((VAR142 OR 0) = 1) AND ((VAR143 OR 0) = 1)) AND VAR144) AND (VAR142 < VAR143))),VAR141,IF((((VAR142 >= VAR143) AND ((VAR143 OR 0) = 1)) AND (VAR136 <= VAR137)),VAR143,VAR139));

ZSG11:(IF((CURRBARSCOUNT <= CONST(VAR125)),CONST(VAR122),DRAWNULL) * VAR1),LINETHICK2,COLOR8080FF;

ZSD11:(IF((CURRBARSCOUNT <= CONST(VAR125)),CONST(VAR123),DRAWNULL) * VAR1),LINETHICK2,COLORRED;

VAR149:=IF((VAR55 OR (0 = 1)),VAR55,IF((VAR54 OR (0 = 1)),VAR54,IF((VAR53 OR (0 = 1)),VAR53,IF((VAR52 OR (0 = 1)),VAR52,IF((VAR51 OR (0 = 1)),VAR51,IF((VAR50 OR (0 = 1)),VAR50,IF((VAR49 OR (0 = 1)),VAR49,IF((VAR48 OR (0 = 1)),VAR48,IF((VAR47 OR (0 = 1)),VAR47,IF((VAR46 OR (0 = 1)),VAR46,IF((VAR45 OR (0 = 1)),VAR45,IF((VAR44 OR (0 = 1)),VAR44,IF((VAR43 OR (0 = 1)),VAR43,IF((VAR42 OR (0 = 1)),VAR42,IF((VAR41 OR (0 = 1)),VAR41,IF((VAR40 OR (0 = 1)),VAR40,VAR39))))))))))))))));

VAR150:=IF((VAR149 <= VAR56),VAR149,VAR56);

NOTEXT_ZSGE1:(IF((((CURRBARSCOUNT <= CONST(VAR150)) AND (CURRBARSCOUNT >= (CONST(VAR125) / 2))) AND (VAR145 > 0)),CONST(VAR145),DRAWNULL) * VAR1),COLOR40C040;

NOTEXT_ZSDE1:(IF((((CURRBARSCOUNT <= CONST(VAR150)) AND (CURRBARSCOUNT >= (CONST(VAR125) / 2))) AND (VAR146 > 0)),CONST(VAR146),DRAWNULL) * VAR1),COLORGREEN;

K线:DRAWKLINE(HIGH,OPEN,LOW,CLOSE);

VAR154:=(((((NOTEXT_L1 = NOTEXT_L2) AND (NOTEXT_L1 > REF(NOTEXT_L1,1))) = 1) OR ((((NOTEXT_L1 > REF(NOTEXT_L1,1)) AND ((REFX(NOTEXT_L2,1) OR 0) = 0)) AND ((REFX(NOTEXT_L1,1) OR 0) = 0)) = 1)) OR ((((BARSTATUS = 1) AND ((REF(NOTEXT_L1,1) OR 0) = 0)) AND ((REF(NOTEXT_L2,1) OR 0) = 1)) = 1));

VAR155:=(((((NOTEXT_L1 = NOTEXT_L2) AND (NOTEXT_L2 < REF(NOTEXT_L2,1))) = 1) OR ((((NOTEXT_L2 < REF(NOTEXT_L2,1)) AND ((REFX(NOTEXT_L2,1) OR 0) = 0)) AND ((REFX(NOTEXT_L1,1) OR 0) = 0)) = 1)) OR ((((BARSTATUS = 1) AND ((REF(NOTEXT_L2,1) OR 0) = 0)) AND ((REF(NOTEXT_L1,1) OR 0) = 1)) = 1));

NOTEXT_GP1:IF(VAR154,HIGH,DRAWNULL),CIRCLEDOT,LINETHICK2,COLORYELLOW;

NOTEXT_DP1:IF(VAR155,LOW,DRAWNULL),CIRCLEDOT,LINETHICK2,COLORYELLOW;

DRAWNUMBER(VAR154,IF((PERIOD < 3),(HIGH * 1.003),IF((HIGH > 1000),(HIGH * 1.005),(HIGH * 1.008))),HIGH),COLOR8080FF;

DRAWNUMBER(VAR155,LOW,LOW),COLOR8000FF;

BOLL:MA(CLOSE,20),COLORWHITE;

VAR161:=(LLVBARS(LOW,5) = 0);

VAR162:=(HHVBARS(HIGH,5) = 0);

VAR163:=IF(((BARSLAST(VAR162) OR 0) = 1),BARSLAST(VAR162),0);

VAR164:=IF(((BARSLAST(VAR161) OR 0) = 1),BARSLAST(VAR161),0);

VAR165:=IF(((VAR163 = VAR164) AND (VAR10 >= MA5)),VAR161,IF((VAR163 > VAR164),VAR161,0));

VAR166:=IF(((VAR163 = VAR164) AND (MA5 >= VAR10)),VAR162,IF((VAR164 > VAR163),VAR162,0));

NOTEXT_BL1:(DRAWLINE(VAR165,LOW,VAR166,HIGH,0) * VAR1),COLOR8080FF;

NOTEXT_BL2:(DRAWLINE(VAR166,HIGH,VAR165,LOW,0) * VAR1),COLOR40C040;

VAR169:=IF((CURRBARSCOUNT <= CONST(VAR56)),CONST(IF(((VAR58 OR 0) = 1),VAR57,0)),0);

VAR170:=((((((((VAR79 < MIN(VAR80,MIN(VAR78,VAR169))) AND (VAR77 < MIN(VAR80,MIN(VAR78,VAR169)))) AND (VAR78 > MAX(VAR77,VAR79))) AND (VAR169 > MAX(VAR77,VAR79))) AND (VAR169 < VAR78)) AND (VAR78 < VAR80)) AND (VAR77 < VAR79)) AND (VOL > 10));

VAR171:=(((((((((VAR80 < MIN(VAR77,MIN(VAR79,VAR81))) AND (VAR78 < MIN(VAR77,MIN(VAR79,VAR81)))) AND (VAR81 > MAX(VAR78,VAR80))) AND (VAR79 > MAX(VAR78,VAR80))) AND (VAR77 > MAX(VAR78,VAR80))) AND (VAR77 < VAR79)) AND (VAR79 < VAR81)) AND (VAR78 < VAR80)) AND (VOL > 10));

DRAWICON((VAR170 AND (CURRBARSCOUNT <= CONST((VAR35 + 1)))),IF(((NOTEXT_L2 OR 0) = 1),NOTEXT_L2,CLOSE),2);

DRAWICON((VAR171 AND (CURRBARSCOUNT <= CONST(VAR37))),IF(((NOTEXT_L2 OR 0) = 1),NOTEXT_L2,CLOSE),2);

VAR174:=(((((((((VAR79 > MAX(VAR80,MAX(VAR78,VAR169))) AND (VAR77 > MAX(VAR80,MAX(VAR78,VAR169)))) AND (VAR169 < MIN(VAR77,VAR79))) AND (VAR78 < MIN(VAR77,VAR79))) AND (VAR80 < MIN(VAR77,VAR79))) AND (VAR77 > VAR79)) AND (VAR78 > VAR80)) AND (VAR169 > VAR78)) AND (VOL > 10));

VAR175:=(((((((((VAR78 > MAX(VAR77,MAX(VAR79,VAR81))) AND (VAR80 > MAX(VAR77,MAX(VAR79,VAR81)))) AND (VAR77 < MIN(VAR78,VAR80))) AND (VAR79 < MIN(VAR78,VAR80))) AND (VAR81 < MIN(VAR78,VAR80))) AND (VAR77 > VAR79)) AND (VAR79 > VAR81)) AND (VAR78 > VAR80)) AND (VOL > 10));

DRAWICON((VAR174 AND (CURRBARSCOUNT <= CONST((VAR35 + 1)))),IF(((NOTEXT_L1 OR 0) = 1),NOTEXT_L1,CLOSE),1);

DRAWICON((VAR175 AND (CURRBARSCOUNT <= CONST(VAR37))),IF(((NOTEXT_L1 OR 0) = 1),NOTEXT_L1,CLOSE),1);

{通达信趋势划线综合主图指标}

打赏好指标 ×

关于通达信趋势划线综合主图指标的评论:

 以下是对 [通达信趋势划线综合主图指标] 的评论,总共:1条评论
匿名 游客:匿名  刚刚 1
124语句不通过
加入收藏 | 联系我们 | 免责声明 | 站内地图 | 关于我们