买好股公式网 > 股票公式 > 通达信公式 > 通达信转折点主图有未来函数

通达信转折点主图有未来函数

2021年11月23日人气:Tags:通达信 主图 未来 未来函数 函数

MA10:=MA(C,10),COLOR009B9B,LINETHICK1;

MA20:=MA(C,20),COLOR009B9B,LINETHICK1;

HX:=MAX(REF(C,1),H);

LX:=MIN(REF(C,1),L);

DRAWBAND(MA10,RGB(231,150,69),MA20,RGB(18,128,144));DRAWKLINE(HX,O,LX,C);   

G:=MA(C,5);

D:=MA(C,10);

HH:=REF(H,5)=HHV(H,11);

LL:=REF(L,5)=LLV(L,11);

FG01:=BACKSET(HH,6)>BACKSET(HH,5) ;

FD01:=BACKSET(LL,6)>BACKSET(LL,5) ;

FG02:=IF(BARSLAST(FG01)=BARSLAST(FD01) AND G>D,FG01,

   IF(BARSLAST(FD01)>BARSLAST(FG01),FG01,0));

FD02:=IF(BARSLAST(FG01)=BARSLAST(FD01) AND D>G,FD01,

   IF(BARSLAST(FG01)>BARSLAST(FD01),FD01,0));

FG0:=FG02 AND H=HHV(H,BARSLAST(FD02));

FD0:=FD02 AND L=LLV(L,BARSLAST(FG02));

GP:=IF(FG0,H,DRAWNULL),CIRCLEDOT,COLORCYAN;

DP:=IF(FD0,L,DRAWNULL),CIRCLEDOT,COLORCYAN;

GQ:=L>REF(H,1) AND DAY!=REF(DAY,1);

DQ:=H<REF(L,1) AND DAY!=REF(DAY,1);

GQL:=REF(L,BARSLAST(GQ));

DQH:=REF(H,BARSLAST(DQ));

FGH:=REF(H,BARSLAST(FG0));

FGL:=REF(L,BARSLAST(FG0));

FGH1:=REF(H,BARSLAST(FG0)+1);

FGL1:=REF(L,BARSLAST(FG0)+1);

FGH2:=REF(H,BARSLAST(FG0)+2);

FGL2:=REF(L,BARSLAST(FG0)+2);

FDH:=REF(H,BARSLAST(FD0));

FDL:=REF(L,BARSLAST(FD0));

FDH1:=REF(H,BARSLAST(FD0)+1);

FDL1:=REF(L,BARSLAST(FD0)+1);

FDH2:=REF(H,BARSLAST(FD0)+2);

FDL2:=REF(L,BARSLAST(FD0)+2);

FGZH:=IF(FGL<=FGL1,FGH2,FGH1);

FGZL:=IF(FGH1<FGL,FGL,IF(FGL<=FGL1,FGL2,FGL1));

FDZH:=IF(FDL1>FDH,FDH,IF(FDH>=FDH1,FDH2,FDH1));

FDZL:=IF(FDH>=FDH1,FDL2,FDL1);

FG1:=FGH>FDZH AND FG0;

FD1:=FDL<FGZL AND FD0;

FG:=FG1 AND FGH>FDH AND FGL>FDL AND FGL1>FDL;

FD:=FD1 AND FDL<FGL AND FDH<FGH AND FDH1<FGH;

BH0:=(H<=REF(H,1) AND L>=REF(L,1)) OR (H>=REF(H,1) AND L<=REF(L,1));

BHG:=COUNT(BH0,BARSLAST(FD0));

BHD:=COUNT(BH0,BARSLAST(FG0));

BGQ:=COUNT(GQ,BARSLAST(FD0));

BDQ:=COUNT(DQ,BARSLAST(FG0));

BK0:=IF(BHG>0,BHG+2,IF(BHD,BHD+2,3));

BK:=IF(BGQ,BK0-BGQ,IF(BDQ,BK0-BDQ,BK0));

G1X:=(FG AND BARSLAST(FD)>BK);

D1X:=(FD AND BARSLAST(FG)>BK);

G1:=(FG0 AND REF(H,BARSLAST(FG0))>=REF(H,BARSLAST(G1X)) AND BARSLAST(D1X)>BARSLAST(G1X))

OR (FG1 AND COUNT(GQ,BARSLAST(FD1))>0 AND REF(H,BARSLAST(FG1))>REF(H,BARSLAST(G1X)));

D1:=(FD0 AND REF(L,BARSLAST(FD0))<=REF(L,BARSLAST(D1X)) AND BARSLAST(G1X)>BARSLAST(D1X))

OR (FD1 AND COUNT(DQ,BARSLAST(FG1))>0 AND REF(L,BARSLAST(FD1))<REF(H,BARSLAST(D1X)));

G1H:=IF(BARSLAST(D1)>BARSLAST(G1),REF(H,BARSLAST(G1)),REF(H,BARSLAST(D1))),;

D1L:=IF(BARSLAST(G1)>BARSLAST(D1),REF(L,BARSLAST(D1)),REF(L,BARSLAST(G1)));

G2:=G1 AND H=HHV(G1H,BARSLAST(D1)+1) AND H>REF(H,1) AND BARSLAST(D1)>BARSLAST(G1);

D2:=D1 AND L=LLV(D1L,BARSLAST(G1)+1) AND L<REF(L,1) AND BARSLAST(G1)>BARSLAST(D1);

G3:=G2 OR (FG0 AND REF(H,BARSLAST(FG0))>REF(H,BARSLAST(G2)) AND BARSLAST(D2)>BARSLAST(G2));

D3:=D2 OR (FD0 AND REF(L,BARSLAST(FD0))<REF(L,BARSLAST(D2)) AND BARSLAST(G2)>BARSLAST(D2));

GPB:=IF(G1X,H,DRAWNULL),CIRCLEDOT,COLORYELLOW;

DPB:=IF(D1X,L,DRAWNULL),CIRCLEDOT,COLORYELLOW;

{画折线}

NN:=G3;

UU:=D3;

L1:DRAWLINE(NN,H,UU, L,0),COLORDAC272,LINETHICK1;

L2:DRAWLINE(UU,L,NN, H,0),COLOR009393,LINETHICK1;


三一:H-(H-L)*0.333,NODRAW;

二一:H-(H-L)*0.5,NODRAW;

三二:H-(H-L)*0.666,NODRAW;

实体三一:O+(C-O)*0.666,NODRAW;

实体腰线:O+(C-O)*0.5,NODRAW;

DRAWTEXT_FIX(ISLASTBAR,0,0,0,HYBLOCK);{在屏幕左上角显示所属行业板块}

DRAWTEXT_FIX(ISLASTBAR,0.05,0,0,DYBLOCK);{在屏幕左上角显示所属地域板块}

DRAWTEXT_FIX(ISLASTBAR,0.1,0,0,GNBLOCK);{在屏幕左上角显示所属概念板块}


C_: CONST(C),COLORLIRED,POINTDOT;{现价线}

MA5:=MA(C,5);

MA5角度: ATAN((MA5/REF(MA5,1)-1)*100)*180/3.1416,NODRAW;

DRAWKLINE(H,O,L,C);{重绘K线}

RC1:=REF(C,1);

CS:=IF(C>=1,10000,100000);

C涨停10:=1.10*RC1-49/CS;{考虑到4舍5入}

C涨停5 :=1.05*RC1-49/CS;

C跌停10:=0.90*RC1+51/CS;

C跌停5 :=0.95*RC1+51/CS;

ST:=NAMELIKE('S') OR NAMELIKE('*S');

涨停:= IF(ST, C>=C涨停5, C>=C涨停10);

跌停:= IF(ST, C<=C跌停5, C<=C跌停10);

盘中涨停:=IF(ST, H>=C涨停5, H>=C涨停10);

盘中跌停:=IF(ST, L<=C跌停5, L<=C跌停10);

STICKLINE(盘中涨停,H,MAX(C,O),0,0),COLORMAGENTA;{涨停后回落}

STICKLINE(盘中跌停,L,MIN(C,O),0,0),COLORLICYAN;{跌停后回升}

大阳线:=C>O AND (C>=C涨停5 OR C>(1.05*O-51/CS) ) OR (C>1000 AND C>RC1*1.024);

STICKLINE(大阳线,O,C,1,0),COLOR0000BB;

大阴线:=C<O AND (C<=C跌停5 OR C<(0.95*O+49/CS) ) OR (C>1000 AND C<RC1*0.976);

STICKLINE(大阴线,O,C,1,0),COLORLIGREEN;

STICKLINE(涨停,O,C,1,0),COLORMAGENTA;

STICKLINE(跌停,O,C,1,0),COLORLICYAN;

假阴:=C<O AND C>REF(C,1);

STICKLINE(假阴,O,C,0,0),COLORRED;{假阴柱};

假阳:=C>O AND C<REF(C,1);

STICKLINE(假阳,O,C,0,0),COLORGREEN;{假阳柱};

大盘TJ:=PERIOD=5 AND NAMELIKE('上证指数') 

        AND (ABS((C-REF(C,1)))/REF(C,1)>=0.025 OR ABS(C-O)>=60);

STICKLINE(大盘TJ,(H+L)/2,(H+L)/2,2,0),COLORYELLOW;{显示大盘日线的60点大K线中值};

STICKLINE((大阳线 OR 大阴线 OR 涨停 OR 跌停) 

  AND BETWEEN(C,1,500),L+(H-L)/2,L+(H-L)/2,1,0),COLORYELLOW;{大K线画中点线};

{通达信转折点主图有未来函数}

打赏好指标 ×

关于通达信转折点主图有未来函数的评论:

 以下是对 [通达信转折点主图有未来函数] 的评论,总共:0条评论
加入收藏 | 联系我们 | 免责声明 | 站内地图 | 关于我们