买好股公式网 > 股票公式 > 通达信公式 > 通达信寻常底主图+选股无未来函数

通达信寻常底主图+选股无未来函数

2018年10月25日 字体: 人气:

通达信寻常底主图+选股无未来函数



C2:=REF(C,1);

涨停:=IF((C-C2)*100/C2>=(10-0.01*100/C2),1,0);

STICKLINE(涨停,OPEN,CLOSE,3,0),COLORYELLOW;

STICKLINE(涨停,H,L,0,0),COLORYELLOW;

跌停:=IF((C2-C)*100/C2>=(10-0.01*100/C2),1,0);

STICKLINE(跌停,OPEN,CLOSE,3,0),COLORGREEN;

STICKLINE(跌停,H,L,3,0),COLORGREEN;

V00:= HIGH<REF(HIGH,1) AND LOW<REF(LOW,1);

V01:= HIGH<REF(HIGH,1) AND LOW>REF(LOW,1);

V02:= HIGH>REF(HIGH,1) AND LOW<REF(LOW,1);

V03:= HIGH>REF(HIGH,1) AND LOW>REF(LOW,1);

V04:= REF(HIGH,2) < HIGH AND REF(LOW,2) < LOW

AND REF(HIGH,2) > REF(HIGH,1) AND REF(LOW,2) < REF(LOW,1);

V1:= COUNT(V00,6)>=3 AND COUNT(V01 OR V02,5)=0 AND LLVBARS(LOW,6) = 1 AND HHVBARS(HIGH,6) >=  5 AND V03;

V2:= COUNT(V00,7)>=3 AND COUNT(V01 OR V02,6)=1 AND LLVBARS(LOW,7) = 2 AND HHVBARS(HIGH,7) >=  6 AND V04;

V3:= COUNT(V00,7)>=3 AND COUNT(V01 OR V02,6)=1 AND LLVBARS(LOW,7) = 1 AND HHVBARS(HIGH,7) >=  6 AND V03;

V4:= COUNT(V00,8)>=3 AND COUNT(V01 OR V02,7)<=2 AND LLVBARS(LOW,8) = 2 AND HHVBARS(HIGH,8)  >= 7 AND V04;

V5:= COUNT(V00,8)>=3 AND COUNT(V01 OR V02,7)<=2 AND LLVBARS(LOW,8) = 1 AND HHVBARS(HIGH,8)  >= 7 AND V03;

V6:= COUNT(V00,9)>=3 AND COUNT(V01 OR V02,8)<=3 AND LLVBARS(LOW,9) = 2 AND HHVBARS(HIGH,9)  >= 8 AND V04;

V7:= COUNT(V00,9)>=3 AND COUNT(V01 OR V02,8)<=3 AND LLVBARS(LOW,9) = 1 AND HHVBARS(HIGH,9)  >= 8 AND V03;

V8:= COUNT(V00,10)>=3 AND COUNT(V01 OR V02,9)<=4 AND LLVBARS(LOW,10) = 2 AND HHVBARS (HIGH,10) >= 9 AND V04;

V9:= COUNT(V00,10)>=3 AND COUNT(V01 OR V02,9)<=4 AND LLVBARS(LOW,10) = 1 AND HHVBARS (HIGH,10) >= 9 AND V03;

V10:= COUNT(V00,11)>=3 AND COUNT(V01 OR V02,10)<=5 AND LLVBARS(LOW,11) = 2 AND HHVBARS (HIGH,11) >= 10 AND V04;

XG:= V1 OR V2 OR V3 OR V4 OR V5 OR V6 OR V7 OR V8 OR V9 OR V10;

DRAWTEXT(FILTER(XG=1,5),L*0.998,'底'),COLORYELLOW;

HV00:= HIGH>REF(HIGH,1) AND LOW>REF(LOW,1);

HV01:= HIGH<REF(HIGH,1) AND LOW>REF(LOW,1);

HV02:= HIGH>REF(HIGH,1) AND LOW<REF(LOW,1);

HV03:= HIGH<REF(HIGH,1) AND LOW<REF(LOW,1);

HV04:= REF(HIGH,2) > HIGH AND REF(LOW,2) > LOW AND REF(HIGH,2) > REF(HIGH,1) AND REF(LOW,2)  < REF(LOW,1);

HV1:= COUNT(HV00,6)>=3 AND COUNT(HV01 OR HV02,5)=0 AND HHVBARS(HIGH,6) = 1 AND LLVBARS (LOW,6) >= 5 AND HV03;

HV2:= COUNT(HV00,7)>=3 AND COUNT(HV01 OR HV02,6)=1 AND HHVBARS(HIGH,7) = 2 AND LLVBARS (LOW,7) >= 6 AND HV04;

HV3:= COUNT(HV00,7)>=3 AND COUNT(HV01 OR HV02,6)=1 AND HHVBARS(HIGH,7) = 1 AND LLVBARS (LOW,7) >= 6 AND HV03;

HV4:= COUNT(HV00,8)>=3 AND COUNT(HV01 OR HV02,7)<=2 AND HHVBARS(HIGH,8) = 2 AND LLVBARS (LOW,8) >= 7 AND HV04;

HV5:= COUNT(HV00,8)>=3 AND COUNT(HV01 OR HV02,7)<=2 AND HHVBARS(HIGH,8) = 1 AND LLVBARS (LOW,8) >= 7 AND HV03;

HV6:= COUNT(HV00,9)>=3 AND COUNT(HV01 OR HV02,8)<=3 AND HHVBARS(HIGH,9) = 2 AND LLVBARS (LOW,9) >= 8 AND HV04;

HV7:= COUNT(HV00,9)>=3 AND COUNT(HV01 OR HV02,8)<=3 AND HHVBARS(HIGH,9) = 1 AND LLVBARS (LOW,9) >= 8 AND HV03;

HV8:= COUNT(HV00,10)>=3 AND COUNT(HV01 OR HV02,9)<=4 AND HHVBARS(HIGH,10) = 2 AND LLVBARS (LOW,10) >= 9 AND HV04;

HV9:= COUNT(HV00,10)>=3 AND COUNT(HV01 OR HV02,9)<=4 AND HHVBARS(HIGH,10) = 1 AND LLVBARS (LOW,10) >= 9 AND HV03;

HV10:= COUNT(HV00,11)>=3 AND COUNT(HV01 OR HV02,10)<=5 AND HHVBARS(HIGH,11) = 2 AND LLVBARS (LOW,11) >= 10 AND HV04;


通达信寻常底主图+选股无未来函数

{选股}


V00:= HIGH<REF(HIGH,1) AND LOW<REF(LOW,1);

V01:= HIGH<REF(HIGH,1) AND LOW>REF(LOW,1);

V02:= HIGH>REF(HIGH,1) AND LOW<REF(LOW,1);

V03:= HIGH>REF(HIGH,1) AND LOW>REF(LOW,1);

V04:= REF(HIGH,2) < HIGH AND REF(LOW,2) < LOW AND REF(HIGH,2) > REF(HIGH,1) AND REF(LOW,2) < REF(LOW,1);

V1:= COUNT(V00,6)>=3 AND COUNT(V01 OR V02,5)=0 AND LLVBARS(LOW,6) = 1 AND HHVBARS(HIGH,6) >=  5 AND V03;

V2:= COUNT(V00,7)>=3 AND COUNT(V01 OR V02,6)=1 AND LLVBARS(LOW,7) = 2 AND HHVBARS(HIGH,7) >=  6 AND V04;

V3:= COUNT(V00,7)>=3 AND COUNT(V01 OR V02,6)=1 AND LLVBARS(LOW,7) = 1 AND HHVBARS(HIGH,7) >=  6 AND V03;

V4:= COUNT(V00,8)>=3 AND COUNT(V01 OR V02,7)<=2 AND LLVBARS(LOW,8) = 2 AND HHVBARS(HIGH,8)  >= 7 AND V04;

V5:= COUNT(V00,8)>=3 AND COUNT(V01 OR V02,7)<=2 AND LLVBARS(LOW,8) = 1 AND HHVBARS(HIGH,8)  >= 7 AND V03;

V6:= COUNT(V00,9)>=3 AND COUNT(V01 OR V02,8)<=3 AND LLVBARS(LOW,9) = 2 AND HHVBARS(HIGH,9)  >= 8 AND V04;

V7:= COUNT(V00,9)>=3 AND COUNT(V01 OR V02,8)<=3 AND LLVBARS(LOW,9) = 1 AND HHVBARS(HIGH,9)  >= 8 AND V03;

V8:= COUNT(V00,10)>=3 AND COUNT(V01 OR V02,9)<=4 AND LLVBARS(LOW,10) = 2 AND HHVBARS (HIGH,10) >= 9 AND V04;

V9:= COUNT(V00,10)>=3 AND COUNT(V01 OR V02,9)<=4 AND LLVBARS(LOW,10) = 1 AND HHVBARS (HIGH,10) >= 9 AND V03;

V10:= COUNT(V00,11)>=3 AND COUNT(V01 OR V02,10)<=5 AND LLVBARS(LOW,11) = 2 AND HHVBARS (HIGH,11) >= 10 AND V04;

XG:V1 OR V2 OR V3 OR V4 OR V5 OR V6 OR V7 OR V8 OR V9 OR V10;


0% (0)
0% (10)

关于通达信寻常底主图+选股无未来函数的评论:

 以下是对 [通达信寻常底主图+选股无未来函数] 的评论,总共:0条评论
加入收藏 | 联系我们 | 免责声明 | 站内地图 | 关于我们