买好股公式网 > 股票公式 > 飞狐公式 > 飞狐开天辟地主图指标公式

飞狐开天辟地主图指标公式

2011年01月14日 字体: 人气:

DRAWGBK(CLOSE>0,COLORRGB(0,0,88),COLORRGB(16,16,95),1);
LC:=REF(OPEN,1);
开盘:=(SMA(MAX(OPEN-LC,0),6,1))/(SMA(ABS(OPEN-LC),6,1))*100;
LC1:=REF(CLOSE,1);
收盘:=(SMA(MAX(CLOSE-LC1,0),6,1))/(SMA(ABS(CLOSE-LC1),6,1))*100;
LC2:=REF(HIGH,1);
最高:=(SMA(MAX(HIGH-LC2,0),6,1))/(SMA(ABS(HIGH-LC2),6,1))*100;
LC3:=REF(LOW,1);
最低:=(SMA(MAX(LOW-LC3,0),6,1))/(SMA(ABS(LOW-LC3),6,1))*100;
A:=(SUM(IF(CLOSE>REF(CLOSE,1),VOL,IF(CLOSE<REF(CLOSE,1),-VOL,0)),0))/10000;
LC4:=REF(A,1);
能量:=(SMA(MAX(A-LC4,0),6,1))/(SMA(ABS(A-LC4),6,1))*100;
STICKLINE(收盘>开盘,开盘,收盘,5,1),colorFF;
STICKLINE(最高>最低 AND 最低>收盘 AND 收盘>开盘,最高,收盘,0.5,1),colorFFFF;
STICKLINE(最高>收盘 AND 收盘>最低 AND 最低>开盘,最高,收盘,0.5,1),colorFFFF;
STICKLINE(最高>收盘 AND 收盘>最低 AND 最低>开盘,最低,收盘,2,0),color808080;
STICKLINE(最低>最高 AND 最高>收盘 AND 收盘>开盘,最低,收盘,0.5,1),colorFF00FF;
STICKLINE(最低>收盘 AND 收盘>最高 AND 最高>开盘,最低,收盘,0.5,1),colorFF00FF;
STICKLINE(最低>收盘 AND 收盘>最高 AND 最高>开盘,最高,收盘,2,0),colorFF00;
STICKLINE(收盘>最高 AND 最高>开盘 AND 开盘>最低,最低,开盘,0.5,1),colorFFFF;
STICKLINE(收盘>最高 AND 最高>开盘 AND 开盘>最低,最高,开盘,2,0),colorFF00;
STICKLINE(收盘>开盘 AND 开盘>最高 AND 最高>最低,最低,开盘,0.5,1),colorFFFF;
STICKLINE(收盘>最低 AND 最低>开盘 AND 开盘>最高,最高,开盘,0.5,1),colorFF00FF;
STICKLINE(收盘>最低 AND 最低>开盘 AND 开盘>最高,最低,开盘,2,0),color808080;
STICKLINE(收盘>开盘 AND 开盘>最低 AND 最低>最高,最高,开盘,0.5,1),colorFF00FF;
STICKLINE(最高>收盘 AND 收盘>开盘 AND 开盘>最低,最低,最高,0.5,1),colorFF;
STICKLINE(最低>收盘 AND 收盘>开盘 AND 开盘>最高,最低,最高,0.5,1),colorFF00FF;
STICKLINE(收盘>最高 AND 最高>最低 AND 最低>开盘,最高,最低,3,1),colorFFFF;
STICKLINE(收盘>最低 AND 最低>最高 AND 最高>开盘,最高,最低,3,1),colorFF00FF;
STICKLINE(收盘<开盘,开盘,收盘,5,0),colorFFFF00;
STICKLINE(最高>最低 AND 最低>开盘 AND 开盘>收盘,最高,开盘,0.5,1),colorFFFF;
STICKLINE(最高>开盘 AND 开盘>最低 AND 最低>收盘,最高,开盘,0.5,1),colorFFFF;
STICKLINE(最高>开盘 AND 开盘>最低 AND 最低>收盘,最低,开盘,3,0),color808080;
STICKLINE(最低>最高 AND 最高>开盘 AND 开盘>收盘,最低,开盘,0.5,1),colorFF00FF;
STICKLINE(最低>开盘 AND 开盘>最高 AND 最高>收盘,最低,开盘,0.5,1),colorFF00FF;
STICKLINE(最低>开盘 AND 开盘>最高 AND 最高>收盘,最高,开盘,3,0),colorFF0000;
STICKLINE(开盘>收盘 AND 收盘>最高 AND 最高>最低,最低,收盘,0.5,1),colorFFFF;
STICKLINE(开盘>最高 AND 最高>收盘 AND 收盘>最低,最低,收盘,0.5,1),colorFF00FF;
STICKLINE(开盘>最高 AND 最高>收盘 AND 收盘>最低,最高,收盘,3,0),colorFF;
STICKLINE(开盘>收盘 AND 收盘>最低 AND 最低>最高,最高,收盘,0.5,1),colorFFFF;
STICKLINE(开盘>最低 AND 最低>收盘 AND 收盘>最高,最高,收盘,0.5,1),colorFF00FF;
STICKLINE(开盘>最低 AND 最低>收盘 AND 收盘>最高,最低,收盘,4,0),colorFFFF;
STICKLINE(最高>开盘 AND 开盘>收盘 AND 收盘>最低,最低,最高,0.5,1),colorFFFF00;
STICKLINE(最低>开盘 AND 开盘>收盘 AND 收盘>最高,最低,最高,0.5,1),colorFFFF00;
STICKLINE(开盘>最高 AND 最高>最低 AND 最低>收盘,最低,最高,3,0),colorFFFF;
STICKLINE(开盘>最低 AND 最低>最高 AND 最高>收盘,最低,最高,3,0),colorFF;
AA:=MIN(开盘,收盘);
BB:=MIN(AA,最高);
XTCC:=MIN(BB,最低);
XT1:=XTCC=最高;
XT2:=XTCC=开盘;
底线:5*(XT1<20 OR XT2<20) AND XTCC<20,colorFF;
AA1:=MAX(开盘,收盘);
BB1:=MAX(AA1,最高);
XTCC1:=MAX(BB1,最低);
顶线:100-(IF(XTCC1>80,5,0)),colorFF00;
TY:=XTCC1;
TY1:=XTCC;
AA:=REF(TY,3)=HHV(TY,7);
BB:=BACKSET(AA,4);
AA2:=FILTER(BB,3) AND TY=HHV(TY,4);
BB2:=REF(TY1,3)=LLV(TY1,7);
CC2:=BACKSET(BB2,4);
GG:=FILTER(CC2,3) AND TY1=LLV(TY1,4);
HH:=ISLASTBAR AND REF(AA2,BARSLAST(AA2));
II:=BACKSET(HH,BARSLAST(AA2)+1);
JJ:=II>REF(II,1);
KK:=REF(BARSLAST(AA2),1);
LL:=BACKSET(JJ,KK+2);
CS:=LL>REF(LL,1);
DRAWLINE(CS,TY,JJ,TY,1),LINETHICK2,colorFF00FF;
GG2:=(REF(TY,BARSLAST(JJ))-REF(TY,BARSLAST(CS)))/(BARSLAST(CS)-BARSLAST(JJ));
阻力:REF(TY,BARSLAST(JJ))+BARSLAST(JJ)*GG2,colorFF00FF;
HH2:=ISLASTBAR AND REF(GG,BARSLAST(GG));
II2:=BACKSET(HH2,BARSLAST(GG)+1);
JJ2:=II2>REF(II2,1);
KK2:=REF(BARSLAST(GG),1);
LL2:=BACKSET(JJ2,KK2+2);
CS2:=LL2>REF(LL2,1);
DRAWLINE(CS2,TY1,JJ2,TY1,1),LINETHICK2,colorFF00;
BXS:=(REF(TY1,BARSLAST(JJ2))-REF(TY1,BARSLAST(CS2)))/(BARSLAST(CS2)-BARSLAST(JJ2));
支撑:REF(TY1,BARSLAST(JJ2))+BARSLAST(JJ2)*BXS,LINETHICK2,colorFF00;
VAR2:=BACKSET(ISLASTBAR,BARSLAST(CS)+2) OR BACKSET(ISLASTBAR,BARSLAST(CS2)+3);
DRAWICON(AA2 AND VAR2,TY*1.02,10);
DRAWICON(GG AND VAR2,TY1*0.99,11);
DRAWICON(CROSS(TY,阻力) AND VAR2 AND CLOSE>OPEN,TY*1.1,'T01');
DRAWICON(CROSS(支撑,TY1) AND VAR2 AND CLOSE<OPEN,TY1*0.9,'T02');
120,color10000;
-50,color10000;
DRAWTEXT(最高<10 AND CROSS(收盘,最高),-5,'★'),colorFF;
DRAWTEXT(最高<10 AND CROSS(收盘,开盘) AND CROSS(收盘,最低),-5,'★'),colorFF;
DRAWTEXT(最高<10 AND CROSS(最低,最高),-5,'★'),colorFF;
DRAWTEXT(最低<10 AND CROSS(最低,开盘),-5,'★'),colorFF;
DRAWTEXT(REF(XTCC,1)<20 AND MA(CLOSE,30)>REF(MA(CLOSE,30),1) AND CROSS(最低,最高),-5,'★'),colorFF;
DRAWTEXT(开盘<20 AND CROSS(收盘,开盘) AND CROSS(收盘,最高) AND CROSS(收盘,最低),-5,'★'),colorFF;
DRAWTEXT(REF(最高,1)>80 AND CROSS(开盘,最高),115,'★'),colorFF00;
DRAWTEXT(REF(最低,1)>80 AND CROSS(开盘,最高),115,'★'),colorFF00;
DRAWTEXT(开盘>80 AND CROSS(开盘,收盘) AND CROSS(开盘,最低),115,'★'),colorFF00;
DRAWTEXT(开盘>70 AND CROSS(开盘,收盘) AND CROSS(开盘,最低) AND CROSS(开盘,最高),115,'★'),colorFF00;
VAR3:=AMOUNT/VOL/100;
VAR4:=EMA(VAR3,8);
VAR5:=STD(VAR3,8);
VAR6:=(VAR3-VAR4)*100/VAR5;
VAR7:=EMA(VAR6,5);
辟地:=EMA(VAR7,8);
开天:=(EMA(VAR7,8)+100)/2-3;
DD:=HHV(开天,2);
AA2:=INDEXC;
EE:=INDEXH;
FF:=INDEXL;
GBDP:=INDEXO;
VARDP:=INDEXA/INDEXV/100;
VAR3DP:=INDEXA/INDEXV/100;
VAR4DP:=EMA(VAR3DP,8);
VAR5DP:=STD(VAR3DP,8);
VAR6DP:=(VAR3DP-VAR4DP)*100/VAR5DP;
VAR7DP:=EMA(VAR6DP,5);
辟地DP:=EMA(VAR7DP,8);
开天DP:=(EMA(VAR7DP,8)+100)/2-3;
ZQ1:=HHV(开天DP,2);
AA1:=ZQ1-开天DP;
AA:=DD-开天;
STICKLINE(AA=0,-35,-25,10,0),colorFFFF;
STICKLINE(AA>0,-35,-25,10,0),colorFFFF00;
DRAWICON(AA<=1.2 AND 开天>开天DP,-15,10);
DRAWICON(AA>1.2 AND 开天>开天DP,-15,11);
STICKLINE(AA1=0,-45,-35,10,0),colorFF;
STICKLINE(AA1>0,-45,-35,10,0),colorFF00;
ZQ2:=IF(BARSLAST(CS)-BARSLAST(CS2)>0,BARSLAST(CS)-BARSLAST(CS2),BARSLAST(CS2)-BARSLAST(CS));
ZQ3:=IF(BARSLAST(CS)-BARSLAST(CS2)>0,BARSLAST(CS2)-BARSLAST(JJ),BARSLAST(CS)-BARSLAST(JJ2));
X:=IF(BARSLAST(CS)-BARSLAST(CS2)>0,BARSLAST(JJ)-BARSLAST(JJ2),BARSLAST(JJ2)-BARSLAST(JJ));
单阳不破:=ZQ2/ZQ3*X;
预测转点天:IF(BARSLAST(CS)-BARSLAST(CS2)>0,单阳不破-BARSLAST(JJ2),单阳不破-BARSLAST(JJ)),LINETHICK0,colorFF;

飞狐开天辟地主图指标公式

0% (0)
0% (10)

关于飞狐开天辟地主图指标公式的评论:

 以下是对 [飞狐开天辟地主图指标公式] 的评论,总共:条评论
加入收藏 | 联系我们 | 免责声明 | 站内地图 | 关于我们