买好股公式网 > 股票公式 > 飞狐公式 > 飞狐KDJ通道指标公式

飞狐KDJ通道指标公式

2011年01月14日 字体: 人气:

input: N(19,1,100),m1(3,1,100),m2(3,1,100);
DRAWGBK(C,COLORRGB(0,150,130),COLORRGB(0,0,0),0);
PARTLINE(C,-20),POINTDOT,COLORGREEN;
PARTLINE(C,120),POINTDOT,COLORYELLOW;
u:=(HHV(H,n)-LLV(L,n))/100;
Rc:=(C-LLV(L,n))/u;
KK:SMA(Rc,m1,1),PRECISION2,COLORWHITE;
KD:SMA(KK,M2,1),PRECISION2,COLORYELLOW;
KJ:3*KK-2*KD,PRECISION2,COLORMAGENTA;
上轨: KD + 14*STD(KD,60)/10,COLORgreen,LINEDOT,PRECISION2;
下轨: KD - 14*STD(KD,60)/10,COLORgreen,LINEDOT,PRECISION2;
Rh:=(H-LLV(L,n))/u;
Ro:=(o-LLV(L,n))/u;
RL:=(L-LLV(L,n))/u;
Ko:=(ro+(m1-1)*ref(kk,1))/m1;
Kh:=(rh+(m1-1)*ref(kk,1))/m1;
KL:=(rL+(m1-1)*ref(kk,1))/m1;
STICKLINE(KK>ko or (KK=ko and KK>=ref(KK,1)),kh,kL,0.1,0),COLOR0000FF;
STICKLINE(KK>ko or (KK=ko and KK>=ref(KK,1)),KK,ko,5,0),COLOR0000FF;
STICKLINE(KK<ko or (KK=ko and KK<ref(KK,1)),kh,kL,0.1,0),COLORFF0000;
STICKLINE(KK<ko or (KK=ko and KK<ref(KK,1)),KK,ko,5,1),COLORFF0000;
KKDJ:=(3*70-2*REF(kk,1))*(HHV(H,9)-LLV(L,9))/100+LLV(L,9);
KKDJ2:=((3*(100-70))-2*REF(kk,1)*(HHV(H,9)-LLV(L,9)))/100+LLV(L,9);
KDJ交叉位:=(3*REF(kd,1)-2*REF(kk,1))*(HHV(H,9)-LLV(L,9))/100+LLV(L,9);
DRAWTEXT(((SYSPARAM(1)=BARSCOUNT(C)) and (KDJ交叉位<C)),10,'KDJ死叉位 = '),SHIFT1,ALIGN2,COLORWHITE;
DRAWNUMBER((SYSPARAM(1)=BARSCOUNT(C) and (KDJ交叉位<C)),10,KDJ交叉位,2),SHIFT1,ALIGN2,COLORWHITE;//死叉
DRAWTEXT(((SYSPARAM(1) = BARSCOUNT(C)) and (KDJ交叉位>C)),10,'KDJ金叉位 = '),SHIFT1,ALIGN2,COLORWHITE;
DRAWNUMBER((SYSPARAM(1) = BARSCOUNT(C) and (KDJ交叉位>C)),10,KDJ交叉位,2),SHIFT1,ALIGN2,COLORWHITE;//金叉

飞狐KDJ通道指标公式

Tags:通道kdj
0% (0)
0% (10)

关于飞狐KDJ通道指标公式的评论:

 以下是对 [飞狐KDJ通道指标公式] 的评论,总共:条评论
加入收藏 | 联系我们 | 免责声明 | 站内地图 | 关于我们