买好股公式网 > 股票公式 > 飞狐公式 > 飞狐关注跟进的机会公式源码

飞狐关注跟进的机会公式源码

2016年03月17日 【字体: 人气:

input: N(14,1,20),M(6,1,10);
DRAWGBK((DATE > 0),COLORRGB(0,33,0),COLORRGB(0,33,0),1);
TR1:=EMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),N);
HD :=HIGH-REF(HIGH,1);
LD :=REF(LOW,1)-LOW;
DMP:=EMA(IF(HD>0&&HD>LD,HD,0),N);
DMM:=EMA(IF(LD>0&&LD>HD,LD,0),N);
PDI: DMP*100/TR1,LINETHICK,PRECISION2,COLORRED;
MDI: DMM*100/TR1,LINETHICK,PRECISION2,COLORCYAN;
ADX: EMA(ABS(MDI-PDI)/(MDI+PDI)*100,M),LINETHICK,PRECISION2,COLORWHITE;
ADXR:EMA(ADX,M),LINETHICK,PRECISION2,COLORYELLOW;
T1:=CROSS(ADX,ADXR) AND PDI>MDI AND PDI>REF(PDI,1) AND BETWEEN(ADXR,MDI,PDI) AND ADX>REF(ADX,1) AND ADXR>REF(ADXR,1);
T2:=CROSS(ADX,MDI) AND CROSS(ADXR,MDI) AND PDI>MDI;
PARTLINE(RANGE(BARPOS,SYSPARAM(3)-82,SYSPARAM(3)+1),PDI),COLORRED;
PARTLINE(RANGE(BARPOS,SYSPARAM(3)-82,SYSPARAM(3)+1),MDI),COLORCYAN;
PARTLINE(RANGE(BARPOS,SYSPARAM(3)-82,SYSPARAM(3)+1),ADX),COLORWHITE;
PARTLINE(RANGE(BARPOS,SYSPARAM(3)-82,SYSPARAM(3)+1),ADXR),COLORYELLOW;
DRAWICON(RANGE(BARPOS,SYSPARAM(3)-82,SYSPARAM(3)+1)&&T1,ADXR,6),ALIGN,PXDN8;//关注
DRAWICON(RANGE(BARPOS,SYSPARAM(3)-82,SYSPARAM(3)+1)&&T2,MDI,10);//关注
DRAWICON(RANGE(BARPOS,SYSPARAM(3)-82,SYSPARAM(3)+1)&&CROSS(PDI,MDI)&&ADX>20,MDI,4),ALIGN,PXDN8;//第一次跟进的机会
DRAWICON(RANGE(BARPOS,SYSPARAM(3)-82,SYSPARAM(3)+1)&&PDI>MDI&&ADX>40&&CROSS(ADX,ADXR),ADXR,8),ALIGN,PXDN8;//最后跟进的机会
DRAWICON(RANGE(BARPOS,SYSPARAM(3)-82,SYSPARAM(3)+1)&&PDI>MDI&&ADXR>50&&CROSS(ADXR,ADX)&&PDI<ref(PDI,1),ADXR,12),ALIGN,PXDN8;//谨慎

 

0% (0)
0% (10)

关于飞狐关注跟进的机会公式源码的评论:

 以下是对 [飞狐关注跟进的机会公式源码] 的评论,总共:0条评论
加入收藏 | 关于我们 | 服务条款 | 广告服务 | 免责声明 | 站内地图 | 联系我们