买好股公式网 > 股票公式 > 飞狐公式 > 飞狐超级疯子主图短线公式源码

飞狐超级疯子主图短线公式源码

2012年08月17日 【字体: 人气:
超级疯子 主图短线指标源码

INPUT:DA(6,1,30),FY(5,0,8),CT(1,0,2),P(0,0,1),N(3,0,10);
 


{超级疯子}

STICKLINE((OPEN>=CLOSE),CLOSE,OPEN,7,1),colorFFFF50;

STICKLINE((OPEN>=CLOSE),HIGH,OPEN,0,0),colorFFFF50;

STICKLINE((OPEN>=CLOSE),CLOSE,LOW,0,0),colorFFFF50;

STICKLINE((CLOSE>=OPEN),CLOSE,OPEN,7,1),color5050FF;

STICKLINE((CLOSE>=OPEN),CLOSE,HIGH,0,0),color5050FF;

STICKLINE((CLOSE>=OPEN),LOW,OPEN,0,0),color5050FF;

X:=(BARSLAST((SYSPARAM(2)=BARPOS))+1);

NS:=IF((HHV(ABS(((HHV(CLOSE,DA)/LLV(CLOSE,DA))-1)),DA)>(10/100)),3,DA);

N1:=IF((DATATYPE=2),(NS*48),IF((DATATYPE=3),(NS*16),IF((DATATYPE=4),(NS*8),IF((DATATYPE=5),(NS*4),NS))));

MM:=IF((((STKTYPE=0) OR (P=0)) OR (VOL=0)),MA(CLOSE,N1),((SUM(AMOUNT,N1)/SUM(VOL,N1))/100));

M1:=REF(MM,1);

买入:=IF(CROSS(CLOSE,M1),M1,0);

卖出:=IF(CROSS(M1,CLOSE),M1,0);

YE:=BARPOS;

费用:=(FY/1000);

DW:=BARSLAST((卖出>0));

EX10:=HHV((买入>0),(DW+1));

BJ:=IF((EX10>REF(EX10,1)),买入,0);

SJ:=IF((EX10<REF(EX10,1)),卖出,0);

BNN:=BARSLAST((BJ>0));

CC:=REF(BJ,BNN);

盈利:=((SJ*(1-费用))-(CC*(1+费用)));

YL:=SUM(IF((SJ>0),盈利,0),0);

每股盈利:YL,LINETHICK0,PRECISION2,colorFFFFFF;

CN:=SUM(IF(((SJ>0) AND (REF(CC,1)>0)),1,0),0);

CG:=SUM(IF(((SJ>0) AND (盈利>0)),1,0),0);

成功率:((100*CG)/CN),LINETHICK0,PRECISION1,color88FF;

H1:=HHV(IF((CT=2),成功率,YL),X);

L1:=LLV(IF((CT=2),成功率,YL),X);

AH:=H1[DATACOUNT];

AL:=L1[DATACOUNT];

AHL:=(AH-AL);

POLYLINE((CT=2),成功率),color88FF;

买入均价:(SUM(BJ,0)/CN),LINETHICK0,PRECISION1,colorFF;

年收益:((100*((240*YL)/YE))/买入),LINETHICK0,PRECISION1,colorFF;

持股时间:(SUM(IF(((SJ>0) AND (CC>0)),(REF(BNN,1)+1),0),0)/YE),LINETHICK0,PRECISION2,colorFF00FF;

交易:CN,LINETHICK0,PRECISION0,colorAAAAAA;

(次)成功:CG,LINETHICK0,PRECISION0,colorAAAAAA;

年交均次:=((240*CN)/YE);

MON:=SUM(IF((MONTH<>REF(MONTH,1)),1,0),0);

上市年:=(MON/12);

DRAWNUMBER((BJ>0),(LOW*0.97),BJ,2),ALIGN0,colorFF;

DRAWICON(((BJ>0) AND (CT=1)),(LOW*0.99),4);

DRAWTEXT(((BJ>0) AND (CT=1)),(LOW*0.95),'★\n 买入'),ALIGN0,colorFFFF;

STICKLINE(((BJ>0) AND (CT=1)),MM,(MM+0.04),16,1),ALIGN0,colorFFFF;

STICKLINE(((BJ>0) AND (CT=1)),CLOSE,OPEN,4,0),ALIGN0,colorFFFF;

DRAWNUMBER((((SJ>0) AND (CT=1)) AND (((盈利/(CC*(1+费用)))*100)>=0)),(HIGH*1.07),((盈利/(CC*(1+费用)))*100),1),ALIGN0,colorFF;

DRAWNUMBER((((SJ>0) AND (CT=1)) AND (((盈利/(CC*(1+费用)))*100)<0)),(HIGH*1.07),((盈利/(CC*(1+费用)))*100),1),ALIGN0,colorFFFF;

DRAWICON(((SJ>0) AND (CT=1)),(HIGH*1.025),5);

STICKLINE(((SJ>0) AND (CT=1)),SJ,(SJ+0.04),16,1),ALIGN0,colorFF;

DRAWNUMBER(((SJ>0) AND (CT=1)),(HIGH*1.05),SJ,2),ALIGN0,colorFF00;

N波动:(SUM(IF((((SJ>0) AND (CC>0)) AND ((REF(BNN,1)+1)<=N)),(REF(BNN,1)+1),0),0)/YE),LINETHICK0,PRECISION2,colorFF00FF;

买价:IF((BJ>0),BJ,0),LINETHICK0,PRECISION2,colorFF;

卖价:IF((SJ>0),SJ,0),LINETHICK0,PRECISION2,colorFF00;

DRAWTEXTEX(CLOSE,1,0,0,(((((((((((((((((('年盈利:'+NUMTOSTR(YL,2))+'元 成功率:')+NUMTOSTR(成功率,1))+'% 年收益:')+NUMTOSTR(年收益,1))+'%')+' 持股时间比:')+NUMTOSTR(持股时间,1))+'\n')+'交易:')+NUMTOSTR(交易,0))+'次 成功:')+NUMTOSTR(CG,0))+'次 年均:')+NUMTOSTR(年交均次,1))+'次 总共:')+NUMTOSTR(YE,0))+'K线')),colorEE5555;

临界:=(((CLOSE/M1)-1)*100);

增减:=(临界-(100*((REF(CLOSE,1)/REF(M1,1))-1)));

{买好股公式网- WWW.buyhaogu.COM}

DRAWTEXTEX(CLOSE,1,630,0,(((((((('当前 信号持续:'+NUMTOSTR(BNN,0))+'(K线)')+' 最高盈利:')+NUMTOSTR(HHV((((HIGH/CC)-1)*100),(BNN+1)),1))+'% 买卖临界点:')+NUMTOSTR(临界,1))+'% 增减:')+NUMTOSTR(IF(((BNN>0) AND (DATATYPE=6)),增减,IF((BNN=0),0,-100)),1))),colorEE5599;

DRAWTEXT(((SYSPARAM(3)=BARPOS) AND (CT<3)),HIGH,'.'),color1;

DRAWTEXT(((SYSPARAM(3)=BARPOS) AND (CT<3)),LOW,'.'),color1;

参考介入价:MM,LINETHICK0,PRECISION2,colorFFFFFF;

FUA:=HHV(HIGH,15);

FUB:=LLV(LOW,15);

DRAWTEXTEX(CLOSE,1,720,60,(('15日最高价:'+NUMTOSTR(FUA,2))+' ')),ALIGN2,colorFF;

DRAWTEXTEX(CLOSE,1,840,60,(('15日最低价:'+NUMTOSTR(FUB,2))+' ')),ALIGN2,colorBB0000;

DRAWTEXTEX(CLOSE,1,950,60,(('参考介入价:'+NUMTOSTR(MM,2))+' ')),ALIGN2,colorEE9999;

VAR2:=(((CLOSE+HIGH)+LOW)/3);

VAR33:=EMA(VAR2,10);

VAR44:=REF(VAR33,1);

FILLRGN((VAR33>VAR44),VAR33,VAR44),colorFF;

FILLRGN((VAR33<VAR44),VAR44,VAR33),colorFF0000;


 



 


 

0% (0)
0% (10)

关于飞狐超级疯子主图短线公式源码的评论:

 以下是对 [飞狐超级疯子主图短线公式源码] 的评论,总共:0条评论
加入收藏 | 关于我们 | 服务条款 | 广告服务 | 免责声明 | 站内地图 | 联系我们