买好股公式网 > 股票公式 > 飞狐公式 > 飞狐缺口背离主图指标公式

飞狐缺口背离主图指标公式

2012年08月11日 【字体: 人气:

{缺口+背离(主图)}

DRAWGBK(1,colorrgb(0,0,100),colorrgb(0,0,0),1);
x1:=(C+L+H)/3;
x2:=EMA(x1,6);
x3:=EMA(x2,5);
b:=Ema(c,5);
超级线:b;
f:=c>o or (c=o and c>ref(c,1));
fL:=L>=b;
STICKLINE(f and fL,l,h,0.01,0),COLORMAGENTA;
STICKLINE(f and fL,o,c,5,1),COLORMAGENTA;
STICKLINE(not(f) and fL,l,h,0.01,0),Color8E2258;
STICKLINE(not(f) and fL,o,c,5,0),Color8E2258;//全上
fH:=h<=b;
STICKLINE(f and fh,l,h,0.01,0),COLORGREEN;
STICKLINE(f and fh,o,c,5,1),COLORGREEN;
STICKLINE(not(f) and fh,l,h,0.01,0),Color666213;
STICKLINE(not(f) and fh,o,c,5,0),Color666213;//全下
fc:=c>=b and o<b;
STICKLINE(f and fc,c,h,0.01,0),COLORMAGENTA;
STICKLINE(f and fc,b,c,5,1),COLORMAGENTA;
STICKLINE(f and fc,b,l,0.01,0),COLORGREEN;
STICKLINE(f and fc,b,o,5,1),COLORGREEN;
fo:=c<b and o>=b;
STICKLINE(not(f) and fo,c,h,0.01,0),Color8E2258;
STICKLINE(not(f) and fo,b,c,5,0),Color666213;
STICKLINE(not(f) and fo,b,l,0.01,0),Color666213;
STICKLINE(not(f) and fo,b,o,5,0),Color8E2258;
ff:=h>b and max(c,o)<=b;
STICKLINE(ff and f,b,l,0.01,0),COLORGREEN;
STICKLINE(ff and not(f),b,l,0.01,0),Color666213;
STICKLINE(f and ff,c,o,5,1),COLORGREEN;
STICKLINE(not(f) and ff,c,o,5,0),Color666213;
STICKLINE(ff and f,b,h,0.01,0),COLORMAGENTA;
STICKLINE(ff and not(f),b,h,0.01,0),Color8E2258;
fff:=L<b and min(c,o)>=b;
STICKLINE(fff and f,b,h,0.01,0),COLORMAGENTA;
STICKLINE(fff and not(f),b,h,0.01,0),Color8E2258;
STICKLINE(f and fff,c,o,5,1),COLORMAGENTA;
STICKLINE(not(f) and fff,c,o,5,0),Color8E2258;
STICKLINE(fff and f,b,l,0.01,0),COLORGREEN;
STICKLINE(fff and not(f),b,l,0.01,0),Color666213;
gr1:=BARSLAST(BETWEEN("bias.bias2"(6,13,24),0,5));
gr2:=ema(x1,13)>ema(x1,21) and ema(x1,21)>ema(x1,34)
and ema(x1,13)>ref(ema(x1,13),1);
gr3:=count("bias.bias2"(6,13,24)>10 and h=hhv(h,gr1),gr1);
gr4:=h=hhv(h,gr1);
gr5:="macd.macd"(12,26,9)<ref("macd.macd"(12,26,9),1);
gr6:=gr2 and gr3 and gr4;
gr7:=gr2 and gr3 and gr4 and gr5;
gr8:=gr6 and gr7;
LC := REF(CLOSE,1);
RSI6:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
BIAS5:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;
bb13:=atan(ema(x1,13)-ref(ema(x1,13),1))*3.1416*10;
ema8:=ema(c,8);
DRAWTEXT(filter(bb13>1 and ema(x1,13)>ref(ema(x1,8),1),10),ema8,'∠45上升'),colorwhite;
DRAWTEXT(BARPOS=SYSPARAM(2),HIGH,'所属板块:'+BLKNAME),ALIGN4,colorFFFFFF;
A1:=BARSLAST(ref(cross("macd.diff","macd.dea"),1));
B1:=ref(c,A1+1)>c and ref("macd.diff",A1+1)<"macd.diff" and cross("macd.diff","macd.dea");
DRAWTEXT(FILTER(B1>0,5),l-0.38,'MACD底背'),COLORGREEN;
A2:=BARSLAST(ref(cross("kdj.k","kdj.d"),1));
B2:=ref(c,A2+1)>c and ref("kdj.k",A2+1)<"kdj.k" and cross("kdj.k","kdj.d");
DRAWTEXT(FILTER(B2>0,5),l-0.39,'KDJ底背'),COLORYELLOW;
A3:=BARSLAST(ref(cross("RSI.RSI1","RSI.RSI2"),1));
B3:=ref(c,A3+1)>c and ref("RSI.RSI1",A3+1)<"RSI.RSI1" and cross("RSI.RSI1","RSI.RSI2");
DRAWTEXT(FILTER(B3>0,5),l,'RSI底背'),COLORCYAN;
C1:=BARSLAST(ref(cross("macd.dea","macd.diff"),1));
D1:=ref(c,C1+1)<c and ref("macd.diff",C1+1)>"macd.diff" and cross("macd.dea","macd.diff");
DRAWTEXT(FILTER(D1>0,5),h+0.08,'MACD顶背'),COLORwhite;
C2:=BARSLAST(ref(cross("kdj.d","kdj.k"),1));
D2:=ref(c,C2+1)<c and ref("kdj.k",C2+1)>"kdj.k" and cross("kdj.d","kdj.k");
DRAWTEXT(FILTER(D2>0,5),h+0.32,'KDJ顶背'),COLORwhite;
C3:=BARSLAST(ref(cross("RSI.RSI2","RSI.RSI1"),1));
D3:=ref(c,C3+1)<c and ref("RSI.RSI1",C3+1)>"RSI.RSI1" and cross("RSI.RSI2","RSI.RSI1");
DRAWTEXT(FILTER(D3>0,5),h+0.1,'RSI顶背'),COLORMAGENTA;
{缺 口1}
DRAWTEXT(l>REF(H,1),REF(H,1),'上缺'),COLOrwhite;
DRAWTEXT(h<REF(L,1),REF(L,1),'下缺'),COLORblue;
{缺 口2}
KOH:=LOW>REF(HIGH,1);
KOL:=HIGH<REF(LOW,1);
HIF:=LOW>REF(HIGH,BARSLAST(KOH)+1);
NHIF:=LOW<=REF(HIGH,BARSLAST(KOH)+1);
LIF:=HIGH<REF(LOW,BARSLAST(KOL)+1);
NLIF:=HIGH>=REF(LOW,BARSLAST(KOL)+1);
DRAWICON(HIF AND BARSLAST(koh)<BARSLAST(nhif) and
BARSLAST(HIF)<BARSLAST(NHIF),REF(HIGH,BARSLAST(KOH)+1),10),ALIGN0;
DRAWICON(LIF AND BARSLAST(kol)<BARSLAST(nlif) and
BARSLAST(LIF)<BARSLAST(NLIF),REF(LOW,BARSLAST(KOL)+1),11),ALIGN0;

 

0% (0)
0% (10)

关于飞狐缺口背离主图指标公式的评论:

 以下是对 [飞狐缺口背离主图指标公式] 的评论,总共:0条评论
加入收藏 | 关于我们 | 服务条款 | 广告服务 | 免责声明 | 站内地图 | 联系我们